Comment 60 for bug 1003309

Darek (ddarek-ch) wrote :

I had similar problem. I was unable to boot with new kernel and update-initrams -u -k all caused that I couldn't also boot with old kernel. At the end I tried to completly reinstall grub and all kernels through a live cd - that did a trick. All works now. Here's short list of steps I did. http://ubuntuforums.org/showthread.php?t=2147608&p=12661995#post12661995 Doesn't matter there's nothing about luks there. I have luks + lvm and all that worked. I didn't write that in that thread to simplify procedure.

I have also one notice. Having luks it's very important to check /etc/crypttab. First parameter should be single name (and not device path), second should be UUID of *encrypted* partition. Next two usually have null and luks. Once I had problems having in /etc/crypttab UUID of decrypted partition instead of encrypted.

Notice also that first parameter must match all other stuff like ones in /etc/fstab.

More over I found on some debian forum that restarting luks/lvm from live cd, by chrooting to your unbooting system and performing update-initrams and some other magic things, before chroot you should mount whole your system just like it's expected in /etc/crypttab and /etc/fstab. So all names should be same as ones in that file - i.e. if you luksOpen your partition then it should look like: sudo cryptsetup luksOpen /dev/sdXY <FIRST PARAMETER FROM /etc/crypttab>.