Comment 0 for bug 1003309

tdn (spam-thomasdamgaard) wrote :

I run 12.04 LTS on a virtualbox image. I use LUKS and LVM for whole disk encryption.

After installing recent kernel updates, my system no longer boots. It says: "cryptsetup: evms_activate is not available" when it would normally ask for passphrase.

If I boot the previous kernel, I do not get this error.

This appears to be a bug in the new kernel package?

Until this is fixed, is there any workaround that will let me boot my system with the new kernel?

More info:
Maybe this issue is related to this bug: https://bugs.launchpad.net/ubuntu/+source/cryptsetup/+bug/957602 ?
However, this is a much more recent kernel.

This kernel works: 3.2.0-23-generic, while this one fails: 3.2.0-24-generic

I have tried doing this:
sudo su -
cd /boot/grub
update-initramfs -u
update-grub
reboot

This did not solve the issue.

It seems that the new kernel does not include evms support, while the older kernel does.
Is this something that has been officially removed from the Ubuntu provided kernel? If so, why? I am pretty sure this breaks a lot of Ubuntu deployments using LUKS and dmcrypt.

My /etc/fstab is available here:
http://p.adora.dk/P2400.html

My /etc/crypttab is available here:
http://p.adora.dk/P2401.html