Comment 4 for bug 1003090

Daniel Nicoletti (dantti) wrote :

Hi, first thanks for looking into this, it's been a while with no activity.
for #2 I'm not sure why HID must be build in, actually the config part of the patch wasn't added by me, I just did the reverse engineering making sure it worked fine for my Apple bluetooth Keyboard and Magic Track pad, on the thread another guy with a mouse from a different brand reported it worked fine.

For #3 the problem was that they enabled the feature but didn't upgrade upower, which had some fixes made by me and ones made by Richard. also starting from 3.4 it power_supply has a scope feature to avoid the confusion. So since Quantal has an up to date upower it will went fine.
It got disabled by default so at that time user space didn't get broken. Now I can say it's safe to enable it. So it's a feature users with devices that have this capability will be quite happy :)
Also about the RH bug I just confirmed and their 3.5 kernel in F17 has it enabled by default again.

And well from your grep it shows CONFIG_HID=m will make it not work, the problem is that I don't understand the kernel config system so I really dunno why this was done, maybe it could be changed to allow having it when using HID as a module. What do you think?