[Gutsy] System freeze when bringing up rt2500pci interface

Bug #129183 reported by Cedric Schieli on 2007-07-30
40
Affects Status Importance Assigned to Milestone
linux-ubuntu-modules-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

With latest rt2500pci driver (from linux-ubuntu-modules-2.6.22_2.6.22-9.22), the system freeze after enabling CTS protection on the interface

I've tracked down the problem to this upstream (git://git.kernel.org/pub/scm/linux/kernel/git/ivd/rt2x00.git) commit : c69ad028b683289fba89ce4a8aa34dddbcf32ce2

Reverting those changes fix the freeze and the system is working properly.

Patch following

Changed in linux-ubuntu-modules-2.6.22:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Cedric Schieli (cschieli) wrote :

The problem seems to have vanished with linux-ubuntu-modules-2.6.22-10-generic

Javier Jardón (jjardon) wrote :

No problems for me with rt2500 card on gutsy tribe4

I still have the same problem with tribe5.

Kai Stempfle (kai-stempfle) wrote :

I had that problem, too.

I pinpointed the problem down to a setting on my router I enabled just before the freezes started. Disabling CTS Protection (also known as 802.11b/g protection) on my router stopped my system from freezing after bringing up the interface. You might want to try that.

With the latest daily live cd this problem seems solved for me also. I'm not going to install gutsy yet, because I still experience the slow connection problem (bug 129719).

Cedric Schieli (cschieli) wrote :

It seems the problem did not really disapeared for me. The CTS protection somehow got disabled on my AP.
After a power failure, my AP rebooted with CTS protection enabled, and the freezes came back.

My above patch still fix the issue for me.
I've just uploaded a patched lum package in my ppa (http://ppa.launchpad.net/cschieli/ubuntu)

diel (djlangton) wrote :

Confirmed those new ppa modules fix the issue for me (two different computers, both rt2500 wifi) - I'm typing this via the gutsy beta livecd right now!

Thanks!

Tim Gardner (timg-tpi) wrote :

Gutsy lum commit 9efb673025a8040bd945a4c9f5f79195b355a903

Changed in linux-ubuntu-modules-2.6.22:
status: Triaged → Fix Committed
Marcus Czeslinski (czessi) wrote :

I comfirm this ppa module too. Works great for me.

Kyle McMartin (kyle) wrote :

linux-ubuntu-modules-2.6.22 (2.6.22-13.33) gutsy; urgency=low

  [Ben Collins]

  * ubuntu/d-i: Add atl2 module to udeb
    - LP: #148532

  [Matthew Garrett]

  * Work around uvc suspend issues
    - LP: #147757
  * Force-enable speakers on recent Thinkpads
    - LP: #140609

  [Tim Gardner]

  * Added et131x Gigabit ethernet driver support.
    - LP: #102291
  * AppArmor patch for disconnected path reporting
  * prism javelin/xbow works out-of-box, but the module is not loaded by
    default
    - LP: #133823
  * System freeze when bringing up rt2500pci interface
    - LP: #129183
  * [xps1330] microphone built-in doesn't work
    - LP: #147682
  * FUJITSU SIEMENS XTB70 snd-hda-intel fix
    - LP: #147827
  * Add ivtv-fb and saa717x support
    - LP: #147886

 -- Kyle McMartin <email address hidden> Thu, 04 Oct 2007 16:09:03 +0000

Changed in linux-ubuntu-modules-2.6.22:
status: Fix Committed → Fix Released

Works Oke on new 2.6.22-13 version. Thnx guys

I can't connect to any WPA network using Gutsy. I can't install Cedric's packages because they are for an older kernel.

Using kernel 2.6.22.14

Peter Belew (peterbe) wrote :

I installed 7.10 on an Averatec 3280 laptop with a built-in rt2500 card two days ago. The laptop previously had had Windows XP and an earlier release of Gutsy, and the card was working well on networks with WEP or no protection.

After reinstalling and updating (over an eth0 connection), the card fails to work, and when I attempt to bring it online with the manual wireless tool, the system will freeze.

Version info as of today:

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=7.10
DISTRIB_CODENAME=gutsy
DISTRIB_DESCRIPTION="Ubuntu 7.10"
Linux cupid 2.6.22-14-generic #1 SMP Tue Dec 18 08:02:57 UTC 2007 i686 GNU/Linux

From lspci:

00:09.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)

From dmesg:

[ 133.292000] handlers:
[ 133.292000] [<dead9810>] (rt2500pci_interrupt+0x0/0xd0 [rt2500pci])
[ 133.292000] [<ded82480>] (via_driver_irq_handler+0x0/0x1d0 [via])

From daemon.log:

daemon.log:Jan 25 14:47:22 cupid NetworkManager: <info> wlan0: Device is fully-supported using driver 'rt2500pci'.

Peter Belew (peterbe) wrote :

This is probably related to Bug #192252, which I reported on the same laptop.
It looks like changing /etc/network/interfaces when any interface is up can cause a freeze (blank screen).

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers