omapdss DISPC error on Panda platform

Bug #758486 reported by Tobin Davis on 2011-04-12
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux-ti-omap4 (Ubuntu)
Medium
Bryan Wu
Natty
Medium
Bryan Wu
Oneiric
Undecided
Unassigned

Bug Description

On the panda platform, if the system remains idle for an extended period of time and auto suspends the video output putting the monitor to sleep, the system doesn't wake up the monitor properly on keypress or soft-reboot events until the platform does a hardware reset.

The following error messages are in the attached syslog:
Apr 12 00:05:36 panda20 kernel: [20594.563293] omapdss DISPC error: SYNC_LOST_DIGIT, disabling TV
Apr 12 00:05:36 panda20 kernel: [20594.579254] HDMI display is not active!
Apr 12 00:05:36 panda20 kernel: [20594.579284] asoc: can't open interface hdmi-audio-dai

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-omap (not installed)
Regression: No
Reproducible: Yes
ProcVersionSignature: User Name 2.6.38-1207.10-omap4 2.6.38
Uname: Linux 2.6.38-1207-omap4 armv7l
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: armel
Date: Tue Apr 12 00:15:59 2011
Lsusb:
 Bus 001 Device 004: ID 05d5:6781 Super Gate Technology Co., Ltd
 Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
 Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: ro elevator=noop vram=32M mem=460M@0x80000000 mem=256M@0xA0000000 root=UUID=44c5f5fe-5c61-487e-b9bf-7db84165dc52 fixrtc quiet splash
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)

Tobin Davis (gruemaster) wrote :
Tobin Davis (gruemaster) on 2011-04-12
tags: removed: needs-upstream-testing unity-2d
Changed in linux (Ubuntu):
importance: Undecided → Medium
Tobin Davis (gruemaster) wrote :
tags: added: iso-testing
Jeremy Foshee (jeremyfoshee) wrote :

changing package

affects: linux (Ubuntu) → linux-ti-omap4 (Ubuntu)
Bryan Wu (cooloney) wrote :

Tobin,

Can you reproduce this issue with latest 1208.12 kernel? I failed to reproduce it.

Changed in linux-ti-omap4 (Ubuntu Natty):
assignee: nobody → Bryan Wu (cooloney)
milestone: none → natty-updates
DeKa (denis-kondratenko) wrote :

Hello Bryan,

I have this issue during boot (dmsg log could be found at following attachment).

HW and SW - Pandaboard rev. A1 and ViewSonic monitor; ubuntu natty 11.05 EVB on 4GB SDHC card.

During boot I could see log messages on monitor, but before GUI start screen become black (HDMI-DVI).
The same time console is alive and monitor is at the active state.

I think it could be connected with long monitor delay -
switch from stand-by state to active state
(delay between appearing of video signal at monitor input and picture show).
My monitor has an extra 1-2 seconds delay.

I've successfully boot Panda using my Samsung TV (HDMI-HDMI).
As could I see, it hasn't such switch delay.

Hope this would help.
Maybe I could provide an additional information?

Thanks.

Best regards,
DeKa

DeKa (denis-kondratenko) wrote :

Hi Tobin,

Per Brian's comment #4, were you ever able to reproduce with the newer Natty kernel?

Also just curious if this is still an issue for Oneiric (2.6.38-1309.14)?

This is still current as of the latest kernel for omap4
(2.6.38-1309-14). My understanding is that TI will push a fix with the
next BSP.

On Fri, 2011-07-15 at 13:30 +0000, Leann Ogasawara wrote:
> Hi Tobin,
>
> Per Brian's comment #4, were you ever able to reproduce with the newer
> Natty kernel?
>
> Also just curious if this is still an issue for Oneiric
> (2.6.38-1309.14)?
>

--
Tobin Davis

Moe: Wanna play poker tonight?
Joe: I can't. It's the kids' night out.
Moe: So?
Joe: I gotta stay home with the nurse.

Ricardo Salveti (rsalveti) wrote :

On Fri, Jun 10, 2011 at 1:57 PM, DeKa <email address hidden> wrote:
> Hello Bryan,
>
> I have this issue during boot (dmsg log could be found at following
> attachment).
>
> HW and SW - Pandaboard rev. A1 and ViewSonic monitor; ubuntu natty 11.05
> EVB on 4GB SDHC card.
>
> During boot I could see log messages on monitor, but before GUI start screen become black (HDMI-DVI).
> The same time console is alive and monitor is at the active state.

Can you boot with "omapdss.debug=1 drm.debug=7 loglevel=8" at your
kernel cmd line and post your dmesg again?

Thanks.

DeKa (denis-kondratenko) wrote :

Hello Ricardo,

Today I've used Ubuntu Natty 11.06 LEB image.
Issue with monitor is disappeared
(screen don't blink anymore).

But error message still present at dmesg log
(see following attachment).

Maybe I could provide an additional information?

Thanks.

Best regards,
DeKa

DeKa (denis-kondratenko) wrote :
Changed in linux-ti-omap4 (Ubuntu Natty):
status: New → Confirmed
Changed in linux-ti-omap4 (Ubuntu):
status: New → Confirmed
Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking
Changed in linux-ti-omap4 (Ubuntu Oneiric):
milestone: none → oneiric-updates
Tobin Davis (gruemaster) wrote :

Not seeing this on Onerirc in recent kernels. May have been fixed in one of the latest pulls from TI. Marking incomplete for now. Will reopen if I see it again.

Changed in linux-ti-omap4 (Ubuntu Oneiric):
status: Confirmed → Incomplete

Per comment #12 from Tobin, I'm just going to close this for now rather than leaving it open but marked Incomplete. Feel free to re-open should this re-appear.

Changed in linux-ti-omap4 (Ubuntu Oneiric):
status: Incomplete → Fix Released
dino99 (9d9) on 2013-05-18
Changed in linux-ti-omap4 (Ubuntu Natty):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers