Cannot wake up from suspend and hibernate

Bug #33372 reported by Tero Karvinen on 2006-03-02
76
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

Computer does not wake up from suspend (suspend-to-ram s3) and hibernate (to hard disk). To reproduce
1. Choose System:LogOut:Suspend. The machine goes to sleep in a couple of seconds, and the fan shuts off, just like it should.
2. Press any key to wake up (computer should wake up in seconds to the state is was before suspend)
3. Computer reads the disk for a while, but screen stays blank. Nothing happens (not even lights blinking) when pressing numlock, alt-ctrl-del, alt-ctrl-backspace.

Also, computer fails to wake up from hibernate.

The problem is shown with Dapper Flight CD 3 with latest updates on 2006-03-02: gnome-power-manager 2.13.92-0ubuntu1, hal 0.5.7-1ubuntu1, Linux 2.6.15-16-386. I am using Acer Travelmate 3000 (3004WTMi).

It used to work out of the box with Dapper Flight CD 3 with updates at 2006-02-12: "Power Manager 2.13.5", linux 2.6.15-15, gnome-applets 2.13.3-0ubuntu1 and hal 0.5.6-1ubuntu3, 915resolution 0.5.1 compiled from source with my script. I described a mostly working setup in #3490 and http://www.iki.fi/karvinen/acer_travelmate_3004wtmi_with_linux.html

Might be related to:
https://launchpad.net/distros/ubuntu/+source/gnome-power-manager/+bug/30132
gnome-power-manager: "Suspend and Hibernate doesn't work" (fix released)
and
915resolution: "915resolution package breaks hibernation"
https://launchpad.net/distros/ubuntu/+source/915resolution/+bug/6408 (fix released)

Daniel Silverstone (dsilvers) wrote :

Sounds like an acpi-support bug to me. Reassigning it over

Just tested with a clean install of Ubuntu Dapper Flight 5, updated today 2006-03-12 and it still does not wake up from sleep (suspend-to-RAM S3).

This shows that the problem is not related to 915resolution.

I am using kernel boot parameters "noapic nolapic pci=noacpi". "noapic nolapic" are required to prevent complete freeze on "Uncompressing Linux", and "pci=noacpi" is required for network and external CD-ROM to work.

description: updated
Vegar Nilsen (vegar-nilsen) wrote :

I have the same problem with my Dell Inspiron 6000, dist-upgraded to Dapper from Breezy yesterday (20060319).

vegar$gain [~] dpkg -l acpi-support 915resolution gnome-power-manager hal Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii 915resolution 0.5-1ubuntu2 resolution modify tool for Intel graphic chi
ii acpi-support 0.59 a collection of useful events for acpi
ii gnome-power-ma 2.13.93-0ubunt Power management policy frontend for GNOME
ii hal 0.5.7-1ubuntu7 Hardware Abstraction Layer

The computer suspends just fine, but fails to resume. (I'm not using any special boot parameters.)

Tested on Dapper Flight 6. Test system has never had 915resolution installed, so the bug is not related to that.

Details on testing it:
System: Preferences: Power Management
- Options: Sleep button action: Suspend
- "Are you sure that you wish to enable suspend?" "Enable
suspend"

Fn-F4. Screen blanks. Fan goes silent. (not sure if a led
became lit).

Waited 20 s.

Pressed ctrl multiple times, nothing happens. Pressed
space, nothing happens. Click many keys. It stays dead as
a rock.

Move mouse, click mouse buttons. Fan is turned on.
 Screen stays black. Caps lock changes
keyboard led state. Numlock (Fn-F11) changes led state
(Maybe the computer came up with just black screen?).

Pressing alt-ctrl-backspace to restart X: the fan went
silent. Caps lock and numlock still change leds on
keyboard. Pressing alt-ctrl-backspace again. It does not
seem to do anything. Pressing alt-ctrl-f1 (2,3,4...).
Nothing comes to screen, but fan is activated (Maybe fan
became heat/load controlled when suspend was enabled?).
Caps lock and numlock don't change led status anymore.
Pressing alt-ctrl-backspace, nothing. Pressing
alt-ctrl-del, after couple of seconds, fan went silent.
It is not reading the disk (according to hd led) so it is
probably not shutting down. Clicked power button. Nothing
happens. Pressed power button for 15 s.

lshw on 3004WTMi

Xorg.log

acpid log. I added .txt suffix so that it opens in the browser.

This problem is still present in Dapper 6.06 beta 2 live.

When trying to wake from suspend-to-RAM (sleep, S3), the screen blinks now. Caps lock light changes state. Trying to change virtual console blinks screen, but virtual consoles don't work either. Fan stays off. Alt-ctrl-del and alt-ctrl-backspace don't work.

erik veninga (ejopzee) wrote :

Problem also present at 28-4-06 on acer aspire 1312LC.

Upgraded to dapper yesterday and updated to today. With kernel 2.6.15-21-k7.

With the old kernel 2.6.12-10-k7, sleep is working however hibernating not.

ot (giuott) wrote :

I have the same problem with a Dell Latitude D610. Suspend to ram worked until 2.6.15-20, and never worked again with newer kernels.
At the moment I am running 2.6.15-19, and sleep works. Never tried suspend to disk.
I have noticed that with revision 19 (with which sleeps works) the kernel shows a lot of debug information before going to sleep. With revisions 20+ the screen simply goes blank (and doesn't wake up). Maybe a video card related problem?

Now only display stays black after suspend-to-ram. Computer no longer freezes. This is a huge improvement.

Things that work after suspend: ssh connection to suspended machine, remotely starting xclock trough ssh, caps changes light state, network works, sound works, display backlight is on.

When trying to change virtual terminal (alt-ctrl-f1), /var/log/Xorg.0.log says "(WW) I810(0): Extended BIOS function 0x5f05 failed.". Restarting gdm does not show image on display. X works otherwise, I can log in if I type blindly.

Using Dapper with updates of 2006-05-20, Linux 2.6.15-22, xserver-xorg 7.0.0-0ubuntu44, xserver-xorg-driver-i810 1.4.1.3-0ubuntu5. Not using any special boot parameters. This test was done with 915resolution. The problem exists also without 915resolution as I tested a couple of days ago.

Thanks for these improvements!

Command outputs from 3004WTMi where display stays black after suspend-to-ram:
http://www.iki.fi/karvinen/acer_travelmate_3004wtmi_command_outputs.html

neurol23 (neurol23) wrote :

what helped me, was adding the boot parameter "acpi_sleep=s3_bios,s3_mode" in the grub. as far as i know in some computers only s3_bios or s3_mode is neeeded (not both)

Suspend-to-ram works now with i915. I am bypassing the blank screen problem with xorg.conf 'Option "VBERestore" "true"' and /etc/default/acpi-support 'DOUBLE_CONSOLE_SWITCH=true'
http://www.iki.fi/karvinen/acer_travelmate_3004wtmi_with_linux.html

This bug is now very similar to bug #46064.

jan_k (wobble-gmx) wrote :

I have the same symptoms on an Acer Travelmate 3020. ACPI2.0b

Jan_k: does my fix work on your Acer Travelmate 3020? I think it should work, as the hardware is very similar. The fix:
http://myy.helia.fi/~karte/acer_travelmate_3004wtmi_with_linux.html

Same problem on Dell Inspiron 6400 bios A14.

^^ this is on Ubuntu 7.04 AMD64.

AngelFire (angelfire) wrote :

Hello

I have installed UBUNTU 7.04, kernel 2.6.20-16 onto a Pentium 4 2 GHZ 1G ddr, TRAVELMATE 422 LC.
I still have the same problem all them above said.
The wake up from standby and hybernate does not work at all.

Regards
Angelfire

marc28 (marc-lopato) wrote :

Same problem here with UBUNTU 7.04, kernel 2.6.22-9 onto a Pentium 4 1.7 GHz, Panasonic CF-Y4.
-> the laptop does not go to sleep when close the lid
-> when I suspend it manually, it goes into sleep, but no way to wake up, the only solution is rebooting
-> hybernate does not work, it only puts the laptop in a freeze position, with black screen, and no way to wake up

I tried everything that I found on forums, but nothing worked so far
Cheers

tuharsky (tuharsky) wrote :

The same problem on
Ubuntu 7.04, notebook HP Compaq nx9105 (AMD Athlon XP-M, nVidia chipset and graphics)
Ubuntu 7.10b1, notebook HP Compaq nx6310 (Intel Core Solo, Mobile 945GM, 82801 SATA)

tuharsky (tuharsky) wrote :

Ubuntu 7.10b1, notebook HP Compaq nx6310:

[ 8.338809] Magic number: 11:476:840
[ 8.338903] hash matches device ptyu6

Ubuntu 7.04, notebook HP Compaq nx9105:

[ 16.454513] Magic number: 11:50:573
[ 16.454611] hash matches device ptyb5

Jason Fischer (jasonfischer) wrote :

Have a Toshiba Satellite A130 running 7.10. Hibernate works great, suspend works great as well as long as I don't have compiz stuff enabled. Using the regular desktop manager I can suspend/recover just fine, including my wireless. Running compiz basic or advanced I just get the black screen and have to power down.

Let me know if I can provide you with more information.

unggnu (unggnu) wrote :

Could everybody please recheck with Gutsy Gibbon?

Changed in linux-source-2.6.15:
status: New → Incomplete
tuharsky (tuharsky) wrote :

For me on HP Compaq nx6310, still dosent wake up.

Tobias McNulty (tmcnulty1982) wrote :

I have this problem with Gutsy after reverting to the vesa driver, because of the outstanding issue with fglrx+s2ram. I don't have any desktop effects enabled.

This is a ThinkPad T60 (ATI Radeon Mobility X1400). Thanks.

Tobias McNulty (tmcnulty1982) wrote :

I should clarify: some things turn back on, like the fan, hard disk, and display, but the display just hangs with a flashing _ followed 10 or so characters later by a yellow "inu".

Tobias McNulty (tmcnulty1982) wrote :

Maybe everyone else realizes this already, but I just realized that a very usable workaround for this problem is to boot the older kernel in gutsy, 2.6.20-16. With that kernel I can sleep and wake up with no problem. On a side note, that kernel also works with the fglrx proprietary driver.

unggnu (unggnu) on 2007-11-19
Changed in linux-source-2.6.22:
status: Incomplete → New

Hi All,

First, For those of you who still experience issues against the 7.10 Gutsty Gibbon release and your hardware differs from the original bug reporter, can you please open a new bug report? It's helpful to the kernel team if bug reports can focus on a single issue against a specific set of hardware. Thanks.

Secondly, Tero, can you confirm the issue still exists against the 7.10 Gutsy Gibbon release? If so, the Hardy Heron kernel was recently uploaded for testing. We'd really appreciate it if you could try testing with this newer kernel and verify if this issue still exists. Unfortunately, the Hardy Heron Alpha1 LiveCD was released with the older 2.6.22 kernel. You'll have to manually install the newer Hardy Heron kernel in order to test. This should not be the case for Alpha2 which is set to come out around Dec 20. However, here are the instructions to install if you choose to do so, otherwise just wait for Alpha2 to come out:

1) edit the file /etc/apt/sources.list and add the following line:

deb http://archive.ubuntu.com/ubuntu hardy main restricted

2) sudo apt-get update
3) sudo apt-get install linux-image-2.6.24-1-generic
4) reboot and select the new kernel from the grub menu

After you've tested, please feel free to revert back - ie boot into the old kernel, sudo apt-get remove linux-image-2.6.24-1-generic, and remove the line from /etc/apt/sources.list . Please update this report with your results. Thanks in advance!

Changed in linux-source-2.6.22:
status: New → Incomplete
Changed in linux:
status: New → Incomplete
Tobias McNulty (tmcnulty1982) wrote :

Thinkpad T60 users can use bug #173722 to discuss this problem. I've done the testing requested by Leann and posted the results there.

Murali (mshanker) wrote :

Machine: Toshiba Protege M200

Kernel: Linux version 2.6.22-14-generic (buildd@terranova) (gcc version 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)) #1 SMP
Distribution: 7.10

It was working fine in the older versions of Ubuntu, and even when I upgraded to 7.10. I now had to reinstall 7.10 completely, after trying 8.04 alpha.

In 7.10 now, my experiences for Hibernation and Suspend are similar to many of the posts above. The screen remains completely blank, and while there is harddrive activity, I can't see anything on the screen. The only option that works is to poweroff and restart.

When I tried 8.04 alpha version with the 2.6.24 development kernel, the issue was again similar.

I do have the nvidia restricted driver on

Murali (mshanker) wrote :

After more testing, it appears that the nvidia driver is creating the problem. Using the NV driver, suspend and hibernate works fine with the current kernel (2.6.22-14).

But I have ATI Mobility Radeon 7500.
Regards
----- Original Message -----
From: "Murali" <email address hidden>
To: <email address hidden>
Sent: Wednesday, January 09, 2008 3:54 PM
Subject: [Bug 33372] Re: Cannot wake up from suspend and hibernate

After more testing, it appears that the nvidia driver is creating the
problem. Using the NV driver, suspend and hibernate works fine with the
current kernel (2.6.22-14).

--
Cannot wake up from suspend and hibernate
https://bugs.launchpad.net/bugs/33372
You received this bug notification because you are a direct subscriber
of the bug.

Again, if you have hardware which differs from the original bug reporter, please open a new bug report.

I just wanted to add an update to this report. Hardy Alpha2 and subsequent releases contain an updated version of the kernel. You can download and try the new Hardy Heron Alpha release from http://cdimage.ubuntu.com/releases/hardy/ . You should now be able to then test the new kernel via the LiveCD. Please note that you can only test Suspend from the LiveCD, not Hibernate. Tero (or anyone with the same hardware) if you can verify if this bug still exists or not and report back your results it would be appreciated. General information regarding the release can also be found here: http://www.ubuntu.com/testing/ . Thanks.

tuharsky (tuharsky) wrote :

With Gutsy, HP nx9105 with nVidia NV17 [GeForce4 450 Go 32M] rev.a3
I see the same results. With distributional driver, it works. With nVidia propietary one, it dosen't.

meim1000 (meim1000) wrote :

I have feisty fawn and i had the same problem with hibernate. I followed tuharsky's directive and removed nvidia-glx and now comes back from hibernation

Care to please test with the latest Hardy Alpha release? Thanks.

Also, this report will remain open against the actively developed kernel but will be closed against 2.6.22. Thanks.

Changed in linux-source-2.6.22:
status: Incomplete → Won't Fix

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

jan_k (wobble-gmx) wrote :

This issue has been fixed for my Acer Travelmate 3020 on Gutsy/2.6.49-19. Hibernate and suspend work flawlessly.

jan_k (wobble-gmx) wrote :

2.6.24-19! Probably already fixed in earlier versions.

Marking this Fix Released per the last comment. Thanks.

Changed in linux:
status: Incomplete → Fix Released
sam88824 (sam88824) wrote :

 have used ubuntu since dapper 6.06 and standby and hibernate never worked. I am now using ubuntu 8.04 on three different compaq presario none will wake after going to standby i have to unplug the machine and plug it back in because power button will do nothing. Moving the mouse should wake from standby but does not.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers