Ubuntu

standby does not turn off fan, wakeup fails

Reported by guerilla on 2007-11-01
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

When sending the machine into standby aka suspend-to-ram (preferable from KDE using the respective logout option), most devices are powered off, but some kind of fan keeps running (most probably the CPU fan, but I didn't open the box). Even worse, any attempt to wake the machine up again fails - the machine doesn't respond in any way when I hit the power button.
The same thing happens with suspend-to-disk.
This was working very well with Feisty.
I tried the Kubuntu Gutsy Live CD to make sure that this isn't an issue with the upgrade from Feisty, but got the exactly same results (fan not turned off, no wakeup possible).
I also tried the nv driver to check if this is an issue with the proprietary nvidia driver - also no use.
Here's some additional information (sorry about not attaching these - I searched the GUI for hours but couldn't find an option to attach files...)

uname -a:
Linux carcass 2.6.22-14-386 #1 Sun Oct 14 22:36:54 GMT 2007 i686 GNU/Linux

cat /proc/version_signature:
Ubuntu 2.6.22-14.46-386

guerilla (raspl) wrote :

Looks like the option to attach files is only available for updates - and only one at a time. Still, here is the rest

guerilla (raspl) wrote :

And here the other half of the rest ;)

guerilla (raspl) wrote :

According to th ACPI FAQ, the output of dmidecode is also not such a bad idea - here it is!

guerilla (raspl) wrote :

Just tried the previous 2.6.20 kernel (had to switch back to the nv driver since the binary nvidia modules were not compatible), and standby works more or less there: The machine powers down correctly, including all fans. Wakeup starts the machine again, but the video adapter doesn't come up anymore - which is a know problem and the reason why I switched to the proprietary nvidia driver.
This seems to be more proof that this is a problem in the 2.6.22 kernel.

I had the same experience on my Apple iMac 4. (Which has an ATI video card instead of Nvidia. Also, running gnome instead of KDE.) This was after an upgrade from fiesty to gutsy.

When I tried to suspend, the machine nearly powered down but a fan was still running. Nothing would wake the machine. It was kernel
2.6.22-14-generic that failed for me. Didn't seem to matter if I was using the proprietary ATI drivers or not.

After reviewing several similar bugs, I reverted to kernel 2.6.20-15-generic (I reinstalled the deb from fiesty) and suspend/resume works ok.

The Hardy Heron kernel was recently uploaded for testing. We'd really appreciate it if you could try testing with this newer kernel and verify if this issue still exists. Unfortunately, the Hardy Heron Alpha1 LiveCD was released with the older 2.6.22 kernel. You'll have to manually install the newer Hardy Heron kernel in order to test. This should not be the case for Alpha2 which is set to come out around Dec 20. However, here are the instructions to install if you choose to do so, otherwise just wait for Alpha2 to come out:

1) edit the file /etc/apt/sources.list and add the following line:

deb http://archive.ubuntu.com/ubuntu hardy main restricted

2) sudo apt-get update
3) sudo apt-get install linux-image-2.6.24-1-generic
4) reboot and select the new kernel from the grub menu

After you've tested, please feel free to revert back - ie boot into the old kernel, sudo apt-get remove linux-image-2.6.24-1-generic, and remove the line from /etc/apt/sources.list . Please update this report with your results. Thanks in advance!

Changed in linux:
status: New → Incomplete

Also just adding a note that this report will remain open against the actively developed kernel. However, against linux-source-2.6.22 this bug does not meet the criteria for a stable release update and is being marked as Won't Fix. You can learn more about the stable release update process at ttps://wiki.ubuntu.com/StableReleaseUpdates . Thanks!

Changed in linux-source-2.6.22:
status: New → Won't Fix
guerilla (raspl) wrote :

I tried kernel 2.6.24-1 in my _Feisty_ installation. I couldn't get X up since the drivers for my NVidia card didn't fit that kernel, but I figured that shouldn't matter. So I did a 'echo mem > /sys/power/state' from the console. However, that didn't quite work - the machine still didn't go into standby, most notably even the monitor was still displaying an image (though harddrives did power down).
I will try the Alpha2 CD once it comes out and report back, but I wouldn't expect any fundamental changes :(

Gordon Hopper (gohopper) wrote :

I was able to successfully suspend and resume on my iMac with the heron kernel (2.6.24-1-generic). That's good news for the new release, but not good news for guerilla, I guess.

guerilla (raspl) wrote :

Just tried the kubuntu Hardy Heron Alpha2 Live CD - and results did not change (especially as compared to installing the Hardy Kernel in my Feisty installation): Most components are still powered down, but that sole fan keeps spinning. And the monitor was still displaying a cursor on an otherwise black console. :(

Hi Guerilla,

The following might help: https://wiki.ubuntu.com/DebuggingKernelSuspend . Also, care to attach your dmesg output for the newer kernel? It might also be more useful to capture the dmesg output after attempting to suspend/resume. For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

guerilla (raspl) wrote :

Thanks for the tip!
I did as described in https://wiki.ubuntu.com/DebuggingKernelSuspend using the Hardy Alpha 2 Live CD, and here is what I found:

[ 49.221823] Magic number: 3:582:246
[ 49.221854] hash matches device ttyw2
[ 49.221930] hash matches device 0000:00:0b.0:pcie00

Now the last entry would translate to my Nvidia grafix card...now the thing is that back with Feisty, I had to install the proprietary Nvidia drivers as the free ones that come with Xorg prevented the machine to go to suspend - not sure what the behavior was back then, I believe it was a bit different from what I see now. However, to rule that out I believe I would have to run Hardy with the proprietary Nvidia drivers...right? Is there a way to do so with the Live CD, or do I have to install Hardy and switch over to the proprietary Nvidia drivers? I believe I read somewhere that Ubuntu started to ship the proprietary drivers as well....
Also, I attached the info as described in the other link, generated from the Hardy Alpha 2 CD.

guerilla (raspl) wrote :
guerilla (raspl) wrote :
guerilla (raspl) wrote :

Thanks Guerilla,

While running with the LiveCD, I believe you should be able to install the 'linux-restricted-modules' package which would give you access to the Non-free modules and allow you to test. Thanks.

guerilla (raspl) wrote :

Hi Leann,
thanks for the hint! Unfortantely, it didn't work, so I finally bit the bullet and installed Alpha2 on a free partition, added the nvidia drivers and retried.
Results:
Standby still didn't work. This time, the graphics adapter powered down properly, but that fan kept on spinning. So I opened up my box to find out which fan that is. And it turns out it is the CPU fan that does not turn off.
Furthermore, I tried the debugging routine as described in https://wiki.ubuntu.com/DebuggingKernelSuspend, but this time it didn't find any matches to the hash code :(
Not sure how to proceed...
I have attached the latest system info using the Hardy Alpha 2 with proprietary nvidia drivers, taken right from the next boot after a failed attempt to go to suspend to ram.
Thanks!

Changed in linux:
assignee: nobody → ubuntu-kernel-acpi
importance: Undecided → Medium
status: Incomplete → Triaged
guerilla (raspl) wrote :

Just tried with alpha 3, no change. System info attached.

guerilla (raspl) wrote :

Just tried again with the latest Hardy kernel (2.6.24-2(?)-10), no change.

guerilla (raspl) wrote :

Retried with 2.6.24-15, no change. By the way, hibernate (suspend to disk) has the same symptoms and doesn't work either.

Andrew (andrew-rw-robinson) wrote :

I am having a similar problem with my desktop amd64 that also has an nvidia graphics card. The thing for me is that suspend works great one time. If I try it a 2nd time without rebooting, the 2nd time it will not fully power down (my power LED blinks to indicate that standby is active, but my fans - CPU and power supply - continue to run).

Like the poster, using the power button to attempt a resume on this "hung" state does nothing. I have to force a cold boot the hard way (hold power down for 4 secs).

My hibernate/suspend to disk is somewhat similar, it does not power off the machine. Instead the screen cycles odd characters across it on a black terminal window. However, if I turn the computer off at that point manually it will resume fine.

Using hibernate vs. pm-utils doesn't seem to make a difference.

I am running Hardy amd64 with nvidia drivers. I cannot use the nv driver as it doesn't support the DVI output which is my only output I have hooked up.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

*This is an automated response*

This bug report is being closed because we received no response to the previous request for information. Please reopen this if it is still an issue in the actively developed pre-release of Jaunty Jackalope 9.04 - http://cdimage.ubuntu.com/releases/jaunty . To reopen the bug report simply change the Status of the "linux" task back to "New".

Changed in linux:
status: Triaged → Won't Fix
Curtis Hovey (sinzui) on 2012-04-09
Changed in linux (Ubuntu):
assignee: Registry Administrators (registry) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers