Kernel Panic - not syncing: VFS after upgrade.

Bug #151146 reported by dutchie86 on 2007-10-10
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

I use Gutsy Gibbon beta release.

After upgrade from kernel version 2.6.22-12-generic to 2.6.22-13-generic i rebooted my computer and it worked ok. Then after installing amarok, kdevelop the system rebooted and I can no longer boot into the 2.6.22-13-generic image in both normal or recovery mode as i get a "Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)".

I can boot into kernel 2.6.22.12-generic fine.

Cheers,
Raymond

Mary Gardiner (puzzlement) wrote :

I also have this kernel panic booting into 2.6.22-14-generic.

Error:
[ 26.490409] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

I did not upgrade until gutsy final so cannot say whether or not it occured in previous 2.6.22 packages.

System boots with 2.6.20-16-generic.

Mary Gardiner (puzzlement) wrote :

Incidentluy, unlike dutchie86, I never had a working boot into 2.6.22-14-generic. It failed on the first attempted boot.

Changed in linux-source-2.6.22:
status: New → Confirmed
Mary Gardiner (puzzlement) wrote :

It turns out for me that running "update-initramfs -k all -u" to rebuild all my initrds made the kernel bootable. So in my case this is the same as bug 149565. dutchie86, if that works for you too, this bug is a duplicate.

Marty (marty-supine) wrote :

Update-manager upgrade to Gutsy from Feisty.

Booting into 2.6.22-14-generic gives the "Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)" error.

Booting into 2.6.20-15-generic works fine.

After running 'sudo update-initramfs -k all -u', booting into 2.6.22-14-generic still doesn't work.

Brian Murray (brian-murray) wrote :

I am assigning this bug to the 'ubuntu-kernel-team' per their bug policy. For future reference you can learn more about their bug policy at https://wiki.ubuntu.com/KernelTeamBugPolicies .

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
Krzysztof Pociecha (kpociecha) wrote :

I have the same error after update to Gutsy from Feisty

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Steve McInerney (spm) wrote :

Am seeing this error with an upgrade to Intrepid Ibex 8.10 beta.
"Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)"

Kernel is v2.6.27-4-generic

The prior kernel, v2.6.24-19-generic can boot to a usable state.

Changed in linux:
status: Incomplete → New
Markus Birth (mbirth) wrote :

Upgraded my Notebook today, 2.6.27-7 gives the kernel panic, the former 2.6.24-21 boots fine as usual.

IDE controller is an Intel 82801DBM (ICH4-M) 8086:24ca. The notebook is a SONY VAIO PCG-Z1XEP, Centrino M.

Markus Birth (mbirth) wrote :

UPDATE: After adding uvesafb to /etc/initramfs-tools/modules and several update-initramfs'es, the new kernel started to work. I'm not sure whether I had the 0 Byte initrd-problem or not. When I read about this problem, I already had some update-initramfs'es done and the file had a normal size of about 8MB.

dutchie86, since you are the original bug reporter, care to comment if this is still an issue for you with Intrepid's final release? Steve, do you also still see this after the final release? Thanks.

Changed in linux:
status: New → Incomplete
TJ (tj) wrote :

I've just updated an x86 system from Hardy to Intrepid and experienced the same issue.

In this case the system has encrypted RAID-5 LVM volumes for /, /var/ and /home/, all opened via a LUKS cryptographic key-file on a USB flash memory device.

The GRUB menu has been incorrectly updated and has no "initrd" entry for the Intrepid kernel (this might be reported as a new bug, depending on my findings). Booting the new Intrepid kernel gets stuck with this bug's error.

Trying to boot the previous Hardy kernel results in GRUB reporting "Error 15: File not found", even though it has an "initrd" entry that looks (from memory) to be correct.

I have to dig some more after booting from a LiveCD to discover the cause.

TJ (tj) wrote :

Update.

 I'm not sure how GRUB came to be missing the "initrd" entry for the Intrepid menu item. As I added it manually I don't feel inclined to try and track down the cause.

The failure to load the Hardy kernel appears to be because the upgrade removed all the Hardy kernels but the original -19 *but* left the corresponding GRUb menu entries intact. Therefore, when I selected to boot from Hardy I picked the first item (the -22 kernel) for which the kernel and initrd files had been deleted.

Selecting the -19 version allowed the system to start with the Hardy kernel.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Incomplete and has not had any updated comments for quite some time. As a result this bug is being closed. Please reopen if this is still an issue in the current Ubuntu release http://www.ubuntu.com/getubuntu/download . Also, please be sure to provide any requested information that may have been missing. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-expired
Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers