gutsy crash on standy or hibernate

Bug #136387 reported by Schmirrwurst on 2007-08-31
24
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: linux-source-2.6.22

When I try to standby the computer, or hibernate, the computer seems to begin with the standbye process, but it is staying on a black screen.
Nothing is responding, the capslock is blicking, and I have to power it off manually...

Schmirrwurst (schmirrwurst) wrote :
Schmirrwurst (schmirrwurst) wrote :
Schmirrwurst (schmirrwurst) wrote :

My computer is a hp pavillon zd7235ea

Thank you for your bug report. Could you copy here the output of uname -a ?

Changed in linux-source-2.6.22:
importance: Undecided → High
status: New → Incomplete
Schmirrwurst (schmirrwurst) wrote :

Linux insurection 2.6.22-10-generic #1 SMP Wed Aug 22 08:11:52 GMT 2007 i686 GNU/Linux

Thank you. I'm assigning this to the kernel team.

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
status: Incomplete → Triaged
VoteZ (votez) wrote :

The similar story with Compaq nw8240.
Nor hibernate nor suspend works. Before upgrading to Gutsy hibernate works.
Now system makes screen black and I see HDD works about 2 seconds. After I can switch to a text mode (by alt-F1) but can not type in anything. I need to power off the laptop manually. After I restart a laptop system does not "resume" but fix filesystem.
I've attached zip with output of dmesg (file per hibernate and suspend), free, kern.log, lspci

Linux alisa 2.6.22-13-generic #1 SMP Thu Oct 4 17:18:44 GMT 2007 i686 GNU/Linux

JB (jb-ubuntu1804) wrote :

Same here on Gutsy with Fujitsu Siemens Amilo A1650G

Linux laptop 2.6.22-13-generic #1 SMP Thu Oct 4 17:18:44 GMT 2007 i686 GNU/Linux

Konstantin Kostov (kostovnet) wrote :

Same for Linux laptop 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

WeaponX (neox-portatil) wrote :

Same for Packard Bell EasyNote R8770
Linux PORTATIL-NeoX 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

Chris (chris-yourdreamnet) wrote :

Confirmed on Acer Aspire 5502WXMi. Again, worked fine on Feisty.

deepdraft (dimitar.nedev) wrote :

I have the same problem on Dell Latitude D510. On Feisty it was fine.

viktor (lfraisse) wrote :

Confirmed on Shuttle AMD 64 barebone. All was fine before upgrade from feisty.
I tried to change the ACPI options in the bios, to no avail.

nitecoder (nitecoder) wrote :

Same problem on Dell Latitude D810. Suspend to RAM (and possibly hibernate) used to work correctly under feisty.
Under gutsy, the screen goes blank, with blinking cursor, but the machine never turns off. Have to turn it off with hard shutdown (press and hold the power button).
Let me know if I can provide any more details.
uname -a:
Linux mango 2.6.22-14-386 #1 Sun Oct 14 22:36:54 GMT 2007 i686 GNU/Linux

balleklorin (balleklorin) wrote :

I've got a similar bug but only with the -rt (realtime kernel):
Linux ubuntu-desktop 2.6.22-14-rt #1 SMP PREEMPT RT Sun Oct 14 22:53:32 GMT 2007 x86_64 GNU/Linux

The generic kernel 2.6.22-14 works just fine.

balleklorin (balleklorin) wrote :
Schmirrwurst (schmirrwurst) wrote :

my post was pretty old, but the bug still remains with the latest kernel version : Linux insurection 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux
My laptop is a zd7235EA from HP (pavillon)

Kurt George Gjerde (tengil) wrote :

Confirmed on HP Compaq nc8430.
Linux tavla 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

Motin (motin) wrote :

Confirmed on HP Pavilion dv4000 (Linux laptop 2.6.22-14-rt #1 SMP PREEMPT RT Mon Oct 15 01:05:51 GMT 2007 i686 GNU/Linux)

When Randall Kennedy blogged about his 5-day long "30-day Ubuntu Plunge", having this ACPI bug as the definitive reason to leave Ubuntu the same day (http://weblog.infoworld.com/enterprisedesktop/archives/2007/11/the_ubuntu_plun_4.html), Scott James Remnant informingly wrote this comment to the post:

>The rigours of a time-based release cycle mean that sometimes we have to accept regressions outside of
>our supported/certified harware set to ensure that the release can be made on time. To counter this, we
>have regular "Long Term Support" releases that have these kinds of problems more specifically targeted
> -- although again, we can still only target issues that we are able to fix; if a hardware vendor will not work
>with us, then there is little that we can do.
>Posted by: Scott James Remnant at November 11, 2007 10:27 PM

Not very hopeful, but informative.

Anyone attempted a kernel upgrade/downgrade to work around this?

Václav Šmilauer (eudoxos) wrote :

I confirm this (black screen without actually powering off) with stock -rt flavor kernel on Thinkpad X61s; -generic hibernates and suspends just fine.

Confirmed on Intel D915GAV mainboard with Pentium 4 HT 3.2 Ghz processor and Nvidia 6200 video card.

This also applies to Dell Inspiron 6400 bios A17 (Intel Core 2 Duo T5600).

A laptop that cannot be suspended simply does not work for me - back to Windows, I'm afraid.

Jan Rathmann (kaiserclaudius) wrote :

I can also confirm this issue on my desktop system with Gutsy AMD64, but only with the -rt kernel. With the generic kernel suspend to disk works just fine.

Jan Rathmann (kaiserclaudius) wrote :
Khurrum1990 (khurrum1990) wrote :

Upgrade to Hardy's kernel 2.6.24-2 fixes this problem or downgrade to Gutsy kernel 2.6.22-12. I can confirm this myself, other people should try this as well.

moses (moses-truong) wrote :

Also happening on HP Pavilion dv2308tx.

moses (moses-truong) wrote :

I can confirm on HP Pavilion dv2308tx, upgrading to Hardy's kernel 2.6.24-2 fixes problem with suspend, but hibernate still doesn't work - though it doesn't lock up the system, just blank screen, then after awhile, the screen shows the unlock screen.

moses (moses-truong) wrote :

To get hibernate to shutdown, I need to change HIBERNATE_MODE to platform in /etc/default/acpi-support.

Khurrum1990 (khurrum1990) wrote :

Oh yeah to those who upgraded to Hardy's kernel please make sure u upgrade ur nvidia drivers from the restricted repositories for Hardy. It should work then.

Khurrum1990 (khurrum1990) wrote :

Sorry, but I think ATI users need the latest drivers as well. I never used an ATI card with Linux so I don't know what package to install but u could always use Envy to install the latest drivers.

For nvidia add this repo in sources list:

deb http://archive.ubuntu.com/ubuntu/ hardy main restricted

sudo apt-get update

sudo apt-get install nvidia-glx-new

u can install the legacy version as required for ur card.

Hi All,

Thank you for your comments and helping to make Ubuntu better. The symptom of this particular bug, failure to Suspend or Hibernate, is specific to the hardware used. So while many of you may have the same symptom they really should be different bugs. It would be helpful if everyone were to test with a Hardy Alpha build, http://www.ubuntu.com/testing/ , and if the issue still exists, open a separate bug report for their hardware using "linux" as the package. The bug report should contain the information requested at http://wiki.ubuntu.com/KernelTeamBugPolicies . Additionally, it would be great if you made the titles of a new bug report contain information about your system. I apologize for any inconvenience this might cause but appreciate your cooperation.

Finally, <email address hidden>, since you are the original bug reporter. Can you comment if this issue still exists in the new Hardy Alpha release? Thanks.

Changed in linux:
status: New → Incomplete

This bug report is being closed because we received no response to the last inquiry for information. <email address hidden>, please reopen it if this is still an issue in the current Ubuntu release. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks.

Changed in linux:
status: Incomplete → Invalid
Changed in linux-source-2.6.22:
status: Triaged → Won't Fix

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers