tv card has white noise sound because module order

Bug #135583 reported by Pelládi Gábor on 2007-08-29
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.22 (Baltix)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: linux-source-2.6.22

When i start any tv viewer application (e.g. tvtime), it has only a white noise sound. The 'tuner' kernel module should be loaded before 'bttv'.

Workarund 1:
This has to be repeated after every boot.
sudo rmmod bt878 && sudo rmmod bttv && sudo rmmod tuner && sudo modprobe tuner && sudo modprobe bttv

Workaround 2:
/etc/modprobe.d/blacklist: blacklist bt878, bttv, tuner
/etc/modules: add tuner, bttv

Either the module loading order should be forced, or the kernel should be adjusted to work in any order.

Pelládi Gábor (pelladigabor) wrote :
Henrik Nilsen Omma (henrik) wrote :

Thanks for reporting and providing debugging info. Milestoning for beta since this seems like a relatively easy fix.

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Low
status: New → Confirmed
Colin Watson (cjwatson) wrote :

Moving milestone forward. Could somebody from the kernel team respond to this?

Pelládi Gábor (pelladigabor) wrote :

Just tested this with current Intrepid. Still the same problem, and the same solution.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Sergio Zanchetta (primes2h) wrote :

The 18 month support period for Gutsy Gibbon 7.10 has reached its end of life -
http://www.ubuntu.com/news/ubuntu-7.10-eol . As a result, we are closing the
linux-source-2.6.22 kernel task. It would be helpful if you could test the
new Jaunty Jackalope 9.04 release and confirm if this issue remains -
http://www.ubuntu.com/getubuntu/releasenotes/904overview. If the issue still exists with the Jaunty
release, please update this report by changing the Status of the "linux (Ubuntu)"
task from "Incomplete" to "New". Also please be sure to run the command below
which will automatically gather and attach updated debug information to this
report. Thanks in advance.

apport-collect -p linux-image-2.6.28-11-generic 135583

Changed in linux-source-2.6.22 (Ubuntu):
status: Confirmed → Won't Fix
Changed in linux-source-2.6.22 (Baltix):
status: New → Invalid
Changed in linux (Ubuntu):
status: New → Incomplete
Kenneth Chai (kennethc) wrote :

I can confirm this bug in Ubuntu 9.04. I'm using a Pinnacle PCTV capture card using the bttv driver. Right after a reboot, tvtime will only output static as sound, but if I run these commands:

sudo modprobe -r bt878 bttv
sudo modprobe snd_bt87x
sudo modprobe bt878

and then run tvtime, I will get sound as normal. This workaround was taken from a related (same?) bug #49528.

Architecture: amd64
DistroRelease: Ubuntu 9.04
HibernationDevice: RESUME=UUID=44eddce6-c526-481c-acb5-de7d0b3ed8c9
MachineType: System manufacturer System Product Name
NonfreeKernelModules: fglrx
Package: linux-image-2.6.28-11-generic 2.6.28-11.42
PackageArchitecture: amd64
ProcCmdLine: root=UUID=16f4a48a-322b-445a-af59-f2e21ed27def ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_AU.UTF-8
ProcVersionSignature: Ubuntu 2.6.28-11.42-generic
Uname: Linux 2.6.28-11-generic x86_64
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin mythtv netdev plugdev powerdev scanner video

Kenneth Chai (kennethc) wrote :
Kenneth Chai (kennethc) wrote :
Kenneth Chai (kennethc) wrote :
Kenneth Chai (kennethc) wrote :
Kenneth Chai (kennethc) wrote :
Kenneth Chai (kennethc) wrote :
Kenneth Chai (kennethc) wrote :
Kenneth Chai (kennethc) wrote :
Kenneth Chai (kennethc) wrote :
Changed in linux (Ubuntu):
status: Incomplete → New
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Triaged a while ago but has not had any updated comments for quite some time. Please let us know if this issue remains in the current Ubuntu release, http://www.ubuntu.com/getubuntu/download . If the issue remains, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Kenneth Chai (kennethc) wrote :

This bug is fixed for me as of Ubuntu 9.10. The tv card now outputs sound as expected after each boot. Thank you!

Jeremy Foshee (jeremyfoshee) wrote :

Kenneth,
    Thank you for following up. I'm marking this bug Fix Released.

Thanks!

~JFo

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers