Ubuntu

Feisty Beta does not recognise CD burner

Reported by Robin T Cox on 2007-03-27
16
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned

Bug Description

Using K3b 0.2.17 (KDE 3.5.6), and have also tried Gnomebaker without success. CD writer is a Liteon 48125, which works perfectly with both Edgy and Dapper on my 3-hard drive system. This also worked fine with Feisty until Kernel 2.6.20-11, but not from Kernel 2.6.20-12 onwards.

I have tried modifying my fstab (but to no avail) as follows:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/sda1 /media/hda1 ext3 user,atime,noauto,rw,dev,exec,suid 0 0
/dev/sdb1 /media/hdb1 ext3 user,atime,noauto,rw,dev,exec,suid 0 0
/dev/sdb3 /media/hdb3 ext3 user,atime,noauto,rw,dev,exec,suid 0 0

/dev/sdc1 / ext3 nouser,defaults,errors=remount-ro,atime,auto,rw,dev,exec,suid 0 1
/dev/sdc5 none swap sw 0 0
/dev/sdd /media/cdrom0 udf,iso9660 user,atime,noauto,rw,dev,exec,suid 0 0
/dev/fd0 /media/floppy0 auto user,atime,noauto,rw,dev,exec,suid 0 0

#Original Feisty fstab

# <file system> <mount point> <type> <options> <dump> <pass>
#proc /proc proc defaults 0 0
# /dev/sdc1
#UUID=48f2e9bb-7358-45bd-8bee-b863a7e43dbd / ext3 nouser,defaults,errors=remount-ro,atime,auto,rw,dev,exec,suid 0 1
# /dev/sdc5
#UUID=72f6ae6d-4b4d-0188-0337-40e2468c22f4 none swap sw 0 0

#/dev/sdd /media/cdrom0 udf,iso9660 user,noauto 0 0

#/dev/sda1 /media/hda1 auto user,noauto 0 0
#/dev/sdb1 /media/hdb1 auto user,noauto 0 0
#/dev/sdb3 /media/hdb3 auto user,noauto 0 0

#/dev/fd0 /media/floppy0 auto user,noauto,rw 0 0

The hard disks are recognised OK, but not the CD burner.
KinfoCentre shows device sdd, but when I tell it to mount the drive with a CD/RW disk loaded, says no medium found.

##################################
<device> none auto nouser,noauto,atime,rw,nodev,noexec,nosuid 0 0

ProblemType: Bug
Architecture: i386
Date: Tue Mar 27 06:18:06 2007
DistroRelease: Ubuntu 7.04
Uname: Linux kubuntu 2.6.20-13-generic #2 SMP Sun Mar 25 00:21:25 UTC 2007 i686 GNU/Linux

Robin T Cox (robin-cox) wrote :

This problem is now rectified. This morning's updates have cured the problem, and my system now recognises the CD burner.

Robin T Cox (robin-cox) wrote :

Correction: problem is not rectified.

Unfortunately, having recognised my CD burner once, Feisty has now returned to her bad old ways post-2.6.20-12 and does not recognise it again.

My fstab is:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/sda1 /media/hda1 ext3 user,noauto,rw,dev,exec,suid 0 0
/dev/sda5 none swap sw 0 0
/dev/sdb1 /media/hdb1 ext3 user,noauto,rw,dev,exec,suid 0 0
/dev/sdb3 /media/hdb3 ext3 user,auto,rw,dev,exec,suid 0 0
/dev/sdc1 / ext3 nouser,defaults,errors=remount-ro,atime,auto,rw,dev,exec,suid 0 1
/dev/sdc5 none swap sw 0 0
/dev/sdc0 /media/cdrom0 udf,iso9660 user,auto,rw 0 0
/dev/fd0 /media/floppy0 auto user,auto,rw 0 0

Since my last report I have tried changing sdd to sdc0, to no avail.

Both Edgy and Dapper work fine on the same machine.

Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add the full output of 'dmesg' as an attachment to your bug report? Thanks in advance.

Robin T Cox (robin-cox) wrote :

Brian,

Output of dmesg attached as requested.

Robin T Cox

Robin T Cox (robin-cox) wrote :

Please also see discussion in Ubuntu Forums thread:

http://www.ubuntuforums.org/showthread.php?t=393614

I have just re-installed kernel 2.6.20-11, and verified that my K3b recognises the CD drive properly with it. So it seems that some change in kernels 2.6.12 and 13 is preventing this.

Brian Murray (brian-murray) wrote :

When you say reinstalled the old kernel do you mean that actually installed the older kernel or chose that kernel in grub? Could add the 'dmesg' output when running the older kernel? Thanks again.

Robin T Cox (robin-cox) wrote :

Prior to the issue of Feisty Beta I had had 2.6.20-11 installed on my system (on hdc1) as part of the earlier Feisty package. Then 2.6.20-12 was added as an upgrade, but I found that that kernel first gave me this problem.

When Feisty Beta was issued, I installed it on hdc1, overwriting my previous Feisty, and so I lost my working 2.6.20-11 kernel. IIRC Feisty Beta came with 2.6.20-12 and then 2.6.20-13 was added as an upgrade. With neither of these kernels does K3b Setup recognise my CD drive.

Yesterday, reading the Ubuntu forums thread:

http://www.ubuntuforums.org/showthread.php?t=393614

I found that poster picpak reported that he had had the same problem as me, and had located and installed the deb of 2.6.20-11:

http://mirror.linux.org.mt/mirror/ubuntu/pool/main/l/linux-source-2.6.20/linux-image-2.6.20-11-generic_2.6.20-11.18_i386.deb

I downloaded and installed this into my Feisty Beta, and found that as before, K3b Setup recognises my CD drive correctly.

To enable you to figure out what might be going on, I attach the following:

- my /boot/grub/menu.lst
- my /etc/fstab
- the dmesg output when I run each of the kernels 20.6.11, 12 and 13

Robin T Cox (robin-cox) wrote :
Robin T Cox (robin-cox) wrote :
Robin T Cox (robin-cox) wrote :
Robin T Cox (robin-cox) wrote :
Robin T Cox (robin-cox) wrote :
Gary (oliaro) wrote :

With Feisty alternate CD install 3/27/07, 2.6.20-13-generic #2 SMP, my Cendyne (Lite-on?) 40125s CD-RW (40x12x48x) is not recognized and causes a delay in startup of approximately 3 minutes. dmesg is the same as others:
...
[ 23.970397] ata2.00: ATAPI, max UDMA/44
[ 24.134131] ata2.01: ATAPI, max UDMA/33
[ 24.290100] ata2.00: configured for UDMA/44
[ 24.565794] ieee1394: Host added: ID:BUS[0-00:1023] GUID[00309526b0086389]
[ 54.261695] ata2.01: qc timeout (cmd 0xef)
[ 54.261705] ata2.01: failed to set xfermode (err_mask=0x4)
[ 54.261711] ata2: failed to recover some devices, retrying in 5 secs
[ 60.060545] ata2.00: configured for UDMA/44
[ 90.032158] ata2.01: qc timeout (cmd 0xef)
[ 90.032168] ata2.01: failed to set xfermode (err_mask=0x4)
[ 90.032177] ata2.01: limiting speed to UDMA/33:PIO3
[ 90.032180] ata2: failed to recover some devices, retrying in 5 secs
[ 95.830998] ata2.00: configured for UDMA/44
[ 125.802596] ata2.01: qc timeout (cmd 0xef)
[ 125.802606] ata2.01: failed to set xfermode (err_mask=0x4)
[ 125.802612] ata2.01: disabled
[ 125.802617] ata2: failed to recover some devices, retrying in 5 secs
[ 130.801913] ata2.00: failed to set xfermode (err_mask=0x40)
[ 130.801921] ata2: failed to recover some devices, retrying in 5 secs
[ 136.436911] ata2.00: configured for UDMA/44
[ 136.437121] scsi 0:0:0:0: Direct-Access ATA WDC WD3200JB-00K 08.0 PQ: 0 ANSI: 5
[ 136.437659] scsi 0:0:1:0: Direct-Access ATA WDC WD800BB-00CA 17.0 PQ: 0 ANSI: 5
[ 136.438060] scsi 1:0:0:0: CD-ROM JLMS DVD-ROM LTD-166S DS0B PQ: 0 ANSI: 5
[
...

Robin T Cox (robin-cox) wrote :

Following today's updates, the K3b fault is now intermittent on my system.

I thought it would be helpful to attach a copy of my dmesg after a) a boot following which K3b recognised my CD burner, and b) a boot following which it did not.

Gary (oliaro) wrote :

I just tried the new 2.6.20-14-generic kernel and still no CD-RW burner. This just started with the Beta release. The burner worked fine with the Herd releases and Edgy. Funny thing is that this is the drive I use to install Feisty!?

Gary (oliaro) wrote :

Folks,

I did an update minutes ago and noticed that there were some kernel changes going from 2.6.20.14.11 to 2.6.20.14.12. Sorry I don't know how to get the log of these changes, however, my CD-RW is now working! Thanks.

Gary (oliaro) wrote :

Folks,

Oops, please disregard the last post. The reason the CD-RW works now is because I booted with a blank CD-R in the drive. I burned a disk just fine. So it seem that If I leave a CD-R disk in the drive, the Kernel discovers the burner.

Robin T Cox (robin-cox) wrote :

My Feisty 2.6.20.14 also still does not recognise the CD burner.

Robin T Cox (robin-cox) wrote :

Kubuntu (Feisty) 7.04 release version (kernel 2.6.20.15-generic) has the same intermittent fault. CD burner is not recognised by kinfocenter, systemsettings or k3b.

I did an online update from Edgy and Feisty doesn't even see my CD drive. There's nothing I can find in my /dev folder that looks remotely like an optical drive. My sources.lst doesn't show it either, but that may be due to the fact that I didn't update from a disc.

Robin T Cox (robin-cox) wrote :

There is now a work-round that cures this fault.

Add the word 'irqpoll' (without quotes) to the kernel line in /boot/grub/menu.lst thus:

kernel /boot/vmlinuz-2.6.20-15-generic root=UUID=48c5a348-eb39-4171-8531-671a49fdb75b ro quiet splash irqpoll

Then Feisty will boot faster, and the Liteon CD burner will be recognised.

See:

http://ubuntuforums.org/showthread.php?t=414002&page=2

I just saw that while looking for a solution to another problem. Damn, it's nice to have the old boot speed back. Getting my CD drive back is gravy. What a great way to start a new week!

Thanks, devs!

beerfan (beerfan) wrote :

The irqpoll boot option doesn't work for me. I tried that and I tried disabling my cdrom in the bios but neither has any effect. I've attached my dmesg output.

yeti (utu) wrote :

The irqpoll addition to the kernel line works for me.

There is another work-around which is easy to try
mentioned in Bug 105437.

Ubuntu folks should co-ordinate this Bug 96826 with Bug 103410.

I had the same problem with my Sony drive and 'irqpoll' works for me.

memroj (memroj) wrote :

For me the same, 'irqpoll' is a good workaround, but I'd rather see the real problem solved. I had the 3-minutes boot delay since kernel 2.6.20-12.

Reading up on kernel options,

I found the following notes on irqpoll in:
usr/share/doc/kernel-doc-2.6.21/Documentation/kernel-parameters.txt

irqpoll ....(detail deleted)....

.... Intended to get systems with badly broken
firmware running.

Maybe, as Pogo said:
   'We have found the enemy, and we are it.'

__________________________________________________
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Robin T Cox (robin-cox) wrote :

<quote>
Maybe, as Pogo said:
   'We have found the enemy, and we are it.'
</quote>

Hardly. Feisty recognised the firmware in our CD burners up to and including 2.6.20-11, but then something in the kernel changed so that it no longer did.

However, it does look as if irqpoll is able to paper successfully over the cracks in the new kernel.

Everything seems to work now as it should with kernel 2.6.20-16. Boot time is normal now with and without irqpoll.

yeti (utu) wrote :

irqpoll still needed here.

Robin T Cox (robin-cox) wrote :

K3b works OK now with 2.6.20-16, without irqpoll.

Again here qc timeout and that stuff after update to 2.6.20-16.28. irqpoll needed again... :-(

Robin T Cox (robin-cox) wrote :

Yes, I'm now using 2.6.20-16-generic and I also need irqpoll again.

yeti (utu) wrote :

Fedora 7 has solved this problem for my hardware.

Its latest kernel, 2.6.21-1.3228.fc7, no longer needs 'irqpoll' (here, anyway) to get around the long boot-up delay and the lack of access to some ide resources.

This is a little bit ahead of the 2.6.22 'upstream' kernel patch rumored to address this problem.

The irqpoll work-around has been a satisfactory work-around for my ubuntu install. I can't say I've found any downside to it in my uses of linux, which are all pretty tame things like wireless, firefox, openoffice and such.

Serhiy Kachaniuk (serzholino) wrote :

I have this problem with Gutsy. irqpool didn't help here. kernel image pakage is of version 2.6.22-14.46.
Similar problem was with original Feisy's kernel, but then upgrade to 2.6.20-16.28 helped. Then there was another one kernel update in Feisty wich had this problem again, so i was using 2.6.20-16.28 prior to my upgrade to Gutsy

See also bug #114081

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Jonathan Thomas (echidnaman) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux:
status: Incomplete → Invalid

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers