Ubuntu

Regression: RealTek 8139 hard-locks system on installation/modprobe (affects Averatec, Philips laptops)

Reported by Nikhil on 2007-03-07
98
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Tim Gardner
linux-source-2.6.20 (Ubuntu)
High
Unassigned
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

Install Feisty Fawn Herd 5 or Edgy Eft and the installation hangs while autodetecting the RealTek "8139too" or "8139cp" driver. This used to work flawlessly in Hoary HedgeHog.
I have tried with acpi off , apic off , lapic off, noirq etc but no effect. This happens on an everex 2052T,averatec and/or Phillips x56 laptop.

CVE References

Mark Reitblatt (mark-reitblatt) wrote :

Could you please explain what you mean by "hangs"? Does the kernel 'Oops' or does it just sit there for a long time? How do you know where it is hanging?

Hi Mark,

By "hangs" I mean it just sits there being totally unresponsive to any input
(keyboard etc). The only way to get around this is to hold the power button
to do a forced power off.

BTW, the place where it gets stuck is when it tries to load to the Realtek
8139cp module then tries to load the 8139too module. Right after it loads
the 8139too module it completely freezes.

This does not happen on on Ubuntu 5.10 but anything after that does not
work. So to install Ubuntu 6.10, I have to install 5.10 then upgrade
to 6.04then
6.10. All the while, using the same kernel from 5.10.

If I want to use any later kernel versions I have to blacklist these modules
(8139cp & 8139too) to prevent them from being loaded on bootup. But this is
kind of useless since I need an internet connection to do anything
meaningful.

This issue is common around the net as I did some research and lots of
people are running into this problem where they cannot even run the Live CD
of any ubuntu version after 5.10.

I hope this answers your question. I cannot provide a log of this since the
machine freezes completely. If you need anything else let me know as I'd
like to see this fixed in Feisty before its released. Or else I will be
stuck in Windows hell, esp. Vista hell since that is what this machine comes
pre-loaded with.

Regards,
Nik

On 3/6/07, Mark Reitblatt <email address hidden> wrote:

> Could you please explain what you mean by "hangs"? Does the kernel
> 'Oops' or does it just sit there for a long time? How do you know where
> it is hanging?
>
> ** Changed in: Ubuntu
> Sourcepackagename: None => linux-source-2.6.20
> Importance: Undecided => High
> Status: Unconfirmed => Needs Info
>
> --
> RealTek 8139 hard-locks system on installation/modprobe
> https://launchpad.net/bugs/90271
>

The reason this happens is because Ubuntu(>5.10) ships with the 8139too module in MMIO mode whereas 5.10 ships with the module in PIO mode. Is there anyway to ship the default kernel on the install/livecd with the 8139too module in PIO mode?

Ben Collins (ben-collins) wrote :

When setting "Needs Info" assign the bug to yourself for follow up.

Changed in linux-source-2.6.20:
assignee: nobody → mark-reitblatt
Fabián Rodríguez (magicfab) wrote :

I can confirm this on Ubuntu 7.04 Herd 5. This is most probably a regression from Edgy, see Bug #48263 for a workaround / explanations .

Fabián Rodríguez (magicfab) wrote :

I tried the workaround mentioned in Bug #48263 (acpi=noirq option) and CPU is back to normal, requesting wireless / network connection no longer freezes the kernel. This seems to be the same bug (regression).

Changed in linux-source-2.6.20:
assignee: mark-reitblatt → ben-collins
status: Needs Info → Confirmed
Ben Collins (ben-collins) wrote :

Fabian: Please read https://wiki.ubuntu.com/KernelTeamBugPolicies

Confirmed bugs get assigned to the kernel team until one of use takes the bug to work on it, in which we change it to "In Progress".

Changed in linux-source-2.6.20:
assignee: ben-collins → ubuntu-kernel-team
Fabián Rodríguez (magicfab) wrote :

Sorry for that, I was a bit quick on the trigger. I appreciate the link and explanation. How can one best evaluate the chances of this being fixed for /before release ?

Fabián Rodríguez (magicfab) wrote :

Last night's update included a " distribution update" which overwrite my /boot/grub/menu.lst file, effectively removing the workaround. A minor inconvenience, but I think this will happen with every kernel update until release. Can someone confirm this ?

I'm having the same problem on my Averatec 2460 laptop. Adding acpi=noirq doesn't help. I'm now running Gentoo with 8139too in PIO mode, recompiling the kernel with 8319too in MMIO mode gives me an unbootable system. Any changes that this gets fixed? I wasn't able to install any of the last 3 Ubuntu releases!

You have to install Ubuntu 5.04 and then compile your own kernel with
8139too in PIO mode... after which you can upgrade to the latest version
but have to take care that you boot from your custom kernel failing
which it will not boot.

el3ktro wrote:
> I'm having the same problem on my Averatec 2460 laptop. Adding
> acpi=noirq doesn't help. I'm now running Gentoo with 8139too in PIO
> mode, recompiling the kernel with 8319too in MMIO mode gives me an
> unbootable system. Any changes that this gets fixed? I wasn't able to
> install any of the last 3 Ubuntu releases!
>
>

Fabian: Anything you change between the ### BEGIN AUTOMAGIC KERNELS LIST and ### END DEBIAN AUTOMAGIC KERNELS LIST lines except for "Default Options" section will get wiped out on an update. What you want to do is change the line "kopt=foo" in the "Start Default Options" section.

Fabián Rodríguez (magicfab) wrote :

Correct. I should have mentioned that in the workaround provided, I hadn't thought of it.

Thank you!

skrpc (skrpc) wrote :

I have found that the problem seems to be with the sdhci driver.

I have posted a message at http://ubuntuforums.org/showthread.php?t=287939&page=4 under the name skrpc detailing what I did to get a version of linux on an X56 laptop. I had to use Debian 4 (Etch) as this was the only installation I could find that did not freeze and allowed me to complete an installation. It froze when rebooting after the installation had completed but as the installation had completed I could use rescue mode enabling me to rebuild my own custom version of the the linux kernel (2.6.18.4) and by a process of driver elimination led me to remove the module load of the sdhci driver and all works ok now albeit using Debian 4 rather than Ubuntu.

All affected Laptops are Twinhead H12Y OEM Models. This laptop has one problem with the 8139too if it use MMIO (PIO works) and an other with the sdhci modul. Both modules crash without any reaction after loading.

This problem is also present in the new Ubuntu 7.10

levander (levander) wrote :

What happens on the box I just built using an old Realtek 8139 card I had lying around is that the 8139too driver will load. But, after using the network for a while, the whole computer will hang.

I finally figured out to swap the Realtek 8139 card out for a Linksys and my computer is running flawlessly.

That does leave the posibility that my problem is a bad NIC and not some issue with the driver. I haven't tried the NIC under another operating system.

I was able to reproduce the problem in a simple test case here by simply downloading a 700 MB iso image. It would consistently hang within an hour with the Realtek, it always worked fine with the Linksys.

@lavander On my other PC Ubuntu works fine with a 8139c and mmio acess. The H12Y crash after the 8139too module was loaded. I have no time to use the network. The same efect happens when the sdhci module is loaded. So i think the problem is not inside the driver's itself.

Jerzy Jalocha N (jjalocha) wrote :

7 duplicates reported, so far.
Affects the following systems:
 * Averatec 2460
 * Everex Stepnote SA2050
 * Everex Stepnote SA2050T
 * Everex StepNote SA2052T
 * Everex StepNote SA2053T
 * Philips Freevents x52
 * Philips Freevents x53
 * Philips Freevents x54
 * Philips Freevents x55
 * Philips Freevents x56
 * Twinhead H12Y

The Hardy Heron Alpha series was recently released. Alpha2 and subsequent releases contain an updated version of the kernel. You can download and try the new Hardy Heron Alpha release from http://cdimage.ubuntu.com/releases/hardy/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/ .

I also noticed that in a few of the duplicate bug reports, bug reporters were comfortable building their own kernels and enabling kernel config options which would resolve this issue. If after testing with the Hardy Alpha kernel and you realize the issue still exists, for those comfortable and willing to build their own kernel, would you care to try building the stock ubuntu hardy kernel and verify which config options need changing? If you could post a comment here regarding the config options, it would be much appreciated. Thanks!

Changed in linux:
status: New → Incomplete

I do have a ubuntu install on my philips freevents now. I followed some instructions on the forums...
http://ubuntuforums.org/showpost.php?p=1844744&postcount=18

The problem now is that the kernel built from the sources in 7.10 fail in loads of other areas. The machine works OK running 7.10 packages and upgrades but using the kernel built from the previous version.

Cheers
John

---- Message from Leann Ogasawara <email address hidden> at 2008-01-24 16:16:22 ------
>The Hardy Heron Alpha series was recently released. Alpha2 and
>subsequent releases contain an updated version of the kernel. You can
>download and try the new Hardy Heron Alpha release from
>http://cdimage.ubuntu.com/releases/hardy/ . You should be able to then
>test the new kernel via the LiveCD. If you can, please verify if this
>bug still exists or not and report back your results. General
>information regarding the release can also be found here:
>http://www.ubuntu.com/testing/ .
>
>I also noticed that in a few of the duplicate bug reports, bug reporters
>were comfortable building their own kernels and enabling kernel config
>options which would resolve this issue. If after testing with the Hardy
>Alpha kernel and you realize the issue still exists, for those
>comfortable and willing to build their own kernel, would you care to try
>building the stock ubuntu hardy kernel and verify which config options
>need changing? If you could post a comment here regarding the config
>options, it would be much appreciated. Thanks!
>
>** Changed in: linux (Ubuntu)
> Status: New => Incomplete
>
>--
>Regression: RealTek 8139 hard-locks system on installation/modprobe (affects Averatec, Philips laptops)
>https://bugs.launchpad.net/bugs/90271
>You received this bug notification because you are a direct subscriber
>of a duplicate bug.
>
>
>

I have just tried Hardy Heron Alpha 3 on the Philips Freevents X59 Laptop that I have here and it crashes whilst trying to boot the Live CD.

Running the livecd with quiet and splash removed I see that it crashes with the last lines being...

[ 58.570143] scsi 4:0:0:0: Attached scsi generic sg1 type 5
[ 58.570296] ACPI: PCI Interrupt 0000:03:04.0[A] -> GSI 16 (level, low) -> IRQ 16
[ 58.570996] eth0: RealTek RTL8139 at 0x884ac00, 00:40:45:XX:XX:XX, IRQ 16

So it looks like the problem is still there in Hardy Heron. Is there any way to stop drivers from being loaded on bootup yet? Then I can block 8139too (and maybe SDHCI if it still causes problems) and have a go at re-compiling the kernel.

Mike

JenniferHodgdon (yahgrp) wrote :

I had the same result as Mike just reported on my Averatek StepNote SA2053T with the Hardy Heron alpha 3 desktop live CD: boot hangs and the only recourse is a hard reboot (power switch). The last lines look just slightly different from the last 2 lines of what Mike reported: the 8139 module is still a problem.

So, I have compiled kernels from kernel.org source from 2.6.20 up through 2.6.23, and there are two modules with problems:

1) 8139too -- if it is compiled with CONFIG_8139TOO_PIO=y it works, but the default uses MMIO instead. Loading the module with MMIO compiling causes the laptop to hang completely - hard reboot necessary - SysRq keys do not work - last reported lines similar to the last 2 of what Mike reported in the last comment.

2) sdhci - this laptop has a card reader, but loading the SDHCI module causes it to hang completely (hard power-switch reboot necessary, SysRq doesn't work). I haven't found any compile options that can prevent that, and even tried putting some debugging into the kernel source, but couldn't figure out what was going wrong.

I haven't tried building with the Hardy Heron or other Ubuntu kernel source (my partner uses other distros, so I got set up with git and the kernel.org source), but if it is based on 2.6.23 or earlier, those are the config options. (I have tried loading the Ubuntu kernels from Feisty and Gutsy; same results as the default-compiled kernel.org kernels.)

If Hardy is based on a later kernel.org source, add a comment here and I can test that with the kernel.org source. We did report this issue to the kernel folks, but they have not seen fit to do anything about it... nice to see that the Ubuntu folks are interested. :)

    --Jennifer

Bob A (ajitin) wrote :

I am a new owner of Everex 2053. I am disappointed to find the problem reported here. The bug was first report in March 2007. I hope we have a solution before the first anniversary. I wish I could help, but I am a Linux newbie and can't get started unless I install Linux.
Thanks to all who are working on this.

JenniferHodgdon (yahgrp) wrote :

The kernel.org folks released 2.6.24 today (or at least recently). So, I did some testing with this kernel on my Everex StepNote SA2053T (not an Averatec - that was a typo in the previous comment I left earlier today). Results:

1) The sdhci problem still occurs (modprobe -r sdhci causes the system to hang completely; only way out is to hold down the power switch and force a reboot). I have sdhci blacklisted so that I can boot, but standard Ubuntu live CDs probably do try to load it (at least they used to as of Feisty Faun). I don't think there is a way to tell the boot loader to avoid loading that module, is there?

2) The 8139too module works fine on my Everex StepNote laptop if compiled with CONFIG_8139TOO_PIO=y -- I have this in my config file by default. When I changed my config file to using the (I think default?) MMIO setting instead of PIO, the 8139 module hung the boot process (hard reboot necessary).

So, I don't think anything has changed, in relation to this bug, between the 2.6.20 and 2.6.24 kernels from kernel.org.

    --Jennifer

Jerzy Jalocha N (jjalocha) wrote :

Bug #34902 is a duplicate. It has 8 duplicates and 'high' importance. Do you recommend marking it as a duplicate? Or would the 'importance' be lost?

JenniferHodgdon (yahgrp) wrote :

I don't agree that Bug #34902 is a duplicate. It is talking about locking of the system due to a totally different card and driver. The card/driver on this bug is an 8139 ethernet card (wired network, not wireless); the card in question for the other bug is a Ralink RT2500 wireless card.

It is true that the Ralink RT73 wireless card on my Everex StepNote SA2053 has some issues with Ubuntu, but not the ones described in Bug #34902.The rausb drivers that came with Feisty and Gutsy did not work, and even with working drivers, the wireless card did not work with the Network manager application, but I never saw the laptop hang due to the wireless issues. Also, commenters on the other bug reported they couldn't get their machines to work even using the Serial Monkey drivers, but this laptop's wireless works just fine with the Serial Monkey drivers, with some scripts and the Serial Monkey wireless manager application (RutilT) in place of the network manager.

The people who reported #34902 and commented on it were having much more serious wireless problems than people with a StepNote laptop (and other similar ones), and not the same problems reported here, from what I can tell.

     --Jennifer

Jerzy Jalocha N (jjalocha) wrote :

Thank you, Jennifer for the quick reply.
I'm really sorry for the confusion!
(I'm still glad I asked before proceeding to merge...)

Hi Jennifer,

Thanks so much for all of your testing and feedback. It is definitely much apprecaited. I'm reassigning to the kernel team to consider enabling the CONFIG_8139TOO_PIO kernel config option. Regarding the issue you are seeing with loading the sdhci module, care to maybe open a new bug report? It's helpful to the kernel team if reports target one specific issue. Thanks!

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → In Progress
status: In Progress → Triaged
JenniferHodgdon (yahgrp) wrote :

Done! The sdhci bug is Bug #187671

Tim Gardner (timg-tpi) wrote :

Enabled CONFIG_8139TOO_PIO=y

Changed in linux-source-2.6.22:
assignee: nobody → timg-tpi
importance: Undecided → Medium
milestone: none → hardy-alpha-5
status: New → Fix Committed
JenniferHodgdon (yahgrp) wrote :

Is that config change just for Ubuntu kernels?

Anyway, thanks -- that will get owners of these laptops one step closer to being able to boot off the live CD and use standard Ubuntu upgrades for the kernel. (There's still the SDHCI problem, but that's now a separate bug.)

Hi Jennifer,

Yes this config change will only apply to Ubuntu kernels:

ogasawara:~/ubuntu-hardy/debian/config$ grep -rn "CONFIG_8139TOO_PIO" *

amd64/config:11:CONFIG_8139TOO_PIO=y

hppa/config.hppa32:7:CONFIG_8139TOO_PIO=y

i386/config:7:CONFIG_8139TOO_PIO=y

ia64/config:10:CONFIG_8139TOO_PIO=y

lpia/config:10:CONFIG_8139TOO_PIO=y

powerpc/config:9:CONFIG_8139TOO_PIO=y

sparc/config:8:CONFIG_8139TOO_PIO=y

Also, I think Tim meant to mark this fix released against the Hardy kernel, the 'linux' pakage, not the Gutsy kernel, the linux-source-2.6.22 package. So I'm fixing the Status' accordingly. Thanks.

Changed in linux:
assignee: ubuntu-kernel-team → timg-tpi
status: Triaged → Fix Committed
Changed in linux-source-2.6.20:
status: Confirmed → Won't Fix
Changed in linux-source-2.6.22:
assignee: timg-tpi → nobody
status: Fix Committed → Won't Fix
Fabián Rodríguez (magicfab) wrote :

Excellent news. I still have a laptop that I can test this with when alpha 5 is released.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.24-8.13

---------------
linux (2.6.24-8.13) hardy; urgency=low

  [Soren Hansen]

  * Add missing iscsi modules to kernel udebs

  [Stefan Bader]

  * Lower message level for PCI memory and I/O allocation.

  [Tim Gardner]

  * Enabled IP_ADVANCED_ROUTER and IP_MULTIPLE_TABLES in sparc, hppa
    - LP: #189560
  * Compile RealTek 8139 using PIO method.
    - LP: #90271
  * Add WD WD800ADFS NCQ horkage quirk support.
    - LP: #147858

  [Upstream Kernel Changes]

  * Introduce WEXT scan capabilities
  * DVB: cx23885: add missing subsystem ID for Hauppauge HVR1800 Retail
  * slab: fix bootstrap on memoryless node
  * vm audit: add VM_DONTEXPAND to mmap for drivers that need it
    (CVE-2008-0007)
  * USB: keyspan: Fix oops
  * usb gadget: fix fsl_usb2_udc potential OOPS
  * USB: CP2101 New Device IDs
  * USB: add support for 4348:5523 WinChipHead USB->RS 232 adapter
  * USB: Sierra - Add support for Aircard 881U
  * USB: Adding YC Cable USB Serial device to pl2303
  * USB: sierra driver - add devices
  * USB: ftdi_sio - enabling multiple ELV devices, adding EM1010PC
  * USB: ftdi-sio: Patch to add vendor/device id for ATK_16IC CCD
  * USB: sierra: add support for Onda H600/Zte MF330 datacard to USB Driver
    for Sierra Wireless
  * USB: remove duplicate entry in Option driver and Pl2303 driver for
    Huawei modem
  * USB: pl2303: add support for RATOC REX-USB60F
  * USB: ftdi driver - add support for optical probe device
  * USB: use GFP_NOIO in reset path
  * USB: Variant of the Dell Wireless 5520 driver
  * USB: storage: Add unusual_dev for HP r707
  * USB: fix usbtest halt check on big endian systems
  * USB: handle idVendor of 0x0000
  * forcedeth: mac address mcp77/79
  * lockdep: annotate epoll
  * sys_remap_file_pages: fix ->vm_file accounting
  * PCI: Fix fakephp deadlock
  * ACPI: update ACPI blacklist
  * x86: restore correct module name for apm
  * sky2: restore multicast addresses after recovery
  * sky2: fix for WOL on some devices
  * b43: Fix suspend/resume
  * b43: Drop packets we are not able to encrypt
  * b43: Fix dma-slot resource leakage
  * b43legacy: fix PIO crash
  * b43legacy: fix suspend/resume
  * b43legacy: drop packets we are not able to encrypt
  * b43legacy: fix DMA slot resource leakage
  * selinux: fix labeling of /proc/net inodes
  * b43: Reject new firmware early
  * sched: let +nice tasks have smaller impact
  * sched: fix high wake up latencies with FAIR_USER_SCHED
  * fix writev regression: pan hanging unkillable and un-straceable
  * Driver core: Revert "Fix Firmware class name collision"
  * drm: the drm really should call pci_set_master..
  * splice: missing user pointer access verification (CVE-2008-0009/10)
  * Linux 2.6.24.1
  * splice: fix user pointer access in get_iovec_page_array()
  * Linux 2.6.24.2

 -- Tim Gardner <email address hidden> Thu, 07 Feb 2008 06:50:13 -0700

Changed in linux:
status: Fix Committed → Fix Released
JenniferHodgdon (yahgrp) wrote :

I'm certain the next Hardy Alpha distro disk won't boot, even with this bug fixed (due to Bug #187671, SDHCI module, as mentioned above) -- but I have the SDHCI module blacklisted on my laptop, so I could at least try booting the new kernel, without the rest of the disk, to verify that the 8139too bug is actually fixed, if that would be useful.

I was going to try this, actually, but I didn't know where to find the kernel package (I tried apt-get, but either I had the package name wrong, or I need to put in a different location, or something like that -- excuse my ignorance of dev locations!).

So, let me know... happy to test if I can find the new kernel module somewhere.

Tim Gardner (timg-tpi) wrote :

The meta packages that trigger the update of 2.6.24-8.13 have not been released yet. They ought to be out in a couple of days.

JenniferHodgdon (yahgrp) wrote :

An update package that works off the Hardy Alpha already being installed is not going to help. Those of us with these laptops have not been able to install off standard Ubuntu distro disks, due to this bug and Bug #187671, which prevent those disks from even being booted. And even with this bug fixed, Bug #18671 is still going to prevent booting the Hardy Alpha distro disk. So we don't have Hardy Alpha installed. This meta update package wouldn't trigger an update from the Gutsy kernels to this new kernel, I think?

Which is why I was wondering if it's possible to grab a package, via apt-get or FTP or whatever (I can handle doing dpkg to install the package if I can get the package), that just has the new kernel in it. I have a Gutsy installation with SDHCI blacklisted, so I can test booting the new kernel without Bug #18671 interfering, and without installing the entire Hardy Alpha distro.

Steve Langasek (vorlon) on 2008-02-15
Changed in linux-source-2.6.22:
milestone: hardy-alpha-5 → none
Andrew Matejcic (matejand) wrote :

There has been some fantastic work and followup on this issue of Ubuntu not installing on selected models of PCs. (I'm using the Philips Freevents X59), and am very keen to install Ubuntu to use.

Can someone provide a link to directions on how to perform an initial install Ubuntu with the linux 2.6.24-8.13 kernel.

Once again, thankyou to all who have brought the resolution of this issue to this point, I hope that with this, and the issue of the SD Card Reader, the issue can be brought to a final resolution, where by new pc's can install Ubuntu.

Cheers,
Andrew.

JenniferHodgdon (yahgrp) wrote :

I got an email message from someone who managed to get a standard Ubuntu distro to install, without a wired network card. He put his experience in the Ubuntu forums:

http://ubuntuforums.org/showthread.php?t=704260

Note that this person completely blacklisted the SDHCI module, so he has no wired network card working. There may also be a way to blacklist the problematic modules at boot time, which I'm looking into.

But in general, there is not yet an easy way to install a standard distribution of Ubuntu on these laptops. Apparently the next Hardy will have the 8139too kernel module compiled in a way compatible to this laptop (that's what this bug is about), but the sdhci kernel module (Bug #187671) is still an issue. I'm working on resolving it with the kernel folks, but it isn't resolved yet.

I'll post here if I figure anything else out...

JenniferHodgdon (yahgrp) wrote :

I just tried the Hardy beta disk, downloaded yesterday.

I think the 8139too problem is resolved. However, the disk still doesn't boot as a live CD on these laptops, because of the SDHCI module (see numerous comments above). But I am pretty sure that 8139too got loaded successfully first. Not positive, but pretty sure.

I tried putting
    sdhci.blacklist=yes
on the boot line (when the CD comes up, F6 and remove "quiet=yes" and "splash" from the boot options, add "sdhci.blacklist=yes", no quotes), but this doesn't prevent the SDHCI module from being loaded. Here's the web page that suggested this: http://d-i.alioth.debian.org/manual/en.i386/ch05s02.html Maybe this would work if booting normally (off the hard drive) but it doesn't seem to work with the live CD.

Anyway, when Hardy comes out, at least those of us who managed to get previous versions of Ubuntu installed by using alternative install CDs can probably upgrade to Hardy and use the kernels provided by Ubuntu.

Hi Jennifer,

The sdhci.blacklist=yes parameter works. But only with the alternate disk. It is a special parameter for the debian install that was not used on the livecd.
The debian installer will put a blacklist entry on the installed system.

Now it is much easier to install a new Ubuntu on the H12Y and it is save to update the kernel.

Short Howto:
-Download and burn the Alternate Install CD
-Boot it and choose your language
-Press F6 and add "sdhci.blacklist=yes" to the prompt. (Without quotes)
-Install it and get a working Ubuntu installation.

JenniferHodgdon (yahgrp) wrote :

I have confirmed that upgrading to Hardy works great! I haven't tried the Alternate Installation disk method, since I already had Gutsy running.

Thanks very much for getting this change into Ubuntu!! As far as I know, this is the only distro that has made it possible to run on these PCs.

    --Jennifer

Oliver Twist (olivier-mougin) wrote :

I just want to thank you for this "fix", as now I am able to really enjoy my Philips Freevents without windoze!
In fact the alternate CD installation works after adding "sdhci.blacklist=yes" and "sdhci_pci.blacklist=yes" before the installation. Didn't work from the first try though (typo mistake maybe...).

Hope I'm not writting on a wrong bug report, but as I found the solution here, wanted to thank people who helped me!

Olivier

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers