touchpad doesn't work after suspend

Bug #86820 reported by Victor Noël
74
This bug affects 10 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Declined for Maverick by Andy Whitcroft
linux-source-2.6.20 (Ubuntu)
Medium
Unassigned
Declined for Maverick by Andy Whitcroft

Bug Description

Binary package hint: linux-source-2.6.20

hi,

since i switched to 2.6.20 (linux-image-2.6.20-8-generic-8.14) my touchpad doesnt work anymore after suspend (not hibernate).

(and the secondary capslock, the one for the numepad on laptop, enabled by fh+special_key, is on too)

i attached the dmesg log and lspci -vv, if you need something else tell me :)

Revision history for this message
Victor Noël (victornoel) wrote :
Revision history for this message
Victor Noël (victornoel) wrote :
Revision history for this message
Cristian Aravena Romero (caravena) wrote :

Thanks for taking the time to report this bug. Unfortunately we can't fix it, because your description didn't include enough information.

Please include the information requested from [WWW] https://wiki.ubuntu.com/DebuggingACPI as separate attachments.

Revision history for this message
Victor Noël (victornoel) wrote :

ok :)

my bios is up to date.

root@gyoza:~# uname -a
Linux gyoza 2.6.20-8-generic #2 SMP Tue Feb 13 05:18:42 UTC 2007 i686 GNU/Linux

i attached lspci -vvn and dmidecode. (and lspci -vv was already attached)

Revision history for this message
Victor Noël (victornoel) wrote :

and i forgot to say that there is in the dmesg a line that say that mouse will not work :)

[21393.132000] i8042: failed to resume active multiplexor, mouse won't work.

Tim Gardner (timg-tpi)
Changed in linux-source-2.6.20:
assignee: nobody → timg-tpi
Revision history for this message
Cristian Aravena Romero (caravena) wrote :

kaouete:

Ask the user to try to hibernate/suspend and then restart the system and attach /var/log/kern.log.0

Revision history for this message
Victor Noël (victornoel) wrote :

my dmesg is the one after i did suspend, before i rebooted, so i guess it is what you are looking for ... no ?

in case it is not that, i attached *exactly* what you are looking for :)

(oh and, i did suspend, not hibernate)

Changed in linux-source-2.6.20:
assignee: timg-tpi → ubuntu-kernel-team
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Revision history for this message
Justin Sunseri (jmsunseri) wrote :

I also have this bug. When i resumed from suspend the mouse seemed to work for a second or two then stopped working and the number lock key came on.

Revision history for this message
derp (dgharibi) wrote :

try i8042.nomux as a kernel option; worked for me.

Revision history for this message
Justin Sunseri (jmsunseri) wrote : Re: [Bug 86820] Re: touchpad doesn't work after suspend

Great that worked perfectly for me. The numb luck was not on and the
touchpad worked when i returned from suspend. Now how to we get it so that
normal users don't have to do that?

On 5/19/07, derp <email address hidden> wrote:
>
> try i8042.nomux as a kernel option; worked for me.
>
> --
> touchpad doesn't work after suspend
> https://bugs.launchpad.net/bugs/86820
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Sincerely

Justin Sunseri

Revision history for this message
Victor Noël (victornoel) wrote :

This fix works but when it is used, sometimes my touchpad and my keyboard stop working and i have to close my lid to suspend the laptop and when i go out from suspend they are back.

It is not really usable for me ...

Revision history for this message
mlaverdiere (mlaverdiere) wrote :

The "i8042.nomux" kernel option didnt' fix the problem on my Kubuntu Feisty system.

I have to use an alternate suspend2 patched kernel (available at: http://3v1n0.tuxfamily.org/dists/feisty/suspend2/index.html) in order to fix the problem. It has also fixed this bug: https://bugs.launchpad.net/ubuntu/+bug/119696

My experience lead me to believe that Feisty kernels are problematic for suspend/hibernation when compared to Dapper and Edgy ones...

Revision history for this message
mlaverdiere (mlaverdiere) wrote :

Well, finaly, the problem came back, even if I was using the suspend2 patched Kernel.

Weird...

It's been over one week now that I'm using the regular 2.6.20-15-generic kernel with the following kernel options:

i8042.nomux i8042.reset

I've been using my laptop quite intensively (frequent sleep/resume sequences) in this past week and up to now, everything works fine. If the problem comes back, I'll let you know.

Revision history for this message
Justin Sunseri (jmsunseri) wrote :

these options work really well for me using gusty and i would like to have it so i don't have to make these changes to my grub config every new kernel that comes out. Could you please create a exception/blacklist for my model laptop?

Revision history for this message
mlaverdiere (mlaverdiere) wrote :

The easy way to have these options automaticaly added when there's a kernel upgrade is to add them in /boot/grub/menu.lst at the following section:

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash locale=fr_FR i8042.nomux i8042.reset

Hope this help.

Revision history for this message
Justin Sunseri (jmsunseri) wrote :

thanks but I think this should "just work" instead of expecting anyone to
edit that file

On 8/23/07, mlaverdiere <email address hidden> wrote:
>
> The easy way to have these options automaticaly added when there's a
> kernel upgrade is to add them in /boot/grub/menu.lst at the following
> section:
>
> ## additional options to use with the default boot option, but not with
> the
> ## alternatives
> ## e.g. defoptions=vga=791 resume=/dev/hda5
> # defoptions=quiet splash locale=fr_FR i8042.nomux i8042.reset
>
> Hope this help.
>
> --
> touchpad doesn't work after suspend
> https://bugs.launchpad.net/bugs/86820
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Sincerely

Justin Sunseri

Revision history for this message
Jerome Lacoste (jerome-lacoste) wrote :

I just experienced this on Hardy, confer the duplicated bug #214985

Changed in linux-source-2.6.24:
status: New → Confirmed
Revision history for this message
Jerome Lacoste (jerome-lacoste) wrote :

As noted in #214985, I've used https://bugs.launchpad.net/ubuntu/+source/acpi-support/+bug/23497/comments/17 , i.e.

  sudo sh -c 'echo -n "i8042" > /sys/bus/platform/drivers/i8042/unbind'
  sudo sh -c 'echo -n "i8042" > /sys/bus/platform/drivers/i8042/bind'

to succesfully work-around the problem.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Revision history for this message
jmkhenka (jmkhenka) wrote :

I have been observing this for a while. I got a Amilo Si1520, everything works in ubuntu (8.04 and Alpha 6 of intrepid ibex) BUT the stupid and annoying bug with the touchpad dies after resume from STR/Sleep/Suspend.

As i said, Alpha 5 and 6 of Intrepid does not solve this issue.
Sorry i cant give you all a more technical explanation for this, im not that into linux and all nicknacks....

But atm, only solution for me is to use a USB mouse if i want to suspend the computer when using ubuntu.

I tried what Jerome mentioned ( sudo sh -c 'echo -n "i8042" > /sys/bus/platform/drivers/i8042/unbind'
  sudo sh -c 'echo -n "i8042" > /sys/bus/platform/drivers/i8042/bind') and that only "restart" my keyboard and had no effect on my touchpad at all.

Im courious if there is a update on this, or if there is something i can test for you guys so we might solve this?

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Just adding a note that the 18 month support period for Feisty Fawn 7.04 has reached it's end of life - http://www.ubuntu.com/news/ubuntu-7.04-end-of-life . As a result, we are closing the linux-source-2.6.20 kernel task. However, this will remain open against the actively developed kernel. Thanks.

Changed in linux-source-2.6.20:
status: Confirmed → Won't Fix
Revision history for this message
Launchpad Janitor (janitor) wrote : Kernel team bugs

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Revision history for this message
Dmitry Torokhov (dtor) wrote :

If you guys still have issues with keyboard/mouse/touchpad not working after suspending to RAM (in absence of i8042.nomux/i8042.reset parameters in grub), could you please try the following patch? It is against 2.6.35-rc3 but should probably apply to 2.6.34 as well.

tags: added: patch
Revision history for this message
Jerome Lacoste (jerome-lacoste) wrote :

I tried to port the patch to Lucid's kernel. Haven't tried compiling yet nor testing it. Will do tomorrow.

Revision history for this message
Jerome Lacoste (jerome-lacoste) wrote :

Here's the patch properly merged using git on top of the Ubuntu-2.6.32-23.37 tag.

I tested the patch (after removing the i8042.quiet grub kernel boot option) and my keyboard resumes properly. Tried 3 times. Never worked before without the kernel option.

I will now update the i8042 maintainer on the related LKML thread (http://lkml.org/lkml/2010/7/1/13)

Hope other's can test it and that Ubuntu will consider applying it on top of 2.6.32. This bug seems to have been affecting many users.

Revision history for this message
Jerome Lacoste (jerome-lacoste) wrote :

Official patch is here

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=1ca56e513a9fd356d5a9e0de45dbe0e189e00386

and has been merged into Linus's kernel (will be out in 2.6.36):

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=fe445c6e2cb62a566e1a89f8798de11459975710

This means it won't be in ubuntu 10.10 neither (which will use 2.6.35). Is there a way to merge this into both the 10.04 and the 10.10 kernels ? That way I don't have to keep patching official kernels... I've already backported the patch.

As said above, 10.04 has a regression which causes previous work-arounds to not work. This means I can't suspend my laptop anymore.

Revision history for this message
Jerome Lacoste (jerome-lacoste) wrote :

I've nominated the bug for Maverick. Not sure if it's the right thing to to do bring attention to it. In the mean time I will lurk again on the #ubuntu-kernel IRC channel

Revision history for this message
Andy Whitcroft (apw) wrote :

Declined Maverick nomination not because this is unsuitable for Maverick but because the development version is Maverick currently so a nomination currently has no meaning,

Changed in linux (Ubuntu):
importance: Undecided → Medium
Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

This should be resolved as of 2.6.35-21.30. Marking Fix Released for Maverick.

linux (2.6.35-21.30) maverick; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: fbcon -- fix OOPs triggered by race prevention fixes
    - LP: #614008

  [ Daniel Lezcano ]

  * SAUCE: fix compilation warning when CONFIG_SECURITY is not set

  [ Henrik Rydberg ]

  * SAUCE: Input: wacom - add fuzz parameters to features
  * SAUCE: Input: wacom - collect device quirks into single function
  * SAUCE: Input: wacom - add support for the Bamboo Touch trackpad
  * SAUCE: Input: wacom - add a quirk for low resolution Bamboo devices
  * SAUCE: hid: ntrig: Remove unused device ids
  * SAUCE: hid: ntrig: remove sysfs nodes
  * SAUCE: hid: ntrig: Correct logic for quirks
  * SAUCE: hid: ntrig: zero-initialize ntrig struct
  * SAUCE: hid: ntrig: Setup input filtering manually
  * SAUCE: hid: ntrig: New ghost-filtering event logic

  [ Leann Ogasawara ]

  * SAUCE: ndiswrapper: Initialize buffer index and check its value
    - LP: #613796

  [ Manoj Iyer ]

  * SAUCE: Add support for Intellimouse Mode in ALPS touchpad on Dell E2
    series Laptops
    - LP: #632884

  [ Ping Cheng ]

  * SAUCE: Input: wacom - parse the Bamboo device family

  [ Rafi Rubin ]

  * SAUCE: hid: ntrig: identify firmware version (wiggled)

  [ Tim Gardner ]

  * [Config] CONFIG_NL80211_TESTMODE=n

  [ Upstream Kernel Changes ]

  * Revert "input: mt: Add support for the Bamboo Touch trackpad"
  * e1000e: initial support for 82579 LOMs
  * e1000e: correct MAC-PHY interconnect register offset for 82579
  * (pre-stable) ALSA: hda - Add a new hp-laptop model for Conexant 5066,
    tested on HP G60
    - LP: #587388
  * DSS2: Don't power off a panel twice
    - LP: #588243
  * mmc: build fix: mmc_pm_notify is only available with CONFIG_PM=y
  * Input: i8042 - reset keyboard controller wehen resuming from S2R
    - LP: #86820
  * ALSA: hda - Fix beep frequency on IDT 92HD73xx and 92HD71Bxx codecs
    - LP: #414795
  * agp/intel: Support the extended physical addressing bits on
    Sandybridge.
    - LP: #632488
  * drm/i915,intel_agp: Add support for Sandybridge D0
    - LP: #632488
  * (pre-stable) intel_agp,i915: Add more sandybridge graphics device ids
    - LP: #632488
  * mmc: omap: fix for bus width which improves SD card's peformance.
 -- Leann Ogasawara <email address hidden> Tue, 07 Sep 2010 09:58:52 -0700

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Sayantan Das (sayantan13) wrote :

Hi, I dont think this is resolved. I am running ubuntu 10.10 and below is my kernel

Studio-XPS-1640:~$ uname -r
2.6.35-23-generic

Studio-XPS-1640:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.10
DISTRIB_CODENAME=maverick
DISTRIB_DESCRIPTION="Ubuntu 10.10"

I still get a dead touchpad after waking from suspend.

Revision history for this message
Jerome Lacoste (jerome-lacoste) wrote :

@Sayantan Interesting. Try adding i8042.debug to your kernel boot line, restart the computer, suspend, resume and attach your syslog here

Revision history for this message
David Benjamin (davidben) wrote :

I'm not Sayantan, but I also have my touchpad disabled on resume until a few seconds pass. This is an up-to-date maverick system on a T400 Thinkpad.

% uname -r
2.6.35-24-generic
% cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.10
DISTRIB_CODENAME=maverick
DISTRIB_DESCRIPTION="Ubuntu 10.10"

I've attached a syslog of a reboot, suspend, and resume with i8042.debug=1. It appears that a lot of the initial kernel bootup spew got lost (perhaps i8042.debug is so noisy that some buffer got exceeded before the logger could capture it).

I have also noticed that, when I resume, the touchpad gets completely reset and I lose all my settings on it, which is a regression from before maverick. Although, it appears from Xorg.0.log that X treats it as a new input device getting plugged in? I don't know if it's intentional, but it seems a little poor. Though, I could believe this should be GNOME's fault for not reprogramming the device (or my fault for using settings GNOME doesn't support; I manually enable two-finger scroll emulation with xinput).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers