CPU fans won't start for Thinkpad 770E and 390E

Bug #70739 reported by Robert Peritsky
18
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Fix Released
High
Unassigned
linux-source-2.6.20 (Ubuntu)
Won't Fix
Medium
Unassigned
linux-source-2.6.22 (Ubuntu)
Won't Fix
Medium
Unassigned

Bug Description

In both versions 6.06 (Dapper) and 6.10 (Edgy), the cpu fans on both my Thinkpad 770E and Thinkpad 390E never start, resulting in eventual CPU overheating.

Fans run under WinXP pro, and run on startup until Linux starts to boot. Then it shuts off and never restarts.

This occurs both with live-cd and hard drive installation.

Revision history for this message
Lee Willis (lwillis) wrote :

Since my bug has been marked as a dupe of this I'll copy some other info from there:

PC is an eMachines 370. Fan worked under previous versions of ubuntu, but no longer comes on under edgy. As well as this acpi reports bogus temperatures:

~$ cat /proc/acpi/thermal_zone/THRM/temperature
temperature: -267 C
~$ acpi -t
     Thermal 1: passive , 4294967040.0 degrees C

bug 24308 and bug 54554 also seem similar

Revision history for this message
Luka Renko (lure) wrote :

Could this be related to this bug in kernel that was fixed recently:

http://bugzilla.kernel.org/show_bug.cgi?id=5534

Revision history for this message
Lee Willis (lwillis) wrote :

It may be, but I don't think so. "acpi -t" doesn't trigger the fans on my machine, and the kernel bug you mentioned doesn't (At brief glance) seem to show anyone reporting ridiculous temperatures as I mentioned in my report (I'm sure 4billion degrees is outside normal operating range :p)

Revision history for this message
Lee Willis (lwillis) wrote :

I've tested with the latest kernel from feisty 2.6.19-5 which I believe contains the patches from that kernel bug and I still experience the same problems, namely:
- Fan's don't (Audibly) come on
- Temperature reported is bogus (Either -ve numbers, or very high +ve numbers)
- Machine shuts down under load due to critical temperature being breached.

I can confirm that ACPI events are received (According to /var/log/acpid). Is there anything else I can do to provide debug information?

Revision history for this message
Lee Willis (lwillis) wrote :

Still present with 2.6.20-15-386 (Latest feisty kernel). Booting with (acpi=off noapic noacpi) means the machine stays up but with the fans on permanently - so not a great solution.

I'm happy to provide further debugging info if required.

Revision history for this message
Lee Willis (lwillis) wrote :

Updated to latest kernel version since bug still present here

Revision history for this message
Lee Willis (lwillis) wrote :

Still present in feisty release

Revision history for this message
David McGlone (david-mcglone) wrote :

I am having the same problem except on an E-Machines desktop. I have spent quite a few weeks trying to figure out what is causing this. I haven't yet, but I would like to add that I have found that If I turn on the computer and let the grub menu come up while the fan is still running, stop the timer using the up and down arrow keys and then put in a fedora or kubuntu live CD and use CTRL+ALT+DEL to restart the computer, the fan will stay running.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Now that the 7.10 Gutsy Gibbon release of Ubuntu is out, we were wondering if you can still reproduce this issue. Could you please download and try the new version of Ubuntu from http://www.ubuntu.com/getubuntu/download and report back your results. If the issue is still present in the new release, please attach the following information:

* uname -a > uname-a.log
* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

Please be sure to attach each file as a separate attachment. For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

Changed in linux-source-2.6.20:
importance: Undecided → Medium
status: New → Incomplete
Revision history for this message
Lee Willis (lwillis) wrote :

Sorry - I can't. The PC in question died a month or so ago - probably a fried CPU ;)

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Thanks for the reponse Lee. Robert, is it possible for you to verify if this is still an issue?

Revision history for this message
randallw (rwayth) wrote :

I am also having this problem in Gutsy (also in Feisty) so the problem has not gone away. I was having overheating problems and had to turn off the acpi (and apm) service in the "services" administration menu for the fan to come back on. Otherwise it comes on when you first switch on, but turns off immediately after the linux kernel boots.

Some diagnostics are below. I don't think this is a hardware problem since the sensors app gets the CPU temp correct (see below).

My machine is an E-machines T1742 destop. Celeron 1.7GHz.

Diagnostics:

abacus:~$ acpi -V
     Thermal 1: passive , 4294967040.0 degrees C
No support for device type: ac_adapter

abacus:~$ cat /proc/acpi/thermal_zone/THRM/*
<setting not supported>
<polling disabled>
state: passive
temperature: -269 C
critical (S5): -264 C
passive: -273 C: tc1=0 tc2=0 tsp=600 devices=CPU0
active[0]: -267 C: devices=FAN1

 sensors
smsc47m192-i2c-4-2d
Adapter: SMBus I801 adapter at 1880
+2.5V: +0.00 V (min = +3.32 V, max = +2.90 V) ALARM
VCore: +0.00 V (min = +2.99 V, max = +2.99 V) ALARM
+3.3V: +0.00 V (min = +4.38 V, max = +4.38 V) ALARM
+5V: +0.00 V (min = +6.43 V, max = +6.64 V) ALARM
+12V: +3.12 V (min = +6.94 V, max = +15.88 V) ALARM
VCC: +3.37 V (min = +4.38 V, max = +2.18 V) ALARM
+1.5V: +0.04 V (min = +1.87 V, max = +1.99 V) ALARM
+1.8V: +0.00 V (min = +2.39 V, max = +2.39 V) ALARM
Chip Temp: +44.0°C (low = +127°C, high = -1°C) ALARM
CPU Temp: +39.0°C (low = -1°C, high = -1°C)
Sys Temp: -128.0°C (low = -1°C, high = -1°C) FAULT
vid: +1.475 V (VRM Version 9.0)

Revision history for this message
randallw (rwayth) wrote :

and now the requested files...

Revision history for this message
randallw (rwayth) wrote :
Revision history for this message
randallw (rwayth) wrote :
Revision history for this message
randallw (rwayth) wrote :
Changed in linux-source-2.6.22:
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

I've temporarily triaged this against linux-source-2.6.22. However, it is most like that this will be retargeted towards the Hardy kernel once it is released. I've tagged this as "hardy-kernel-candidate" so that we make sure to retarget this report once the new release is out. However against the linux-source-2.6.20 package this is being marked as "Won't Fix" as it does not meet the criteria for a stable release update. To learn more about the stable release update process please refer to https://wiki.ubuntu.com/StableReleaseUpdates . Thanks!

Changed in linux-source-2.6.20:
status: Incomplete → Won't Fix
Revision history for this message
Lee Willis (lwillis) wrote :

Hmmm - having a PC that shuts off at random times, without warning certainly seems to qualify it under "Bugs which may, under realistic circumstances, directly cause a loss of user data".

In fact this bug can easily lead to an unbootable machine (If it dies during a routine upgrade or similar as it did for me ...)

I defer to your judgement - however I think it's important to understand that this bug is more than just an inconvenience for those affected.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Oops, my apologies Lee. I got a little trigger happy with a greasemonkey script I was leveraging. I'm opening this back up against linux-source-2.6.20. Thanks!

Changed in linux-source-2.6.20:
status: Won't Fix → Triaged
Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

The Hardy Heron kernel was recently uploaded for testing. We'd really appreciate it if you could try testing with this newer kernel and verify if this issue still exists. Unfortunately, the Hardy Heron Alpha1 LiveCD was released with the older 2.6.22 kernel. You'll have to manually install the newer Hardy Heron kernel in order to test. This should not be the case for Alpha2. However, here are the instructions to install (if you choose to do so):

1) edit the file /etc/apt/sources.list and add the following line:

deb http://archive.ubuntu.com/ubuntu hardy main restricted

2) sudo apt-get update
3) sudo apt-get install linux-image-2.6.24-1-generic
4) reboot and select the new kernel from the grub menu

After you've tested, please feel free to revert back - ie boot into the old kernel, sudo apt-get remove linux-image-2.6.24-1-generic, and remove the line from /etc/apt/sources.list . Please update this report with your results. Thanks in advance!

Changed in linux:
importance: Undecided → High
status: New → Incomplete
Revision history for this message
Robert Peritsky (rperitsky) wrote :

I recently received a request to see if the new kernel for Hardy Heron
> still exhibited this problem...
>
> Started 390E Thinkpad....fan running
>
> Booted H/H live cd Alpha-1....fan shut off
>
> Installed H/H Alpha-1 to hard drive.....near end of install (approx
> 90%) fan came on and continued running.
>
> Rebooted from hard drive....fan came on and ran normally.
>
> (All the above with 2.6.22 kernel that came with H/H live cd.)
>
> Unfortunately, at this time, I am unable to download the main and
> restricted repostiories to try
> the newer 2.6.24 kernel.
>
> However, based on the 2.6.22 results, I would think that the bug has
> been eliminated.
>
> If the repository comes back on-line, I will update with 2.6.24
> results.
>

Revision history for this message
Robert Peritsky (rperitsky) wrote :

Have now tested Thinkpad 390E with Hardy Heron, both the 2.6.22 and 2.6.24 kernels.

CPU fan runs normally under both WHEN RUNNING FROM HARD DRIVE INSTALLATION.

Fan did not run when booted from Live CD.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Hi Robert,

Thanks for the update. This sounds promising. I'd really like to get your feedback regarding this issue when the Alpha2 LiveCD gets released. It's due to come out I believe Dec 20. If you could just follow up with a comment to this report at that time it would be much appreciated. Thanks!

Revision history for this message
Brian Murray (brian-murray) wrote :

I am assigning this bug to the 'ubuntu-kernel-team' per their bug policy. For future reference you can learn more about their bug policy at https://wiki.ubuntu.com/KernelTeamBugPolicies .

Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team
Revision history for this message
randallw (rwayth) wrote :

Hi,

Alas, nothing has changed for me. Still broken:
abacus:~$ acpi -V
     Thermal 1: passive , 4294967040.0 degrees C
No support for device type: ac_adapter

abacus:~$ uname -a
Linux abacus 2.6.24-1-generic #1 SMP Fri Dec 7 22:06:49 GMT 2007 i686 GNU/Linux

abacus:~$ cat /proc/acpi/thermal_zone/THRM/*
<setting not supported>
<polling disabled>
state: passive
temperature: -270 C
critical (S5): -264 C
passive: -273 C: tc1=0 tc2=0 tsp=600 devices=CPU0
active[0]: -267 C: devices=FAN1
rwayth@abacus:~$ sensors
smsc47m192-i2c-4-2d
Adapter: SMBus I801 adapter at 1880
+2.5V: +0.00 V (min = +3.32 V, max = +3.32 V) ALARM
VCore: +0.00 V (min = +2.99 V, max = +2.99 V) ALARM
+3.3V: +0.00 V (min = +4.38 V, max = +4.38 V) ALARM
+5V: +0.00 V (min = +6.43 V, max = +6.64 V) ALARM
+12V: +3.12 V (min = +11.94 V, max = +13.88 V) ALARM
VCC: +3.39 V (min = +4.38 V, max = +2.18 V) ALARM
+1.5V: +0.03 V (min = +1.87 V, max = +1.49 V) ALARM
+1.8V: +0.00 V (min = +1.19 V, max = +2.39 V) ALARM
Chip Temp: +37.0°C (low = +127°C, high = -1°C) ALARM
CPU Temp: +31.0°C (low = -1°C, high = -1°C) ALARM
Sys Temp: -128.0°C (low = -1°C, high = -1°C) ALARM
vid: +1.475 V (VRM Version 9.0)

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!

Revision history for this message
randallw (rwayth) wrote :

Hi all,

I have stumbled across the fix to the negative temp problems. See: http://ubuntuforums.org/showthread.php?t=623633

I tried the hardy alpha2 livecd, and the CPU fan does run, but quite slowly. It is the same as running with the current gutsy kernel. I will try to load up the system enough to change the fan status and report back. (I put in an extra fan at the back of the box, which keeps the whole thing cool enough now that it is hard to get the CPU too hot.)

cat /proc/acpi/thermal_zone/THRM/*
<setting not supported>
<polling disabled>
state: ok
temperature: 33 C
critical (S5): 95 C
passive: 50 C: tc1=2 tc2=3 tsp=100 devices=CPU0
active[0]: 58 C: devices=FAN1

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Hi Randallw,

Care to open a new bug report regardung the issue you are seeing? It seems you are experienceing a bug that is slightly different than the origianl bug reporter. The original issue was that the fans never start whereas you are mentioning that they start but are just slow. Also, the original bug reporter has commented that this appears to be fixed when running from an installation. Thanks.

Revision history for this message
randallw (rwayth) wrote :

Hi Leann,

Actually, now that I have discovered what is going on, I don't think my problem is a linux/ubuntu bug. It is caused by a broken acpi DSDT on my computer. (I even paid to upgrade my bios before finding that article, and it made no difference). It seems that a broken DSDT is not at all uncommon.

A quick search of "cpu temp" in ubuntu bugs finds a few items which may well be realted (85984, 111576, 27233, 152988) and also for "cpu fan" (72775,64691,70599,140468,160291). (#140468 was exactly the problem I was having in edgy.)

For the original problem reported for this bug, it is probably worth looking at a the ACPI settings/logs including what temp it thinks the CPU is and what the trip points, polling frequencies and initial fan settings are. Every single one of those items (reported temps, trip points, polling freq, initial fan state) was broken for the DSDT on my computer. Last night after fixing my DSDT and running a CPU intensive task I got the CPU temp up to 50C (active cooling) and I heard the fan speed up for a little while. After that it wouldn't get any hotter, which I suppose is exactly what it is supposed to do.

So unless you think otherwise, I don't think there is any new bug to report.

Cheers,
Randall.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Randallw, thanks so much for the update. Since things appear to be resolved with the newer release for both yourself and the original bug reporter I'm going to close this bug for now. Please feel free to reopen this report of the issue reappears. Also please report any future bugs that you may find, we really do appreciate it. Thanks!

Changed in linux:
status: Incomplete → Fix Released
Changed in linux-source-2.6.20:
status: Triaged → Won't Fix
Changed in linux-source-2.6.22:
status: Triaged → Won't Fix
Revision history for this message
wb8nbs (wb8nbs) wrote :

Last weekend I installed Ubuntu 6.06 on this 770E. I can tell you how I dealt with the fan. This was worked out a year or so ago on a Vector installation which also would not start the fan.

1. force acpi on by editing "acpi=force" to the end of the kernel line in /boot/grub/menu.lst.
  My kernel line looks like:
kernel /boot/vmlinuz-2.6.15-29-386 root=/dev/hda2 ro acpi=force
I took out the "quiet splash" parameters so I could watch what's going on at boot time. Beware of automatic system updates rewriting the menu.lst file and erasing your change.

2. Add the line "echo 0 > /proc/acpi/fan/FN00/state" to the end of /etc/rc.local file.
Reboot and the fan will be running continuously but at a almost inaudible slow speed. It starts up about time the desktop is loaded. Crude fix but good enough for me.

BTW I also have a 770Z and the fan works automatically on it.

Now if I could only get the sound to work.....

Revision history for this message
Launchpad Janitor (janitor) wrote : Kernel team bugs

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers