tifm_7xx1 SD card reader cannot read MMC partition table

Bug #111756 reported by أحمد المحمودي (Ahmed El-Mahmoudy) on 2007-05-02
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
New
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.20 (Ubuntu)
Medium
Unassigned
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: linux-source-2.6.20

I got a card reader on my laptop, according to lspci it is:

06:06.4 Generic system peripheral [0805]: Texas Instruments PCI6411/6421/6611/6621/7411/7421/7611/7621 Secure Digital Controller

On Feisty, linux-image-2.6.20 cannot read MMC partition table, when I insert the MMC card I get this on dmesg:
[ 6600.960000] tifm_7xx1: sd card detected in socket 3
[ 6601.016000] mmcblk0: mmc3:0001 000000 1003520KiB
[ 6601.016000] mmcblk0: unknown partition table

I rebooted Feisty using linux-image-2.6.17-11, and the MMC card gets mounted, here's the dmesg output when using linux-image-2.6.17:
[17179657.564000] tifm_7xx1: sd card detected in socket 3
[17179658.824000] mmcblk0: mmc3:0001 000000 1003520KiB
[17179658.824000] mmcblk0: p1

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug does not meet the criteria for a stable release update and is being marked as Won't Fix for this particular version of the kernel. You can learn more about the stable release update process at https://wiki.ubuntu.com/StableReleaseUpdates .
However, the issue that you reported is one that should be possible to test with the live environment of the Desktop CD of the development release - Gutsy Gibbon. It would help us greatly if you could test with it so we can work on getting it fixed in the actively developed kernel. You can find out more about the development release at http://www.ubuntu.com/testing/ .
If you do decide to test with the development release of Ubuntu please comment on this bug report and include at least the minimal information requested at http://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help.

Changed in linux-source-2.6.20:
assignee: nobody → brian-murray
importance: Undecided → Medium
status: New → Won't Fix

Hello,

  I just tested under Gutsy, I got the same problem, here's the relevant dmesg output when I inserted the MMC card:

[ 137.980000] tifm_core: MMC/SD card detected in socket 0:3
[ 138.168000] mmcblk0: mmc3:0001 000000 1003520KiB
[ 138.168000] mmcblk0: unknown partition table

Changed in linux-source-2.6.20:
assignee: brian-murray → nobody
Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged

This bug still exists in Hardy and in Intrepid ! Can someone look at it please !

The following attachments are after upgrading to Intrepid.

I just tested reading the MMC card on the same laptop under windows XP and it worked fine, I did that test to make sure that it is not a hardware malfunction.

Also that MMC card worked fine on another laptop that got a Ricoh R5C822 card reader, that other laptop is running Intrepid.

Brian Murray (brian-murray) wrote :

I've opened a task against the new kernel package in Launchpad, just linux, and am closing the 2.6.22 kernel task as Won't Fix.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Changed in linux-source-2.6.22:
assignee: ubuntu-kernel-team → nobody
status: Triaged → Won't Fix

This problem still exists in Intrepid after I upgraded the kernel to 2.6.27-10.20

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Shakthi Kannan (shakthimaan) wrote :

1. What filesystem do you use on the card?

2. Can you post lsmod output to see what drivers are loaded?
  /bin/lsmod

1. vfat filesystem
2. lsmod output attached.

Hello,

  I just tried with Jaunty's latest Alpha6 yet I still got the same problem. Is anyone looking at this ?

trybik (m-rybik) wrote :

Hi,

I've got similar problem since one of the system upgrades about a year ago... really irritating. I've searched on web but nothing works (the card is unlocked, manual mount won't do because of the partition table - see fdisk.err.log etc)

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers