scroll function of Synaptics touchpad not working

Bug #106969 reported by exactt on 2007-04-16
40
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned
xserver-xorg-input-synaptics (Ubuntu)
Undecided
Unassigned

Bug Description

== Regression details ==
Discovered in version: 0.15.2-0ubuntu3
Last known good version: 0.14.7~git20070706-1ubuntu4

Binary package hint: xserver-xorg-input-synaptics

Binary package hint: linux-source-2.6.20

Hi,

the Synaptics touchpad of my Asus Z96Jm notebook has an area on the right which can be used as a replacement for the missing scroll wheel.

This functionality is not working with the very latest Feisty x86 release.

Thx for your help! Can I help with with anything else than the attachments?

exactt (giesbert) wrote :
exactt (giesbert) wrote :
exactt (giesbert) wrote :
description: updated
Ketil (ubuntu-rytmisk) wrote :

I can confirm this on an asus A9rp

Ketil

Jose Bernardo (bernardo-bandos) wrote :

I believe this is a duplicate of bug #112915 - do any of you guys get the touchpad properly detected in /proc/bus/input/devices, or does it show as some kind of PS/2 mouse like it does on my Fujitsu Pi1505?

jtyler4 (james-d-tyler) wrote :

I configured the Synaptics keypad following the community document:
https://help.ubuntu.com/community/SynapticsTouchpad

I am running on a ASUS z96j, and they are essentially the same model.

I found that I had to leave the entries for the wacom untouched, and search the synaptic list for gsynaptics to
and xbindkeys and the 2 scripts in the walk-through actually enabled the disable button when I have my bluetooth mouse
connected.

tuharsky (tuharsky) wrote :

I have the same problem on HP Compaq nx9105 with Ubuntu 7.04 Feisty.

The /proc/bus/input/devices reveals, that the touchpad is detected as mouse (see attachement)

tuharsky (tuharsky) wrote :

Can I help somehow?

tuharsky (tuharsky) wrote :

Hm, this is wonderful. With Ubuntu 7.10 Gutsy, the scrollpad WORKS, although it is still detected as mouse! The scrolling area is very narrow, on the right side of scrollpad.

tuharsky (tuharsky) wrote :

With Hardy alpha4, scrollpad works no more.

Bogdan Butnaru (bogdanb) wrote :

In my case scrolling works (vertical only), although it's detected as a mouse. I also have a trackpoint (nipple-mouse), which I think is the last one below. There's no mouse right now, but I did have an apple mouse plugged in earlier, which I think is responsible for the first entry below.

$ cat /proc/bus/input/devices
I: Bus=0017 Vendor=0001 Product=0001 Version=0100
N: Name="Macintosh mouse button emulation"
P: Phys=
S: Sysfs=/devices/virtual/input/input0
U: Uniq=
H: Handlers=mouse0 event0
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

I: Bus=0011 Vendor=0002 Product=0008 Version=0000
N: Name="PS/2 Mouse"
P: Phys=isa0060/serio1/input1
S: Sysfs=/devices/virtual/input/input10
U: Uniq=
H: Handlers=mouse1 event2
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

I: Bus=0011 Vendor=0002 Product=0008 Version=6337
N: Name="AlpsPS/2 ALPS GlidePoint"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input11
U: Uniq=
H: Handlers=mouse2 event3
B: EV=f
B: KEY=420 0 70000 0 0 0 0 0 0 0 0
B: REL=3
B: ABS=1000003

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

This bug still exists in intrepid, at least for me.

Changed in linux:
status: Incomplete → New

Thanks Jose,

Can you attach an updated dmesg output when running the Intrepid kernel. Thanks.

Changed in linux:
status: New → Incomplete

Sure. This time, the synaptics touchpad is detected as "input: PS/2 Logitech Wheel Mouse as /class/input/input10"

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged

Same problem here in Intrepid Alpha 3.
I also seem not to be able to click and drag by tapping. This is really irritating.

from dmesg:
[ 14.590091] Synaptics Touchpad, model: 1, fw: 6.5, id: 0x81a0b1, caps: 0xa04711/0xa04000
[ 14.637682] input: SynPS/2 Synaptics TouchPad as /class/input/input8

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Matthew Woerly (nattgew) wrote :

I have a fully up-to-date Intrepid install, and my Inspiron 1525 touchpad works great with Hardy, but has very low sensitivity and no scrolling with Intrepid.

Jos Dehaes (jos-dehaes) wrote :

confirmed here, no scrolling in intrepid.

I have a section in xorg.conf with driver synaptics, but it appears this is now ignored. Worked fine in hardy.

xens (r-aviolat) wrote :

I had the same problem in Intrepid on my Dell Latitude D630.

Fixed the problem with the following command:

xinput set-ptr-feedback "AlpsPS/2 ALPS GlidePoint" 3 8 1

See you :-)

Romain

Andrew King (anders-king-00) wrote :

Hi,

reconfiguring xserver-xorg (sudo dpkg-reconfigure -phigh xserver-xorg) fixed this on Intrepid for me. This is on a Dell vostro 1400.
kernel 2.6.27-4-generic
xorg-server 2:1.5.0-1ubuntu1

Cheers,
Andrew

Andres Mujica (andres.mujica) wrote :

i'm marking this one as a regression because the behaviour wasn't present on hardy.

I'm attaching devices, dmesg and Xorg.0.log

description: updated
Andres Mujica (andres.mujica) wrote :

Also i'm adding xserver-xorg-input-synaptics as Need fixing too.

Andres Mujica (andres.mujica) wrote :
Changed in xserver-xorg-input-synaptics:
status: New → Confirmed
Andres Mujica (andres.mujica) wrote :

the workaround from https://bugs.launchpad.net/ubuntu/+source/linux/+bug/106969/comments/22 works for me (didn't test the previous one)

jsschreck (jsschreck) wrote :

I can confirm that Andrew King's post has corrected the scrolling feature on my touchpad for a Dell Inspiron 1525. Just to reiterate -

sudo dpkg-reconfigure -phigh xserver-xorg

Thanks!
John Schreck

William Grant (wgrant) wrote :

The only remaining bug that I can see is the need to remove InputDevice sections on upgrade to Intrepid. This should be automated soon.

Changed in xserver-xorg-input-synaptics:
status: Confirmed → Invalid
Matthew Woerly (nattgew) wrote :

Sounds good, the dpkg-reconfigure worked on my 1525 too.

William Grant (wgrant) wrote :

InputDevice sections are now commented out on upgrade:

update-manager (1:0.93.23) intrepid; urgency=low

  * DistUpgrade/xorg_fix_intrepid.py:
    - comment out input devices from xorg.conf (handled via
      hal now). Thanks to Alberto Milone for his help,
      LP: #247608

 -- Michael Vogt <email address hidden> Mon, 13 Oct 2008 20:35:06 +0200

Steve Beattie (sbeattie) wrote :

This bug was reported in the Intrepid development cycle; removing regression-potential and marking as regression-release.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Sergey (hvmptydvmpty) wrote :

With xserver-xorg-input-synaptics 0.99.3-1ubuntu1 in Jaunty my Synaptics touchpad's scroll function just stopped working. Previous version (of a few days ago) was working fine. Should I file a new bug for this? Here's what X says:

(II) config/hal: Adding input device SynPS/2 Synaptics TouchPad
(II) LoadModule: "synaptics"
(II) Loading /usr/lib/xorg/modules/input//synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
        compiled for 1.5.99.901, module version = 0.99.3
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 4.0
(II) Synaptics touchpad driver version 0.99.3
(**) Option "Device" "/dev/input/event7"
(II) SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5472
(II) SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4448
(II) SynPS/2 Synaptics TouchPad: pressure range 0 - 255
(II) SynPS/2 Synaptics TouchPad: finger width range 0 - 0
(II) SynPS/2 Synaptics TouchPad: buttons: left right middle double triple
(--) SynPS/2 Synaptics TouchPad touchpad found
(**) SynPS/2 Synaptics TouchPad: always reports core events
(II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD)
(**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
(**) SynPS/2 Synaptics TouchPad: (accel) filter chain progression: 2.00
(**) SynPS/2 Synaptics TouchPad: (accel) filter stage 0: 20.00 ms
(**) SynPS/2 Synaptics TouchPad: (accel) set acceleration profile 0
(--) SynPS/2 Synaptics TouchPad touchpad found

Jonas Pedersen (jonasped) wrote :

Exact same behaviour here. It worked 7-14 days ago. Yesterday I decided to upgrade all pending packages on my Jaunty installation and it no longer works.

I have xserver-xorg-input-synaptics installed in version 0.99.3-1ubuntu1.

(II) config/hal: Adding input device SynPS/2 Synaptics TouchPad
(II) LoadModule: "synaptics"
(II) Loading /usr/lib/xorg/modules/input//synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
        compiled for 1.5.99.901, module version = 0.99.3
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 4.0
(II) Synaptics touchpad driver version 0.99.3
(**) Option "Device" "/dev/input/event8"
(II) SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5472
(II) SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4448
(II) SynPS/2 Synaptics TouchPad: pressure range 0 - 255
(II) SynPS/2 Synaptics TouchPad: finger width range 0 - 0
(II) SynPS/2 Synaptics TouchPad: buttons: left right middle double triple
(--) SynPS/2 Synaptics TouchPad touchpad found
(**) SynPS/2 Synaptics TouchPad: always reports core events
(II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD)
(**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
(**) SynPS/2 Synaptics TouchPad: (accel) filter chain progression: 2.00
(**) SynPS/2 Synaptics TouchPad: (accel) filter stage 0: 20.00 ms
(**) SynPS/2 Synaptics TouchPad: (accel) set acceleration profile 0
(--) SynPS/2 Synaptics TouchPad touchpad found

Alberto Milone (albertomilone) wrote :

Sergey, Jonas, please have a look at bug 320632

Hi Everyone,

Just curious if anyone who had this issue was able to test the final Jaunty 9.04 release yet and confirm if this issue remains? Please let us know. Thanks.

http://www.ubuntu.com/getubuntu/download

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Matthew Woerly (nattgew) wrote :

I'm using up to date Jaunty, and the touchpad works fine with scrolling. It even treats the touchpad different from the mouse sensitivity-wise.

With no other feedback I'm closing this per the previous comment. Thanks for the udpate Nattgew.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers