Comment 0 for bug 106864

jerrylamos (jerrylamos) wrote :

Feisty 20070415 CD Live "can't access tty" will not boot.

Dapper's running great on same system, 1280x960 LCD, Intel 82845G graphics so I didn't understand the "tty" failure.

Tried booting a bunch of times chasing around mulititude of boot options and got dozens of screenfulls of errors. Most significant:
"...device sda Write cache enabled Read cache enabled doesn't support DPO or FUA." No idea what that means.
More tweaking on boot commands see lots of "sector errors". Looks bad.
Finally saw a "fsck failed, see /var/log/checkfs" buried in the middle of the messages that roar up the screen. When the messages stop there's not much running so I can't look at or save anything with anything I tried.

The hard drive is an IDE, WDC AC143006. I disconnected it and Feisty booted right up, no hard drive installed on the computer. If I'm running CD Live, it would be nice to get an "fsck fail" message and boot on up so I could look at it. Evidently Feisty CD Live won't run if it has errors with the hard drive, which obviously it doesn't even need since it will run without it.

Whatever code Feisty is using to support this IDE drive doesn't work. I plugged the hard drive back in and Dapper booted right up beautifully, and Feisty boot still fails. Any chance of a package to put hard drive IDE code into Feisty instead of SATA? Otherwise this system's staying with Dapper. (Runs great, by the way!).

The error message is misleading: from the "can't access tty" I was chasing screen drivers and graphics modes. If the error had been reported as "fsck error" in the first place it would be more to the point.

So there are three Feisty CD Live bugs here:
1. Feisty won't boot with a hard drive that runs fine on Dapper.
2. Feisty error message is misleading pointing to tty instead of hard drive.
3. Feisty boot failed on hardware it didn't need to run.

Cheers, Jerry