Certain VIA-based chipsets erroneously enable DXS support

Bug #68659 reported by Pawel on 2006-10-27
82
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Low
Daniel T Chen
Hardy
Low
Unassigned
linux-restricted-modules-2.6.15 (Ubuntu)
Undecided
Daniel T Chen
Hardy
Undecided
Unassigned
linux-restricted-modules-2.6.20 (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
linux-restricted-modules-2.6.22 (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
linux-source-2.6.15 (Ubuntu)
Undecided
Daniel T Chen
Hardy
Undecided
Unassigned
linux-source-2.6.17 (Ubuntu)
Low
Unassigned
Hardy
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
linux-ubuntu-modules-2.6.24 (Ubuntu)
Medium
Stefan Bader
Hardy
Medium
Stefan Bader

Bug Description

Binary package hint: arts

After update to Kubuntu Edgy Arts is freezing computer and then I got a popup box telling me "Sound server fatal error: cpu overload, aborting". Arts now isn't running, after while atrs starts again freezes computer and disappers. Sound is partially working or not workin at all.

Related branches

Daniel T Chen (crimsun) wrote :

Please attach the output from ``lspci -nv && amixer''.

Changed in arts:
importance: Undecided → Low
status: Unconfirmed → Needs Info
Pawel (paweldk) wrote :

OK, there is output of `lspci -nv && amixer''.
Thanks for Your attention
;)

Pawel (paweldk) wrote :
Download full text (9.3 KiB)

00:00.0 0600: 1106:3189 (rev 80)
        Subsystem: 1458:5000
        Flags: bus master, 66MHz, medium devsel, latency 8
        Memory at d0000000 (32-bit, prefetchable) [size=128M]
        Capabilities: [80] AGP version 3.5
        Capabilities: [c0] Power Management version 2

00:01.0 0604: 1106:b198
        Flags: bus master, 66MHz, medium devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        I/O behind bridge: 0000c000-0000cfff
        Memory behind bridge: e8000000-e9ffffff
        Prefetchable memory behind bridge: d8000000-e7ffffff
        Capabilities: [80] Power Management version 2

00:0a.0 0200: 10ec:8029
        Flags: medium devsel, IRQ 185
        I/O ports at d000 [size=32]

00:0f.0 0101: 1106:0571 (rev 06) (prog-if 8a)
        Subsystem: 1458:5002
        Flags: bus master, medium devsel, latency 32, IRQ 169
        I/O ports at d400 [size=16]
        Capabilities: [c0] Power Management version 2

00:10.0 0c03: 1106:3038 (rev 81)
        Subsystem: 1458:5004
        Flags: bus master, medium devsel, latency 32, IRQ 177
        I/O ports at d800 [size=32]
        Capabilities: [80] Power Management version 2

00:10.1 0c03: 1106:3038 (rev 81)
        Subsystem: 1458:5004
        Flags: bus master, medium devsel, latency 32, IRQ 177
        I/O ports at dc00 [size=32]
        Capabilities: [80] Power Management version 2

00:10.2 0c03: 1106:3038 (rev 81)
        Subsystem: 1458:5004
        Flags: bus master, medium devsel, latency 32, IRQ 177
        I/O ports at e000 [size=32]
        Capabilities: [80] Power Management version 2

00:10.3 0c03: 1106:3038 (rev 81)
        Subsystem: 1458:5004
        Flags: bus master, medium devsel, latency 32, IRQ 177
        I/O ports at e400 [size=32]
        Capabilities: [80] Power Management version 2

00:10.4 0c03: 1106:3104 (rev 86) (prog-if 20)
        Subsystem: 1458:5004
        Flags: bus master, medium devsel, latency 32, IRQ 177
        Memory at ea000000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [80] Power Management version 2

00:11.0 0601: 1106:3227
        Subsystem: 1458:5001
        Flags: bus master, stepping, medium devsel, latency 0
        Capabilities: [c0] Power Management version 2

00:11.5 0401: 1106:3059 (rev 60)
        Subsystem: 1458:a002
        Flags: medium devsel, IRQ 193
        I/O ports at e800 [size=256]
        Capabilities: [c0] Power Management version 2

01:00.0 0300: 1002:4150
        Subsystem: 1458:4022
        Flags: bus master, 66MHz, medium devsel, latency 255, IRQ 201
        Memory at d8000000 (32-bit, prefetchable) [size=128M]
        I/O ports at c000 [size=256]
        Memory at e9000000 (32-bit, non-prefetchable) [size=64K]
        [virtual] Expansion ROM at e8000000 [disabled] [size=128K]
        Capabilities: [58] AGP version 3.0
        Capabilities: [50] Power Management version 2

01:00.1 0380: 1002:4170
        Subsystem: 1458:4023
        Flags: bus master, 66MHz, medium devsel, latency 32
        Memory at e0000000 (32-bit, prefetchable) [size=128M]
        Memory at e9010000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [50] Power Management version 2

Simpl...

Read more...

Daniel T Chen (crimsun) wrote :

Please try:

sudo modprobe -r $(lsmod |grep ^snd |awk '{print $1}' |sort -r) && sudo modprobe snd-via82xx dxs_support=2

Pawel (paweldk) wrote :

OK, I've got:

" pawel@kubuntu:~$ sudo modprobe -r $(lsmod |grep ^snd |awk '{print $1}' |sort -r) && sudo modprobe snd-via82xx dxs_support=2
FATAL: Module snd_via82xx is in use."

Pawel (paweldk) wrote :

And the problem still exist :(

Johnny Levai (digistyl3) wrote :

Same here :(
Please help...

Johnny Levai (digistyl3) wrote :

I was stupid enough not to search 1st... oh well, here is my report, with more info:
https://launchpad.net/distros/ubuntu/+bug/68876

Daniel T Chen (crimsun) wrote :

sudo kill $(lsof -t /dev/dsp* /dev/snd/*) && sudo modprobe -r $(lsmod |grep ^snd |awk '{print $1}' |sort -r) && sudo modprobe snd-via82xx dxs_support=2

Johnny Levai (digistyl3) wrote :

Thank you for your help... but it still doesn't work, this time i get:
FATAL: Module snd_timer is in use.

:(

Daniel T Chen (crimsun) wrote :

Ok. Please issue the following command (as one line), and then reboot:

echo "options snd-via82xx dxs_support=2" |sudo tee -a /etc/modprobe.d/alsa-base

Pawel (paweldk) wrote :

Ok - I've done:
"echo "options snd-via82xx dxs_support=2" |sudo tee -a /etc/modprobe.d/alsa-base"
and now all seems to work good. No more "cpu overload" and sound working in all apllications.
Thank You very much
Best regards

Daniel T Chen (crimsun) wrote :
Changed in linux-source-2.6.17:
status: Needs Info → Fix Committed
Johnny Levai (digistyl3) wrote :

Thank you so much for your help :) I hope this kernel patch will reach us as soon as possible.
Another question: what do I do with Knotify? It disables the arts output, and I don't have system sounds, nor kopete ones.

Mirco Briosi (mail-miobio) wrote :

Please,

Consider this card as well

00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
         Subsystem: IBM Unknown device 05b7
         Flags: bus master, fast devsel, latency 0, IRQ 169
         Memory at b0000000 (64-bit, non-prefetchable) [size=16K]
         Capabilities: [50] Power Management version 2
         Capabilities: [60] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
         Capabilities: [70] Express Unknown type IRQ 0
         Capabilities: [100] Virtual Channel
         Capabilities: [130] Unknown (5)

It has the same problem as the via82xx!!!

My laptop is an IBM Z60m, I tried to add

options snd-hda-intel dxs_support=2

to

/etc/modprobe.d/alsa-base

with no success, if i do so the card is not detected at boot time :-(

Please help

More infos at:

https://launchpad.net/distros/ubuntu/+source/arts/+bug/66982

Thanks

Johnny Levai (digistyl3) wrote :

Hi, I still can't set the volume in KMix, nor in Alsamixer. PCM is not present in KMix, and in Alsamixer I can't give a value to it (dead). Will the kernel update fix this? Because volume management is imposible via these... :(

Daniel T Chen (crimsun) wrote :

@Mirco: Your issue is completely different, since you use different hardware. Your hda_intel driver doesn't have the dxs_support parameter (because it's via82xx-specific, and well, you don't have that sound chipset). Please search other hda_intel bug reports.

Keep in mind there are a bevy of hda_intel patches that have yet to be merged into Dapper and Edgy by our kernel lead, and there's no ETA on that.

In short, don't confuse similar symptoms with identical causes.

@Johnny: Please describe your problem succinctly as it regards the "sound server fatal error." If that's no longer an issue after using the dxs_support=2 parameter, please file a separate bug report for the alsamixer & KDE issues. This bug report is _not_ the place for general audio support.

kiki9 (kiki9) wrote :

Same problem for me.
first time i start kde, it freezes for about 15 secs. then the message "sound server fatal error....." appears. this message appears every few secs.
cpu load for artsd is at 99%. when i click to disable arts at knotify dialog, the message doesnt appear anymore -> artsd is closed.
although i can play audio files with amarok, but i dont hear system sounds.

lspci:
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 30)

lsmod:
via82cxxx 9604 0 [permanent]

snd_via82xx 28696 2
gameport 15368 1 snd_via82xx
snd_ac97_codec 96672 1 snd_via82xx
snd_ac97_bus 2432 1 snd_ac97_codec
snd_pcm_oss 46080 0
evdev 10496 1
rtc 12596 0
snd_mixer_oss 18560 1 snd_pcm_oss
snd_pcm 80520 3 snd_via82xx,snd_ac97_codec,snd_pcm_oss
snd_timer 23172 2 snd_seq,snd_pcm
snd_page_alloc 10504 2 snd_via82xx,snd_pcm
snd_mpu401_uart 8704 1 snd_via82xx
snd_rawmidi 25600 2 snd_seq_midi,snd_mpu401_uart
snd_seq_device 8972 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq,snd_rawmidi
snd 55428 15 snd_seq_oss,snd_seq,snd_via82xx,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device

Johnny Levai (digistyl3) wrote :

I commited the fix, then
System Settings -> Sound system -> Hardware -> Select audio device:
I selected ALSA there. And then after a restart I had system sounds with KNotify (Use KDE sound system).

kiki9 (kiki9) wrote :

yes, problem solved for me too with:
1.
echo "options snd-via82xx dxs_support=2" |sudo tee -a /etc/modprobe.d/alsa-base
2. reboot
3. then System Settings -> Sound system -> Hardware -> Select audio device: ALSA
4. reboot

thanks a lot

Johnny Levai (digistyl3) wrote :

Users affected by this bug and have fixed it, should check out this too: https://launchpad.net/distros/ubuntu/+bug/69984
please

Joel Oliver (joelol75) wrote :

A fix is to modify /etc/modprobe.d/alsa-base

and make the option line read:

options snd-via82xx dxs_support=5

This seems to fix everything on my MSI KT6-Delta with VIA chipset with VIA CMedia 5.1 sound

Joel Oliver (joelol75) wrote :

This thread is duplicates of 68876 and 69984

Brian Murray (brian-murray) wrote :
Changed in linux-source-2.6.17:
status: Fix Committed → Fix Released
Changed in linux-source-2.6.15:
assignee: nobody → crimsun
status: New → Fix Released
Changed in linux-source-2.6.15:
status: Fix Released → Fix Committed
Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
Changed in linux-restricted-modules-2.6.15:
assignee: nobody → crimsun
status: New → Fix Released
Changed in linux-restricted-modules-2.6.15:
status: Fix Released → Invalid
Changed in linux-source-2.6.15:
status: Fix Released → Fix Committed
Schmirrwurst (schmirrwurst) wrote :

I experience the same problem under feisty with kernel :
Linux marion-laptop 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

The options is not there by default in modprobe.d, I'm now trying with it, and report back...
But one is sure, the issue remains in feisty !

Schmirrwurst (schmirrwurst) wrote :
Caroline Ford (secretlondon) wrote :

schmirrwurst:

00:07.5 Multimedia audio controller [0401]: VIA Technologies, Inc. VT82C686 AC97 Audio Controller [1106:3058] (rev 50)
 Subsystem: Compaq Computer Corporation SoundMax Digital Integrated Audio [0e11:0097]
 Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Interrupt: pin C routed to IRQ 5
 Region 0: I/O ports at 1000 [size=256]
 Region 1: I/O ports at 1854 [size=4]
 Region 2: I/O ports at 1850 [size=4]
 Capabilities: [c0] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-

Changed in linux-restricted-modules-2.6.20:
status: New → Invalid
Changed in linux-restricted-modules-2.6.22:
status: New → Invalid
Caroline Ford (secretlondon) wrote :

Does this still happen in hardy?

Also adding a note that we'll keep this open against the actively developed kernel but against 2.6.20 and 2.6.22 this will be closed. Thanks.

Changed in linux:
status: New → Incomplete
Changed in linux-source-2.6.20:
status: New → Won't Fix
Changed in linux-source-2.6.22:
status: New → Won't Fix
Daniel T Chen (crimsun) on 2008-03-08
Changed in linux-source-2.6.15:
status: Fix Committed → Won't Fix
Changed in alsa-driver:
assignee: nobody → crimsun
importance: Undecided → Low
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-driver - 1.0.16-0ubuntu4

---------------
alsa-driver (1.0.16-0ubuntu4) hardy; urgency=low

  * Patches (debian/patches/):
    - post_16_20080307.patch (obsoletes post_16_20080226) adds shadowed
      variable and integer as NULL pointer fixes and HDA quirks,
    - add_suspend_quirk_hp_nc6220_nw8240.patch fully fixes LP: #151111,
    - readd refix_lp_68659_by_disabling_dxs_for_0x1458a002.patch to
      close LP: #68659. This patch apparently never made it into Feisty,
      Gutsy, or Hardy.

 -- Daniel T Chen <email address hidden> Sat, 08 Mar 2008 20:11:33 -0500

Changed in alsa-driver:
status: In Progress → Fix Released

I think this will still need to be pulled into linux-ubuntu-modules. Reasigning to the apropriate package. Thanks.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged

This problem still exists in gutsy, at least in the 64 bit. should i just try the fix mentioned above or should i wait for a patch?

uname -a :
Linux real-ate-server 2.6.24-16-generic #1 SMP Thu Apr 10 12:47:45 UTC 2008 x86_64 GNU/Linux

Stefan Bader (smb) on 2008-06-10
Changed in linux-ubuntu-modules-2.6.24:
assignee: ubuntu-kernel-team → stefan-bader-canonical
status: Triaged → In Progress
Stefan Bader (smb) wrote :

SRU justification:

Impact: Enabling DXS for a certain (known to be broken) ID results in errors and freezes.

Fix: Add code to disable DXS through a quirk entry. Impact should be minimal, since the change only takes effect for a specific PCI ID.
(Commited as 3447d1b2f89556ce3da8675bf972c0bb047d45da)

Testcase: (from bug report) arts sound (kde) is not working at all, arts daemon freezes, etc. With DXS disabled it works.

Changed in linux-ubuntu-modules-2.6.24:
milestone: none → ubuntu-8.04.1
status: In Progress → Fix Committed
Steve Langasek (vorlon) on 2008-06-11
Changed in linux-ubuntu-modules-2.6.24:
milestone: ubuntu-8.04.1 → none
Changed in alsa-driver:
importance: Undecided → Low
status: New → Fix Released
Changed in linux-restricted-modules-2.6.15:
status: New → Invalid
Changed in linux-restricted-modules-2.6.20:
status: New → Invalid
Steve Langasek (vorlon) on 2008-06-11
Changed in linux-restricted-modules-2.6.22:
status: New → Invalid
Steve Langasek (vorlon) on 2008-06-11
Changed in linux-source-2.6.15:
status: New → Invalid
Steve Langasek (vorlon) on 2008-06-11
Changed in linux-source-2.6.17:
status: New → Fix Released
Changed in linux-source-2.6.20:
status: New → Invalid
Changed in linux-source-2.6.22:
status: New → Invalid
Changed in linux-ubuntu-modules-2.6.24:
importance: Undecided → Medium
status: New → Triaged
Stefan Bader (smb) on 2008-06-12
Changed in linux-ubuntu-modules-2.6.24:
assignee: nobody → stefan-bader-canonical
status: Triaged → In Progress
Stefan Bader (smb) wrote :

Fix is commited to git but not yet to any release.

Changed in linux-ubuntu-modules-2.6.24:
status: In Progress → Fix Committed
Steve Langasek (vorlon) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

linux-ubuntu-modules-2.6.24 -21 copied to hardy-updates.

Changed in linux-ubuntu-modules-2.6.24:
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments