BUG: soft lockup detected on CPU#0!

Bug #60053 reported by Matteo Giordano on 2006-09-12
14
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.17 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-image-2.6.17-7-generic

When I reboot or shutdown the system I get the line:

BUG: soft lockup detected on CPU#0!

before the system locks up without rebooting or halting.

malte@ubuntu-lamp:~$ uname -a
Linux ubuntu-lamp 2.6.17-7-generic #2 SMP Wed Sep 6 14:54:50 UTC 2006 x86_64 GNU/Linux

Janne Vanhala (jpvanhal) wrote :

I have the same problem. It seems that if I type 'sudo reboot' on terminal, the system reboots as it should.

I also noticed that when this soft lockup occurs, some files get corrupted on my home partition. Firefox bookmarks and settings get corrupted every time because of this, and sometimes settings of other programs too.

$ uname -a
Linux ubuntu 2.6.17-7-generic #2 SMP Wed Sep 6 14:54:50 UTC 2006 x86_64 GNU/Linux

Øyvind Grønnesby (oyving) wrote :

Same problem here as well, locks up when doing shutdown.

: othello ~$ uname -a
Linux othello.oyving.org 2.6.17-7-generic #2 SMP Wed Sep 6 14:54:50 UTC 2006 x86_64 GNU/Linux
: othello ~$ cat /proc/cpuinfo | grep "model name" | head -1
model name : AMD Athlon(tm) 64 X2 Dual Core Processor 4200+

Ben Collins (ben-collins) wrote :

Is there any further information with this output. Can you try Alt+SysRQ+t and see if there's anything running that might be hung?

Janne Vanhala (jpvanhal) wrote :

Alt+SysRq+T prints "SysRq: Show State", but I guess that doesn't help much.

Matteo Giordano (ilmalteo) wrote :

I get the same "SysRq: Show State" message.

Ben Collins (ben-collins) wrote :

Try doing Alt+SysRQ+9 first, to bump the log level up,

Yachar (yach) wrote :

Had the same problem, related to usplash I think because removing it solved it.
Since the latest usplash update (0.4-25), everything's fine.

AMD64 x2 3800+

Janne Vanhala (jpvanhal) wrote :

I tried doing Alt+SysRq+T again and now it printed a few screenfuls of text. I was able to read that usplash was running before the screen was filled with a call trace. I couldn't find any log of this in /var/log, but I'll take a couple of pictures of the output tomorrow when I have a camera available.

The latest usplash didn't solve this for me, but disabling usplash did.

Yachar (yach) wrote :

Hmmm... maybe it's working for me with the latest usplash because it can't find any artwork =)
So this might be related to usplash after all... maybe someone could re-assign the bug (don't know how this should work).

Janne Vanhala (jpvanhal) wrote :

Yep, it seems to be a usplash problem, since disabling usplash resolves it. Maybe this is somehow related to usplash segfaulting on amd64?

Here's the output of Alt+SysRq+T:

Janne Vanhala (jpvanhal) wrote :
Henk Koster (h-a-j-koster) wrote :

Just today (18 Sept/06) installed Edgy Knot 3, the same "soft lockup" message on my AMD Opteron box, alternating between CPU#0 and CPU#1. Also, usplash segfaults, and in fact there is no splash screen on boot or on shutdown/reboot;
the latter needs using the shutdown/reboot button.

FWIW, I use the same kernel version 2.6.17-7 with Gentoo, no problem there.

Yachar (yach) wrote :

Some annoying thing, when this bug occurs, somehow gconf settings are lost... disabling usplash then helps the box stopping / rebooting and gconf settings to be remembered.
That may be a file system issue, but I don't think so as only gconf settings are lost, no other settings / files.

BenjaminOtto (benjaminotto) wrote :

I don't know if that is the same Bug, but after yesterdays

apt-get update && apt-get dist-upgrade

i got that bug everytime i booted. Reading through launchpad i found out it might have to do with the linux-restricted-modules (wifi). Voila,

apt-get remove linux-restricted-modules-2.6.17-8-386

and my laptop (Lenovo T60) booted again.

Yachar (yach) wrote :

No wifi card here. And the box boots nicely, the bug only prevents it to stop (or reboot).
The gconf settings are probably lost because the bug is triggered before gconf had time to store its settings...

Yachar (yach) wrote :

Happened to me once again as a dist-upgrade happened to install usplash again... I held the package and disabled usplash at start.

IMO, this bug should be marked "Confirmed" and severity "High" or "Critical", as all gconf settings are lost and that is extremely annoying... I don't know yet if I'm the only one losing my gconf settings everytime, but that would be very bad luck.

Does anyone confirm this behavior ?

Janne Vanhala (jpvanhal) wrote :

I can confirm that I lose Firefox settings everytime this happens, sometimes I lose settings of Nautilus, Thunderbird, Liferea, Gaim, etc. It's not just gconf settings that are lost. The config files don't get deleted, but somehow they get corrupted. If I open them, they contain just some random data.

Henk Koster (h-a-j-koster) wrote :

Well, the Soft Lockup errors are gone with the latest kernel update, 2.6.17-9-generic -- but then the restricted-modules for this kernel are being held back (this is 22 Sept/06 1900 UTC). We'll keep our fingers crossed. I still have all the problems with various gconf files, and also Synaptic and Update do not accept my password... I wonder how these things can be restored?

Austin (austin-linux) wrote :

I've had this error consistently at every boot, right near the end of init scripts. CPU usage goes to full and the system locks up. Every time. This has happened with all of the 2.6.17 generic kernels. Going back to 2.6.15 fixes the problem. Going to 2.6.17-386 kernel also fixes the problem, but it's not an SMP kernel, which I need.

Hardware: i945, core duo, ipw3945, hda audio

James W. Dumay (jdumay) wrote :

I can comfirm this also. This happens for me after the machine has been up for 10 or so minutes and I loose ndiswrapper functionality (the wireless card wont respond).

Turning off Hyperthreading functionality allows the machine to keep running without issue.

When this occurs I get the following trace in the kernel log
[17180332.336000] BUG: soft lockup detected on CPU#1!
[17180332.336000] <c01491df> softlockup_tick+0x9f/0xf0 <c012bee1> update_process_times+0x31/0x80
[17180332.336000] <c0114d13> smp_apic_timer_interrupt+0x53/0x60 <c010413c> apic_timer_interrupt+0x1c/0x30
[17180332.336000] <c026007b> pci_early_fixup_cyrix_5530+0x2b/0x50 <f8bbb884> ExInterlockedPopEntrySList+0x84/0xb0 [ndiswrapper]
[17180332.336000] <f8bc7175> tx_worker+0x585/0x700 [ndiswrapper] <c0132702> run_workqueue+0x72/0xf0
[17180332.336000] <f8bc6bf0> tx_worker+0x0/0x700 [ndiswrapper] <c01332e7> worker_thread+0x117/0x140
[17180332.336000] <c011bde0> default_wake_function+0x0/0x10 <c01331d0> worker_thread+0x0/0x140
[17180332.336000] <c0135f8b> kthread+0xab/0xe0 <c0135ee0> kthread+0x0/0xe0
[17180332.336000] <c0101005> kernel_thread_helper+0x5/0x10

Here is a cat /proc/cpuinfo for more details
processor : 0
vendor_id : GenuineIntel
cpu family : 15
model : 2
model name : Intel(R) Pentium(R) 4 CPU 2.80GHz
stepping : 5
cpu MHz : 2793.501
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe up cid xtpr
bogomips : 5592.27

soc (simon-ochsenreither) wrote :

i can confirm this, too.
nearlx the same log as above, except that i have an ipw3945.
cpu is an intel core duo.

Timothy (timothyparez) wrote :

I have the same problem while trying to intall (booting the cd)

Intel Core Duo 2.16Ghz

eMerzh (emerzh) wrote :

Same Problem.... multiple freeze with error "soft lockup detected..."
after many reboot, i've remove usplash... and....ubuntu seems to work well now....

Thadeu Penna (tjpp) wrote :

I confirm this is related to usplash on amd64.
~$ uname -a
Linux ubuntu 2.6.17-7-generic #2 SMP Wed Sep 6 14:54:50 UTC 2006 x86_64 GNU/Linux

Removing uspĺash does the trick.

Andrew Jorgensen (ajorg) wrote :

I see the same notice. Just before this notice I get:

eth0: Host error, FIFO diagnostic register 8000.
eth0: PCI bus error, bus status 800000a0

This is on a Dell Lattitude C600 which has a 3com NIC. It only seems to happen on a reboot (not on a halt and then a boot).

Many of the other reports I've read seem to suggest that pcmcia might be related to the problem. I have a very generic Prism 2.5 card (BenQ AWL100) in my pcmcia slot.

Changed in linux-source-2.6.17:
status: Unconfirmed → Confirmed
Ante Karamatić (ivoks) wrote :

This happens to me even with usplash off.

Ante Karamatić (ivoks) wrote :

Update: it happens only with wifi kill swtich on. If kill switch is off, only way to boot is to disable acpi.

Ante Karamatić (ivoks) wrote :

Sorry, it's ipw3945.

U Uto, 17. {$Month}. 2006., u 15:45 +0000, Ante Karamatić je napisao/la:

> Sorry, it's ipw3945.

This is a regression from Dapper. Dapper boots with wifi turned off.

shrd (shrd) wrote :

I have this bug too on edgy , i have a lapton dell inspiron 6400.
I guess the problem is the wifi (ipw3945).
If I desactivate the wifi (in the bios or with the hotkey), edgy load normally.
If i let wifi open, edgy crash at the middle of loading with the error "soft lockup detected on cpu#o"
Notice that i have this message only in recovery mode (no error message in normal mode, the system hangs)
When edgy is load, and if i reactivate wifi with the hotkey, wifi dont work completly for me : all seems to be normal , access point found, iwconfig normal (but ifconfig display packets errors) => no way to route any packets even to the access point. (ping 192.168.0.1 (my access point) gives 'destination host unreachable')
However, In network monitor, wifi packets are well received (many per seconds), but only few are send, 1 each second or like that.
I have noticed too, a strange thing, if I use the ethernet card for internet and go on a random http address wth firefox, and next desactivate the ethernet card and next activate the wifi, and reload the page on firefox, it is working for this page (wifi packets seems to send when i look the network monitor) but only on this page (what is strange is that it seems to be not the cache on firefox which display the page but really packets transmission via wifi)

Else, In Dapper wifi worked fine (but I had a problem with the smp kernel with speedstep cpu like the core duo until the patch release some months ago).
Edgy and his generic kernel is very fine for that.

Øyvind Grønnesby (oyving) wrote :

This was not an error with WiFi cards, since my computer is a regular
desktop and doesn't have one. It was connected with usplash, though.
After an update of that package it stopped hanging on boot, but would
segfault due to missing theme for my screen resolution (or something in
this direction, forgive me if my memory fails me).

A few updates of usplash later I no longer get the lockup during
shutdown, but usplash still doesn't work properly (doesn't update during
the boot sequence and the picture looks awful).

This doesn't sound like the problem the laptop users have, even if they
get the same symptoms. My guess is that this bug shouldn't have been
merged earlier, because the soft lockup issues seems to be resolved.

--
Øyvind Grønnesby

shrd (shrd) wrote :

nota : after reinstallation of linux-restricted-modules-generic, my wifi connection works fine now.
I tell you later if I have again the bug "soft lockup detected on CPU#0!" on boot

Jon A. (jonathanadams02) wrote :

This happened to me tonight as well - as this was one of the few places I found information on the problem, and more importantly, found a 'resolution', I felt obliged to share.

uname -a
Linux $machineName 2.6.17-10-generic #2 SMP Fri Oct 13 hh:mm:ss UTC 2006 i686 GNU/Linux

I have Ubuntu Edgy Eft installed on a Dell XPS M1210 laptop and until today, it was always booted with the hardware WiFi switch turned ON. As I was in a place w/o WiFi earlier in the day I had turned this off and had problems on every subsequent reboot. After reading most of the way down this page I rebooted (read 'one finger saluted') the laptop w/ the hardware switch on - and it worked like a charm.

There seems to be various causes for this - hopefully the dev teams will give this some attention soon.

No package changes, just booting w/ the hardware switch turned ON was enough.

Hope this helps someone else!

As a P.S. aside - before this problem, and the reboot w/ the hardware switch on, I had always had to 'sudo ifup eth1' after booting, but this time I had an IP by the time I had a desktop. Weird?! Word.

Jon A. (jonathanadams02) wrote :

Incidentally, the laptop now boots up and shuts down faster... Stranger still.

Sascha Herres (saschaherres) wrote :

I can confirm this bug and the solution presented by Jon A.:

My system is a "Dell Latitude D820" with no cables connected at all. A boot up with the WiFi switch turned OFF will fail with a freezed splash screen, the recovery mode shows a "Bug: soft lockup detected on CPU#0!" during starting LVM. If I set the WiFi switch to ON the system boots up normal. I tested this behaviour five times each way.

I have an up-to-date system with no special adaptions. I use the nvidia-glx.

If more informations are needed, please feel free to contact me.

Ante Karamatić (ivoks) wrote :

This bug was reported cause of the issues with usplash. Usplash has been fixed, but same symptoms are caused by another bug. That bug is reported as bug 63418. I'm marking this bug as a duplicate of that one.

jdmux (johnwohlbier) wrote :

I have the same issue as Andrew Jorgensen

eth0: Host error, FIFO diagnostic register 8000.
eth0: PCI bus error, bus status 800000a0

my box is an old one with no wifi.

Ante Karamatić (ivoks) wrote :

U Sri, 08. 11. 2006., u 04:56 +0000, jdmux je napisao/la:

> my box is an old one with no wifi.

But probably has something from nvidia? :) Try adding 'irqpoll' as a
boot option.

Do you get 'Soft lockup detected' message or your computer just freezes?
This is not about freezing, but about CPU lockups (which includes
freezing, tough).

jdmux (johnwohlbier) wrote :

It does have an old nvidia card (circa 2001). I'll try the boot option.
If that were to work, but the winxp didn't boot, that would mean ...?

I don't get "Soft lockup," it just freezes at the

eth0: Host error, FIFO diagnostic register 8000.
eth0: PCI bus error, bus status 800000a0

message.

jgw

On 11/7/06, Ante Karamatić <email address hidden> wrote:
>
> *** This bug is a duplicate of bug 63418 ***
>
> U Sri, 08. 11. 2006., u 04:56 +0000, jdmux je napisao/la:
>
> > my box is an old one with no wifi.
>
> But probably has something from nvidia? :) Try adding 'irqpoll' as a
> boot option.
>
> Do you get 'Soft lockup detected' message or your computer just freezes?
> This is not about freezing, but about CPU lockups (which includes
> freezing, tough).
>
> --
> BUG: soft lockup detected on CPU#0!
> https://launchpad.net/bugs/60053
>

Ante Karamatić (ivoks) wrote :

U Sri, 08. 11. 2006., u 05:56 +0000, jdmux je napisao/la:

> It does have an old nvidia card (circa 2001). I'll try the boot option.
> If that were to work, but the winxp didn't boot, that would mean ...?

You should check your BIOS, since this error is about broken PCI. Set
your BIOS config to default and try with that. You could also try
removing last hardware you added to your computer, cause it could be
causing this problem.

> I don't get "Soft lockup," it just freezes at the

So, you problem has nothing to do with this bug :) As I said, it's
probably hardware problem or wrong BIOS setup.

--
Ante Karamatić <email address hidden>

The 18 month support period for Edgy Eft 6.10 has reached its end of life. As a result, we are closing the linux-source-2.6.17 Edgy Eft kernel task. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers