rt61pci can't scan or associate

Bug #58117 reported by Nafallo Bjälevik on 2006-08-29
32
Affects Status Importance Assigned to Milestone
linux-source-2.6.17 (Ubuntu)
High
Ben Collins
linux-source-2.6.20 (Baltix)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned
linux-ubuntu-modules-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

 Hi!

As discussed on IRC, rt2x00 isn't quite mature yet. I can't scan for network and I can't associate to them manually. This is a regression from 6.06 LTS, where we used RaLinks drivers. It is probably to late in the cycle to figure all this out, so a revert should be made. I guess the sames counts for rt73, but I have no facts on that.

Cheers, /Nafallo

Nafallo Bjälevik (nafallo) wrote :

Oh, this is i386 by the way. Have tried with the i686 aswell, and in 6.06 LTS the 686-kernel crashed, while i386 does fine. I think that's an SMP-bug I've read about somewhere :-).

Changed in linux-source-2.6.17:
assignee: nobody → ben-collins
importance: Untriaged → High
Nafallo Bjälevik (nafallo) wrote :

rt61 legacy works.

Ben Collins (ben-collins) wrote :

Newer rt2x00 in edgy will hopefully fix this.

Changed in linux-source-2.6.17:
status: Unconfirmed → Fix Committed
Nafallo Bjälevik (nafallo) wrote :

nafallo@silverfairy:~ $ iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wmaster0 No scan results
wlan0 No scan results
sit0 Interface doesn't support scanning.

- - -
Nope, it does not.

Nafallo Bjälevik (nafallo) wrote :

Still the same with 2.6.17-9-generic.

Nafallo Bjälevik (nafallo) wrote :

One difference though:
wmaster0 Failed to read scan data : Operation not supported

Nafallo Bjälevik (nafallo) wrote :

Since it didn't fix it, I'll bump down to Confirmed again so it won't be missed.

Changed in linux-source-2.6.17:
status: Fix Committed → Confirmed
Nafallo Bjälevik (nafallo) wrote :

Ben, it's to late to fix this in edgy I'm rather certain. What's the plan for feisty?

Hamish Downer (mishd) wrote :

Is there a manual way to make it use the legacy driver (which Christian Bjälevik reports works OK)? By the legacy driver I assume you are referring to

/lib/modules/2.6.17-10-386/kernel/drivers/net /wireless/rt2x00-legacy/rt2500/rt2500.ko

I've tried a few things but been unable to get ra0 up as under dapper.

I've added rt61pci to /etc/modprobe.d/blacklist to ensure there is no conflict

I've added the file /etc/modprobe.d/rt2500 with contents of

alias ra0 rt2500

I've tried manually doing modprobe of rt2500. I've tried adapting bits of http://rt2x00.serialmonkey.com/phpBB2/viewtopic.php?t=899 - I've loaded ieee80211, rate-control and rt2500 (in that order), but so far nothing has worked. But even after that, ifconfig -a and iwconfig do not report any wireless interfaces.

(lspci -v reports the chip is RaLink RT2561/RT61 )

Any clues? Otherwise I may have to regress to dapper :(

Nafallo Bjälevik (nafallo) wrote :

rt2500 is for rt2500, not for rt61... so no, I was referring to the daily built tarball from upstream. you will have to compile it yourself.

Karsten Dello (karsten-dello) wrote :

Had the same problem. The card ran fine using rt61-module in dapper, but I couldn't get it to work using the rt61pci-module in edgy. Have spent hours but could not get it to work.

But the card works flamelessly in edgy using the ratech drivers (rt61).
Here is what I did:

1) i got the drivers from http://www.ralinktech.com/drivers/Linux/RT61_Linux_STA_Drv1.0.4.0.tar.gz

2) followed the readme to compile the kernel-module.
the rt61-module compiles fine, as usual linux-headers were required.
copied the firmware and the modified configuration file (set up ssid,wpa etc.) to /etc/Wireless/RT61STA/
Afterwards copied rt61.ko somewhere below /lib/modules/<kernel-version/
and run depmod

3) blacklisted the - broken? - ubuntu kernel module in /etc/modprobe.d/blacklist:
blacklist rt61pci

4) added the ratech-module in /etc/modules
and put an alias in /etc/modprobe.d/aliases:
alias ra0 rt61

5) added the following lines to /etc/network/interfaces:

iface ra0 inet static
address 192.168.7.228
netmask 255.255.255.0
gateway 192.168.7.1
auto ra0

Works perfectly for me.

Hi,

I newly bought a EDIMAX 7108PCg Wlan Card, which uses the ralink drivers and i have the same problem as described above from Karsten. I plugged in the the card and the rt61pci was loaded, but that was it. I couldn't do anything, no associate, no scan. I googled for an answer, but all I found was that it should work fine.
Then I downloaded the rt61 driver from: http://rt2x00.serialmonkey.com and everything is working fine now.

well not quite, the guis don't like that driver much obviously.
CLI saves me for now, everything is working on it. :)

Gaëtan Petit (gaetanp) wrote :

instead of the rt61 from serialmonkey you could install the official drivers from ralink (yes they are free).
It is nicely describe in the ubuntu.com wiki.

Andrew Conkling (andrewski) wrote :

Christian Bjälevik says:
> Ben, it's to late to fix this in edgy I'm rather certain. What's the plan for feisty?

Um... seriously? This is a showstopper for anyone with this card, and it's simply not going to be updated/fixed in Edgy?

Saesneg (david-deans) wrote :

I can confirm the same problem with the rt2500 card. Unfortuntly the card does not work following a blacklisting of the rt61pci driver and an install of the legacy drivers - leaving me without an internet connection. Without the blacklisting, my card refuses to see any network or connect to anything. Stranded in windows as a result atm.

Nafallo Bjälevik (nafallo) wrote :

David: This bugreport is not about rt2500 however. And for me rt2500 works just fine.
tenshu: The rt61 legacy drivers from the rt2x00 project is the ralink ones with bugfixes applied. The best alternative would be to use that nightly-cvs since the "latest stable" are one that causes instant kernel panic on modprobeing.

Cheers, /C

Saesneg (david-deans) wrote :

Christian: but rt2500 and rt61 are covered by the same driver under ubuntu? I thought we were talking about all cards covered by this driver?

Gaëtan Petit (gaetanp) wrote :

No rt2500 and rt61 are two different drivers (see ralink official site).
I think your confuse because the open source project serialmonkey is developping support both rt2500 and rt61

Nafallo Bjälevik (nafallo) wrote :

David: In 6.10 we are using rt2400, rt2500 and rt2570 legacy drivers (ralink+rt2x00 fixes), for the rest (rt61*, rt73*) we are using the rewritten rt2x00 driver. So no, not the same driver. My proposal from the starting of this bugreport have been to use the legacy drivers for all cards, as I think it was in 6.06.

Javier Jardón (jjardon) wrote :

t's possible to upgrade the rt61pci module to the latest CVS and compiled with the 'debug' option enabled?

This manner I would help the developers to investigate the problems with the driver

Thanks.

Javier Jardón (jjardon) wrote :

A partial solution: see bug #67607

Gaëtan Petit (gaetanp) wrote :

This bug still in Fesity herd1

It is listing wlan0 & wlanmaster, and none of them work

still there on herd 2; btw last cvs from serialmonkeys seems to be working!

Javier Jardón (jjardon) wrote :

Please consider rt61 PCI/PCMCIA (http://rt2x00.serialmonkey.com/rt61-cvs-daily.tar.gz) drivers instead rt2x00 (http://rt2x00.serialmonkey.com/rt2x00-cvs-daily.tar.gz).
rt61 works fine for me but rt2x00 not.

Timo Jyrinki (timo-jyrinki) wrote :

I saw some changes just a few days ago, so apparently rt2x00 is not anymore used for every card. So try eg. next Thursday's beta and report back.

Steffen Torp (steffen-ubuntu) wrote :

It's still not working out of the box, it seems from this post: http://www.ubuntuforums.org/showthread.php?t=392415

Gaëtan Petit (gaetanp) wrote :

na this won't work out from the box

because the driver used isn't working with network-manager
so i have to use the old panel and do a sudo /etc/initi.d/networking restart every boot ...

Huygens (huygens-25) wrote :

To Gaëtan and Steffen,
Did you try the suggestion in this forum (posted today): http://www.ubuntuforums.org/showpost.php?p=2394056&postcount=271

Javier Jardón (jjardon) wrote :

 Huygen, this bug is about rt61pci driver (new rewriten driver developed for the rt2x00 team), no rt61 (oficial driver of ralink packaged for rt2x00 team)

Javier Jardón (jjardon) wrote :

In Xubuntu 7.04 final

I blacklisted rt61
Add rt61pci to /etc/modules
Changue my /etc/network/interfaces:
       iface wlan0 inet dhcp
       auto wlan0
iwlist scan
   lo Interface doesn't support scanning.
   eth0 Interface doesn't support scanning.
   wmaster0 No scan results
   wlan0 No scan results
   sit0 Interface doesn't support scanning.

Changue to rt61 driver causes me lookups: bug #34902

Javier Jardón (jjardon) wrote :

I make a mistake

Changed in linux-source-2.6.20:
status: Unconfirmed → Rejected

try appending acpi=force irqpoll to your kernel parameters https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.17/+bug/63134

Paul van Genderen (paulvg) wrote :

Tried that, but it yields the same result

once loggedin with those parameters I disabled and re-enabled the interface and then I gave a

sudo dhclient

from the terminal and I was connected... (not intuitive though...)

bye

Javier Jardón (jjardon) wrote :

Hello,

in Gutsy tribe 5 no problems for me. My two cards (rt2500 and rt61 based) work 'out of the box'. Seems that the new rt2x00 driver (rt2500pci and rt61pci) are used instead legacy drivers (rt2500 and rt61).

Thank you!

Brian Pitts (bpitts) wrote :

I experience freezes in current Gutsy. See bug #68810.

Kyle M Weller (kylew) wrote :

A status update on this fix would be appreciated to us all, and a few questions im sure we all are wondering/waiting for...
Is this being worked on?
Is there a patch/solution?
Who is in charge of the compatibility/coding of this driver?
Will it be fixed before Gutsy is released?
Why has the ralink drivers not been working well in ubuntu for the past 5-6 releases?
--
We all love Ubuntu and unfortunately us users with belkin/ralink drivers can not see the full beauty and usability of this great new os, I know it is a goal/standard to make Ubuntu run straight out of the box for anything, if we could resolve this issue it would be more than appreciated, maintainers/dev's please search for ralink, rt73, belkin, and other problems because there should be none, we want this os to be grandparent friendly/new user friendly.
Thankyou & Best Regards,
Kyle Weller

Brian Pitts (bpitts) wrote :

rt61pci is working for me now

Hi Nafallo,

Can you confirm if this bug still exists with the new 7.10 Gusty Gibbon release that just came out. Thanks!

Changed in linux-ubuntu-modules-2.6.22:
importance: Undecided → Medium
status: New → Incomplete

confirmed with rt73 ralink card

Gaëtan Petit (gaetanp) wrote :

this bug report is for rt61pci

i can confirm this was fixed for gusty
(maybe in feisty bu i can't remember)

please close this bug report =)

Changed in linux-ubuntu-modules-2.6.22:
status: Incomplete → Fix Released
litemotiv (nospam-capstone) wrote :

I can confirm this bug still exists on 7.10 Gutsy Gibbon with a Linksys WMP54G v4.1 (RT61).

The CVS hourly tarball from Serialmonkey works for me: http://rt2x00.serialmonkey.com/wiki/index.php/Downloads

Note: the official ralink driver didn't work for me either, but it shouldn't really be used anyway (imho) as it doesn't comply well with current kernel module standards.

Kyle M Weller (kylew) wrote :

rt73 card does not enable routing for static connections, only dhcp. Any
fix for this issue, my static config is fine with other drivers

On Dec 1, 2007 1:39 AM, litemotiv <email address hidden> wrote:

> I can confirm this bug still exists on 7.10 Gutsy Gibbon with a Linksys
> WMP54G v4.1 (RT61).
>
> The CVS hourly tarball from Serialmonkey works for me:
> http://rt2x00.serialmonkey.com/wiki/index.php/Downloads
>
> Note: the official ralink driver didn't work for me either, but it
> shouldn't really be used anyway (imho) as it doesn't comply well with
> current kernel module standards.
>
> --
> rt61pci can't scan or associate
> https://bugs.launchpad.net/bugs/58117
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Nafallo Bjälevik (nafallo) wrote :

 Hi Leann,

On Fri, 2007-10-19 at 15:52 +0000, Leann Ogasawara wrote:
> Can you confirm if this bug still exists with the new 7.10 Gusty
> Gibbon release that just came out. Thanks!

No, I can't. I live in a different country then the computer I
experienced this bug on now.

Cheers, /N
--
Nafallo Bjälevik <email address hidden>

Javier Jardón (jjardon) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 134660, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers