linux-image-2.6.15-23-686 freezes when using irda

Bug #45542 reported by Adriaan Peeters on 2006-05-19
72
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.15 (Ubuntu)
Undecided
Unassigned
linux-source-2.6.15 (Ubuntu)
Critical
TDave
Warty
Undecided
Unassigned
Hoary
Undecided
Unassigned
Breezy
Undecided
Unassigned
Dapper
Undecided
Unassigned

Bug Description

> This IS the final dapper kernel. There have been many kernels like this, but
> this one superceeds them all. The kernel you are about to install is the
> hard work of the following people:

I am sorry guys, bad news: this last update freezes when starting irda.

Adriaan Peeters (apeeters) wrote :

adpeeter@twiadria:/var/log$ diff Xorg.0.log.freezing Xorg.0.working
6c6
< Current Operating System: Linux twiadria 2.6.15-23-686 #1 SMP PREEMPT Thu May 18 17:31:41 UTC 2006 i686
---
> Current Operating System: Linux twiadria 2.6.15-22-686 #1 SMP PREEMPT Sun May 7 16:37:57 UTC 2006 i686
14c14
< (==) Log file: "/var/log/Xorg.0.log", Time: Fri May 19 09:47:53 2006
---
> (==) Log file: "/var/log/Xorg.0.log", Time: Fri May 19 09:49:17 2006
83c83
< (II) Bus 1: bridge is at (0:30:0), (0,1,5), BCTRL: 0x0004 (VGA_EN is cleared)
---
> (II) Bus 1: bridge is at (0:30:0), (0,1,1), BCTRL: 0x0004 (VGA_EN is cleared)
2229,2231c2229,2231
< (II) I810(0): Allocated 4 kB for HW cursor at 0x7fff000 (0x37f40000)
< (II) I810(0): Allocated 16 kB for HW (ARGB) cursor at 0x7ffb000 (0x375bc000)
< (II) I810(0): Allocated 4 kB for Overlay registers at 0x7ffa000 (0x37b18000).
---
> (II) I810(0): Allocated 4 kB for HW cursor at 0x7fff000 (0x37e45000)
> (II) I810(0): Allocated 16 kB for HW (ARGB) cursor at 0x7ffb000 (0x37594000)
> (II) I810(0): Allocated 4 kB for Overlay registers at 0x7ffa000 (0x379bc000).
2249,2250c2249,2250
< (II) I810(0): [drm] added 8192 byte SAREA at 0xf8de6000
< (II) I810(0): [drm] mapped SAREA 0xf8de6000 to 0xb795b000
---
> (II) I810(0): [drm] added 8192 byte SAREA at 0xf8ddb000
> (II) I810(0): [drm] mapped SAREA 0xf8ddb000 to 0xb7955000
2372a2373
> ProcXCloseDevice to close or not ?

I included that information in the bug report:

> My machine is a Dell Latitude D505 with the i810 driver on a 82852/855GM.

Please let me know if you need more information.

Oops, missed that. Could you try vesa please.

By changing to vesa I noticed a kernel dump which indicates a problem with irda. When I started /etc/init.d/irda-utils manually in single user mode, the system crashed again about one second after running the command.

kernel_trace of irda problem

description: updated
Adriaan Peeters (apeeters) wrote :

This is probably related to bug #41589

Jede28 (news-saring) wrote :

Hi,

I can report the same problem with the latest Dapper install. I have a Dell Latitude D620 with Centrino Duo, IPW3945 and Intel GMA 950.
Since I updated to kernel 2.6.15-23 the kernel very often (not always) freezes on booting. It happens during the GDM is beeing started. No chance to change to console. After rebooting the old kernel I was not able to find any informations about the problem in the logs.
I've checked the bug list and found this one. So I disabled IRDA in the BIOS and now it doesn't crashes on boot anymore. So this workaround seems to work for now, but without IRDA ...

HTH, Eddie

joe (joerg-unglaub) wrote :

I can confirm this issue same trace of kernel for kirdaD
And X locks up before loginscreen

if it helps Hardware is here

247417981cbbb26a9b840e3e1ff4c495

joe (joerg-unglaub) wrote :

Ok blacklistet IRDA a et voila system works but therefore no irda-support....

Philip Axer (phaxer-merged) wrote :

Hi,
in drivers/net/irda/sir_kthread.c line 133:

                 prepare_to_wait(&irda_rq_queue.kick, &wait, TASK_INTERRUPTIBLE);
                 if (list_empty(&irda_rq_queue.request_list))
                        schedule_timeout(HZ/10);
                else
                        __set_task_state(current, TASK_RUNNING);
                finish_wait(&irda_rq_queue.kick, &wait);

I'm not a kernel expert, but what's doing the else branch? Is it still necessary after changing to prepare_to_wait in -23?

Changed in linux-source-2.6.15:
status: Unconfirmed → Confirmed
Łukasz Halman (lukasz-halman) wrote :

I have exactly the same problem. Kernel the 2.6.15-23 kernel freezes when irda-utils are being started. I don't even plug my irda dongle, just starting irda-utils is enough.

Kernel trace is exactly the same as attached in one of above comments.

Jan Schmidt (thaytan) wrote :

I dist-upgraded yesterday, and was also suffering the same problem, with the same kernel panic trace.

I ended up removing irda-utils to fix it.

Olivier Cortès (olive) wrote :

Probably not related to the problem, but connected somewhere : I've got no kIrDAd running on my system... I've tried to sync my WorkPad c505 (rebranded Palm m505c) to my IBM X31 using IrDA, and i couldn't. here's what I found in my dmesg :

[4294683.956000] Unable to handle kernel NULL pointer dereference at virtual address 00000004
[4294683.956000] printing eip:
[4294683.956000] c013c886
[4294683.956000] *pde = 00000000
[4294683.956000] Oops: 0002 [#1]
[4294683.956000] PREEMPT SMP
[4294683.956000] Modules linked in: sir_dev nsc_ircc snd_intel8x0 snd_ac97_codec snd_ac97_bus irda snd_pcm_oss snd_mixer_oss crc_ccitt parport_pc snd_pcm snd_timer parport e100 mii pcmcia airo tsdev snd yenta_socket rsrc_nonstatic pcmcia_core soundcore snd_page_alloc psmouse pcspkr serio_raw shpchp pci_hotplug intel_agp agpgart sg sd_mod evdev ext3 jbd usb_storage scsi_mod ide_generic ohci1394 ieee1394 ehci_hcd uhci_hcd usbcore ide_disk piix generic thermal processor
fan capability commoncap vesafb fbcon tileblit font bitblit softcursor
[4294683.956000] CPU: 0
[4294683.956000] EIP: 0060:[<c013c886>] Not tainted VLI
[4294683.956000] EFLAGS: 00010092 (2.6.15-23-686)
[4294683.956000] EIP is at finish_wait+0x36/0x70
[4294683.956000] eax: 00000202 ebx: dfa27fd8 ecx: 00000000 edx: 00000000
[4294683.956000] esi: dfa27fcc edi: f914a2a8 ebp: 00000000 esp: dfa27fb4
[4294683.956000] ds: 007b es: 007b ss: 0068
[4294683.956000] Process kIrDAd (pid: 3123, threadinfo=dfa26000 task=f792e560)
[4294683.956000] Stack: dfa26000 dfa27fcc 00000000 f9146b83 f9147b20 00000000 00000000 f792e560
[4294683.956000] c011f4e0 00000000 00000000 f9146ae0 00000000 c0101525 f7a45f74 00000000
[4294683.956000] 00000000 cccccccc cccccccc
[4294683.956000] Call Trace:
[4294683.956000] [<f9146b83>] irda_thread+0xa3/0xe0 [sir_dev]
[4294683.956000] [<c011f4e0>] default_wake_function+0x0/0x20
[4294683.956000] [<f9146ae0>] irda_thread+0x0/0xe0 [sir_dev]
[4294683.956000] [<c0101525>] kernel_thread_helper+0x5/0x10
[4294683.956000] Code: 24 04 89 d6 89 7c 24 08 89 c7 b8 00 e0 ff ff 21 e0 8b 00 c7 00 00 00 00 00 3b 5a 0c 7
4 2f 89 f8 e8 a0 fe 1c 00 8b 53 04 8b 4e 0c <89> 51 04 89 0a 89 c2 89 f8 89 5e 0c 89 5b 04 8b 1c 24 8b 74 24
[4294683.956000] <6>note: kIrDAd[3123] exited with preempt_count 1

Olivier Cortès (olive) wrote :

Note that for me the machine doesn't hang/freeze at all. I was following http://howto.pilot-link.org/irdasync/, but i didn't get much farther when I noticed kIrDAd has died...
I did :
modprobe irda
modprobe ircomm
modprobe ircomm-tty
irattach /dev/ttyS1 -s
cd /dev
mknod ircomm0 c 161 0
irdadump

the dump outputed absolutely nothing, so I went to dmesg, and found the ooops. I don't know what to do next, but if you need more info, feel free to ask.
PS: dapper "up-to-date", kernel 2.6.15-23.39 *686*.

Marc Schiffbauer (mschiff) wrote :

Hi,

just wanted to confirm that bug: Also happens with that kernel on my Fujitsu-Siemens Lifebook. -22 is working...

-Marc

Karol Bryd (karolbe) wrote :

the same happens on HP Compaq NC8000...

robepisc (robepisc) wrote :

Can confirm also on my SiS630 based Gericom laptop.

Today I updated my Breezy laptop to Dapper and, surprise! It locks hard on reboot, just while GDM is loading.

I rebooted in single user mode and discovered the presence of an irda related OOPS in my dmesg log.
That OOPS doesn't seem to have any effect at first, but when irda-utils is initialized (by "/etc/rc2.d/S20irda-utils", which happens to run while GDM is loading), the kernel freezes.

John Cooper (choffee) wrote :

Happens just like this on my Thinkpad R51 is there any more info that I can provide to help fix this?

Thanks

john

Changed in linux-source-2.6.15:
importance: High → Critical
Changed in linux-source-2.6.15:
status: Unconfirmed → Rejected
status: Unconfirmed → Rejected
status: Unconfirmed → Rejected
status: Unconfirmed → Rejected
degerrit (degerrit) wrote :

Any progress on this? Needless to say, I have the same problem (external Tekram IrMate IR-210B serial dongle).

The kernels before the final kernel did NOT have this behaviour: irda worked just fine.

Ben Collins (ben-collins) wrote :

Fixed the kernel thread's use of wait.

Changed in linux-source-2.6.15:
assignee: nobody → ben-collins
status: Confirmed → Fix Committed
saquetf (saquetf) wrote :

Hello,

I use ubuntu with linux-image-2.6.15-23-k7 and I have an AMD Athlon k7 with an irda device I made on the motherboard (in BIOS irda replace ttyS1(com2:)). It used to work with previous linux distribs (SuSE, Mandrake) and under Windows.
With Ubuntu 6.06 it doesn't work anymore.
When I start "irdattach /dev/ttyS1 -s" (I use SIR mode with irtty module) then few seconds after that my PC freezes.
Last message is:
irlap_change_speed(), setting speed to 9600

Anybody could help me?

Thanks
Luca

saquetf (saquetf) wrote :

Hi,

Just update your kernel from linux-image-2.6.15-23 to linux-image-2.6.15-25 and the problem will be fixed :-)

Thanks a lot for this update!
Luca

Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
degerrit (degerrit) wrote :

Confirmed, IRDA works again.
Thank you Ben!

- Gerrit

Adiu,

Veiqui la solucion a ton problema d'IRDA.

$ sudo su
# apt-get update && apt-get upgrade && apt-get dist-upgrade

quo deuria far l'afar. si quo marcha, podeis tornar botar IRDA au
desmaratge emb :

$ sudo sysv-rc-conf

Potons

guilhon

saquetf a écrit :
> Hi,
>
> Just update your kernel from linux-image-2.6.15-23 to linux-
> image-2.6.15-25 and the problem will be fixed :-)
>
> Thanks a lot for this update!
> Luca
>

no output from irdadump

I used the following to make usb-irda dongle ma620 work:
#modprobe uhci_hcd
#modprobe pl2303
#modprobe irda
#echo 9600 > /proc/sys/net/irda/max_baud_rate
#modprobe irtty-sir
#modprobe ma600-sir
#modprobe ircomm-tty
#irattach irda0 -d ma600 -s

as there was no output, I used
#irattach /dev/ttyUSB0 -d ma600 -s

I do not have any output with
#irdadump
but dmesg shows:
[4295979.536000] sirdev_receive - too early: e67c4324 / 1!
hundreds of times

#modprobe uhci_hcd
#modprobe pl2303
#modprobe irda
#echo 9600 > /proc/sys/net/irda/max_baud_rate
#modprobe irtty-sir
#modprobe ma600-sir
#modprobe ircomm-tty
#irattach /dev/ttyUSB0 -d ma600 -s

dongle works!

TDave (tdave) on 2006-08-23
Changed in linux-source-2.6.15:
assignee: ben-collins → tdavecrc
Changed in linux-restricted-modules-2.6.15:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers