smart card reader Ricoh Co Ltd RL5c476 II not working

Bug #36964 reported by Nicolò Chieffo on 2006-03-28
30
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned
Nominated for Intrepid by Petr Dlouhý
linux-source-2.6.15 (Ubuntu)
Wishlist
Unassigned
Nominated for Intrepid by Petr Dlouhý
linux-source-2.6.17 (Ubuntu)
Wishlist
Unassigned
Nominated for Intrepid by Petr Dlouhý
linux-source-2.6.20 (Ubuntu)
Wishlist
Unassigned
Nominated for Intrepid by Petr Dlouhý
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Petr Dlouhý

Bug Description

ASUSTeK Computer Inc.
M6Ne
1.0
Controller: R5C476 (ricoh) found here http://mmc.drzeus.cx/wiki/LaptopMatrix

this is some info I could obtain when inserting a RS-MMC

Feb 22 18:43:45 localhost kernel: [4294884.426000] pccard: PCMCIA card inserted into slot 0
Feb 22 18:43:45 localhost kernel: [4294884.426000] pcmcia: registering new device pcmcia0.0

Feb 22 18:46:34 localhost kernel: [4295053.141000] pccard: card ejected from slot 0

and this is the output of cardctl info (again using an RS-MMC)
      PRODID_1="RICOH"
      PRODID_2="Bay1Controller"
      PRODID_3=""
      PRODID_4=""
      MANFID=0000,0000
      FUNCID=254
      PRODID_1=""
      PRODID_2=""
      PRODID_3=""
      PRODID_4=""
      MANFID=0000,0000
      FUNCID=255

Paul Sladen (sladen) wrote :

There's bits of information on:

  http://mmc.drzeus.cx/wiki/Controllers/Ricoh/Frontreport

What's:

  $ sudo cardctl ident

show?

Changed in linux-source-2.6.15:
status: Unconfirmed → Needs Info
Nicolò Chieffo (yelo3) wrote :

Socket 0:
  product info: "RICOH", "Bay1Controller"
  manfid: 0x0000, 0x0000
  function: 254 ((null))
Socket 1:
  no product info available

note that I have also a pcmcia nic from RICOH so I don't know if the info is about the mmc reader or the pcmcia nic...

Matthew Garrett (mjg59) wrote :

No driver exists for this hardware at the moment.

Paul Sladen (sladen) wrote :

Nicolò: If you do the:

  cardctl ident

with the card actually inserted, does it show up with a string containing the name and size of the card (reports elsewhere suggest that it does).

And given that the chip has gone far enough to present the ID of the card and generate CS insertion events then it may emulate other features too (so writing a driver may be simpler) or maybe even just forcing ide-cs/memory-cs to load (extreme optimism and very unlikely).

Nicolò Chieffo (yelo3) wrote :

no, the output I gave you is with my RS-MMC card inserted!
Socket 0:
  product info: "RICOH", "Bay1Controller"
  manfid: 0x0000, 0x0000
  function: 254 ((null))
Socket 1:
  no product info available

I did load ide-cs while monitoring messages, syslog, debug, dmesg, kern.log and udev with no output (and no /dev/sd*)

memory-cs module doesn't exist in my installation (linux-image-2.6.15-19-686)

and I found these lines reguarding something I could not identify, and caused by an action which I don't know that may help you:

Mar 29 15:55:52 chievo kernel: [4298985.183000] pcmcia: Detected deprecated PCMCIA ioctl usage.
Mar 29 15:55:52 chievo kernel: [4298985.184000] pcmcia: This interface will soon be removed from the kernel; please expect breakage unless you upgrade to new tools.
Mar 29 15:55:52 chievo kernel: [4298985.184000] pcmcia: see http://www.kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html for details.

Paul Sladen (sladen) wrote :

Yeah, I think we'll just have to leave this as a wish-list and wait for somebody outside Ubuntu to do some work and magically resolve it :)

Changed in linux-source-2.6.15:
status: Needs Info → Confirmed
Nicolò Chieffo (yelo3) wrote :

linux 2.6.17 will support out driver!!!
see here
http://www.fsf.org/resources/hw/storage/sd.html

Matthew Garrett (mjg59) wrote :

No it won't. You don't have an sdhci controller.

Matthew Garrett (mjg59) wrote :

Just to be clear: Unless you have something like

0000:02:00.1 0805: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 13)

then the driver in 2.6.17 will do nothing for you. The "0805" bit is important.

I hope my model (M6Ne) has the same chip M6N has! I will check this bit soon!

Someone please test this in edgy.

i've tested with an SD this is the output

Aug 17 09:58:00 yelo3-laptop kernel: [17181194.212000] pccard: PCMCIA
card inserted into slot 0
Aug 17 09:58:01 yelo3-laptop kernel: [17181194.212000] cs: memory
probe 0xff900000-0xff9fffff: excluding 0xff900000-0xff90ffff
0xff9d0000-0xff9dffff 0xff9f0000-0xff9fffff
Aug 17 09:58:01 yelo3-laptop kernel: [17181194.212000] pcmcia:
registering new device pcmcia0.0
Aug 17 09:58:01 yelo3-laptop NetworkManager: <debug
info>^I[1155801481.071431] nm_hal_device_added (): New device added
(hal udi is '/org/freedesktop/Hal/devices/pcmcia__1__1').

I think that the reader is in socket 1

cardctl ident
Socket 0:
  product info: "RICOH", "Bay1Controller"
  manfid: 0x0000, 0x0000
Segmentation fault

cardctl status
Socket 0:
  3.3V 16-bit PC Card
  function 0: [ready]
Socket 1:
ioctl(): Invalid argument

I have ASUS M6Ne and there is chip exactly same as M6N ...

0000:02:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)

Lukáš Obořil (lukas.oboril) wrote :

Is possible backport tha latest driver from 2.6.18rc5 to 2.6.17, which will be in edgy ???

Nicolò Chieffo (yelo3) on 2006-11-18
Changed in linux-source-2.6.17:
status: Unconfirmed → Confirmed
Nicolò Chieffo (yelo3) wrote :

Testing it in feisty. The result of the commands is very similar:

(cardctl seems deprecated, and I had to install it by hand. Which package replaces it?)

# cardctl info
PRODID_1="RICOH"
PRODID_2="Bay1Controller"
PRODID_3=""
PRODID_4=""
MANFID=0000,0000
FUNCID=254
PRODID_1=""
PRODID_2=""
PRODID_3=""
PRODID_4=""
MANFID=0000,0000
FUNCID=255

# cardctl ident
Socket 0:
  product info: "RICOH", "Bay1Controller"
  manfid: 0x0000, 0x0000
Segmentation fault (core dumped)

# cardctl status
Socket 0:
  3.3V 16-bit PC Card
  function 0: [ready]
Socket 1:
  no card

Changed in linux-source-2.6.19:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Changed in linux-source-2.6.17:
importance: Undecided → Wishlist
Ben Collins (ben-collins) wrote :

Please retest against 2.6.20-2 when it is available in the feisty archive.

Changed in linux-source-2.6.19:
status: Confirmed → Needs Info

It is still not working. But This time I have the crash report to the
segmentation fault, from "sudo cardctl ident". do you need it?
Anyway using this kernel, the module "sdhci" and "mmc_block" are not
automatically loaded.
even with loading them there is nothing to do.

Lukáš Obořil (lukas.oboril) wrote :

Ok, i tries this new one.

Here are results:

My HW (Asus M6Ne)
[luc@merlin /tmp/sdricoh_cs-0.1]$ lspci

02:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)
02:01.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)

Compile is fine. (needed linux-headers, build-essentials)

[luc@merlin /tmp/sdricoh_cs-0.1]$ modinfo sdricoh_cs
filename: /lib/modules/2.6.20-9-generic/kernel/drivers/mmc/sdricoh_cs.ko
license: GPL
version: 0.1
description: Ricoh RL5c476 II Secure Digital Interface driver
author: Sascha Sommer <email address hidden>
srcversion: F1B79D2638461655B1DC596
alias: pcmcia:m*c*f*fn*pfn*paD9F522EDpbC3901202pc*pd*
depends: mmc_core,pcmcia
vermagic: 2.6.20-9-generic SMP mod_unload 586
parm: debug:Enable debugging (default 0) (uint)
parm: write:Dangerous: Enable writting. Might destroy the data on the sd card. (default 0) (uint)
[luc@merlin /tmp/sdricoh_cs-0.1]$

After insert a card

tail -f /var/log/messages
Mar 9 14:58:17 merlin kernel: [23348.368000] pccard: PCMCIA card inserted into slot 0
Mar 9 14:58:17 merlin kernel: [23348.368000] pcmcia: registering new device pcmcia0.0

[luc@merlin /dev]$ lspcmcia
Socket 0 Bridge: [yenta_cardbus] (bus ID: 0000:02:01.0)
Socket 0 Device 0: [-- no driver --] (bus ID: 0.0)
Socket 1 Bridge: [yenta_cardbus] (bus ID: 0000:02:01.1)

[luc@merlin /tmp/sdricoh_cs-0.1]$ sudo pccardctl info
PRODID_1="RICOH"
PRODID_2="Bay2Controller"
PRODID_3=""
PRODID_4=""
MANFID=0000,0000
FUNCID=254
PRODID_1=""
PRODID_2=""
PRODID_3=""
PRODID_4=""
MANFID=0000,0000
FUNCID=255
[luc@merlin /tmp/sdricoh_cs-0.1]$

[luc@merlin /tmp/sdricoh_cs-0.1]$ sudo pccardctl ident
Socket 0:
  product info: "RICOH", "Bay2Controller", "", ""
  manfid: 0x0000, 0x0000
  function: 254 ()
Socket 1:
  no product info available

[luc@merlin /tmp/sdricoh_cs-0.1]$ sudo pccardctl status
Socket 0:
  3.3V 16-bit PC Card
  Subdevice 0 (function 0) [unbound]
Socket 1:
  no card

Lukáš Obořil (lukas.oboril) wrote :

i forgot ...

[luc@merlin /tmp/sdricoh_cs-0.1]$ lsmod |grep sd
sdricoh_cs 9608 0
mmc_core 27780 1 sdricoh_cs
pcmcia 39212 1 sdricoh_cs
tsdev 8768 0
sd_mod 22272 5
scsi_mod 142348 5 sbp2,sg,sr_mod,sd_mod,libata

Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team
status: Needs Info → Confirmed
Whoopie (whoopie79) wrote :

any chance to get this driver into gutsy? It works with my Samsung P35 laptop under feisty.

Thanks in advance.

Changed in linux-source-2.6.22:
status: New → Confirmed
Henrik Nilsen Omma (henrik) wrote :

Setting beta milestone milestone as this looks like low-hanging fruit (but with Low priority).

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Low
Henrik Nilsen Omma (henrik) wrote :

At this point, we'll only fix this in Gutsy.

Changed in linux-source-2.6.15:
status: Confirmed → Won't Fix
Changed in linux-source-2.6.17:
status: Confirmed → Won't Fix
Changed in linux-source-2.6.20:
status: Confirmed → Won't Fix
Whoopie (whoopie79) wrote :

FYI, the SVN version also has MMC support now. -> http://sdricohcs.svn.sourceforge.net/viewvc/sdricohcs/sdricoh_cs/

Whoopie (whoopie79) wrote :

@Michael: No, you card reader is supported by sdhci. It could be related to http://intr.overt.org/blog/?p=59
But that's totally off-topic.

Colin Watson (cjwatson) wrote :

Moving milestone forward. Is this really appropriate for 7.10 at this point, though?

Valentin Rocher (bishiboosh) wrote :

I don't know if this could help, but I'm currently under 2.6.22.14 and the experimentalk driver worked fine in Gutsy.

Will it be integrated in the kernel so I won't have to recompile the module every time I got a new kernel package ?

fcolcord (fcolcord) wrote :

I would like to ask for this to work as well.

I did a plain vanilla Gutsy install on a Dell x300 and the SD Card reader doesn't work.

This bug seems linked to bug 153341 (https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/153341)

I can see the project on source forge, but don't know enough about linux to do it myself.

http://sourceforge.net/project/showfiles.php?group_id=190281

the home page does not talk about ubuntu or debian package

http://sdricohcs.sourceforge.net/

I can't see clear instructions on the pages above which will help me. Can anyone else give me the steps I should follow? thanks, Frank

TomasHnyk (sup) wrote :

fcolcord: 153341 is a duplicate, I am marking as such.

I am also changing the target package to linux as in the duplicate bug (reasoning: linux is developement kernel, 22 is stable now and this is no candidate for backporting)

Valentin Rocher (bishiboosh) wrote :

Just download the tar.gz, unpack it somewhere, and follow the instructions in the README file (do a make and make install). Make sure you have the linux-yourkernel-header installed.

Worked properly for me :)

Brad Pitcher (bradpitcher) wrote :

it works great for me!
brad@brad-laptop$ lspci | grep Ricoh
00:0a.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)
00:0a.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)
Is it too experimental now to include in Ubuntu?

I haven't tested it since I don't have any mmc now

Could this be included into Ubuntu, cause I've been using it too without any problems for a few months...

TomasHnyk (sup) wrote :

it has been included in the kernel an will be in 2.6.27, so there is no need for this one to be fixd in ubuntu, i has been fixed upstream.

http://kernel.org/pub/linux/kernel/v2.6/snapshots/patch-2.6.26-git5.log

      mmc: host driver for Ricoh Bay1Controllers

Here's the upstream git commit id for the patch Thomas is referring to. As Thomas pointed out this is already upstream and will likely be pulled into the upcoming Intrepid kernel when the next rebase occurs or the kernel team can cherrypick this specific patch. Thanks.

commit 6a36913a33cf3d366e124f25c486a71212d02bce
Author: Sascha Sommer <email address hidden>
Date: Tue Jul 15 14:21:29 2008 +0200

    mmc: host driver for Ricoh Bay1Controllers

Changed in linux:
status: Confirmed → Triaged

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Petr Dlouhý (petr-dlouhy) wrote :

I can confirm, that the card reader is working in Intrepid now (at least for SD cards).

TomasHnyk (sup) wrote :

yep, it works, so unless the 2.6.27 is going to be rolled back, this can be marked as fixed.

Setting this to "Fix Released" based on the decision to stick with the 2.6.27 kernel for Intrepid - https://lists.ubuntu.com/archives/kernel-team/2008-September/003107.html . However against 2.6.22 this will be closed as it does not qualify for a Stable Release Update - http://wiki.ubuntu.com/StableReleaseUpdates . Thanks.

Changed in linux:
status: Triaged → Fix Released
Changed in linux-source-2.6.22:
status: New → Won't Fix
Mike (michael-calcano) wrote :

Hi,

I still can't use Memory Sticks Pro with the kernel 2.6.27, SD cards work fine.

uname -a

 (: Linux laptop 2.6.27-7-generic #1 SMP Fri Oct 17 22:24:21 UTC 2008 i686 GNU/Linux)

lspci -v

09:09.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05) (prog-if 10)
        Subsystem: Hewlett-Packard Company Device 30cc
        Flags: bus master, medium devsel, latency 32, IRQ 20
        Memory at f8100000 (32-bit, non-prefetchable) [size=2K]
        Capabilities: <access denied>
        Kernel driver in use: ohci1394
        Kernel modules: ohci1394

09:09.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
        Subsystem: Hewlett-Packard Company Device 30cc
        Flags: bus master, medium devsel, latency 32, IRQ 21
        Memory at f8100800 (32-bit, non-prefetchable) [size=256]
        Capabilities: <access denied>
        Kernel driver in use: sdhci-pci
        Kernel modules: sdhci-pci

09:09.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 12)
        Subsystem: Hewlett-Packard Company Device 30cc
        Flags: bus master, medium devsel, latency 32, IRQ 11
        Memory at f8100c00 (32-bit, non-prefetchable) [size=256]
        Capabilities: <access denied>
        Kernel driver in use: ricoh-mmc
        Kernel modules: ricoh_mmc

09:09.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
        Subsystem: Hewlett-Packard Company Device 30cc
        Flags: bus master, medium devsel, latency 32, IRQ 11
        Memory at f8101000 (32-bit, non-prefetchable) [size=256]
        Capabilities: <access denied>

09:09.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev ff) (prog-if ff)
        !!! Unknown header type 7f

Mike (michael-calcano) wrote :
Changed in linux:
status: Fix Released → Incomplete
Mike (michael-calcano) on 2008-10-22
Changed in linux:
status: Incomplete → New
Changed in linux:
status: New → Triaged
TomasHnyk (sup) wrote :

Mike:You have got a different card reader, this is working for me (ant others, I suppose), so I marked this as fixed.
For your bug, see https://bugs.launchpad.net/ubuntu/+source/linux/+bug/202490

Changed in linux:
status: Triaged → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

jevgtv (tugevus) on 2012-10-22
summary: - [dapper] Asus sd/mmc card reader not working
+ smart card reader Ricoh Co Ltd RL5c476 II not working
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers