Ubuntu 22.04 not waking up after second suspend

Bug #2008774 reported by Kristian Lange
This bug affects 15 people
Affects Status Importance Assigned to Milestone
linux-signed-hwe-5.19 (Ubuntu)

Bug Description

After the first suspend it wakes up just fine - it's the second suspend after which the screen stays blank and keyboard doesn't react (although the power LED starts glowing). It happens if I close the laptop's lid or do a manual suspend via the system menu. It happens only recently (I think after some kernel update, but I'm not sure about this) - before it worked fine for month (since I installed Ubuntu).

I have a recent Thinkpad T14s with a Ryzen CPU, Ubuntu 22.04 is the only OS (if that's important).

What I tried:

* turn off security chip in the BIOS (https://askubuntu.com/a/1412049/424896)
* turn off Wayland and enable X11 (https://askubuntu.com/a/1412032/424896)
* I looked through the logs in /var/log but couldn't find anything obvious to me (but I'm not a Linux guru).

ProblemType: Bug
DistroRelease: Ubuntu 22.04
Package: linux-image-5.19.0-32-generic 5.19.0-32.33~22.04.1
ProcVersionSignature: Ubuntu 5.19.0-32.33~22.04.1-generic 5.19.17
Uname: Linux 5.19.0-32-generic x86_64
ApportVersion: 2.20.11-0ubuntu82.3
Architecture: amd64
CasperMD5CheckResult: pass
CurrentDesktop: ubuntu:GNOME
Date: Tue Feb 28 11:02:36 2023
InstallationDate: Installed on 2022-06-14 (258 days ago)
InstallationMedia: Ubuntu 22.04 LTS "Jammy Jellyfish" - Release amd64 (20220419)
SourcePackage: linux-signed-hwe-5.19
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Kristian Lange (madsen953) wrote :
Revision history for this message
Formula Ron (formula-ron) wrote :

There's many other screen related issues like this with 5.19.0-32 and with RYZEN processors with integrated graphics too.

My desktop is a RYZEN 5 2400G and I have the same issue with resuming from suspend or hibernation. I have a workaround though.

Once the monitor is blank but processor appears running, I do ctrl+alt+F2 to get to the console. The screen then flickers into life and then ctrl+alt+F7 to get back the the monitor. And all appears OK on the display again.

Revision history for this message
Kristian Lange (madsen953) wrote :

The ctrl+alt+F2 trick didn't work with me. My keyboard seems to be not working after suspend.

But I stumbled over this Reddit post: https://www.reddit.com/r/thinkpad/comments/lnyrt6/til_i_learn_newer_thinkpads_have_a_setting_for. There is a "Sleep State" switch in the BIOS of some Thinkpads (Config ➜ Power ➜ Sleep State ➜ “Linux” / “Windows 10”). I just turned it from "Windows" to "Linux" and it seems to work now. But I'm not sure yet. I will test more.

Revision history for this message
Kristian Lange (madsen953) wrote :

So switching the "Sleep State" in the BIOS to "Linux" solved the issue.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-signed-hwe-5.19 (Ubuntu):
status: New → Confirmed
Revision history for this message
Andrey Lebedev (andrey-lebedev) wrote :

I have the same problem on my Thinkpad T14 with "AMD Ryzen 7 PRO 6850U with Radeon Graphics" CPU. My BIOS doesn't provide "Sleep State" option.

What I've found is it is possible to put system to sleep many times in a row with this command:

$ echo mem | sudo tee /sys/power/state

However, closing the lid, or using Gnome menus to put system to sleep works only once per boot.

Revision history for this message
Anthony Kamau (ak-launchpad) wrote (last edit ):

In response to #6

$ echo mem | sudo tee /sys/power/state

That works for me too - but then there's no password protection on resume...

PS: I recently upgraded from Ubuntu 20.04.5 - never had this problem there. In fact, I was able to suspend and resume daily over the course of 1 month without issue. And now, on Ubuntu 22.04, I'm forced to REISUB multiple times a day! Starting to feel like I should have waited 'til 22.04.3 (or maybe even 22.04.4). I think Canonical has really dropped the ball really badly on this one!

Revision history for this message
Sachin Kumar Singh (sachinkumarsingh092) wrote :

I was having this exact same problem on my HP Pavilion 14 on Ubuntu 22.04. It worked fine a few days ago but I encountered this problem after an update. Lots of stack answers pointed to some problems with Nvidia drivers, but I don't have Nvidia graphics. I have an integrated AMD Radeon along with AMD Ryzen 7.

What worked for me:

Installing `amdgpu-install` and installing the AMD graphic cards components[1] after checking the secure boot support[2]:
amdgpu-install --usecase=graphics


Revision history for this message
Andrey Lebedev (andrey-lebedev) wrote :

amdgpu-install method fixed the problem on my Thinkpad T14 with Ryzen 7 PRO 6850U. Thanks for sharing this, Sachin Kumar Singh!

Revision history for this message
Daniele (danielik) wrote :

Hello, I have exactly the same problem, with a Huawei MateBook X Pro 2022. In my case the solutions:
#2 The ctrl+alt+F2 trick didn't work with me. My keyboard seems to be not working after suspend.
#4 doesn't work for me because I don't have the option "Sleep State" in my BIOS
#6 the command "echo mem | sudo tee /sys/power/state" doesn't work for me. The computer actually goes to sleep, but when wake up, the screen, keyboard and mouse not responds
#8 this doesn't work for me because I have an integrated Intel Iris Xe card

I also tried installing the drivers directly from Intel (https://www.intel.com/content/www/us/en/download/747008/intel-arc-graphics-driver-ubuntu.html) but without success.

Does anyone have any other options to try or was there any other way to fix this? For work reasons I have to suspend the PC several times a day and this bug is hell!
Thanks a lot!!

Revision history for this message
Andrey Lebedev (andrey-lebedev) wrote :

It looks like the latest Ubuntu 23.04 with linux kernel 6.2.0 solved the problem (for me ,ThinkPad T14 with AMD CPU, at least). Sleep works out-of-the-box without having to do amdgpu-install trick.

Revision history for this message
Sven Schultschik (svanschu) wrote :

I have an Lenovo T16 AMD Ryzen 7 6850U and the amdgpu-install fixed the balck screen suspend bug, but since then my CPU usage is much higher in idle and the fan is permanently running.

I'm currently limited to Ubuntu 22.04 and have to wait for the next LTS version.

Revision history for this message
Daniele (danielik) wrote :

I response to #11, I think that the installation of a new Kernel version it is not associated with the Linux version. Taking this article as an example (https://itsfoss.com/upgrade-linux-kernel-ubuntu/), I understand that you can proceed to install the version of the kernel that you prefer.
Now, my question is: does version 6.2 solve the problem only with Ubuntu 23 or also with the other ubuntu versions (LTS and not)?

Revision history for this message
Daniele (danielik) wrote :

In response to #11, I installed the mainline software (https://github.com/bkw777/mainline) and installed kernel 6.2.14, the newest of version 6.2, and restarted with this new kernel version. Unfortunately, kernel 6.2.14 does not fix the suspend issue.
I remind you that I made this test with ubuntu 20.04 LTS. A few days ago I downgraded from 22.04 LTS as a test against message #7.
Do you consider that installing kernel 6.2.14 with a newer ubuntu version would solve the problem?

Revision history for this message
Arman Arushanyan (arushanyan) wrote :

#8 Working for me, thank you very much

Laptop: Asus VivoBook M1603Q,
Processor: AMD® Ryzen 7 5800h with radeon graphics × 16
OS: Linux Ubuntu 22.04.2 LTS

Revision history for this message
wateenellende (fpbeekhof) wrote :

Have a HP Pavilion 14-ec0660nd with Radeon 5700U and had the same screen-won't-wake-up syndrome.

Installing AMD drivers downloaded from AMD seems to have fixed it.

Revision history for this message
manic (nicolas-launchpad-iselin) wrote (last edit ):

I was also hit by this issue on a `HP ProBook 635 Aero G7 (2E9E4EA)` with a `AMD Ryzen 7 4700U with Radeon Graphics`.

I found (by experiments) a different solution:

Calling (as root) `/lib/systemd/systemd-sleep suspend` makes the wake up from suspend to work every time (not only the first time), but this does not handle screen locking. Then I did the following (with a passwordless sudo rule for `/lib/systemd/systemd-sleep suspend`):

/usr/bin/xdg-screensaver lock; sudo /lib/systemd/systemd-sleep suspend

In this configuration, I had back the old buggy behaviour (2nd suspend does not wake up).

I switched now to

sudo /lib/systemd/systemd-sleep suspend; /usr/bin/xdg-screensaver lock

and this works reliably. Unfortunately, there is a short moment where the plain screen content is visible
after wake up, but the screen is locked almost immediately.

So this is hacky, but **far more** better than before, as I can now use suspend and hibernate :-)

* If the laptop is stolen suspended, the attacker has less than half a second to see what is on the screen, then it is locked
* If the laptop is stolen hibernated, the attacker needs the disk encryption password before the machine really boots.

Maybe this weird setup helps in debugging.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.