kernel-rt freeze after new install jaunty studio

Bug #366352 reported by Susan Cragin
52
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux-rt (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

I have an ASUS G1S. Have run Ubuntu Studio on it for months.
Yesterday tried to install studio using the latest daily build, which installs the real-time kernel. 2.6.28-3-rt.
On reboot the system froze.
So, I rebooted to prompt, installed linux-generic and rebooted.
Everything seems to work, except there is no sound.
I tried with and without pulseaudio, so that is not the problem. Tried purging and re-installing sound system. Tried installing tiwai's latest drivers.
Nothing works.

Ben Koerner (koernerb)
affects: ubuntu → linux (Ubuntu)
Revision history for this message
scrondle (kjel-anderson) wrote :

I'm seeing something similar. I have a Gigabyte GA-MA74GM-S2 Motherboard. Another user on the Ubuntu Studio IRC with the same motherboard was reporting the same problem. When booting to the realtime kernel in Ubuntu Stuido Jaunty, the boot process ends almost immediately with a stack trace. The first line is:

tick_handle_periodic+0x19/0x80

It freezes there.

Revision history for this message
scrondle (kjel-anderson) wrote :
Revision history for this message
Eric Hedekar (stochastic) wrote :

changed bug to affect linux-rt rather than linux

affects: linux (Ubuntu) → linux-rt (Ubuntu)
Revision history for this message
Susan Cragin (susancragin) wrote :

After re-booting a couple of times, I was able to make my linux-rt kernel run for a few minutes before it froze. Here is the Xorg.0.log.old for that.
I will also attach my lspci -vv.
Susan

Revision history for this message
Susan Cragin (susancragin) wrote :

lspci -vv

Revision history for this message
cha0s (the-real-cha0s) wrote :

I can confirm that the realtime kernel in Jaunty won't boot. My screenshot looks identical to the latest one posted by scrondle, so I didn't attach it. Thanks!

Revision history for this message
Luis de Bethencourt Guimerá (luisbg) wrote :

For the people having problems: please test this...

"I was having this problem. I was able to roll an RT kernel that works. I threw it up on my webserver if anyone needs it, but I don't have much for bandwidth, so if someone could toss this somewhere, it'd be great.

http://www.lukemacneil.com/linux-headers-2.6.29.1-rt8-custom_2.6.29.1-rt8-custom-10.00.Custom_i386.deb

http://www.lukemacneil.com/linux-image-2.6.29.1-rt8-custom_2.6.29.1-rt8-custom-10.00.Custom_i386.deb

If you install vanilla jaunty, use this kernel, and then install the ubustu metapackages from the repos, all is well."

If the reports are positive, this could be very helpful.

_ p l e a s e t e s t _

Revision history for this message
Mark Falcey (mfalcey) wrote :

I am having an almost identical problem with the 64 bit rt kernel which I installed along with the UbuntuStudio-audio packages over the generic jaunty install. It is fully updated

I am using a Biostar TA790GX A2+ mobo and a ATI HD3650 1GB PCIE card. I am using the most recent bios from BIostar.

 I have attached a screenshot since it is a little different from the OP but essentially the same issue.
If you come up with something for me to try, please let me know.

Revision history for this message
cha0s (the-real-cha0s) wrote :

Hey, thanks a lot for the upload Luis. Unfortunately, I'm running amd64, so that 386 build won't work for me.

Sorry though, I don't have anywhere I can put that file to help you out.

Revision history for this message
Travis Carter (princemanfred) wrote :

I installed the kernel packages Luis uploaded. Everything is running smooth now. Nvidia drivers working without any intervention on my part as well :). I uploaded the packages to my server. I'll keep em there as long as I can. There may be a bug in the packages, though, because Synaptic cries about it any time I install a new package. Says it didn't install correctly or something to that extent, but it is all there as far as I can tell. I'll post the output if anyone really cares.

http://traviswcarter.com/linux-rt/linux-headers-2.6.29.1-rt8-custom_2.6.29.1-rt8-custom-10.00.Custom_i386.deb
http://traviswcarter.com/linux-rt/linux-image-2.6.29.1-rt8-custom_2.6.29.1-rt8-custom-10.00.Custom_i386.deb

Revision history for this message
Susan Cragin (susancragin) wrote :

I compiled the newer 2.6.29.2-rt11-custom and am very happy with it. I encourage anyone compiling their own to go with the newer version.

Revision history for this message
martron (imartron) wrote :

I installed the custom kernel linked in this thread. Jaunty feels a lot more stable now and jacks doesn't seem to be crashing anymore when I use firewire. Hurray for no lock-ups!

Also, I installed the kernel onto ubuntustudio and not vanilla. So far so good.

Revision history for this message
martron (imartron) wrote :

I should also mention that I'm running an ASUS a8js laptop. Before I installed the custom kernel, htop would report my second cpu core as always being at 100%. With the custom kernel it's reporting usage properly.

Revision history for this message
Ben Bailes (eurobob) wrote :

same problem, as i am using AMD64 I have reverted to standard kernel until a fix is produced for the RT.

Revision history for this message
Philip (panmanphil) wrote :

I have a similar problem with the stock rt kernel. High cpu use as soon as I start jackd. With connections to jack, it hits 60% constant cpu. Everything works well with the vanilla kernel except the xruns, so I am hoping we get an update. I have a 686 arch so I'll try the kernel package in this thread.

Revision history for this message
Philip (panmanphil) wrote :

mixed results with the new kernel. First, the cpu is corrected. However, when I took the next step and added @audio - memlock 512000 to my limits.conf, Jackd crashes, leaving a defunct jackd process and unresponsive qjackctl, taking my gnome toolbar with it. Or rather it fails to start jack and the toolbar disapears anytime I click on it with my mouse. If I uncheck the lock memory option in qjackctl, it works well. Hmmm, I just tried the same thing with the generic kernel and the same thing happens. I'll pursue that separately.

Also I am seeing lots of this from dmesg with this kernel
[ 33.858219] get_mtrr: cpu0 reg00 base=0000000000 size=0000020000 write-back
[ 33.858227] get_mtrr: cpu0 reg01 base=000001e000 size=0000002000 uncachable
[ 33.858234] get_mtrr: cpu0 reg06 base=00000e0000 size=0000008000 write-combining
[ 33.858405] [drm] Initialized savage 2.4.1 20050313 on minor 0
[ 33.950590] get_mtrr: cpu0 reg00 base=0000000000 size=0000020000 write-back
[ 33.950600] get_mtrr: cpu0 reg01 base=000001e000 size=0000002000 uncachable
[ 33.950608] get_mtrr: cpu0 reg06 base=00000e0000 size=0000008000 write-combining
[ 33.950615] get_mtrr: cpu0 reg00 base=0000000000 size=0000020000 write-back
[ 33.950622] get_mtrr: cpu0 reg01 base=000001e000 size=0000002000 uncachable
[ 33.951013] get_mtrr: cpu0 reg00 base=0000000000 size=0000020000 write-back
[ 33.951133] get_mtrr: cpu0 reg01 base=000001e000 size=0000002000 uncachable
[ 33.951141] get_mtrr: cpu0 reg02 base=00000d0000 size=0000008000 write-comb

Revision history for this message
Travis Carter (princemanfred) wrote :

@Philip May be some other issue on your end. jackd was running fine for me with the custom kernel and the lock memory option. I had a vanilla jaunty install and used the mark package by task option to install the 'audio creation and editing suite'.

Revision history for this message
Vivian Stewart (vivichrist) wrote :

I have a AMD64 install and 2.6.28-3-rt. which boots and seems fine, except one of the cores is in 100% IOWait, until desktop freezes mouse is still moveable but keyboard is unresponsive.

Revision history for this message
Philip (panmanphil) wrote :

@Travis Yes other issues with memlock. I spent more time that I would have like to yesterday trying to get the memlock issue isolated. It is not the kernel, so for purposes of this bug, it is not an issue.

The real memlock problem was with pulse audio. I didn't realize that qjackctl was a shell script that also called pasuspender. That is what was causing most of my problems. I found if I stopped pulse (pacmd suspend 1), I could start jackd from the command line. From qjackctl I would get Bus Error. Then I found I could start qjackctl and jackd if I started qjackctl.bin instead. Still not out of the woods, other audio apps launched from the gnome toolbar or menu would still fail.

For now I have removed pulse audio and as a result ubuntu.desktop which depends on it. Too bad, but this is a dedicated box for recording with jack, so it seems the best option.

Revision history for this message
Rüdiger Kupper (ruediger.kupper) wrote :

I installed the kernel packages Luis uploaded (cf. comment #7). I confirm what Travis reports about it (comment #10): This custom kernel works with the current nvidia driver. But:

1. Synaptic complains about a failed post-installation script. This is most probably a minor issue.

2. I have compared this custom kernel to the 2.6.28-3-rt kernel that comes with ubuntu studio (both with the proprietary nvidia driver disabled). Jack processor load with the custom kernel is *much* higher than with the rt-3-kernel. Identical Jack cofig, identical setup (Ardour routed through JAMin):
- rt-3-kernel processor load: 14%
- Luis' custom kernel: 54% (!)

Either the rt-3-kernel is strongly optimized, or Luis kernel is in some way infefficient.
However, Luis has abviously solved the problem with the nvidia driver.
Luis, can you comment on what you had to do to compile the ciustom kernel?

Revision history for this message
Stephen Parry (sgparry) wrote :

Hi all, just to direct your attention to the discussions here:

https://bugs.launchpad.net/ubuntu/+source/linux-rt/+bug/290498;

Realtime Ducthman has compiled and made available a build of the rt kernel which seems to work very well (see copy of my latest post below), resolving the iowait issues and such; it's worth a look.

-------------------------------------------------------------------------------------------------------------------------------------------------------

Hi,
Here are my experiences of using Realtime Dutchman's 25th May build for about 36 hours:
Firstly, I am running with a different installation order from RTD:
1. Install 9.04 studio (all multimedia options) - reboot
2. Install all updates - reboot
3. Add workaround for clash involving snd-hda-intel driver and my system (see below) - reboot
4. Install headers
5. Install image - reboot.
6. Enable memlock 50% nice -99 via @ -> System -> Administration -> Ubuntu Studio Controls - Reboot

My acpi works infinitely better with kernel than it did without!

I have not dared enable wireless yet in any shape or form because the iwl3945 driver seems yet again to be very broken. I will try this later.

So far, my system:
- Boots
- Reboots
- Shuts down
- ~0% idle CPU
- realtime Jack
- captures and plays back audio (jack, audacious, audacity, ZynAddSubFx)
- suspends, resumes and hibernates (caveat - some processes exit)

* IT DOES THESE RELIABLY *

This is 100% improvement on the stock studio realtime kernel.

My snd-hda-intel needs a tweak to alsa-base.conf and the volume controls, but this is nothing to do with this realtime kernel; it's been a problem with my system at least as far back as hardy:
options snd-hda-intel model=dell-m27 enable_msi=0 probe_mask=1
Unmute the capture channel in the standard volume control / alsa mixer.
For those interested, without this JACKD watchdog timeouts trying to open the capture channel.

My system is as follows:
Dell Inspiron 9400 / E1705, 1GB memory, Core Duo 1.8GHz, Intel 945GM graphics, SigmaTel HDA, Intel 3945ABG wireless.

Revision history for this message
vervelover (alessiopangos) wrote :

The custom kernel by travis nearly solves the problem for me, but I still get some freezes (very rarely), but they might be related to my video card, I don't know.. I had the cpu issue but solved it by removing the jaunty rt kernel (maybe there was some conflict, I don't know..). I'm considering trying the Dutchman kernel to see if I solve the issue once and for all.. but I'm afraid it's my stupid intel i965..

Revision history for this message
Jani F (j-frilander) wrote :

I just installed studio on my vanilla jaunty installation and I have this same problem. Motherboard is Asus M2NPV-MX.

Revision history for this message
Pierre-Antoine Champin (pchampin) wrote :

I experience the same problem with Jaundty, x86, linux-2.6.28-3-rt on a Dell Latitude D820 (nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300]).

I found out that the problem can be solved by either
- using driver nv instead of nvidia
- not using the network at all (the idea came when reading #354816)

I didn't try yet to use nosmp (as suggested on #354816), but it seems that both bugs may be related: this would be a strange interaction btw network and nvidia (and possibiy multi-processor)...

Revision history for this message
Lukáš Zapletal (lzap) wrote :

I experience the same problem with Jaundty, x86, linux-2.6.28-3-rt on an ASUS motherboard with integrated net and GeForce 5 series gfx card. RT kernel boots but after some time the system freezes.

Revision history for this message
Susan Cragin (susancragin) wrote :

Can anyone confirm that the problem is fixed with the 2.6.29 series?
It seems to be working for me without crashing, but I'm only using a couple of apps.

Revision history for this message
lexum (justmoen) wrote :

building a custom kernel to 2.6.29.6-rt23 fixed the problem on my machine.

Revision history for this message
Susan Cragin (susancragin) wrote :

2.6.31-rc1-rt4 is now on the linux kernel repository and will soon be available in Ubuntu.
http://www.kernel.org/pub/linux/kernel/projects/rt/
The 29 kernel is now in Ubuntu and that works without freezing.
In view of this, I think this bug might be closed out.

Revision history for this message
jhfhlkjlj (fdsuufijjejejejej-deactivatedaccount) wrote :

Running Jaunty, and the repos still say 2.6.28-3.

Will this not be updated for Jaunty, leaving Ubuntu-Studio 9.04 completely and utterly unusable? That's two releases in a row.

Revision history for this message
gorgon (blindmanonacid) wrote :

is there a way to use the 29 kernel in Jaunty?

Revision history for this message
Susan Cragin (susancragin) wrote :

I don't know at all but I imagine not a problem. And while you're at it, the 31 kernel is out and works well.
Download it and headers from the Karmic repository.

I would compile it myself.
To get a working distro so you can compile, just install the generic kernel and boot to that.
sudo apt-get install linux
That way you have a useable distro.

download kernel patch from:
http://www.kernel.org/pub/linux/kernel/projects/rt/
download matching kernel from:
http://www.kernel.org/pub/linux/kernel/v2.6/testing/
Find out how to apply a patch, then
Follow these directions.
https://help.ubuntu.com/community/Kernel/Compile

Revision history for this message
jasonsmr (jasonsmr) wrote :

Hi, Ive been working off base here with another distro, knoppix for the sake of a lab, and gaming programmer.

I do however want to get back to Ubuntu, for the purposes of another project game.

While I was on knoppix this summer I came across this post, and have put this off until now, but the thing is I have also been working closely with the same kernel as luis, the 2.6.29.6-rt23 rt-kernel freely available online.

I have been attempting to boot knoppix with this kernel using the kernel changing tutorials found on the wiki, however you know how those wiki's are sometimes they leave out idle info's like in my case how the patches are reqquired and how the ini and the initrd should be compiled with out the use of functional modules?

any one want to do a walk through on this or a blogg separate to this?
and one for /Ubuntu is fine I’m sure the minirt.gz in knoppix is similarity helpful in the modules for knoppix. as passing the knoppix operating parameters on to the kernel built modules via the initrd=/boot/minitr.gz option

The boiled down question as per relating to Ubuntu is how would I create a dual boot system with both the Knoppix gaming lab (compiler+forensic set) and the testing distro Ubuntu prototyping set??

I could really use some help on this. I’m planing on using grub2, however I currently have only grub-legacy on the MRB. I would like to upgrade for chainloading and pxe boot options to become available.

currently available is my knoppix disrto as a compiler distro it uses the 2.6.19 kernel with the usual patches (knoppix setup.c patch) and a slab.c patch along with a ksize, lhash, and fuse patches.

I would also like to upgrade all compiler tools on this disrto for newer 4.3+ compiler toolset under the usual /usr/src/toolset. however in knoppix it seems all compiler tools are preinstalled in the /usr/src and there darn difficult to update to the newer sets (so far).

My ubuntu distro chosen is the gutsy set. (just call me a dill) just don’t call me obsolete.

Revision history for this message
Alessio Igor Bogani (abogani) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that could be fixed in the Beta release of Karmic Koala. It would help us greatly if you could test with it! Thanks again and we appreciate your help.

Changed in linux-rt (Ubuntu):
status: New → Incomplete
Revision history for this message
ebrjvd (jos-van-dyck) wrote :

I can confirm that the bug still persists in Beta Karmic Ubuntustudio 9.10 with kernel 2.6.31-9-rt using dual core AMD64.

With the old trick "nosmp acpi=off" it works however, so this issue is still unsolved.

Jos

Revision history for this message
Susan Cragin (susancragin) wrote :

My system has worked pretty well. Occasionally it seems to churn a little CPU for no good reason, and with no apps seeming to take a lot of power, but overall it's performing.
I have a dual-core Intel T7700@2.4.
I have also re-installed my system several times, most recently with the 10/18 daily build.
So Beta Karmic Studio 9.10 with 2.6.31-9-rt, as above, works for me.
I have not tried "nosmp acpi=off"
I have not installed the proprietary NVIDIA graphics driver.

Revision history for this message
Alessio Igor Bogani (abogani) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Karmic Koala.

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please do steps 1 and 2 of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Changed in linux-rt (Ubuntu):
status: Incomplete → Invalid
status: Invalid → Fix Released
Revision history for this message
ebrjvd (jos-van-dyck) wrote :

Ubuntu Studio 9.10 RC with 2.6.31-9-rt works on i386 Core 2 architecture.

Still freezing on amd64 (temporary solution with "nosmp" boot option).
How can this be solved?
Related to bug #354816 ?

RayK (kolment)
Changed in linux-rt (Ubuntu):
status: Fix Released → Fix Committed
Changed in linux-rt (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers