Ubuntu

linux-rt restricted to one CPU

Reported by Thomas E Jenkins on 2008-10-28
102
This bug affects 10 people
Affects Status Importance Assigned to Milestone
linux-rt (Ubuntu)
High
Unassigned

Bug Description

Opening a new report as advised by Andrew Hunter in #281276.

The linux-rt 2.6.27-3.8 release only uses one CPU (or core). Perhaps of note is that the rt variant does not set CONFIG_NR_CPUS which is set to 64 in 2.6.27-7-generic and is set to 8 in the old 2.6.24-21-rt. It also does not set CONFIG_SMP which is set to y on the other two.

After booting 2.6.27-3-rt dmesg contains this line:

[ 0.000000] WARNING: NR_CPUS limit of 1 reached. Processor ignored.

Compared to booting the non-rt 2.6.27-7-generic:

[ 0.000000] SMP: Allowing 2 CPUs, 0 hotplug CPUs
[ 0.000000] PERCPU: Allocating 64928 bytes of per cpu data
[ 0.000000] NR_CPUS: 64, nr_cpu_ids: 2, nr_node_ids 1

Changed in linux-rt:
assignee: nobody → abogani
importance: Undecided → High
status: New → Confirmed

+1 here, only 1 cpu is shown for a core2 duo cpu

ScottMiller (stmiller) wrote :

I just ran across this:

http://ubuntustudio.org/8-10_release_note

"We are sad to announce the real time kernel won't be installed by default in
Ubuntu Studio in this release. Because of some issues that were out of our
control, the real time kernel in this release has some problems: only supports
one processor (even on dual core machines) and suspend/hibernation/shutdown
don't work properly because of conflicts with the Network Manager. We are
doing our best to get these fixed, the kernel is in the repository for those
who want it anyway and an upgrade with the pristine version will be available
soon."

vivichrist (vivichrist) wrote :

I tried used Alessio's PPA and Its more stable but I still only see one cpu on my hp compaq v5001au laptop. anybody else got custom packages I could try? I heard someone compiled a vanilla unpatched kernel with preempt enabled or something and that worked. I don't have enough room to compile kernels.

Kyle Milz (kmilz) wrote :

Confirmed intrepid 64-bit linux-image-2.6.27-4-rt.

vivichrist (vivichrist) wrote :

I think there mite be a memory leak 'cause something takes up more and more memory until it spills over into swap file and everything slows down. this takes quite a while to happen but I use only the usual apps and this doesn't happen with generic kernel. guess I should start a new bug?

vivichrist (vivichrist) wrote :

hmmm interesting... I have no idea but this doesn't look good

Martin (martin00) wrote :

Some here. I used the old kernel to hotfix this problem till the kernel maintainer will fix this.

--
http://packages.ubuntu.com/hardy/linux-rt
--
dpkg --force-depends -i linux-restricted-modules-rt_2.6.24.22.24_amd64.deb
dpkg --force-depends -i linux-rt_2.6.24.22.24_amd64.deb
---

Changed in linux-rt:
assignee: abogani → nobody
status: Confirmed → Triaged
pablomme (pablomme) wrote :

If I understand correctly, the -rt patches have been ported to the 2.6.29 codebase by their authors. Is Jaunty shipping with 2.6.29? If not, is there going to be a 2.6.29-rt module in the repositories for us real-time people?

Alessio Igor Bogani (abogani) wrote :

Latest Jaunty rt kernel works on SMP configuration so i marked that bug as "Fix released"

Changed in linux-rt:
status: Triaged → Fix Released
pablomme (pablomme) wrote :

@Alessio: not quite.

I've installed the 2.6.28-2-rt kernel on my desktop and my laptop, which have nothing in common hardware-wise. The kernel does see the second core, but (reportedly) it's unusable. Running 'top' and pressing '1' I get:

Cpu0 : 0.7%us, 0.3%sy, 0.0%ni, 99.0%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Cpu1 : 4.3%us, 0.7%sy, 0.0%ni, 0.0%id, 0.0%wa, 95.0%hi, 0.0%si, 0.0%st

The second core remains at 95-99% no matter what.

Plus, if I try to reboot, by using the user-switch applet on my desktop or by pressing the power button on my laptop for the dialogue to show up, the computer stops responding to keyboard and mouse events (I do see my temperature and CPU monitor applets updating themselves, so the computer does not hang entirely), and the computer does not reboot.

Let me know how I can help debug this.

pablomme (pablomme) wrote :

I'm still getting the issues I described above on 2.6.28-3-rt. Has anyone else tried the RT kernel on Jaunty?

Rob van den Berg (rghvdberg) wrote :

I have installed it, two things happend:

1) Nvidia drivers wouldn't install / run, so I had to use the x.org nv driver
2) after a while the pc froze; don't remember if I used ALT-F1 > sudo reboot, or did a hard (power button) reset.

Realtime Dutchman (nico-conny) wrote :

I also installed Jaunty beta on a single Intel processor machine with 700 Mbyte memory and the installation worked like a champ but...
since I'need the real time beaviour for studio work I had to modify the menu.lst so that I was able to boot from --linux-rt 2.6.27-3--.
So far so good.
Everything went wrong when I wanted to work with Jack and Ardour. The processor suddenly needed much more time (DSP indicator in Ardour went sky high) resulting a very slow performing and unworkable daw. It seems to mee that the realtime kernel isn't ready yet and since I can not work with the generic kernel (xruns in Jack) I'm forced to switch back to good old Hardy 8.04.
Does some one have a clue how to work around this RT behaviour?

ciao,

Realtime Dutchman.

Realtime Dutchman (nico-conny) wrote :

sorry mentioned wrong version of RT..again..:
I also installed Jaunty beta on a single Intel processor machine with 700 Mbyte memory and the installation worked like a champ but...
since I need the real time behaviour for studio work I had to modify the menu.lst so that I was able to boot from --linux-rt 2.6.28-3--.
So far so good.
Everything went wrong when I wanted to work with Jack and Ardour. The processor suddenly needed much more time (DSP indicator in Ardour went sky high) resulting a very slow performing and unworkable daw. It seems to me that the realtime kernel isn't ready yet and since I can not work with the generic kernel (xruns in Jack) I'm forced to switch back to good old Hardy 8.04.
Does some one have a clue how to work around this RT behaviour?
ciao,
Realtime Dutchman.

Mike Slinn (mslinn) wrote :

Any progress on RT for Jaunty?

vivichrist (vivichrist) wrote :

I have an hp compaq v5001au with turion x2 processor and kernel 2.6.28-3.1 hangs after a good 10minutes of boot. one of the cores is in 100% IOWait state.

Mike,

I installed the official jaunty 9.04 release and don't see any improvements
concerning CPU performance. It still is very slow, asking to much time from
my cpu and the strange thing is that when I install jaunty on a dual core pc
(Intel cpu) it appears to be very unstable but I don't see the delays. Even
during installation I had a system hang/crash which resulted in doing the
installation all over again.
After googling I found out that I'm not the only one having this nasty
issue.
Last night I gave up using the official ubuntu 2.6.28-3-rt kernel and
compiled my own from the www.kernel.org site.

I used info from the following web page :
https://lists.ubuntu.com/archives/ubuntu-studio-users/2009-May/004757.html

and the Debian tutorial how to build a kernel.
It took almost three hours before the pc had ended its complie and linking
actions but finally I was able to generate to installation deb. files for
kernel 2.6.29.3-rt13 which is running on my pc.
I still see delays on my single core so that one seems not to be resolved
but I hope this kernel will run on our dual core (It should if have read the
comments well about this issue).

Realtime Dutchman.

2009/5/12 Mike Slinn <email address hidden>

> Any progress on RT for Jaunty?
>
> --
> linux-rt restricted to one CPU
> https://bugs.launchpad.net/bugs/290498
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux-rt” source package in Ubuntu: Fix Released
>
> Bug description:
> Opening a new report as advised by Andrew Hunter in #281276.
>
> The linux-rt 2.6.27-3.8 release only uses one CPU (or core). Perhaps of
> note is that the rt variant does not set CONFIG_NR_CPUS which is set to 64
> in 2.6.27-7-generic and is set to 8 in the old 2.6.24-21-rt. It also does
> not set CONFIG_SMP which is set to y on the other two.
>
> After booting 2.6.27-3-rt dmesg contains this line:
>
> [ 0.000000] WARNING: NR_CPUS limit of 1 reached. Processor ignored.
>
> Compared to booting the non-rt 2.6.27-7-generic:
>
> [ 0.000000] SMP: Allowing 2 CPUs, 0 hotplug CPUs
> [ 0.000000] PERCPU: Allocating 64928 bytes of per cpu data
> [ 0.000000] NR_CPUS: 64, nr_cpu_ids: 2, nr_node_ids 1
>

Realtime Dutchman (nico-conny) wrote :

See the same crashes on a intel dual core which is sitting in our studio.
I can't confirm the 100% IOwait though. My cpu's seems to be in good shape.

2009/5/12 vivichrist <email address hidden>

> I have an hp compaq v5001au with turion x2 processor and kernel
> 2.6.28-3.1 hangs after a good 10minutes of boot. one of the cores is in
> 100% IOWait state.
>
> ** Attachment added: "kernel log"
> http://launchpadlibrarian.net/26630794/kern.log
>
> --
> linux-rt restricted to one CPU
> https://bugs.launchpad.net/bugs/290498
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux-rt” source package in Ubuntu: Fix Released
>
> Bug description:
> Opening a new report as advised by Andrew Hunter in #281276.
>
> The linux-rt 2.6.27-3.8 release only uses one CPU (or core). Perhaps of
> note is that the rt variant does not set CONFIG_NR_CPUS which is set to 64
> in 2.6.27-7-generic and is set to 8 in the old 2.6.24-21-rt. It also does
> not set CONFIG_SMP which is set to y on the other two.
>
> After booting 2.6.27-3-rt dmesg contains this line:
>
> [ 0.000000] WARNING: NR_CPUS limit of 1 reached. Processor ignored.
>
> Compared to booting the non-rt 2.6.27-7-generic:
>
> [ 0.000000] SMP: Allowing 2 CPUs, 0 hotplug CPUs
> [ 0.000000] PERCPU: Allocating 64928 bytes of per cpu data
> [ 0.000000] NR_CPUS: 64, nr_cpu_ids: 2, nr_node_ids 1
>

Realtime Dutchman (nico-conny) wrote :

Mike,

I installed the official jaunty 9.04 release and don't see any improvements concerning CPU performance. It still is very slow, asking to much time from my cpu and the strange thing is that when I install jaunty on a dual core pc (Intel cpu) it appears to be very unstable but I don't see the delays. Even during installation I had a system hang/crash which resulted in doing the installation all over again.
After googling I found out that I'm not the only one having this nasty issue.
Last night I gave up using the official ubuntu 2.6.28-3-rt kernel and compiled my own from the www.kernel.org site.

I used info from the following web page :
https://lists.ubuntu.com/archives/ubuntu-studio-users/2009-May/004757.html

and the Debian tutorial how to build a kernel.
It took almost three hours before the pc had ended its complie and linking actions but finally I was able to generate to installation deb. files for kernel 2.6.29.3-rt13 which is running on my pc.
I still see delays on my single core so that one seems not to be resolved but I hope this kernel will run on our dual core (It should if have read the comments well about this issue).

Realtime Dutchman.

Realtime Dutchman (nico-conny) wrote :

Guys,

I have been testing kernel 2.6.29.1-rt8 quite a bit now. This is the home made kernel Luke MacNeil had put on his web site.
see download links:

http://www.lukemacneil.com/linux-headers-2.6.29.1-rt8-custom_2.6.29.1-rt8-custom-10.00.Custom_i386.deb
http://www.lukemacneil.com/linux-image-2.6.29.1-rt8-custom_2.6.29.1-rt8-custom-10.00.Custom_i386.deb

Firstly install 9.04 from scratch and after that install both debs by double clicking the files.
Ignore the two ¨hmm¨ warnings you will get during installation.
Then run update-manager if you want to.

Do not use wicd network tool for wireless because it gave trouble in my pc causing it not to shut down properly
(acpid exiting problem). I installed the ubuntu network manager instead.

I have running it on a my single core P4 and on a dual core pc (Intel E8400) and runs without crashing and audio is handled real time as it should. Jack shows me latencies far below 1 ms .

Jack settings:
Priority = 89
Frames/Period = 128
Sample Rate = 48000
Periods/Buffer = 3

The rest is default settings.

It seems that Luke has managed to build a fast kernel without speed and instability troubles. As far as I understand he has used an old ubuntu kernel configuration to setup his kernel (Hardy? I am not sure). Het took his sources from kernel.org.

see web site :
http://<email address hidden>/msg04152.html

I hope someone at the Ubuntu Studio team can have a look at the jaunty kernel and compare it with Lukes just to find out what is causing an almost unworkable situation.

If i have some time left I will try to duplicate Lukes work and see if I can get the same results with newer kernel versions.

I will keep you posted.

Realtime Dutchman.

Realtime Dutchman (nico-conny) wrote :

Hopefully this looks better concerning Luke Macneils kernel:

site:<email address hidden>/msg04152.html

Realtime Dutchman (nico-conny) wrote :

Ok guys here is the deal.

If finally managed to reproduce a working jaunty 9.04 kernel, in fact it is running right now while I am writing this update.

I found out that Luke macneil´s kernel did not show a splash when studio was booting up and gave me trouble when I wanted to install my wireless. Both Wireless tool wicd and studio's network-manager gave me trouble and killed my sound tools.

The only thing I had left was spending some time studying how to build a proper kernel and I think I got it right now.
I wrote a tutorial how to build the kernel and tested it three times in a row ending up with the most recent kernel sources from kernel.org (http://www.kernel.org). the kernel I have running on my 32 bit Intel single core (p4) is

2.6.29.4-rt15-pentiumpro-nvk-052309-1.

If someone is interested in the installation files (header and image .deb´s) and/or tutorial feel free to send an e-mail

       realtime.dutchman<at>gmail.com

and use the files at your own risk.
I will send you the data you require (free of charge of course.. :-) ).

realtime dutchman.

medvind (peter-toth) wrote :

Hello!
I'd be very interested in both the installation files and the tutorial!

I'm very happy that someone with a little more knowledge than me is working
on this... :)

Regards
Péter

On Sat, May 23, 2009 at 8:22 PM, Realtime Dutchman <email address hidden>wrote:

> Ok guys here is the deal.
>
> If finally managed to reproduce a working jaunty 9.04 kernel, in fact it
> is running right now while I am writing this update.
>
> I found out that Luke macneil´s kernel did not show a splash when studio
> was booting up and gave me trouble when I wanted to install my wireless.
> Both Wireless tool wicd and studio's network-manager gave me trouble and
> killed my sound tools.
>
> The only thing I had left was spending some time studying how to build a
> proper kernel and I think I got it right now.
> I wrote a tutorial how to build the kernel and tested it three times in a
> row ending up with the most recent kernel sources from kernel.org (
> http://www.kernel.org). the kernel I have running on my 32 bit Intel
> single core (p4) is
>
> 2.6.29.4-rt15-pentiumpro-nvk-052309-1.
>
> If someone is interested in the installation files (header and image
> .deb´s) and/or tutorial feel free to send an e-mail
>
> realtime.dutchman<at>gmail.com
>
> and use the files at your own risk.
> I will send you the data you require (free of charge of course.. :-) ).
>
>
> realtime dutchman.
>
> --
> linux-rt restricted to one CPU
> https://bugs.launchpad.net/bugs/290498
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux-rt” source package in Ubuntu: Fix Released
>
> Bug description:
> Opening a new report as advised by Andrew Hunter in #281276.
>
> The linux-rt 2.6.27-3.8 release only uses one CPU (or core). Perhaps of
> note is that the rt variant does not set CONFIG_NR_CPUS which is set to 64
> in 2.6.27-7-generic and is set to 8 in the old 2.6.24-21-rt. It also does
> not set CONFIG_SMP which is set to y on the other two.
>
> After booting 2.6.27-3-rt dmesg contains this line:
>
> [ 0.000000] WARNING: NR_CPUS limit of 1 reached. Processor ignored.
>
> Compared to booting the non-rt 2.6.27-7-generic:
>
> [ 0.000000] SMP: Allowing 2 CPUs, 0 hotplug CPUs
> [ 0.000000] PERCPU: Allocating 64928 bytes of per cpu data
> [ 0.000000] NR_CPUS: 64, nr_cpu_ids: 2, nr_node_ids 1
>

Realtime Dutchman (nico-conny) wrote :

Hi Peter,

I will be happy to help you out.
Send me an email to : realtime.dutchman<at>gmail.com and I will provide you with some stuff to play with.

regards,

realtime dutchman.

vivichrist (vivichrist) wrote :

I went to http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=M;O=D and grabed the 2.6.29-4 source deb and applied the rt16 patch to it from http://www.kernel.org/pub/linux/kernel/projects/rt/. then copied across the /boot/config-2.6.28-12-generic to that kernel source root directory. did "make gconfig" and opened that config changed to full pre-emtion and timing to 1000 like Luke Macneil has done. "make-kpkg clean" then "CONCURRENCY_LEVEL=2 fakeroot make-kpkg --initrd --append-to-version=-custom kernel_image kernel_headers" installed the resulting packages headers first. and hey presto. note. CONCURRENCY_LEVEL=2 because my puta has duel core and this required installation of certain dev packages.

Realtime Dutchman (nico-conny) wrote :

vivichrist,

I assume you grabbed :

linux-source-2.6.29_2.6.29-02062904_all.deb and made an install by double clicking this file?

Didn´t you mean patch-2.6.29.4-rt15.bz2 instead of 2.6.26.8-rt16 as you suggested?

realtime dutchman.

vivichrist (vivichrist) wrote :

um actually yes. wish that was editable. oops

vivichrist (vivichrist) wrote :

also I compiled for amd64

Realtime Dutchman (nico-conny) wrote :

Thx Vivichrist,

I´ll give it a try on my other installation disk.
I must say that the kernel I´m running now, the one I took from kernel.org I mean, is running like a champ, but never the less it is always healthy to try a few other options too.

I´ll keep you posted because this procedure will take me couple of hours..

ciao,

realtime dutchman.

Realtime Dutchman (nico-conny) wrote :

Hi Vivichrist,

I´m back online with my single core p4 sytem running using the RT patched Ubuntu Studio generic kernel (build from linux-source-2.6.29_2.6.29-02062904_all.deb) like vivichrist did.

The system is running smoothly and I don´t notice any problems and had a short test with jack and ardour which turned out to be fine. See jack settings as I reported earlier.

My new kernel is called: 2.6.29.4-rt15-all-nvk-052409-1

I did change the .config a little bit though because I switched off kernel debugging in the kernel hacking menu and made the RT settings.

I will write a tutorial based on the one I have for the kernel.org based kernel 2.6.29.4-rt15-pentiumpro-nvk-052309-1 .

So at leased we have two options now; using the kernel.org based RT kernel or the fully Ubuntu Studio based RT kernel.

If anyone is interested please send me an e-mail ( realtime.dutchman<at>gmail.com ) and tell me which version you would like to try (at your own risk) and I will provide you with the data your require.

 --> header deb + image deb for quick install
--> tutorial how to build your own kernel + kernel config file
--> how-to-tar instruction

Thanks to vivichrist for his/her help.

realtime.dutchman.

vivichrist (vivichrist) wrote :

suspends and resumes too. yay. I don't use wireless though, so haven't tested that.

dutchman: I have been thinking of compiling a more architecture specific but what's a Turion?

Realtime Dutchman (nico-conny) wrote :

Vivichrist,

My wireless (SMC card) is working ok. I didn't do a lot of testing though, because it got late yesterday night (it took my system about 3 hrs to build a kernel).
Processor time is low and realtime behaviour seems to be fine with Jack/Ardour.

What I don't understand is why the Ubuntu Studio team doesn't use the same procedure...because it seems to work very well.

Tonight I will test my tutorial once more on another disk to see if it can be made public to everyone who wants to try to compile for him/herself.

About the Turion see AMD site:

http://www.amd.com/us-en/Processors/ProductInformation/0,,30_118_13909,00.html

ciao.

realtime.dutchman<at>gmail.com

vivichrist (vivichrist) wrote :

so I would compile for Athlon64 to get optimisations at a guess? compiling was way to easy compared to my past efforts. most should find it a cinch given detailed instructions. I got some weird errors installing the deb because I installed the kernel first then the headers and then tried reinstalling the kernel but make-kpkg doesn't seem to make packages capable of re-installation instead one must remove and install again. without the headers I couldn't get dkms to compile nvidia 180 drivers (duh). as for ubuntustudio team not not doing this stuff. maybe the kernel doesn't require so much patching now and they just haven't picked up on that yet ...? then again, I don't know how patched the kernel from http://kernel.ubuntu.com/ is, but the one I tried from kernel.org using the same procedure paniced at boot with a sync problem (Turion cores go out of sync).

Realtime Dutchman (nico-conny) wrote :

Hi Vivichrist,

I'm back online again and can confirm that my second attempt building the kernel was a succes!
I'm running the Ubuntu Studio RT patched generic kernel and realtime behaviour is ok, and don't see any problems.

The kernel I have spinning as we speak is : 2.6.29.4-rt15-all-nvk-052509-1

My offer to provide anyone with installation files is still open (see previous messages) but send me a mail first : realtime.dutchman<at>gmail.com

I hope there is someone out there who wants to test the files.

As far as I'm concerned and able to judge the situation, we have solved the kernel problem.

Thanks and talk to you later.

Realtime Dutchman.

Realtime Dutchman (nico-conny) wrote :

Vivichrist,

The last couple of nights I have been trying to reproduce an Ubuntu Studio 9.04 system with our new RT kernels but I'm dealing with an inconsistent clean jaunty install.
The problems I'm having is that sometimes Jaunty does not want to shutdown and after that my sound gets killed. At first I thought that it had to do with the new RT kernels but I am pretty sure that this is not the case because I also saw this problem once after I made a clean Jaunty install and a system update through update manager. What happens is that I get an --apci exiting-- problem when I try to reboot the system, followed by the fact that my sound is gone.

Do you also experiencing such problems and if so what is your solution to work around this problem. Would it be better to make a clean install, then install the generic kernel and then install one of the new RT kernels we have been working on?

I hope you have some answers/solutions for me..

thanks in advance,

Realtime dutchman

vivichrist (vivichrist) wrote :

"Jaunty does not want to shutdown"

this is a whole other bug in the kernel in ubuntu at the mo. one which I don't get so ....

"followed by the fact that my sound is gone."

I've been having problems with sound reseting and defaulting to 0 volume and muted after boot with or without the new rt I compiled. is just another ubuntu bug.

... wait for updates? I had problems with my ati HD4830 fglrx doesn't compile with dkms (has different scripting or something) or if it does gives corrupted X. so must use open source Radeon driver and metacity but thats ok. some of the modules don't get compiled or found or are very different form 2.6.28. I have a medium understanding of linux.

Realtime Dutchman (nico-conny) wrote :

I have been testing a couple of nights and it happened everytime I had done a Jaunty update. I could pretty well be a motherboard related issue because my suspicion was pointing to the acpid tools. so what I did is :

1. install 9.04
2. install wicd wireless network tool (skip this when you don´t need it) +reboot
3. removal of acpid and dependencies +reboot
4. jaunty update + reboot
5. install of both new ubuntu based RT kernel + reboot:

Files for everyone to use (at own risk) can be found at:

   https://www.yousendit.com/download/MnFqYURNTkw5bEJMWEE9PQ

5. changed audio settings

sudo gedit /etc/security/limits.conf

at the end of file:

@audio - rtprio 99
@audio - memlock unlimted
@audio - nice -19

And voila no problem anymore, a perfected running pc.

I did a reboot almost after every installation action because I wanted to know if the sound modules were still in working condition after I had done the installs.

Again the not shutting down issue and sound getting killed could have been a local issue with my pc, but at least what I can do is share this information with you.

Realtime dutchman.

Stephen Parry (sgparry) wrote :

Hi,
Here are my experiences of using Realtime Dutchman's 25th May build for about 36 hours:
Firstly, I am running with a different installation order from RTD:
1. Install 9.04 studio (all multimedia options) - reboot
2. Install all updates - reboot
3. Add workaround for clash involving snd-hda-intel driver and my system (see below) - reboot
4. Install headers
5. Install image - reboot.
6. Enable memlock 50% nice -99 via @ -> System -> Administration -> Ubuntu Studio Controls - Reboot

My acpi works infinitely better with kernel than it did without!

I have not dared enable wireless yet in any shape or form because the iwl3945 driver seems yet again to be very broken. I will try this later.

So far, my system:
- Boots
- Reboots
- Shuts down
- ~0% idle CPU
- realtime Jack
- captures and plays back audio (jack, audacious, audacity, ZynAddSubFx)
- suspends, resumes and hibernates (caveat - some processes exit)

* IT DOES THESE RELIABLY *

This is 100% improvement on the stock studio realtime kernel.

My snd-hda-intel needs a tweak to alsa-base.conf and the volume controls, but this is nothing to do with this realtime kernel; it's been a problem with my system at least as far back as hardy:
options snd-hda-intel model=dell-m27 enable_msi=0 probe_mask=1
Unmute the capture channel in the standard volume control / alsa mixer.
For those interested, without this JACKD watchdog timeouts trying to open the capture channel.

My system is as follows:
Dell Inspiron 9400 / E1705, 1GB memory, Core Duo 1.8GHz, Intel 945GM graphics, SigmaTel HDA, Intel 3945ABG wireless.

Realtime Dutchman (nico-conny) wrote :

Good news Stephen, it proves we are on the right track.

And for those who are interested in the latest 2.6.29.4-all rt16 patched version build 060109-1 (install at your own risk) you can download the installation tar from:

https://rcpt.yousendit.com/694843214/2ef79476f82640fd0d94413097c85706

I have this version currently running.

have fun.

Realtime dutchman.

Realtime Dutchman (nico-conny) wrote :

(previous link to the rt kernel has expired)

For those who are still interested in the latest 2.6.29.4-all rt16 patched version build 060109-1 (install at your own risk) you can download the installation tar from:

https://rcpt.yousendit.com/696896592/f3cca9902281f0c62185d4ea3ff15f69

Realtime dutchman.

Hey thanks Realtime dutchman!

Finally I could update my old intrepid with hardy kernel to jaunty using your kernel.

And after cheating the NVIDIA Installer by copying your headers into the default source files 2.6.29.4 dled from kernel.org I was able to install the driver again.

Thanks alot!

Rob van den Berg (rghvdberg) wrote :

@Realtime Dutchman
Have you got a amd64 build for the rt-kernel, or could you give me instructions how to do it ?

I've build an rt-kernel in the last couple of weeks following the advice from vivichrists post https://bugs.launchpad.net/ubuntu/+source/linux-rt/+bug/290498/comments/26 and the Master Kernel Thread http://ubuntuforums.org/showthread.php?t=311158.

Somehow I end up with a huge kernel image (200+ mb) and pulseaudio becomes very unstable (unusable) and flash (youtube etc) becomes unusable because of the pulseaudio thing.

greetings from a fellow dutchman

Luctor

Realtime Dutchman (nico-conny) wrote :

Luctor,

Send me an e-mail and I will provide you a tutorial.

<email address hidden>

RTD.

Realtime Dutchman (nico-conny) wrote :

Luctor,

Send me an e-mail and I will provide you a tutorial.

Now with a readable e-mail address:

realtime.dutchman<at>gmail.com

RTD.

hey everyone,

i have installed the kernel realtime dutchman has provided the link to,
and it solved alll of my issues.. mainly the fact that my cpu's weren't being handled properly and
i had the IOWAIT issue that was sucking up my cpu. thank you so much! i am running a fairly custom
setup not using ubuntu studio and i was having a hell of a time, getting past my problems.
i haven't really put it under rigorous testing yet., but already a huge, very noticable difference..

But!!

i still have one minor issue.... i am running a dell inspiron 6400, which uses a proprietary wireless driver,
i haven't been able to get it working, which is a pain as i will need internet at some point of another in that kernel. any advice or help would be greatly appreciated, even just push me in the right direction!

thanx again, and cheers! :)

one other quick note if someone knows the answer...??!?

how do i set SOUND_CARD_IRQ...?as requested by - realTimeConfigQuickScan.pl

it is the only parameter in this diagnostic that i don't have in order. i have scoured around the net
to find an answer with no luck.... i realize this is a bit off topic, but maybe someone
here could still provide me with an answer?

thanx in advance

Realtime Dutchman (nico-conny) wrote :

(previous link to the rt kernel has expired)

For those who are still interested in the latest 2.6.29.4-all rt16 patched version build 060109-1 (install at your own risk) you can download the installation tar from:

https://rcpt.yousendit.com/700198668/fdf4910cf9f074606810ee28ec97e620

RTD.

Realtime Dutchman (nico-conny) wrote :

(previous link to the rt kernel has expired)

For those who are interested in the latest kernel

         2.6.29.5-rt21-all build 062109-1

For 32bit sytems only.
Feel free to download the installation tar (at your own risk) from:

http://www.send2deliver.com/deliver.php?cb5ef5041dab10043f568085e5073e90

The link will expire on 06-29-09

RTD.

Cecil (ccoupe) wrote :

Using RTD's tutorial I was able to build 2.6.29.5-rt21 for my 9.04 system. (AMD 64 bit).

I had one problem and it's doozy. It died in the very last step of the build because I had the nvidia drivers (non free). The kernel would boot and run (but a few things didn't work). It took a lot of hacking around to get rid of *all* of the nvidia artifacts so that syslog/messages/X.log didn't have errors.

My advice is that if you have propriety drivers and you want to build a custom kernel, that you remove all the proprietary drivers before building the kernel. Then you can figure out how to get the proprietary drivers re-installed. Actually, my first thought would be to not build a custom kernel if you have proprietary drivers but if you do, you better know your dpkg and looking at the log files in recovery mode.

Realtime Dutchman (nico-conny) wrote :
Download full text (16.9 KiB)

Cecil,

Many thanks for your help concerning the nvidia driver issue.

For anyone who is interested in the kernel building tutorial please find the tutorial text below. This is the tutorial written by me and has been tested by others and is a pretty much cut and paste method.

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

Kernel building tutorial for Ubuntu Studio 9.04 build 2.6.29.5-rt21-all-nvk-062109-1
Source code based on Ubuntu Studio Generic with RT patch from kernel.org.

__________________________________________________________________________________________________________________________________________________________

1. Introduction.

This tutorial describes in nine steps how to get kernel sources and how to compile, build and install a new real time kernel for Ubuntu Jaunty 9.04.
The procedure as desribed below has been tested by the author but gives no guarantee for other pc hardware/software setups, but feel free to try
the kernel building steps at your own risk.

This tutorial desribes how to obtain, patch and compile Ubuntu Studio generic kernel.
Real time patch wil be obtained from kernel.org.

IMPORTANT NOTE:
Before you start using the tutorial you should take notice of the following issue concerning nvidia proprietary drivers.
Users who are using nvidia proprietary drivers should take care because these drivers could lead to building errors.
I would like to refer to the comments made by Cecil on web page: https://bugs.launchpad.net/ubuntu/+source/linux-rt/+bug/290498/

She has made the following comment:

$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$
Using RTD's tutorial I was able to build 2.6.29.5-rt21 for my 9.04 system. (AMD 64 bit).

I had one problem and it's doozy. It died in the very last step of the build because I had the nvidia drivers (non free). The kernel would boot and run
(but a few things didn't work).
It took a lot of hacking around to get rid of *all* of the nvidia artifacts so that syslog/messages/X.log didn't have errors.

My advice is that if you have propriety drivers and you want to build a custom kernel, that you remove all the proprietary drivers before building the kernel.
Then you can figure out how to get the proprietary drivers re-installed.
Actually, my first thought would be to not build a custom kernel if you have proprietary drivers but if you do, you better know your dpkg and looking
at the log files in recovery mode.
$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$

2. Installing tools:

## Become root:

 sudo -s

## For building the new kernel you need to install development tools first.

 apt-get install kernel-package ncurses-dev fakeroot bzip2 wget

3. Obtain and install generic kernel sources.

## Obtain the latest Ubuntu Studio generic kernel source for which a real-time patch is available at kernel.org:

Go to web sit...

pierre (covorec) wrote :

Thank you Realtime Dutchman,

following your instructions I successfully compile and run a 2.6.29.6 realtime kernel under cruchbang 9.04.
It works nicely with jack and vmware workstation.

In theory a generic 2.6 kernel should handle HZ > 100 using special config in /etc/security/limits.conf:

@audio - rtprio 99
@audio - memlock unlimited

and so handles jack realtime option, but I find that the 2.6.29.6 realtime kernel works much better with vmware workstation: with the generic kernel I had some hangs/sluggish in the Windows XP guest due to /etc/rtc I suppose.

If someone need some kind of help write me at covorec<at>gmail.com

happy gnu to everybody!

Realtime Dutchman's instructions for compiling a kernel are excellent. This was my first time compiling a kernel and I was able to do so with no problems compiling or installing. I have an AMD Athlon64 X2 5600+ (i.e. dual-core).

When I compiled the exact generic kernel and patch recommended by Realtime Dutchman (linux-source-2.6.29_2.6.29-02062905_all.deb and patch-2.6.29.5-rt21.bz2), it seems to have resolved everything. No system issues, no xruns on jackd and the load on the CPUs looks normal:

Cpu0 : 0.3%us, 0.3%sy, 0.0%ni, 99.3%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Cpu1 : 1.0%us, 0.7%sy, 0.0%ni, 98.3%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st

NB: When I compiled and installed what I believe to be the most recent generic kernel code and rt patch as of this writing (i.e. linux-source-2.6.29_2.6.29-02062906_all.deb and patch-2.6.29.6-rt23.bz2), I experienced intermittent issues with my USB keyboard's keys getting 'sticky' (i.e. single keystroke results in multiple characters) and what looked like a video card issue when the machine booted up (just once). Not sure if this is related, but my machine has an NVidia video card (GeForce 7100 GS).

pablomme (pablomme) wrote :

This bug appears to be solved in Karmic. As far as I can tell the current Karmic RT kernel (2.6.31-9-rt) does not have the SMP issue that Intrepid's and Jaunty's had.

If I had to guess, I would say this is because the kernel version matches the upstream RT patch version this time around, which hadn't happened since Hardy. In my opinion, the RT patch is highly non-trivial to port across kernel versions, and the Ubuntu linux-rt maintainers should stick to shipping the latest kernel version for which an RT patch was published, even if it doesn't match that of the generic kernel, because chances are that users will lose more from the RT kernel being broken than they would gain from having a newer kernel. Or to ship both.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers