Ubuntu

Broadcom STA/wl driver causes random kernel panics

Reported by Killeroid on 2008-11-02
154
This bug affects 22 people
Affects Status Importance Assigned to Milestone
linux-restricted-modules (Ubuntu)
High
Tim Gardner
Nominated for Karmic by amarradi
Hardy
High
Stefan Bader
Intrepid
High
Stefan Bader
Jaunty
High
Tim Gardner

Bug Description

SRU justification:

Impact: The current broadcom driver (wl.ko) seems to have several issues during operation. Reported have been random crashes between 5 a day to only 1 every 4 days.

Fix: The latest driver from broadcom had positive feedback on Jaunty and has been released there. This is the backport of that driver for intrepid.
The same code is intended to get ported to Hardy LRM. This would sync up the Hardy codebase with the Intrepid and Jaunty layout. So this would yield bug fixes and ease maintenance.

Changes are local to wl.ko only.

Testcase: Generic usage will sometimes cause panics.

---

The new wl driver(Broadcom STA) randomly causes my Dell Inspiron E1505 to experience kernel panics. I haven't been able to get a picture of the kernel panic though. The kernel panic happens randomly, sometimes even during bootup.

The reason why I know its from the wl driver is because, I was using the b43 driver back on hardy. When the new broadcom driver was released, I manually compiled it and installed it. The driver kept randomly causing kernel panics on my system. When I blacklisted the driver and reverted back to b43, no more kernel panics. I wiped my disk down and installed intrepid and set my system to use the new wl driver again. The kernel panics started all over again. When I changed to the b43 driver, the kernel panics disappeared.

The system can sometimes run for 4/5 days before experiencing a kernel panic and at other times, I can get about 5 kernel panics in a day. I googled around and found a few people on both the ubuntu and debian forums having the same problem with different systems and different broadcom cards but same driver.

Killeroid (killeroid) on 2008-11-02
description: updated
rRNA (jjovinr) wrote :

Same thing also happens to me in ubuntu hardy on my dell inspiron 1420 using the bcm4311 chipset. The computer just froze and the caps lock light was flashing intermittently. This problem did not start until I updated the b43 driver to the new broadcom STA driver.

jarviw (jarviw) wrote :

I would also like to confirm this bug.
Running Linux Mint 5 (Hardy base) with kernel 2.6.24.21. running wl driver for broadcom 4321.
We mostly get kernel panic when waking up from suspension or hibernation. It seems wl driver is trying to reconnect but fails. about 3 out of 4 times frequency of getting kernel panic this way.

I am tempted to try Intrepid 2.6.27 kernel, but that's a different bug report. Not having any luck with Intrepid live CD as yet.

tchu11 (tchu11) wrote :

I am running Intrepid Ibex and I suspect I have the same problem as well, although I have no proof as studying the system logs after the crashes did not give me any clues.

I installed the driver through GNOME Control Centre > Hardware Drivers > select 'Broadcom STA Driver' > click 'Activate' button at bottom right. I can use my home wireless without any problems (which is protected by WPA2). But when I tried to log on to my University wireless network, which uses the settings in Ubuntu similar to these here http://www.lshtm.ac.uk/its/wireless/jrswin.htm the Network Manager took a very long time to attempt to log on and then crashed (without logging on). The whole system froze with no responses from keyboard and trackpad. I tried Ctrl + Alt + F1 to F8, but no response either and had to do a hard reboot (several times).

I did not have this problem with Hardy, but maybe I was using the other B43 open source driver at that time. The crash occured everytime when I tried to log on to my University wireless (ie. consistently reproducible).

lspci told me my wireless card is Broadcom BCM4312 which comes with Dell Inspiron 1525 I bought in July 2008.

jarviw (jarviw) wrote :

Let me correct myself from the previous post...
I have Broadcom 4328, running wl driver under kernel 4.6.24.21-generic
attached is the screen shot, when I wake the computer up from suspension.

jarviw (jarviw) wrote :

sorry again. 2.6.24.21-generic

Joe Kilner (joekilner) wrote :

Just another me too with getting kernel panics since I switched drivers. For now I will swap back to the open source drivers and see if that fixes it.

Do You have laptop-mode enabled? If so disable and see. I was having the issue in my HP Pavilion DV 2240br (Broadcom BCM4311 802.11b/g WLAN (rev 01)). I cannot say wich setting(s) in laptop-mode tools are (or is) the culprit, but the problem stopped as soon as I disabled it, about one week ago.

I have a similar problem.
I run Ubuntu 8.04 on my HP Compaq nx6325 with kernel 2.6.24-19-generic.
When I update to a newer one (eg. 2.6.24-22-generic), install the new STA driver, restart and login, the machine connects to my WLAN (AVM FRITZ!Box Fon WLAN 7141) and crashes: my screen gets dark, I only see the cursor but can't move it. The keyboard shows CAPSLOCK enabled.
In other environments (other router) it worked.

tchu11 (tchu11) wrote :

I no longer have this problem after disabling the proprietary STA driver and enabling the open-source B43 driver. I have no idea why Ubuntu made the propriety STA driver available on their CD. May be it should ship the open-source driver with its CD instead to be true to the open-source spirit?

dubs (sergioduran) wrote :

I have a HP Pavilion dv6000 with a BCM4312 card, I normally use a Linksys WUSB54GC because the bcm driver (with b43-fwcutter) didn't quite work for me.

I noticed the Broadcom STA driver so I tried it, after a while, the whole computer freezes with a blinking caps lock.

Killeroid (killeroid) wrote :

Other people comfirmed same problem and verified that it was caused by the same factor(Broadcom STA wireless driver)

Changed in linux-restricted-modules:
status: New → Confirmed
guyvdb (guyvdb-gmail) wrote :

Seeing some very ugly kernel panics on Intrepid here. Messed up my partition.
It seems to happen more often when the wireless is used more intensively.

brad (bradlambeth) wrote :

I'm getting these panics too. Here is a message that is repeated in my kern.log file hundreds of times:

TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88013386cb40

When I switch to the b43 driver this message goes away, as well as the kernel panics.

Tim Gardner (timg-tpi) wrote :

Uploaded linux-restricted-modules-2.6.24_2.6.24.15-23.55

Changed in linux-restricted-modules:
assignee: nobody → timg-tpi
importance: Undecided → High
milestone: none → ubuntu-8.04.3
status: New → Fix Committed
Tim Gardner (timg-tpi) wrote :

Hardy SRU Justification

Impact: Broadcom wireless binary-blob driver crashes

Patch Description: Updated the binary blob to 5.10.27.11 from 5.10.27.9

Test case: This update is a side effect of testing performed on OEM platforms. I'm not sure of the exact failure scenarios.

jarviw (jarviw) wrote :

thanks for the update Tim!
Can you tell me where the new patched package is available? repository to enable?
I would love to help test the new fix.

Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Killeroid (killeroid) on 2008-12-17
Changed in linux-restricted-modules:
status: New → Confirmed
jarviw (jarviw) wrote :

updated to the fixed package. so far it has been working well.
suspend/wake cycle (which induces kernel panic previously in high frequency) seems to work well.

upon waking, it does take a little bit (~30 sec or less) before network manager gets the wireless interface to resume connectivity, but it also seems to be an improvement (previously it could be much longer or not resume at all!)

I am using BCM 4328 (and therefore only have the option of wl or ndiswrapper) here.
Thanks guys!

dg (dan-g) wrote :

Can we get this fix into intrepid / intrepid-proposed?

I reported the bug on my Intrepid at https://bugs.launchpad.net/bugs/304926 which is now a duplicate of this one, and I see this bug is confirmed for Intrepid here ....

Tim Gardner (timg-tpi) wrote :

Intrepid SRU Justification

Impact: Broadcom wireless binary-blob driver crashes

Patch Description: Updated the binary blob to 5.10.27.11 from 5.10.27.6

Test case: This update is a side effect of testing performed on OEM platforms. I'm not sure of the exact failure scenarios.

Uploaded linux-restricted-modules_2.6.27-11.15

Changed in linux-restricted-modules:
assignee: nobody → timg-tpi
importance: Undecided → High
milestone: none → intrepid-updates
status: Confirmed → Fix Committed
Steve Langasek (vorlon) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

dg (dan-g) wrote :

Am I just being impatient or should I be able to see linux-restricted-modules_2.6.27-11.15 in intrepid-proposed now?

Having enabled -proposed, latest version I can see is linux-restricted-modules_2.6.27-10.14 ....
(although I have linux-image_2.6.27-11.21 already ...)

Killeroid (killeroid) wrote :

@dg Hold on for a couple of hours. A tar.gz and dsc file for the update is already in the repos. A deb would be generated very soon and then you can update to it.

dg (dan-g) wrote :

Hmmm ... it's been nearly 24 hours and I still don't see the new .deb!
In fact if I enable -proposed and try to upgrade, I get this:

The following packages have been kept back:
   linux-restricted-modules-generic (2.6.27.9.13 => 2.6.27.11.14)

.... which is due to the package "linux-restricted-modules-2.6.27-11-generic" not being available....

dg (dan-g) wrote :

OK it's appeared, installed and running 2.6.27.11.14.
All good so far.

Jeremy Wilkins (wjeremy) wrote :

Since the update in Intrepid to 2.6.27-11 the Realtek 8180 wireless drivers fail to work if the backports modules are installed, but I haven't been able to find a related bug report. Removing the backports modules and rebooting seems to fix it since it is running on the kernel stock drivers. The strange part is that the modules give no error and load just fine, the wmaster0 interface is created, but the wlan0 interface isn't created. Should I open a new kernel report?

Ken Savich (ksavich) wrote :

Still happening here. I'm running linux-restricted-modules-2.6.27-11-generic

Running a Dell D630. The entire system locks up while caps an num flash. I don't know if this is related, but I've had several instances of intrepid popping up a dialog with nonsense on it, at which point I force it to reboot and the root partition is horked. A very long fsck has brought it back from the dead a few times for me.

Lets just say that this release has been extremely unstable for me.

I've reverted back to the slow b43 driver --

dg (dan-g) wrote :

Also still happening here.
Had the same caps-lock flashing system freeze-up while using wireless, albeit after some days using it without problem.

I don't get any dialogs popping up, nor do I have any debug lines in the system logs either. I also don't need to do any fsck after rebooting (luckily).

But it would be nice to have a stable 802.11 driver.

[ Network controller: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01) ]

jarviw (jarviw) wrote :

Just for the sake of adding information:
this upgrade in Hardy seems to have fixed the problem for me (BCM 4328). I have not had any kernel panic since. So perhaps dg's report is more specific to Intrepid?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-restricted-modules - 2.6.28-4.3

---------------
linux-restricted-modules (2.6.28-4.3) jaunty; urgency=low

  [Tim Gardner]

  * Update Broadcom wl to 5.10.27.11 from 5.10.27.6
    - LP: #292450
  * Bumped ABI

 -- Tim Gardner <email address hidden> Sat, 20 Dec 2008 16:33:42 -0700

Changed in linux-restricted-modules:
status: Confirmed → Fix Released
brad (bradlambeth) wrote :

Updated to the new wl driver, still have the same issue. I get the message:

TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88013386cb40

several hundred times, then a kernel panic with the blinking caps lock. Switching back to b43-fwcutter for now.

James Schriver (dashua) wrote :

The kernel panics have been mitigated as far as I can see. I've been using linux-restricted-modules 2.6.27-11.15, including the latest Broadcom blob wl 5.10.27.11, from intrepid-proposed since 12/19. The sporadic flashing caps and number lock flashes (kernel panics) are gone. I'll continue to monitor. Dell XPS m1530 Broadcom 4328.

Yi Yang (yy) wrote :
Download full text (5.6 KiB)

I'm using intrepid linux-restricted-modules 2.6.27-9.13 , and the problem exists. How can I find any newer kernel ? I've enabled proposed in sypantic but there's no newer packages.

#uname -a
Linux yy-dell13 2.6.27-9-generic #1 SMP Thu Nov 20 22:15:32 UTC 2008 x86_64 GNU/Linux

#lspci -v

0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)
 Subsystem: Dell Device 000b
 Flags: bus master, fast devsel, latency 0, IRQ 17
 Memory at f6cfc000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: [40] Power Management version 3
 Capabilities: [58] Vendor Specific Information <?>
 Capabilities: [e8] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
 Capabilities: [d0] Express Endpoint, MSI 00
 Capabilities: [100] Advanced Error Reporting <?>
 Capabilities: [13c] Virtual Channel <?>
 Capabilities: [160] Device Serial Number 23-00-36-ff-ff-4e-e8-24
 Capabilities: [16c] Power Budgeting <?>
 Kernel driver in use: wl
 Kernel modules: wl

#vim /var/log/syslog
...
Jan 1 13:47:00 yy-dell13 kernel: [ 5735.958538] TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88007e985300
Jan 1 13:47:01 yy-dell13 kernel: [ 5736.982643] TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88007e985300
Jan 1 13:47:07 yy-dell13 kernel: [ 5743.843370] TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88007e985300
Jan 1 13:47:08 yy-dell13 kernel: [ 5744.693429] TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88007e985300
Jan 1 13:47:09 yy-dell13 kernel: [ 5745.891532] TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88007e985300
Jan 1 13:47:10 yy-dell13 kernel: [ 5746.813197] TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88007e985300
Jan 1 13:47:11 yy-dell13 kernel: [ 5747.691855] TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88007e985300
Jan 1 13:47:12 yy-dell13 kernel: [ 5748.861909] TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88007e985300
Jan 1 13:47:18 yy-dell13 kernel: [ 5754.185980] TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88007e985300
Jan 1 13:47:19 yy-dell13 kernel: [ 5755.209796] TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88007e985300
Jan 1 13:48:21 yy-dell13 kernel: [ 5817.469368] TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88007e985300
Jan 1 13:48:22 yy-dell13 kernel: [ 5818.390932] TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88007e985300
Jan 1 13:48:24 yy-dell13 kernel: [ 5820.438923] TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88007e985300
Jan 1 13:48:31 yy-dell13 kernel: [ 5827.114938] TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88007e985300
Jan 1 13:48:35 yy-dell13 kernel: [ 5831.293369] TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88007e985300
Jan 1 13:48:36 yy-dell13 kernel: [ 5832.254028] TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88007e985300
Jan 1 13:48:37 yy-dell13 kernel: [ 5833.444058] TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88007e985300
Jan 1 13:48:38 yy-dell13 kernel: [ 5834.365378] TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88007e985300
Jan 1 13:48:39 yy-dell13 kernel: [ 5835.389507] TKIP: RX tkey->key_idx=2 frame keyidx=1 priv=ffff88007e985300
Jan 1 13:48:41 yy-dell13 kernel: [ 5837.437381] TKIP: RX tkey->key_idx=2 frame keyidx=1 pr...

Read more...

James Schriver (dashua) wrote :

New Broadcom STA Driver blob uploaded on 12/31/08. Not sure of the change log.

http://www.broadcom.com/support/802.11/linux_sta.php

Yi Yang (yy) wrote :

Oh, it's the best new year gift! I've installed it and for the last 15 mins, the problem was gone! Wonderful.

Tim Gardner (timg-tpi) wrote :

Further stability updates: linux-restricted-modules-2.6.24_2.6.24.16-23.56

Tim Gardner (timg-tpi) wrote :

Further stability updates: linux-restricted-modules_2.6.27-11.16

I've been seeing this with a Dell Vostro 1710. The random kernel panics have stopped but the wireless connection is unstable. Fingers crossed for this latest update.

Michael Rooney (mrooney) wrote :

Thanks Tim! If I am currently using ndiswrapper, what step[s] do I need to take before re-enabling the restricted driver to ensure no clashing?

torquill (spammo-hung) wrote :

I'm using linux-restricted-modules_2.6.27-11.16, but still getting random panics (lockup with Caps-Lock flashing, nothing in the logs). I've tried enabling the b43 driver -- despite having loaded the firmware, unloading wl, and following every howto I can find, the b43 module does nothing except load obediently. No wlan0 installed, no wireless ability in network-manager, no errors. I'm running this machine on the wl driver and waiting for the next panic.

chip: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 02)

I guess I'll give ndiswrapper a try, but that's always a longshot in my experience.

Changed in linux-restricted-modules:
status: Fix Committed → Fix Released
Changed in linux-restricted-modules:
status: Fix Released → Confirmed
status: Fix Released → Confirmed
Pete Graner (pgraner) on 2009-03-20
Changed in linux-restricted-modules:
assignee: nobody → timg-tpi
importance: Undecided → High
Tim Gardner (timg-tpi) on 2009-03-23
Changed in linux-restricted-modules (Ubuntu Jaunty):
milestone: none → ubuntu-9.04
status: Confirmed → Fix Committed
Changed in linux-restricted-modules:
status: Fix Committed → Fix Released
Peter Whittaker (pwwnow) on 2009-03-27
Changed in linux-restricted-modules (Ubuntu Jaunty):
status: Fix Released → Confirmed
Pete Graner (pgraner) on 2009-04-03
Changed in linux-restricted-modules (Ubuntu Jaunty):
status: Confirmed → Fix Released
Steve Langasek (vorlon) on 2009-04-03
Changed in linux-restricted-modules (Ubuntu Jaunty):
status: Fix Released → Confirmed
Steve Langasek (vorlon) on 2009-04-03
Changed in linux-restricted-modules (Ubuntu Jaunty):
status: Confirmed → Fix Committed
Tim Gardner (timg-tpi) on 2009-04-04
Changed in linux-restricted-modules (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Tim Gardner (timg-tpi) on 2009-04-07
Changed in linux-restricted-modules (Ubuntu Hardy):
assignee: timg-tpi → stefan-bader-canonical
Changed in linux-restricted-modules (Ubuntu Intrepid):
assignee: timg-tpi → stefan-bader-canonical
Stefan Bader (smb) on 2009-04-08
Changed in linux-restricted-modules (Ubuntu Hardy):
status: Fix Committed → In Progress
Changed in linux-restricted-modules (Ubuntu Intrepid):
status: Confirmed → In Progress
54 comments hidden view all 134 comments
Stefan Bader (smb) wrote :

@jarviw, I think this would be a different bug. The description here (as far as I can see) was about random crashes while using the wireless. So for problems after suspend, could you please open a new bug report? Did you see improvements during operations?

Stefan Bader (smb) wrote :

Uploaded linux-restricted-modules-2.6.24_2.6.24.17-24.1

description: updated
Changed in linux-restricted-modules (Ubuntu Hardy):
status: In Progress → Fix Committed
Stefan Bader (smb) wrote :

Applied to LRM repo

Changed in linux-restricted-modules (Ubuntu Intrepid):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Please test:

 linux-restricted-modules-2.6.24 (2.6.24.17-24.1) hardy-proposed; urgency=low
 .
   * Updated broadcom wl driver to 5_10_79_10
     This has been tested to fix issues with random crashed and at least one
     buffer overrun with 32 byte SSIDs.
     - LP: #292450
   * Added build-orig-source target to automatically create orig.tar.gz

tags: added: verification-needed
removed: verification-done
Peter Whittaker (pwwnow) wrote :

Is bug# 300784 a duplicate of this bug? Should status against the Dell Mini Project be opened here and bug# 300784 duped to this one? I'm pretty sure they are the same problem (same symptoms on my Mini and Studio 1535; this fix fixed the Studio) so we just need to get it into LPIA generally and Dell Mini specifically.

Peter Whittaker (pwwnow) wrote :

I just updated my Dell MINI - wireless works against my WPA2 network.

Thanks, devs, great work.

Martin Pitt (pitti) on 2009-04-27
tags: added: verification-done
removed: verification-needed
James Schriver (dashua) wrote :

New version released 5.10.91.9 GOLD.

http://www.broadcom.com/support/802.11/linux_sta.php

ISSUES FIXED IN THIS RELEASE
----------------------------
#72138 - SLED11 / Ubuntu 8.04: 43224 fails to associate after 6 hours

KNOWN ISSUES AND LIMITATIONS
----------------------------
#72238 - 20% lower throughput on channels 149, 153, 157, and 161
#72324 - Ubuntu 8.04: cannot ping when Linux STA is IBSS creator with WEP enabled
#72216 - Ubuntu 8.04: standby/resume with WPA2 and wpa_supplicant causes a continuous assoc/disassoc loop
         (issue with wpa_supplicant, restarting wpa_supplicant fixes the issue)

Martin Pitt (pitti) wrote :

Accepted linux-restricted-modules into intrepid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Steve Beattie (sbeattie) wrote :

Per bug 372425, linux-restricted-modules-2.6.24 was accepted into hardy-proposed. Please test and give feedback in bug 372425. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-restricted-modules - 2.6.27-14.20

---------------
linux-restricted-modules (2.6.27-14.20) intrepid-proposed; urgency=low

  [ Tim Gardner ]

  * Update Broadcom to 5.10.79.10
    - LP: #292450
  * wl: applied web site patch to 5.10.79.10
    - LP: #292450
  * Update Broadcom wl to 5.10.91.9
    - LP: #372425

 -- Stefan Bader <email address hidden> Thu, 09 Apr 2009 08:57:01 +0200

Changed in linux-restricted-modules (Ubuntu Intrepid):
status: Fix Committed → Fix Released
fejes (anthony-fejes) wrote :

I hope this is the right place to put this error report.

I am seeing highly similar behaviour in Karmic Koala: (from dmesg)

[ 3950.330817] TKIP: RX tkey->key_idx=1 frame keyidx=2 priv=ffff88006c409f00
[ 3951.348500] TKIP: RX tkey->key_idx=1 frame keyidx=2 priv=ffff88006c409f00
[ 3952.378822] TKIP: RX tkey->key_idx=1 frame keyidx=2 priv=ffff88006c409f00
[ 3953.402793] TKIP: RX tkey->key_idx=1 frame keyidx=2 priv=ffff88006c409f00
[ 3954.427080] TKIP: RX tkey->key_idx=1 frame keyidx=2 priv=ffff88006c409f00
[ 3955.450826] TKIP: RX tkey->key_idx=1 frame keyidx=2 priv=ffff88006c409f00
[ 3998.663788] TKIP: RX tkey->key_idx=1 frame keyidx=2 priv=ffff88006c409f00
... ad nauseum.

This comes from: (from lspci)

05:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)

Additionally, I have long "pauses" in connectivity that last 1+ minute at a time, and cause large lags in web browsing, chat, etc.

Cheers

Mikael Wiesel (mikwie) wrote :

I see exactly the same behavior as described by fejes, in comment #105, on my Jaunty and Intrepid installations - both with the 5.10.91.9 version Broadcom driver.
(BTW, as far as I can tell, it seems to be worse than it was with the previous version.)

Broadcom hasn't responded to bug reports, the b43 driver unfortunately yet doesn't support BCM4312 (PCI-ID 14e4:4315) - and I'm would rather not having to install ndiswrapper once again.

Wish I could switch to another WLAN mini-PCI card, but HP's BIOS "whitelisting" makes that virtually impossible.
Three cheers for closed source and proprietary software...

Stefan Bader (smb) wrote :

The update of the driver has been released in Hardy with LRM-2.6.24.18-24.1 but attributed to LP bug #372425

Changed in linux-restricted-modules (Ubuntu Hardy):
status: Fix Committed → Fix Released
Stefan Bader (smb) wrote :

Comment #107 describes a different problem. Please open a new bug for this.

Stefan Bader (smb) wrote :

Sorry, in the previous comment I wanted to write comment #105. Actually, this came up on IRC today, there might be a debugging option set in the wl driver for karmic, which is responsible for the many messages. But that should go into another bug to keep it separate.

JeSTeR7 (cblocker) wrote :

This seems to be happening in Karmic beta. I don't know if I'm supposed to create a new bug for it, but the description is exactly like the one listed here.

JeSTeR7 wrote:
> This seems to be happening in Karmic beta. I don't know if I'm supposed
> to create a new bug for it, but the description is exactly like the one
> listed here.
>
It would be better to open a new bug. Especially if you do not get kernel panics.

jomtois (jomtois) wrote :

I found this bug after I posted for Karmic here:

https://bugs.launchpad.net/ubuntu/+source/wpasupplicant/+bug/453647

Seems to be exactly the same.

Hello,

i've an HP Compaq with the Broadcom Wireless-Network-Card.

Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller (rev ff)

I used the kernel 2.6.31-18-generic under ubuntu 9.10

If i try to install the STA driver like this tutorial http://wiki.ubuntuusers.de/WLAN/Broadcom_bcm43xx

my ubuntu freezes :-) Something is wrong, because under the other kernel like 2.6.31.14 an 17 its the same problem. No wireless runs. The last crash was at Th. 28.02.10 11:24 (if you want watch the logfile?field.comment=Hello,

i've an HP Compaq with the Broadcom Wireless-Network-Card.

Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller (rev ff)

I used the kernel 2.6.31-18-generic under ubuntu 9.10

If i try to install the STA driver like this tutorial http://wiki.ubuntuusers.de/WLAN/Broadcom_bcm43xx

my ubuntu freezes :-) Something is wrong, because under the other kernel like 2.6.31.14 an 17 its the same problem. No wireless runs. The last crash was at Th. 28.02.10 11:24 (if you want watch the logfile) The ubuntu said. Look at the jockey.log for details. I don't know were i have to look.

Jens Janssen (jayjay) wrote :

I'm the one who mostly wrote this tutorial ;-) but don't blame me. The Broadcom wl / STA driver is closed source so there is not much you can do about it. So blame Broadcom :-)

Normally Ubuntu uses most recent STA driver version. You can check that with
"strings `modinfo wl | grep filename | awk '{print $2}'` | grep Broadcom".

What happens if you execute "sudo iwconfig eth2 power off" ?

You can put the latter in /etc/rc.local before "exit 0" (run "gksudo gedit /etc/rc.local") to make it automatically available every startup.

Gruesse

That not your mistake, i buyed a cheap notebook. And thats the Punishment.
I don't blame you. sorry if it sounds so

Thats the output for the string
bash: strings /lib/modules/2.6.31-18-generic/updates/dkms/wl.ko | grep Broadcom: No such file or directory

The second command bring this result

Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device eth2 ; No such device.

I looked at the tutorial page and I saw no mention of how to install the
broadcom sta driver. I'm not a german speaker so I just might have missed
it. In any case, the broadcom sta driver bundled in the ubuntu repositories
should work perfectly. The package you need to install for ubuntu 9.10 is
bcmwl-kernel-source <http://packages.ubuntu.com/lucid/bcmwl-kernel-source>.
Its the source package containing the broadcom sta driver. When installed,
dkms will configure it and voila, after a reboot, wireless works.

Good luck

On Thu, Jan 28, 2010 at 12:04 PM, Jens Janssen <email address hidden> wrote:

> I'm the one who mostly wrote this tutorial ;-) but don't blame me. The
> Broadcom wl / STA driver is closed source so there is not much you can
> do about it. So blame Broadcom :-)
>
> Normally Ubuntu uses most recent STA driver version. You can check that
> with
> "strings `modinfo wl | grep filename | awk '{print $2}'` | grep Broadcom".
>
> What happens if you execute "sudo iwconfig eth2 power off" ?
>
> You can put the latter in /etc/rc.local before "exit 0" (run "gksudo
> gedit /etc/rc.local") to make it automatically available every startup.
>
> Gruesse
>
> --
> Broadcom STA/wl driver causes random kernel panics
> https://bugs.launchpad.net/bugs/292450
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
I dare do all that may become a man; Who dares do more is none. -- Macbeth

What man is a man who does not make the world a better place? -- Balian of
Ibelin (Kingdom of Heaven[2006])

I put no stock in Religion. By the word of religion, I've seen the lunacy of
fanatics of every denomination be called the "Will of God". By what you
decide to do every day, you will be a good man or not. -- Hospitaller
(Kingdom of Heaven[2006])

People Shouldn't Be Afraid of Their Government, Governments' Should Be
Afraid of Their People.

To all the hackers around the world -- put on your Batman masks when you
fight. -- Anonymous

Jens Janssen (jayjay) wrote :

First: "sudo iwconfig" gives you the right device name. So replace "eth2" with correct device name.

Second: Where is your kernel module wl.ko?

@killeroid:
Jockey is your partner installing closed source drivers.
System -> Administration -> Hardware Drivers.... then select the driver.
Sure you can also manual install bcmwl-kernel-source.

Killeroid (killeroid) wrote :

@Jens Jockey is kinda buggy. On three different laptops with the same B4311 card, joeky would recognize the card and offer me the option of install the broadcom sta but the installation never went well. It would tell me that the sta driver was installed and then when i'd restart, id find that the driver wasnt installed. it became too much of a hassle so I've just resorted to the easier task of just installing the driver package.

Jens Janssen (jayjay) wrote :

@Killeroid: Is there any bug report due to this problem? Never had this problem with jockey.

Killeroid (killeroid) wrote :

@Jens I am ashamed to say I never filed any bug reports. I recall someone mentioning a similar sounding bug report on irc however. ill look for it and post a link if i can find it.

@Jens
where i fount the module wl.ko? How can i install/remove it.

If i use Hardware Driver to install the STA Driver the system hangs.

I had also an ubuntuusers-Forum-Entry http://forum.ubuntuusers.de/topic/w-lan-taste-aktivieren

Whats wrong with it?

mcdjork (mcdjork) wrote :

If I'm not mistaken, this is an issue with the Broadcom STA driver, specific to 64 bit operating systems. I have experienced identical, random kernel attacks in Ubuntu 9.04, 9.10 and 10.4 Alpha2 as well as in Fedora 12 and openSuse 11.2. If I use the b43 fwcutter extractor, the panics do not occur. The drawback I have seen with the b43 tool however, is that it doesn't support as many wireless encryption types--for example, I cannot connect to a PEAP network at my office.

It may be a completely different issue, but wireless in my Windows 7 64 bit OS even becomes unresponsive, requiring a complete reboot.

Since the Broadcom STA driver is not open source, I don't believe there is anything the Ubuntu team can do about this problem. I encourage people to submit this issue to the Broadcom team by emailing <email address hidden>. I'd like to see this issue resolved!

Caleb K (ckemere) wrote :

I'm running 9.10 (Karmic 32-bit, kernel 2.6.31-20-generic-pae). My experience of this problem is that removing and reloading the STA module (wl) reliable yields kernel panics within 10 s - 5 minutes. This appears only to happen if the driver has been used (i.e., I've connected to a network) prior to removing the module. Both the 5.10.91.9 version of the module (from jockey) and the 5.60.xxx module available on the broadcom website have this problem. It's quite annoying because of another bug, where if I suspend at home, I can't resume and then connect to another network somewhere else without reloading the module / rebooting.

I can confirm this - when waking up from suspension, say at the office, the wireless still attempts to connect to the home network, which is not present at the office, and reloading the wl module causes kernel panic, forcing me to reboot. I am running 9.10 Karmic on a Dell Vostro V13.

I am using the wl driver with Ubuntu 10.04 and I can confirm the random crashes and that they are related to the wireless card. With the wireless card on, I get 2-5 crashes per day. When i turn it off and run off of the wired NIC. I have never had a crash. I can reproduce the crash fairly quickly when running on the wireless card and bringing up a virtual box machine. VirtualBox runs flawless on the wired NIC.

mcdjork (mcdjork) wrote :

I have completely resolved (or worked around) this problem on my computer. I was having major problems with freezing and kernel panics. I was also losing my connection and not able to connect to certain wireless networks because of their encryption type. I tried switching between STA and bwfcutter multiple times.

This might be a little too dramatic of a solution for some, but I was able to completely resolve the problem by simply replacing the wireless card in my laptop.The Intel 3945ABG works natively with Linux, and you can find it for about $10 online.

With it, there is no need to install third party drivers! Ubuntu works on the first boot, no problems. It has saved me so many headaches with Fedora, openSuse, Mandriva, Arch, Gentoo, etc etc. Since switching, I haven't had a single kernel panic, and it's been several months.

I know this isn't a solution to the problem--I just thought I'd throw the option out there to those who are interested.

This is the model I got:
3945ABG Intel PRO/Wireless 3945ABG 802.11a/b/g Mini-PCI Express
http://www.ayagroup.com/product.php?productid=17632&cat=0&page=1

mikewhatever (mikewhatever) wrote :

This bug is still present in Lucid Lynx. Unfortunately, I can neither get a new one nor replace the card old easily. Something like Intel PRO/Wireless 3945ABG costs about 65$ here, and I'll have to take the netbook apart to replace the card.

Emilio Merino (emerino55) wrote :

broadcom STA syas is cuurently OK but it dont works, please help me. I have a mini Dell Intell Atom N series, 12 inches.
thanks a lot

Emilio, it is probably better to look in Ubuntu Forums than add comments to
this bug.

Also, you need to give more detail than just "it doesn't work."

How do you know it doesn't work? What is the specific action you are trying
now that fails?
The more specific you can be, the better the help will be.

On 19 July 2012 16:20, Emilio Merino <email address hidden> wrote:

> broadcom STA syas is cuurently OK but it dont works, please help me. I
> have a mini Dell Intell Atom N series, 12 inches.
> thanks a lot
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (304926).
> https://bugs.launchpad.net/bugs/292450
>
> Title:
> Broadcom STA/wl driver causes random kernel panics
>
> Status in “linux-restricted-modules” package in Ubuntu:
> Fix Released
> Status in “linux-restricted-modules” source package in Hardy:
> Fix Released
> Status in “linux-restricted-modules” source package in Intrepid:
> Fix Released
> Status in “linux-restricted-modules” source package in Jaunty:
> Fix Released
>
> Bug description:
> SRU justification:
>
> Impact: The current broadcom driver (wl.ko) seems to have several
> issues during operation. Reported have been random crashes between 5 a
> day to only 1 every 4 days.
>
> Fix: The latest driver from broadcom had positive feedback on Jaunty and
> has been released there. This is the backport of that driver for intrepid.
> The same code is intended to get ported to Hardy LRM. This would sync up
> the Hardy codebase with the Intrepid and Jaunty layout. So this would yield
> bug fixes and ease maintenance.
>
> Changes are local to wl.ko only.
>
> Testcase: Generic usage will sometimes cause panics.
>
> ---
>
> The new wl driver(Broadcom STA) randomly causes my Dell Inspiron E1505
> to experience kernel panics. I haven't been able to get a picture of
> the kernel panic though. The kernel panic happens randomly, sometimes
> even during bootup.
>
> The reason why I know its from the wl driver is because, I was using
> the b43 driver back on hardy. When the new broadcom driver was
> released, I manually compiled it and installed it. The driver kept
> randomly causing kernel panics on my system. When I blacklisted the
> driver and reverted back to b43, no more kernel panics. I wiped my
> disk down and installed intrepid and set my system to use the new wl
> driver again. The kernel panics started all over again. When I changed
> to the b43 driver, the kernel panics disappeared.
>
> The system can sometimes run for 4/5 days before experiencing a kernel
> panic and at other times, I can get about 5 kernel panics in a day. I
> googled around and found a few people on both the ubuntu and debian
> forums having the same problem with different systems and different
> broadcom cards but same driver.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/linux-restricted-modules/+bug/292450/+subscriptions
>

While starting from Ubuntu 11.10 to 12.10 wl drivers worked like a charm on my broadcom 4313, it seems that the drivers in ubuntu 13.04 started giving this problem to me. The version I'm using is a fresh install of ubuntu 13.04 amd64 plus all the updates as of today and the home folder restored from an ubuntu 12.10 backup, but I don't think it could make the difference as the freeze happens also when logged as a "clean" user.
I'm pretty sure this problem is cause of broadcom drivers (or broadcom related network stuff) because as soon as I blacklisted wl, mac80211 and cfg80211 modules and plugged in an usb ralink wifi card it stopped to freeze.
Can someone confirm this?

Kimr1508 (kimr1508) wrote :

Yes. I also experience kernel panics.

The issue started after upgrading Xubuntu from 12.10 to 13.04.

But it only happens with kernel 3.8. If I boot 13.04 with kernel 3.5 the issue does not occur.

tags: added: raring

Does anybody know how to reopen this bug?

Kimr1508 (kimr1508) wrote :

I just want to an some extra comments to my #131 comment.

On my machine with broadcom 4312 wifi the kernel panic can be reproduced quite easily, if I start Transmission and add a couple of torrents. After 2 - 15 minutes the panic normally happens.

If I do ordinary web browsing with Firefox, I do not experience any problems, so maybe the issue is related to network load.

With kernel 3.5 there are no issues at all.

As this bug has been marked as fixed and I cannot reopen it, I opened another similar to this.
https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/1134389
For all those still affected by this bug they can subscribe also to that and maybe some developer will pay more attention to us

Displaying first 40 and last 40 comments. View all 134 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers