Comment 36 for bug 276445

alejaaandro (alejaaandro) wrote :

cheers everybody.. i have good news...

after setting up everything with the new modem, i haven't had a kernel panic the whole day (some serious traffic has been going on like p2p more than 500 kBs, media streaming etc).. i sure hope it's not just luck..

i did 2 things..

1) changed my wireless router to "802.11b only" instead of "b and g"... i 'm not sure that this is what made it work 'cause i think i had already tried that before.. strange thing though: iwconfig gives me

ath0 IEEE 802.11g

but in case you cant' do that,
2) the second thing i tried is enabling the ath9k driver module.. apparently in 8.10 it's already in there (at least that's what i think) so just do

sudo modprobe ath9k

and then

lsmod |grep ath

and check it's enabled.. notice that you'll have to do that again if you restart, but if it actually works you can just add it as a startup command in system->preferences->sessions

i'd love to hear that it worked for you too