wl vs. b43 are not properly configured

Bug #263097 reported by ullix on 2008-08-30
40
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Undecided
Martin Pitt
Hardy
Undecided
Martin Pitt
Intrepid
Undecided
Martin Pitt
linux-restricted-modules (Ubuntu)
Medium
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Medium
Unassigned

Bug Description

Fresh install of kubuntu Intrepid alpha 5, then full update. Attempt detection of wlan hardware with Hardware Drivers Manager, which finds and activates "wl", and also proposes fwcutter usage to get "Broadcom B43 wireless driver". This downloads the firmware without complaint, and finally requests reboot. After reboot the B43 driver is still not checked. This procedure repeats, but no check of the B43 results, and wlan does not see any networks.

On same computer using kubuntu 8.04 all works fine

SRU justification: The current hardy-proposed kernel (2.6.24-21) now contains the wl driver as well, and we need a GUI friendly way to configure it (relative to b43). "wl" was not shipped yet with hardy final (it didn't even exist at that time), thus we need to supply the corresponding handler in a jockey SRU as well.

Test case: On a system with a Broadcom wireless card, open jockey. You should see the "B43" or the "Broadcom STA" driver, or both if your card is supported by both. Only one should be displayed as active/in use at a time. Try to enable the other one, reboot, and make sure your wifi works.

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in linux.

Please include the output of the command 'uname -a' in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command 'dmesg > dmesg.log' and attach the resulting file 'dmesg.log' to this bug report.
3. Please run the command 'sudo lspci -vvnn > lspci-vvnn.log' and attach the resulting file 'lspci-vvnn.log' to this bug report.
For your reference, the full description of procedures for kernel-related bug reports is available at https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks in advance!

Correction: original install was alpha4 (not 5)

However, now after the release of alpha 5 the system had been fully upgraded. The behaviour as described above has NOT changed.

uname -a: Linux cy810 2.6.27-2-generic #1 SMP Thu Aug 28 17:20:02 UTC 2008 i686 GNU/Linux

dmesg and lspci attached; but note following text :

calling "Hardware drivers" shows:
Firmware: Broadcom B43 wireless driver ; Enabled is NOT checked; Status is "in use"
Device driver: wl ; Enabled is checked; Status is "in use"
After clicking to enable firmware, a download appears to be initiated (it had asked for admin password), and it ends without any message. Firmware Status then says " need to restart". But very same situation after restart. The before-* files were taken at this stage.

Then went to http://linuxwireless.org/en/users/Drivers/b43#devicefirmware (as shown in dmesg) and executed the command found on this site: sudo /usr/share/b43-fwcutter/install_bcm43xx_firmware.sh
This did result in a download, and the directories /lib/firmware/b43 and /lib/firmware/b43legacy were created. The Firmware enabled status received a checkmark. The after-* files were created after another reboot.

It seems that the firmware files were actually never downloaded?

I am now able to see the networks in my neighborhood as I would expect, but I still cannot connect. Neither manual nor automatic connection works. Cold reboot also does not help. Ethernet connection works flawlessly.

Now what?

ullix (ullix) wrote :
ullix (ullix) wrote :
ullix (ullix) wrote :
Changed in jockey:
status: New → Confirmed
Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged
ullix (ullix) wrote :

upgrading to next kernel version: same as before. wlans are visible, but I can't connect to it.

uname -a: Linux cy810 2.6.27-3-generic #1 SMP Wed Sep 10 16:02:00 UTC 2008 i686 GNU/Linux

In fact Tim, Mario, and me are just figuring this out for the hardy-proposed version (whose kernel ships wl as well). I have an almost perfect hardy jockey now, will clean that up and adopt it for intrepid once it works.

Changed in jockey:
assignee: nobody → pitti
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

The driver side is ok now (not really optimal, since they constantly fight each other, and if you have b44, all bets are off for using wl), but since wl is not free software, we can't do a lot about it besides bugging broadcom.

Changed in linux:
status: New → Invalid
Martin Pitt (pitti) wrote :

Test package for hardy available at http://people.ubuntu.com/~pitti/tmp/jockey-wl/

Changed in jockey:
assignee: nobody → pitti
status: New → Fix Committed
Changed in linux-restricted-modules:
status: Triaged → Invalid
Martin Pitt (pitti) on 2008-09-25
Changed in jockey:
milestone: none → ubuntu-8.10
ullix (ullix) wrote :

After updating (now: uname -a: Linux cy810 2.6.27-4-generic #1 SMP Wed Sep 24 01:30:51 UTC 2008 i686 GNU/Linux) I can now connect to the wlan; it actually seems to be doing it faster than before. But the script may not be complete:

first, the wlan access key is asked every time I start the computer, although KWallet is available. It does not even ask about storing the key. This is a bit cumbersome.

second, I now have two icons in the system tray, the old one from KNetworkmanager, and the new one from the NetworkManagerApplet. Did the script forget to delete the old one, or is KNetworkmanager still needed? As before I can see all wlan networks in KNetworkmanager, but cannot connect to them. Only the applet allows connections. Once it is connected, the KNetworkmanager icon changes to the staircase icon showing the signal strength, just as the applet icon does. A bit confusing.

Lastly, since in fiddling with this I had manually initiated some downloads of drivers and such, I cannot tell if the script does the whole thing properly. If you like, I can try it out if you tell me how to reset this thing to start condition.

costales (costales) wrote :

Confirm in Intrepid Ibex, laptop nx 7300.

Martin Pitt (pitti) wrote :

Test packages for hardy:

  http://people.ubuntu.com/~pitti/tmp/jockey-wl/

I asked Mario and Tim for testing. If all goes well, I'll upload these to hardy-proposed.

Changed in jockey:
status: Fix Committed → In Progress
Martin Pitt (pitti) wrote :

 jockey (0.3.3-0ubuntu8.1) hardy-proposed; urgency=low
 .
   Fix configuration of "b43" vs. the new "wl" wifi driver. (LP: #263097)
 .
   * jockey/oslib.py: Check all /etc/modprobe.d/blacklist* files in
     module_blacklisted(). The new Broadcom wl driver generates
     blacklist-bcm43, which Jockey needs to evaluate in order to handle the
     enabling/disabling properly. (Cherrypicked from trunk, r296)
   * tests/sandbox.py: Provide temporary module_blacklist_file in
     AllAvailOSLib, so that handlers which modify blacklists do not die with
     EPERM during tests. (Cherrypicked from trunk, r297)
   * Add data/handlers/broadcom_wl.py: Handler for the alternative Broadcom
     'wl' module. Enabling this will automatically blacklist b43 and bcm43xx.
   * data/handlers/b43.py: Remove the blacklist generated by enabling wl when
     enabling b43.
   * data/handlers/b43.py: Do not show the handler as "in use" if no firmware
     is present.
   * jockey/ui.py, jockey-{gtk,kde}: Cowboy ui_download_start() to take an
     alternative title for the progress window, so that we can abuse it for
     other progress dialogs.
   * broadcom_wl.py: Spawn a progress dialog while update-initramfs is running.

Uploaded to hardy-proposed. Sorry for the long list of changes; it's the minimum stuff to provide a reasonably user friendly and correct way to enable/disable wl/b43 in hardy. It has been extensively tested by Mario and Tim.

Martin Pitt (pitti) wrote :

Subscribed ubuntu-sru, I cannot ack my own upload, so Steve needs to do it.

Martin Pitt (pitti) wrote :

For the record, this is the debdiff.

description: updated
Martin Pitt (pitti) wrote :

Adapted the wl handler to intrepid now, too, and committed to bzr. Will upload after beta freeze.

If somebody already wants to try this:
  bzr get ubuntu-core-dev/jockey/ubuntu/ jockey-ubuntu
  cd jockey-ubuntu
  debuild -us -uc -b
  sudo dpkg -i ../*.deb

Changed in jockey:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5~beta1-0ubuntu2

---------------
jockey (0.5~beta1-0ubuntu2) intrepid; urgency=low

  * Merge some bug fixes from trunk:
    - ui.py: Fix "not installed" -> "not activated" string inconsistency.
      (LP: #274697)
    - Fix typos in German translation.
    - Add and use enabled/disabled/free icons from Kenneth Wimer.
    - Fix jockey-kde crash when no drivers are available. [Alberto]
    - Report indefinite progress if the handler does long non-package
      operations (such as rebuilding initramfs), instead of freezing the UI.
    - UI: Select first driver by default, and keep selection after
      enable/disable. (LP: #274699)
    - jockey-kde: Fix display of window text and subtext, and adapt it to
      driver changes. (LP: #274558)
    - Avoid flickering the progress bar dialog for very fast detect() calls.
    - jockey-kde: Fix indeterminate progress bar behaviour, and fix "Searching
      for drivers..." progress bar at startup.
    - kde/ManagerWindowKDE4.ui: Drop the expander next to the window heading,
      it prevented proper resizing. (LP: #274700)
    - Various test suite fixes.
  * data/handlers/b43.py: Do not show the driver as "in use" if the firmware
    is not installed.
  * Add data/handlers/broadcom_wl.py: Handler for the alternative Broadcom
    'wl' module. Enabling this will automatically blacklist b43 and bcm43xx.
    (LP: #263097)
  * data/handlers/b43.py: Remove blacklist-bcm43 on activation.
  * data/handlers/b43.py: Add (derived) handler for b43legacy. (LP: #247495)
  * data/handlers/b43.py: Actually call the firmware fetching script after the
    -fwcutter installation.

 -- Martin Pitt <email address hidden> Thu, 02 Oct 2008 20:44:09 +0200

Changed in jockey:
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in jockey:
status: In Progress → Fix Committed
Mario Limonciello (superm1) wrote :

I can confirm that the upload works as expected in the default case, but this *can't* enter -updates until bug 271191 is fixed too.

Mario Limonciello (superm1) wrote :

With the improvements to bug 271191, I can confirm it fully works now.

Martin Pitt (pitti) wrote :

Copied to hardy-updates, thanks for testing!

Changed in jockey:
status: Fix Committed → Fix Released
Dave Vree (hdave) wrote :

I am using the latest Intrepid on a laptop with a Broadcom BCM4328 and this still isn't working for me. In my case, B44 was being loaded (and thus ssd) prior to jockey attempting to utilize "wl". Therefore my wireless networking adapter (wlan0) never show up. I had to work around this problem by forcing the loading of wl prior to b44 and ssd -- thanks to the help of an expert in the forums.

http://ubuntuforums.org/showthread.php?t=959451

I am not sure if I should file a new bug.

Martin Pitt (pitti) wrote :

HDave,

right now this is actually on purpose. I was told that it isn't possible to load both ssd (and b44) and wl at the same time. So if you load wl first, and then b44, do both the wifi and the ethernet card actually work? If so, we should modify the handler accordingly; please file a new bug in this case.

Thank you!

costales (costales) wrote :

Not works for me :(
Updated yesterday to the last updates.
I put others bug about this, and was change the status as duplicate.
Best regards and thanks!

ullix (ullix) wrote :

For some time now the B43 wireless driver was working well. I noticed the alternative Broadcom STA driver and changed to it, and it is also working well. In fact the transfer speed judged by mythtv smoothness is consistently better (and it is showing 54Mb/s where previously on B43 I had only 1-6Mb/s, although I believe the real speed was higher).

I no longer see the option to change back to the B43 driver - was this intended? (And the wl driver is also no shown any more).

Overall, works well for me.

Martin Pitt (pitti) wrote :

ullix, this is not intended. You should see at least one of b43 and wl ("STA") in jockey, or both. Please file a separate bug about this one.

costales (costales) wrote :

Hi!
I reinstall b43-fwcutter, It's crash with exit error 1.
I restart in english, reinstall again, and It reinstalled fine.
I disable wl in "Hardware drivers" and enable only B43 and IT WORKS FINE!
I have got Wifi in Intrepid :D
Thanks very much!

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers