Comment 71 for bug 197209

Hi Bart,

on Sun Oct 26 2008, Crackh34d <bartmacco-AT-hotmail.com> wrote:

> Dear Dave, I also have a T60p and have used an early version of your
> script on Hardy, and it worked fine with fusion-icon.
>
> Today I installed the Intrepid RC, and suspend was working with the open
> source Radeon driver, but I get ´bars´ of screen corruption when
> resuming.

Did you report that bug to the ubuntu people?

> I installed the fglrx driver, so I had to use your scripts again.

Did you report the fact that it still needs hacks/workarounds to the
ubuntu people also?

> I did the following:
>
> - I downloaded the latest 00compiz and 00-compiz-stop.sh to my home directory
> - sudo chmod +x 00-compiz-stop.sh
> - sudo cp 00-compiz-stop.sh /etc/acpi/suspend.d/00-compiz-stop.sh
> - sudo cp 00compiz /etc/pm/sleep/00compiz
>
> Is this correct?

Not on Hardy.
My 00-compiz-stop.sh is in /etc/pm/config.d/
My 00compiz is in /etc/pm/sleep.d/

I can't speak for intrepid.

> With compiz active, I tried suspending, which worked fine. Upon resume I
> was prompted with the login-screen, which is more than the blank screen
> before! But the computer was not responding at all, I could only move my
> mouse. No keyboard input at all, and the cursor in the text field wasn´t
> blinking. CTRL-ALT-Fx didnt work either.
>
> After a hard reboot I tried the command metacity --replace before
> suspending, after which suspending/resuming worked like a charm (Except
> for the Atheros wifi, but that is another bug I have to file I guess :P)

Well, that's promising. I would try putting the scripts where I put
them.

> After another reboot I tried to suspend again with compiz active, but
> this time I didn't even get the login screen.
>
> I have not installed fusion-icon yet, that is the first thing I'm gonna
> try now.
>
> I would appreciate some more help with this, and maybe see if others
> have it too with Intrepid RC?

I probably can't go much further with this than I have already.
Although I will probably make a feeble attempt to get Intrepid to work
on my T60p, I am not going to sink a lot more time into getting Ubuntu
to work properly on a laptop, and the Ubuntu devs are not picking up my
workarounds and folding them into the distro. My Hardy suspend/resume
stopped working reliably again a few weeks ago, for unknown reasons.
I'm planning to switch to Macbook Pro as soon as the new 17" models come
out; I just can't waste any more of my life getting the thing to an
acceptable baseline working state.

Regards,

--
Dave Abrahams
BoostPro Computing
http://www.boostpro.com