cannot resume from suspend with nvidia-glx-new and compiz

Bug #144732 reported by Nick Barcet on 2007-09-25
36
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.24 (Ubuntu)
High
Unassigned

Bug Description

Environment:
- Gutsy with kernel 2.6.22-12.3,
- nvdia-glx-new 100.14.19,
- compiz 0.5.2+git20070918,
- video card Nvidia 8600M GT (Apple MacBookPro3.1)

Problem:
Resuming from suspend bring back corrupted X, machine only accessible through network. gdm restart allows to regain control.
Applying 'gconftool --set /apps/compiz/general/screen0/options/sync_to_vblank 0 --type bool' allows resume to work fine.

Michael Vogt (mvo) on 2007-09-25
Changed in compiz:
importance: Undecided → High
status: New → Confirmed

Hi. Just a "me too", here with a nVIDIA Quadro FX360M (Dell Precision M4300). Same problem, same resolution works perfectly. with "sync_to_vblank" off, I get my X back on resume ! Thanks for the tip.

lichtgestalt (lichtgestalt) wrote :

It's not just you. Came by to report bug and solution -just like yours.

pixl (mkschreder) wrote :

The 100.14.19 driver is crap. Use 9639 instead. I got a GF 7300 card and I experienced the same problems as you. Downgrading the driver solved it all. There is a very nice utility called Envy that automatically installs drivers for you.

Nick Barcet (nijaba) wrote :

pixl: that would certainly solve your view of the problem, certainly not the ones that require the newer driver because they have a newer nvidia card than you have.

Sitsofe Wheeler (sitsofe) wrote :

(Sounds like Bug #96240 and thus might be Bug #88152)

Changed in compiz:
status: Confirmed → Fix Committed
Michael Vogt (mvo) wrote :

compiz (1:0.6.0+git20071002-0ubuntu1) gutsy; urgency=low

  * new 0.6.0 release:
    - more focus stealing improvements
  * taken from git to include a fix that restacks windows
    on map (avoid problem that sometimes windows are put
    under the panel)
  * debian/compiz-gnome.gconf-defaults:
    - set sync_to_vblank to False to make suspend on nvidia working
      (LP: #144732)
    - set unredirected_fullscreen_windows to True to make compiz work
      better with games
    - move fade down the plugin loading list

 -- Michael Vogt <email address hidden> Tue, 02 Oct 2007 10:31:55 +0200

Changed in compiz:
status: Fix Committed → Fix Released
Chris Lord (cwiiis) wrote :

So to fix this bug that affects some nvidia users, you disabled the feature for all users...? Wouldn't it be better to add a script to set the setting to false on suspend and to reinstate its previous value on resume? Lack of vsync makes compiz useless for watching video, and now that it's the default, that seems to be a really silly thing to do...

Nick Barcet (nijaba) wrote :

Just updated to 0.6.0 and sync_to_vblank is still set to true on my nvidia machine.

Travis Watkins (amaranth) wrote :

If you've every changed the value locally our system-wide change cannot override that.

Nick Barcet (nijaba) wrote :

Yes I did change this, but to false, and it was reset to true after update.

Paulus (donmatteo) wrote :

This bug (probably in NVIDIA's drivers) is still present in Gutsy final, and affects people who upgrade from feisty, or used earlier versions of the compiz package, or manually set the "Sync to VBlank" option.

pauls (paulatgm) wrote :

For me this problem is not solved by either driver 9639 or 100.14.23 or compiz's sync_to_vblank on or off. I can only suspend one or two times, then the following suspend will not resume correctly or will reboot itself. The only way to get consistently successful suspend is by disabling compiz altogether. I have the G72 mobility GeForce Go 7300 video card.

For 7xxx cards, nvidia has admitted a regression from driver 9639 to 100.14.23 that causes freezing (this is different than the resume problem). So any 7xxx user should go to 9639 for gutsy. However, 9639 still has the out-of-memory black window bug.

Anyway, why does suspend work without compiz? Would it be possible to revise the scripts in /etc/acpi to disable compiz before suspend and then reenable after resume? Any volunteer to try?

And another 'me too' .

Doesn't seem to be compiz at fault, as I get the same result with any glx application running; can suspend once or twice, but then get a hard lock with a blank screen after a second or so of disk activity on resume the next time..

This is on a hp dv8333ea, which required acpi_osi=!Linux on the kernel command line, SAVE_VBE_STATE=false and POST_VIDEO=false in /etc/default/acpi-support to get this far, without these changes results in a hard lock on resume every time.

Okay, probably it's not compiz' fault.
But disabling VSync is not a fix as it makes the computer useless for watching videos, as written above. VSync should be on per default IMHO, and this issue should be fixed.

Travis Watkins (amaranth) wrote :

The problem is GLX_SGI_video_sync is (seemingly) completely broken after resume from suspend with nvidia.

This bug is still here:
1. The known workaround breaks vsync under compiz, and hence makes tearing appear during normal usable, specially making watching videos impossible.
2. Switching users (or going from X to a text console and back) triggers it too.
3. Disabling compiz's sync to vblank, going out of X and back and re-enabling it works fine, but it's extremely annoying, forget-prone and not a solution.

Newer versions of nvidia driver and compiz than those available on Gutsy exist in next ubuntu; maybe those fix it?

I can't upgrade the machine where this problem does happen (It's not my computer, but the desktop of a non-tech-savvy user that I do mantain) to try it, but at least on the nvidia part it's a serious problem if newest drivers (which might widen hardware compatibility and fix bugs) aren't available in Gutsy.

See https://wiki.ubuntu.com/UpToDateAtiNvidiaDrivers?highlight=%28nvidia%29

Changed in compiz:
status: Fix Released → Confirmed
Travis Watkins (amaranth) wrote :

Well, if you're going to reopen it...reassigning to linux-restricted-modules.

Timo Aaltonen (tjaalton) wrote :

Works just fine in Hardy with 169.09 with my 8600GT. There will be no updates to Gutsy though.

Changed in linux-restricted-modules-2.6.24:
status: Confirmed → Fix Released

I fail to see any reason why users of the stable distribution should suffer an old and known unstable version of the nvidia-drivers.

See https://wiki.ubuntu.com/UpToDateAtiNvidiaDrivers?highlight=%28nvidia%29

Please update.

Timo Aaltonen (tjaalton) wrote :

envyNG will be integrated in hardy, so users can use it to update the drivers. There will be no backported restricted-modules -packages though.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers