Comment 6 for bug 121653

After further testing I narrowed it down to the fglrx module, but even using the latest drivers (8.38.6) it gives me problems under 2.6.22 but works flawlessly under 2.6.20.