Comment 240 for bug 121653

Suspend is working fine on Gusty and Hardy, but not resume. I always end up with a black screen and some white and orange "artefact" at the top left and bottom right of the screen when the computer resume and I can't do anything, except hitting the power switch.

I just upgraded to Hardy alpha 3 (from Gusty) two days ago to see if it worked better (and test it by the way), but I end up at the same place with the same black screen every time. I tested it with kernels 2.6.24-5, 2.6.24-4 and gusty kernel (2.6.22-13 I think). I also tried every possible combinaison in acpi-support...

I have and ATI Radeon X1600 card. Direct rendering is ok and Compiz isn't activated (Something related to another bug...)

malou@Ubuntu:~$ glxinfo | grep "direct rendering"
direct rendering: Yes

malou@Ubuntu:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1600 Series
OpenGL version string: 2.1.7276 Release

malou@Ubuntu:~$ uname -r
2.6.24-5-generic

I attached my acpi-support file and my xorg.conf file.