Comment 234 for bug 121653

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-restricted-modules-2.6.24 - 2.6.24.6-4.13

---------------
linux-restricted-modules-2.6.24 (2.6.24.6-4.13) hardy; urgency=low

  [ Timo Aaltonen ]
  * nvidia: Update to 169.09
    - Fixed a problem causing the fan on some GPUs to always run
      at full speed. (LP: #184914)
    - Fixed a bug that caused the X driver to crash if the X.Org
      GLX extension module was loaded intead of NVIDIA's.
    - Improved the X driver's awareness of the current notebook
      docking status.
    - Fixed brightness control on HP Compaq notebooks.
    - Fixed a bug in the Linux/i2c algorithm driver implementation
      that prevented core transfer types from succeeding.
  * fglrx: Update to 8-01 (LP: #177829, #148345)
    - Corruption will no longer be noticed in the lower right corner
      of the display or on the mouse pointer after the system is
      running for a long period of time. (LP: #106148)
    - Connecting a display device that supports 1680x1050 to a system
      running Linux will no longer result in a maximum display resolution
      of 1280x1024 only being available.
    - Custom mode lines in xorg.conf will no longer be ignored by the
      fglrx driver.
    - Suspending to RAM or DISK on kernel version 2.6.23 or later no
      longer fails. (LP: #121653)
  * nvidia/nvidia-glx-config: Remove, not needed anymore and only confuses
    people and breaks keyboard setups (LP: #152486)
  * control.stub.in: Add fglrx-amdcccle dummy package for easy transition
    from packages generated by the ATI installer.
  * fglrx-control:
    - Remove fireglcontrol*.desktop, and install amdcccle*.desktop from
      the extracted installer instead.
    - Install amdcccle in this package, not the driver.
    - Conflicts/Replaces xorg-driver-fglrx <= $previousversion.
  * fglrx.xsession: Obsolete by now, removed.
  * Drop obsolete build-dependencies: libxxf86misc-dev, libxtst-dev,
    libxxf86vm-dev, libxinerama-dev, libstdc++5, libqt-mt-dev.

  [ Johan Kiviniemi ]
  * nvidia_supported: New version to support the latest NVIDIA
    release. (LP: #182237)

 -- Timo Aaltonen <email address hidden> Wed, 23 Jan 2008 11:41:54 +0200