Comment 229 for bug 121653

SixedUp (disposable01) wrote :

IBM Thinkpad T60p, with an ATI Mobility FireGL V5200, running with a fresh install of Gutsy 7.10 (Kernel 2.6.22-14-generic), to which I added nothing but the 8.01 fglrx using the manual install method from wiki.cchtml.com.

Despite trying most combinations of the previously recommended changes to /etc/default/acpi-support, both with and without compositing enabled, I still can't get the machine to even suspend (let alone resume). System ends up with the screen blank, the suspend LED blinking (it never gets to solid-on), but with the screen backlight running and the fan on. At that point the system is unresponsive and needs to be power-cycled. Looking at the release notes for 8.01, it looks like suspend/resume with the FireGL 5200 requires a 2.6.23 or higher kernel.

Are there any pre-canned 2.6.23+ kernels available for Gutsy (backported or otherwise), or am I going to be faced with compiling a custom kernel?