ltmodem use hangs 686 kernel

Bug #41991 reported by Eric Johnson on 2006-04-29
60
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.15 (Ubuntu)
High
Unassigned
wvdial (Ubuntu)
Medium
Unassigned

Bug Description

Lucent winmodem (ltmodem) modules load properly, and the modem works with i386 kernel.

/vmlinuz-2.6.15-21-386 root=/dev/hda3 ro quiet splash

Booting with i686, though, and dialling with the same modem settings, causes wvdial to report "Cannot set information for serial port" and the machine locks up.

/vmlinuz-2.6.15-21-686 root=/dev/hda3 ro quiet splash

Adding pci=routeirq and lapic boot options make no difference.

This is a regression from Hoary, where the modem worked perfectly (though it never did work in Breezy).

I have seen this behavior on two laptops: an IBM Thinkpad X22 and a Dell Inspiron 5000.

Gabriel Patiño (gepatino) wrote :

The same happened to me, runing an old Toshiba Portege 7140.

I've managed to compile the lucent modules on breezy, if I have some time, I'll try to compile it by hand and ask someone how to put it inside linux-restricted-modules-i686

Gabriel Patiño (gepatino) wrote :

In the README file for the ltmodem module sources, is mentioned that SMP support could be unsupported on some machines, and pakage linux-image-2.6.15-22-686 installs a SMP kernel.

Maybe the problem is related to this, since I'm testing on a single procesor machine, this could be the reason.

I don't have a multi CPU machine to test if ltmodem modules work, so I give up the recompiling tests and go back to linux-image-386, which works great with ltmodem.

Norbert Fischer (nobart) wrote :

Same problem here: Even scanning the ltmodem within kppp or wvdialconf hangs my computer.

When I have time I try the i386-kernel.

Simon Law (sfllaw) wrote :

This is confirmed by various reports in bug 46885.

Changed in linux-restricted-modules-2.6.15:
status: Unconfirmed → Confirmed
assignee: nobody → ubuntu-kernel-team
Ben Collins (ben-collins) wrote :

Without a trace or a way to reproduce this, I'm a little unable to do anything. Can anyone try some of the info here?

https://wiki.ubuntu.com/DebuggingSystemCrash

Eric Johnson (eric-el-studio) wrote :

None of those debugging hints work.

Once the system is hung, pressing Alt+SysRq+1 followed by Alt+SysRq+t shows nothing on the console, nor anything in either /var/log/messages or kern.log.

The machine is locked up cold.

Other suggestions?

Norbert Fischer (nobart) wrote :

I tried many things, but results are already standing above:

  * using a i386-kernel, the modem is found and can be configured. wvdialconf gives some AT-commands and finds the right settings

  * using a i686-kernel: machine locks up when using wvdialconf. Alt+SysRq+..-commands do not work, nothing is reported into any log (looked into messages, kern.log, syslog, debug)

Computer: Gericom 1st Supersonic 1000MHz

Are there other debugging steps available?

Gabriel Patiño (gepatino) wrote :

Does anyone tried it in a multi-cpu machine?

I've read in the ltmodem documentation that there could be issues with SMP enabled kernels, and i686 has smp support.

Since I don't a multi-processor machine, I quit this bug. There's nothing elso I can do.

See you.

KarlGoetz (kgoetz) wrote :

On the Dapper final install there is no 686 module for the LT winmodems.
Could this cause lockups if the modem config stuff thinks /dev/modem will be there pointing to /dev/ttyLTM0 when it doesnt exist?
kk

Ivan Jekic (the-edge) wrote :

I can also confirm this, though I cannot use ltmodem found in restricted package (they don't work - and never did!). I must compile ltmodem-alk8 drivers myself. Even though they are compiled on Generic kernel of Edgy, they cause the machine to hang the moment I try the dialing.

I noticed there's no ltmodem supported in restricted packages for k7/686/generic kernels.... makes me wonder?!

York Rapp (york-rapp) wrote :

There is no 686 module for the LT winmodems on a Dapper final installation (using the 2.6.15-28-686 image). So I'd compile (without any errors) the current martian driver and have the same problem with wvdial.

Therefore I think it's not a ltmodem-module problem only (also concerns the martian-module).

Any solutions.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Thank you for posting this bug.

Is this an issue in Maverick?

Changed in wvdial (Ubuntu):
status: New → Incomplete
Changed in linux-restricted-modules-2.6.15 (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for wvdial (Ubuntu) because there has been no activity for 60 days.]

Changed in wvdial (Ubuntu):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for linux-restricted-modules-2.6.15 (Ubuntu) because there has been no activity for 60 days.]

Changed in linux-restricted-modules-2.6.15 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers