Ubuntu

Comment 14 for bug 37773

i think my notebook's hangups are not related to madwifi, because i compiled madwifi-ng anc commented out the contents of /etc/udev/rules.d/25-iftab.rules, but the freeze reappeared. I think this is an hal problem or something similar. Before the hangup dmesg shows:

[ 69.878357] pnp: Device 00:0d cannot be configured because it is in use.
[ 69.878603] pnp: Device 00:0d cannot be configured because it is in use.

When the card was plugged dmesg showed:

[ 61.994316] wlan: 0.8.4.2 (svn 2006-05-16)
[ 62.195863] ath_hal: module license 'Proprietary' taints kernel.
[ 62.199956] ath_hal: 0.9.16.16 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
[ 62.349803] wlan: 0.8.4.2 (svn 1560)
[ 62.366708] ath_rate_sample: 1.2 (svn 1560)
[ 62.455328] ath_pci: 0.9.4.5 (svn 1560)
[ 62.456609] PCI: Enabling device 0000:06:00.0 (0000 -> 0002)
[ 62.917167] wifi0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
[ 62.917194] wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
[ 62.917207] wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
[ 62.917235] wifi0: turboA rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
[ 62.917255] wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
[ 62.917274] wifi0: H/W encryption support: WEP AES AES_CCM TKIP
[ 62.917309] wifi0: mac 5.9 phy 4.3 radio 3.6
[ 62.917327] wifi0: Use hw queue 1 for WME_AC_BE traffic
[ 62.917333] wifi0: Use hw queue 0 for WME_AC_BK traffic
[ 62.917339] wifi0: Use hw queue 2 for WME_AC_VI traffic
[ 62.917346] wifi0: Use hw queue 3 for WME_AC_VO traffic
[ 62.917352] wifi0: Use hw queue 8 for CAB traffic
[ 62.917358] wifi0: Use hw queue 9 for beacons
[ 62.963747] wifi0: Atheros 5212: mem=0x16000000, irq=11

(I can't live without wifi :-( ewoking wired is like a prison...)