Load average inexplicably high with 5.0 kernel on rpi

Bug #1825235 reported by Paul Larson
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux-raspi2 (Ubuntu)
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

Linux ubuntu 5.0.0-1006-raspi2 #6-Ubuntu SMP Thu Apr 11 18:04:26 UTC 2019 aarch64 aarch64 aarch64 GNU/Linux

I've seen this on rpi2, as well as rpi3 with both armhf and arm64 using the disco release candidate.
After booting, the load average stays quite high, typically over 4.0. This persists, even if I leave it idle for several hours:
ubuntu@ubuntu:~$ w
 19:44:05 up 2:22, 1 user, load average: 4.16, 4.03, 4.01

/proc/loadavg is consistent with these numbers. But when I check top, there are no obvious culprits hogging the cpu or anything. Typically everything looks to be <1% cpu usage, with top being the biggest cpu hog at about 2%. The system doesn't seem too slow (for a pi), but it's unusual to see such high numbers.

Nothing seems to be swapping:

ubuntu@ubuntu:~$ free -m
              total used free shared buff/cache available
Mem: 908 173 422 6 312 707
Swap: 0 0 0

ubuntu@ubuntu:~$ iostat
Linux 5.0.0-1006-raspi2 (ubuntu) 04/17/19 _aarch64_ (4 CPU)

avg-cpu: %user %nice %system %iowait %steal %idle
           1.64 0.15 1.57 2.06 0.00 94.57

Device tps kB_read/s kB_wrtn/s kB_read kB_wrtn
loop0 0.08 0.50 0.00 354 0
loop1 2.56 3.98 0.00 2805 0
loop2 0.01 0.01 0.00 4 0
mmcblk0 12.70 367.40 705.16 258830 496785

ubuntu@ubuntu:~$ vmstat 1
procs -----------memory---------- ---swap-- -----io---- -system-- ------cpu-----
 r b swpd free buff cache si so bi bo in cs us sy id wa st
 0 0 0 514540 18004 224072 0 0 97 182 2564 76 2 2 94 2 0
 0 0 0 514512 18004 224136 0 0 0 2012 10136 142 0 0 94 5 0
 0 0 0 514512 18004 224136 0 0 0 0 10117 106 0 0 100 0 0
 0 0 0 514512 18004 224136 0 0 0 0 10121 98 0 0 100 0 0
 0 0 0 514512 18012 224128 0 0 0 2028 10129 141 0 0 93 7 0
 0 0 0 514512 18012 224136 0 0 0 0 10149 135 0 0 100 0 0
 0 0 0 514512 18012 224136 0 0 0 0 10108 97 0 0 100 0 0
 0 0 0 514512 18012 224136 0 0 0 2012 10125 126 0 0 95 5 0
 0 0 0 514512 18012 224136 0 0 0 0 10117 101 0 0 100 0 0
 0 1 0 514512 18012 224136 0 0 0 2012 10109 104 0 0 98 2 0
 0 0 0 514512 18020 224128 0 0 0 12 10139 150 0 0 96 4 0
 0 0 0 514512 18020 224128 0 0 0 0 10108 90 0 0 100 0 0

Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1825235

tags: added: iso-testing
Paolo Pisati (p-pisati)
Changed in linux-raspi2 (Ubuntu):
status: New → Confirmed
Revision history for this message
Paolo Pisati (p-pisati) wrote :

I can reproduce the bug on a fresh installation of Disco/armhf rpi3.

Moreover, the bug appears to be kernel in-kernel - by installing the Disco kernel on a Bionic image (that didn't show any abnormal load with its Bionic/armhf kernel), the bug appears there too.

The bug is reproducible as early as Ubuntu-raspi2-5.0.0-1002.2, and before that there's the Broadcom BSP, and the initial config sync wrt bcm2709_defconfig - bisecting the Broadcom BSP is a bit problematic, because removing patches, often, breaks the build.

Revision history for this message
Georgi Georgiev (chutz) wrote :
Changed in linux-raspi2 (Ubuntu Disco):
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (69.7 KiB)

This bug was fixed in the package linux-raspi2 - 5.0.0-1013.13

---------------
linux-raspi2 (5.0.0-1013.13) disco; urgency=medium

  * linux-raspi2: 5.0.0-1013.13 -proposed tracker (LP: #1834884)

  * [SRU][B/B-OEM/C/D/OEM-OSP1] Add RTL8822 wifi driver rtw88 (LP: #1831828)
    - raspi2: [Config] Add realtek wifi RTW88 support

  * AX88772A USB to Ethernet dongle doesn't work (LP: #1834114)
    - raspi2: [Config] Rename ASIX module

  * Load average inexplicably high with 5.0 kernel on rpi (LP: #1825235) //
    Refresh RaspberryPi BSP (LP: #1831219)
    - raspberrypi: remove the old RaspberryPi BSP
    - arm: partially revert 702b94bff3c50542a6e4ab9a4f4cef093262fe65
    - Revert "rtc: pcf8523: properly handle oscillator stop bit"
    - smsx95xx: fix crimes against truesize
    - smsc95xx: Experimental: Enable turbo_mode and packetsize=2560 by default
    - Allow mac address to be set in smsc95xx
    - Protect __release_resource against resources without parents
    - irq-bcm2836: Prevent spurious interrupts, and trap them early
    - irq-bcm2836: Avoid "Invalid trigger warning"
    - irqchip: bcm2835: Add FIQ support
    - irqchip: irq-bcm2835: Add 2836 FIQ support
    - spi: spidev: Completely disable the spidev warning
    - dmaengine: bcm2835: Load driver early and support legacy API
    - firmware: Updated mailbox header
    - rtc: Add SPI alias for pcf2123 driver
    - watchdog: bcm2835: Support setting reboot partition
    - reboot: Use power off rather than busy spinning when halt is requested
    - bcm: Make RASPBERRYPI_POWER depend on PM
    - Register the clocks early during the boot process, so that special/critical
      clocks can get enabled early on in the boot process avoiding the risk of
      disabling a clock, pll_divider or pll when a claiming driver fails to
      install propperly - maybe it needs to defer.
    - bcm2835-rng: Avoid initialising if already enabled
    - clk-bcm2835: Mark used PLLs and dividers CRITICAL
    - clk-bcm2835: Add claim-clocks property
    - clk-bcm2835: Read max core clock from firmware
    - clk: bcm2835: Mark GPIO clocks enabled at boot as critical.
    - sound: Demote deferral errors to INFO level
    - Update vfpmodule.c
    - i2c: bcm2835: Add debug support
    - mm: Remove the PFN busy warning
    - ASoC: Add prompt for ICS43432 codec
    - irqchip: irq-bcm2836: Remove regmap and syscon use
    - lan78xx: Enable LEDs and auto-negotiation
    - amba_pl011: Don't use DT aliases for numbering
    - amba_pl011: Round input clock up
    - amba_pl011: Insert mb() for correct FIFO handling
    - amba_pl011: Add cts-event-workaround DT property
    - pinctrl-bcm2835: Set base to 0 give expected gpio numbering
    - Main bcm2708/bcm2709 linux port
    - Add dwc_otg driver
    - bcm2708 framebuffer driver
    - fbdev: add FBIOCOPYAREA ioctl
    - Speed up console framebuffer imageblit function
    - dmaengine: Add support for BCM2708
    - MMC: added alternative MMC driver
    - Adding bcm2835-sdhost driver, and an overlay to enable it
    - vc_mem: Add vc_mem driver for querying firmware memory addresses
    - vcsm: VideoCore shared memory service for BCM2835
    - Add /dev/gpiomem device for roo...

Changed in linux-raspi2 (Ubuntu Disco):
status: Fix Committed → Fix Released
Changed in linux-raspi2 (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Georgi Georgiev (chutz) wrote :

Too bad that the fix mentioned in Comment #4 is now crashing my raspi2 on boot with a kernel panic :(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.