[Dell Inspiron 5737] brightness could not be controlled by the indicator applet "System settings -> Brightness and Lock"" but sysfs works

Bug #1250401 reported by Taihsiang Ho on 2013-11-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
Trusty
Medium
Edward Lin
Utopic
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Edward Lin
linux-lts-raring (Ubuntu)
Medium
Unassigned
Trusty
Undecided
Unassigned

Bug Description

Dell Inspiron 5737 (CID 201305-13636) with ubuntu 12.04.3

steps to reproduce the bug:
1. install 12.04.3 on this machine
2. update the system via update manager to make the system up-to-date
3. click the upper-right indicator to launch the "System settings -> Brightness and Lock" applet
4. try to adjust the brightness bar to control the brightness

expected result:
the brightness could be adjusted by the bar

actual result:
screen brightness has no response

--------------------------------------

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.8.0-33-generic 3.8.0-33.48~precise1
ProcVersionSignature: Ubuntu 3.8.0-33.48~precise1-generic 3.8.13.11
Uname: Linux 3.8.0-33-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version k3.8.0-33-generic.
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 1: PCH [HDA Intel PCH], device 0: ALC283 Analog [ALC283 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 1708 F.... pulseaudio
 /dev/snd/controlC0: ubuntu 1708 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'MID'/'HDA Intel MID at 0x90710000 irq 62'
   Mixer name : 'Intel Haswell HDMI'
   Components : 'HDA:80862807,80860101,00100000'
   Controls : 21
   Simple ctrls : 3
Card1.Amixer.info:
 Card hw:1 'PCH'/'HDA Intel PCH at 0x90714000 irq 63'
   Mixer name : 'Realtek ALC283'
   Components : 'HDA:10ec0283,102805ec,00100002'
   Controls : 16
   Simple ctrls : 7
Date: Tue Nov 12 05:49:09 2013
HibernationDevice: RESUME=UUID=d809501f-7daa-47a2-8299-1844cd4d75cc
InstallationMedia: Ubuntu 12.04.3 LTS "Precise Pangolin" - Release amd64 (20130820.1)
MachineType: Dell Inc. Inspiron 5737
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-33-generic root=UUID=fdac94e0-b7ee-402a-a160-6567b65501c6 ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-33-generic N/A
 linux-backports-modules-3.8.0-33-generic N/A
 linux-firmware 1.79.7
SourcePackage: linux-lts-raring
StagingDrivers: rts5139
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/30/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A05
dmi.board.name: 04X8RP
dmi.board.vendor: Dell Inc.
dmi.board.version: X01
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A05
dmi.modalias: dmi:bvnDellInc.:bvrA05:bd08/30/2013:svnDellInc.:pnInspiron5737:pvrA05:rvnDellInc.:rn04X8RP:rvrX01:cvnDellInc.:ct8:cvrA05:
dmi.product.name: Inspiron 5737
dmi.product.version: A05
dmi.sys.vendor: Dell Inc.

Taihsiang Ho (taihsiangho) wrote :
description: updated
tags: added: block-hwcert
removed: hwcert-block
tags: added: blocks-hwcert
removed: block-hwcert
Taihsiang Ho (taihsiangho) wrote :

This command works to change the brightness to be max
cat /sys/class/backlight/intel_backlight/max_brightness | sudo tee -a /sys/class/backlight/intel_backlight/brightnes

or adjust the brightness by a integer, for example, 400
echo <a-integer-for-example-400> | sudo tee -a /sys/class/backlight/intel_backlight/brightnes

Taihsiang Ho (taihsiangho) wrote :

the value returned from
    cat /sys/class/backlight/intel_backlight/actual_brightness
does not change together with the brightness slider

Taihsiang Ho (taihsiangho) wrote :

the value returned from
    cat /sys/class/backlight/acpi_video0/actual_brightness
does not change together with the brightness slider

The problem here is that the gsd-backlight-helper code used by the brightness applet prefers to always use 'acpi_video0' or whatever backlight device has type 'firmware'. This means that it will update /sys/class/backlight/acpi_video0/brightness, which does not work. Our test code will update the intel_backlight device, which does work but is meaningless because the OS doesn't use that same interface. Bottom line is that this is probably a firmware issue (but could possibly be a kernel issue). That's my $0.02

Changed in linux-lts-raring (Ubuntu):
status: New → Incomplete
status: Incomplete → New
Taihsiang Ho (taihsiangho) wrote :

command

 $ sudo -u root -i
 $ cat /sys/class/backlight/acpi_video0/actual_brightness; echo 3 >> /sys/class/backlight/acpi_video0/brightness; cat /sys/class/backlight/acpi_video0/actual_brightness

will dump

99
99

---

that is, before and after the echo, actual_brightness is the same

Daniel Manrique (roadmr) on 2014-01-17
Changed in linux-lts-raring (Ubuntu):
importance: Undecided → Medium
Taihsiang Ho (taihsiangho) wrote :

The bug is still there on 14.04

tags: added: trusty
Ara Pulido (ara) on 2014-06-02
Changed in linux-lts-raring (Ubuntu Trusty):
status: New → Invalid
tags: added: blocks-hwcert-enablement

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu Trusty):
status: New → Confirmed
Changed in linux (Ubuntu Trusty):
assignee: nobody → Edward Lin (airken)
Edward Lin (airken) wrote :

Tried following kernel parameters,
1. acpi_osi="!Windows 2012"
2. acpi_backlight=vendor
3. video.use_native_backlight=1
each of them can fix this bug.

Since upstream is going to change the default for video.use_native_backlight to 1,
this bug can be fixed in later release after the patch is merged.

ref: https://<email address hidden>/msg658581.html

Changed in linux (Ubuntu Trusty):
status: Confirmed → Triaged
Edward Lin (airken) wrote :

The patch mentioned in #9 is committed in upstream v3.16-rc1.
Need to cheery-pick it to trusty kernel.

Changed in linux (Ubuntu Trusty):
status: Triaged → Fix Committed
Edward Lin (airken) on 2014-06-20
Changed in linux (Ubuntu Trusty):
status: Fix Committed → In Progress
Edward Lin (airken) wrote :

Add Dell Inspiron 5737 to the the ACPI video detect blacklist.
http://marc.info/?l=linux-acpi&m=140325203002742&w=2

Edward Lin (airken) on 2014-06-24
Changed in linux (Ubuntu Trusty):
status: In Progress → Triaged
Edward Lin (airken) wrote :

Backlight works with the kernel mentioned in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1333638/comments/10.

I will submit a sauce patch for Dell Inspiron 5547/5447/5737 and Vostro 5470.

Edward Lin (airken) wrote :

Upstream accepts the patch mentioned in #11.
https://kernel.googlesource.com/pub/scm/linux/kernel/git/rafael/linux-pm/+/08a56226d84706d402372d891550e130ef5df9f0

And the bug for Vostro 5470 is set to invalid.
I will submit the sauce patch for Dell Inspiron 5547/5447 only.

Edward Lin (airken) wrote :

3.16-r5 will include the patch (comment #11)
http://marc.info/?l=linux-acpi&m=140502326708708&w=2

Changed in linux (Ubuntu Trusty):
status: Triaged → Fix Committed
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Edward Lin (airken) on 2014-08-21
tags: added: verification-done-trusty
removed: verification-needed-trusty
Launchpad Janitor (janitor) wrote :
Download full text (38.9 KiB)

This bug was fixed in the package linux - 3.13.0-35.62

---------------
linux (3.13.0-35.62) trusty; urgency=low

  [ Joseph Salisbury ]

  * Release Tracking Bug
    - LP: #1357148

  [ Brad Figg ]

  * Start new release

  [ dann frazier ]

  * SAUCE: (no-up) Fix build failure on arm64
    - LP: #1353657
  * [debian] Allow for package revisions condusive for branching

  [ David Henningsson ]

  * SAUCE: Call broadwell specific functions from the hda driver
    - LP: #1317865

  [ Edward Lin ]

  * SAUCE: (no-up) Add use native backlight quirk for Dell Inspiron
    5547/5447
    - LP: #1332437

  [ Imre Deak ]

  * SAUCE: drm/i915: move power domain init earlier during system resume
    - LP: #1353405

  [ Jani Nikula ]

  * SAUCE: drm/i915: use lane count and link rate from VBT as minimums for
    eDP
    - LP: #1338582
  * SAUCE: drm/i915/dp: force eDP lane count to max available lanes on BDW
    - LP: #1338582
  * SAUCE: drm/i915: provide interface for audio driver to query cdclk
    - LP: #1188091
  * SAUCE: drm/i915: demote opregion excessive timeout WARN_ONCE to
    DRM_INFO_ONCE
    - LP: #1351014

  [ Joseph Salisbury ]

  * [Config] updateconfigs after Linux 3.13.11.6 updates

  [ Luis Henriques ]

  * Revert "[Packaging] linux-udeb-flavour -- standardise on linux prefix"

  [ Ming Lei ]

  * Revert "SAUCE: (no-up) ata: Fix the dma state machine lockup for the
    IDENTIFY DEVICE PIO mode command."
    - LP: #1335645

  [ Paulo Zanoni ]

  * SAUCE: drm/i915: consider the source max DP lane count too
    - LP: #1338582

  [ Tim Gardner ]

  * [Config] CONFIG_GPIO_SYSFS=y
    - LP: #1342153
  * [Config] CONFIG_KEYS_DEBUG_PROC_KEYS=y
    - LP: #1344405
  * [Config] updateconfigs
  * [Config] CONFIG_SCSI_IPR_TRACE=y, CONFIG_SCSI_IPR_DUMP=y
    - LP: #1343109
  * [Config] CONFIG_CONTEXT_TRACKING_FORCE=n
    - LP: #1349028

  [ Timo Aaltonen ]

  * SAUCE: Fix a typo in hda i915_bdw support.
    - LP: #1343140

  [ Upstream Kernel Changes ]

  * Revert "net/mlx4_en: Fix bad use of dev_id"
    - LP: #1347012
  * Revert "ACPI / AC: Remove AC's proc directory."
    - LP: #1356913
  * Revert "mac80211: move "bufferable MMPDU" check to fix AP mode scan"
    - LP: #1356913
  * mm, pcp: allow restoring percpu_pagelist_fraction default
    - LP: #1347088
  * net: Fix permission check in netlink_connect()
    - LP: #1312989
  * netlink: Rename netlink_capable netlink_allowed
    - LP: #1312989
  * net: Move the permission check in sock_diag_put_filterinfo to
    packet_diag_dump
    - LP: #1312989
  * net: Add variants of capable for use on on sockets
    - LP: #1312989
  * net: Add variants of capable for use on netlink messages
    - LP: #1312989
  * net: Use netlink_ns_capable to verify the permisions of netlink
    messages
    - LP: #1312989
  * netlink: Only check file credentials for implicit destinations
    - LP: #1312989
  * igb: fix stats for i210 rx_fifo_errors
    - LP: #1338893
  * HID: use multi input quirk for 22b9:2968
    - LP: #1339567
  * crypto/nx: disable NX on little endian builds
    - LP: #1338666
  * ACPI / video: Add Dell Inspiron 5737 to the blacklist
    - LP: #1250401
  * Input: elantech - deal with clickpads reportin...

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
Changed in linux-lts-raring (Ubuntu):
status: New → Invalid
Po-Hsu Lin (cypressyew) wrote :

Verified with 14.04 + update (3.13.0-40) on 201305-13636,
this issue has been fixed in Trusty

Changed in hwe-next:
status: Invalid → Fix Released
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions