Ubuntu

Comment 10 for bug 827942

On Sun, 21 Aug 2011, Nathan Neal wrote:
> Well, I had originally installed Ubuntu under ext3, but could not
> write to it under Mac OS X, and did some searching online, and I seem
> to remember reading that MOSX works better with ext2 formatting than
> ext3, so I wiped my Linux partition, reformatted as ext2, and
> reinstalled Ubuntu. MOSX does now allow read/write to the Linux
> partition, whereas under ext3 it did not. Anyway, all that is just
> some background as why I chose ext2.

It might be related under the hood. Did you write to your linux partition
from MacOS some time before the failure?

> I did as as you suggested, and tried installing dselect again, and
> this time it worked. I'm copying/pasting the text of the terminal

Weird. Did something change at the kernel level? Did you enable/disable
some security stuff (SMACK) ?

> of an easier way (maybe a cache of some sort), then you could instruct
> me on how to access it.

There's /var/log/dpkg.log but I saw your apt-history file and I don't
think the supplementary packages can explain why it works now. It's more
a kernel level issue or maybe a glibc issue. Somehow I would favor a bug
in the kernel with ext2 possibly related to some unexpected stuff done
by MacOS. But it's just a wild guess. It might also be some issue with
SMACK or similar security modules but I doubt we would get EINVAL as error
code if that was the reason.

Cheers,
--
Raphaël Hertzog ◈ Debian Developer

Follow my Debian News ▶ http://RaphaelHertzog.com (English)
                      ▶ http://RaphaelHertzog.fr (Français)