Maintenance release of iwlwifi 1000 uCode

Bug #752829 reported by Tim Gardner
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-firmware (Ubuntu)
Undecided
Tim Gardner
Lucid
Undecided
Tim Gardner
Maverick
Undecided
Tim Gardner
Natty
Undecided
Tim Gardner

Bug Description

Binary package hint: linux-firmware

Adds a new ucode file iwlwifi-1000-5.ucode, version 39.31.5.1

Revision history for this message
Tim Gardner (timg-tpi) wrote :

SRU Justification

Impact:

> Maintenance release version 39.31.5.1 of uCode for Intel 1000BGN
> > Series
> > WiFi Adapter is now available for download from
> > http://intellinuxwireless.org/?n=Downloads
> >
> > Changes:
> > - Fix "tid mismatch" issue
> >
> > Wey-Yi

Patch Description: Adds a new ucode file iwlwifi-1000-5.ucode with little chance of regression. This ucode is used by backported drivers in compat-wireless from kernel version 2.6.39.

Tim Gardner (timg-tpi)
Changed in linux-firmware (Ubuntu Natty):
status: New → Fix Committed
assignee: nobody → Tim Gardner (timg-tpi)
Changed in linux-firmware (Ubuntu Lucid):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux-firmware (Ubuntu Maverick):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.50

---------------
linux-firmware (1.50) natty; urgency=low

  * Added iwlwifi-1000-5.ucode
    -LP: #752829
 -- Tim Gardner <email address hidden> Wed, 06 Apr 2011 13:26:02 -0600

Changed in linux-firmware (Ubuntu Natty):
status: Fix Committed → Fix Released
Tim Gardner (timg-tpi)
Changed in linux-firmware (Ubuntu Maverick):
status: In Progress → Fix Committed
Changed in linux-firmware (Ubuntu Lucid):
status: In Progress → Fix Committed
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted linux-firmware into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Revision history for this message
Steve Conklin (sconklin) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-maverick
Revision history for this message
Martin Pitt (pitti) wrote :

Accepted linux-firmware into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Revision history for this message
Martin Pitt (pitti) wrote :

Can anyone please test the firmware package in -proposed? This is blocking further updates. Thanks!

Revision history for this message
Clint Byrum (clint-fewbar) wrote :

Hello Tim, or anyone else affected,

Accepted linux-firmware into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Revision history for this message
Clint Byrum (clint-fewbar) wrote :

Hello Tim, or anyone else affected,

Accepted linux-firmware into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Revision history for this message
James M. Leddy (jm-leddy) wrote :

Unless we can find someone that is experiencing the tid miss match issue today, we're likely not going to find someone to test to ensure its fixed:

http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=2214

Since there is little chance of regression, it is better to keep the fix.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.38.10

---------------
linux-firmware (1.38.10) maverick-proposed; urgency=low

  * ath3k-fw: Fix EEPROM radio table issue.
    LP: #882685

linux-firmware (1.38.9) maverick-proposed; urgency=low

  * Added firmware files to support compat-wireless
    linux-firmware: add new firmware for RTL8168E-VL
    linux-firmware: update firmware for RTL8111E
    linux-firmware: Add firmware for RTL8168/8111E
    linux-firmware: Add firmware for RTL8105E
    rtl_nic: Add firmware for RTL8111D(L)
    -LP: #804671

linux-firmware (1.38.8) maverick-proposed; urgency=low

  * Added carl9170.fw for Atheros wireless AR9170 based devices.
    -LP: #713987

linux-firmware (1.38.7) maverick-proposed; urgency=low

  * Added iwlwifi-1000-5.ucode
    -LP: #752829
 -- Tim Gardner <email address hidden> Fri, 28 Oct 2011 09:50:12 -0600

Changed in linux-firmware (Ubuntu Maverick):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.34.14

---------------
linux-firmware (1.34.14) lucid-proposed; urgency=low

  * Add new iwlwifi ucode files
    iwlwifi: add new firmware for 6000g2b devices
    iwlwifi: add new firmware for 2030 devices
    iwlwifi: add new firmware for 2000 devices
    iwlwifi: add new firmware for 135 devcies
    iwlwifi: add new firmware for 105 devices
    -LP: #918351

linux-firmware (1.34.13) lucid-proposed; urgency=low

  * ath3k-fw: Fix EEPROM radio table issue.
    LP: #882685

linux-firmware (1.34.12) lucid-proposed; urgency=low

  * Added firmware files to support Oneiric LTS backport
    linux-firmware: Add a new FW 7.0.20.0
    bnx2x: Adding FW 7.0.23.0
    -LP: #808884

linux-firmware (1.34.11) lucid-proposed; urgency=low

  * Added firmware files to support compat-wireless
    linux-firmware: add new firmware for RTL8168E-VL
    linux-firmware: update firmware for RTL8111E
    linux-firmware: Add firmware for RTL8168/8111E
    linux-firmware: Add firmware for RTL8105E
    rtl_nic: Add firmware for RTL8111D(L)
    -LP: #804671

linux-firmware (1.34.10) lucid-proposed; urgency=low

  * Added carl9170.fw for Atheros wireless AR9170 based devices.
    -LP: #713987

linux-firmware (1.34.9) lucid-proposed; urgency=low

  * Add Firmware for Atheros HTC devices (ath9k)
    -LP: #653854

linux-firmware (1.34.8) lucid-proposed; urgency=low

  * Added iwlwifi-1000-5.ucode
    -LP: #752829
 -- Tim Gardner <email address hidden> Tue, 24 Jan 2012 11:20:22 -0700

Changed in linux-firmware (Ubuntu Lucid):
status: Fix Committed → Fix Released
Revision history for this message
RALOVICH, Kristóf (kristof-ralovich) wrote :
Download full text (7.4 KiB)

Under Ubuntu 12.10 amd64 on a Dell XPS15 L501X with Intel Wireless-N 1000, the firmware needs to be downgraded from v5 to v3, as described in here: https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=903668

Otherwise I got:

[ 8.785447] iwlwifi: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
[ 8.785451] iwlwifi: Copyright(c) 2003-2012 Intel Corporation
[ 8.785598] iwlwifi 0000:04:00.0: pci_resource_len = 0x00002000
[ 8.785602] iwlwifi 0000:04:00.0: pci_resource_base = ffffc900117ec000
[ 8.785604] iwlwifi 0000:04:00.0: HW Revision ID = 0x0
[ 8.785726] iwlwifi 0000:04:00.0: irq 56 for MSI/MSI-X
[ 8.787445] iwlwifi 0000:04:00.0: loaded firmware version 39.31.5.1 build 35138
[ 8.787573] iwlwifi 0000:04:00.0: CONFIG_IWLWIFI_DEBUG disabled
[ 8.787576] iwlwifi 0000:04:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[ 8.787578] iwlwifi 0000:04:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[ 8.787580] iwlwifi 0000:04:00.0: CONFIG_IWLWIFI_DEVICE_TESTMODE enabled
[ 8.787582] iwlwifi 0000:04:00.0: CONFIG_IWLWIFI_P2P disabled
[ 8.787584] iwlwifi 0000:04:00.0: Detected Intel(R) Centrino(R) Wireless-N 1000 BGN, REV=0x6C
[ 8.787716] iwlwifi 0000:04:00.0: L1 Enabled; Disabling L0S
[ 8.795041] iwlwifi 0000:04:00.0: RF_KILL bit toggled to enable radio.
...
[ 8.811075] iwlwifi 0000:04:00.0: device EEPROM VER=0x15d, CALIB=0x6
[ 8.811080] iwlwifi 0000:04:00.0: Device SKU: 0x50
[ 8.811083] iwlwifi 0000:04:00.0: Valid Tx ant: 0x1, Valid Rx ant: 0x3
[ 8.811094] iwlwifi 0000:04:00.0: Tunable channels: 13 802.11bg, 0 802.11a channels
...
[ 8.820222] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
...
[ 12.494913] iwlwifi 0000:04:00.0: L1 Enabled; Disabling L0S
[ 12.510326] iwlwifi 0000:04:00.0: Microcode SW error detected. Restarting 0x82000000.
[ 12.510333] iwlwifi 0000:04:00.0: CSR values:
[ 12.510336] iwlwifi 0000:04:00.0: (2nd byte of CSR_INT_COALESCING is CSR_INT_PERIODIC_REG)
[ 12.510344] iwlwifi 0000:04:00.0: CSR_HW_IF_CONFIG_REG: 0X00c80300
[ 12.510352] iwlwifi 0000:04:00.0: CSR_INT_COALESCING: 0X00000040
[ 12.510360] iwlwifi 0000:04:00.0: CSR_INT: 0X80000000
[ 12.510367] iwlwifi 0000:04:00.0: CSR_INT_MASK: 0X00000000
[ 12.510375] iwlwifi 0000:04:00.0: CSR_FH_INT_STATUS: 0X40010000
[ 12.510382] iwlwifi 0000:04:00.0: CSR_GPIO_IN: 0X00000000
[ 12.510390] iwlwifi 0000:04:00.0: CSR_RESET: 0X00000000
[ 12.510398] iwlwifi 0000:04:00.0: CSR_GP_CNTRL: 0X080403c5
[ 12.510406] iwlwifi 0000:04:00.0: CSR_HW_REV: 0X0000006c
[ 12.510413] iwlwifi 0000:04:00.0: CSR_EEPROM_REG: 0Xc63f3885
[ 12.510421] iwlwifi 0000:04:00.0: CSR_EEPROM_GP: 0X90000001
[ 12.510428] iwlwifi 0000:04:00.0: CSR_OTP_GP_REG: 0X00210801
[ 12.510436] iwlwifi 0000:04:00.0: CSR_GIO_REG: 0X00080046
[ 12.510444] iwlwifi 0000:04:00.0: CSR_GP_UCODE_REG: 0X00000000
[ 12.510451] iwlwifi 0000:04:00.0: CSR_GP_DRIVER_REG: 0X00000000
[ 12.510458] iwlwif...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.