ubuntu 18.04.3 : intel 7260 bluetooth firmware doesn't have working hsp/hfp profile

Bug #1852785 reported by kaillasse91@hotmail.fr on 2019-11-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-firmware (Ubuntu)
Undecided
You-Sheng Yang
Bionic
Undecided
You-Sheng Yang

Bug Description

[SRU Justification]

[Impact]
When using a bluetooth headset the ad2p profile is supported but the
hsp/hfp profile doesn't work.

[Fix]
Using the latest firmware with patch version 42 solves from commit
629a5e089e30 ("linux-firmware: Update firmware patch for Intel
Bluetooth 7260 (B5/B6)").

[Test Case]
Pair with headset/mobile phone with HSP/HFP support and try A/V
control.

[Regression Potential]
Low. This upgrades only the firmware blob used by affected hardware,
and the proposed blob is also used by later releases.

========== original bug description ==========

--ubuntu release :
lsb_release -d
Description: Ubuntu 18.04.3 LTS

-- package :
apt show linux-firmware 2>&1 | grep -i "version:\|package:"
Package: linux-firmware
Version: 1.173.12

--hardware :
lspci -vnn | grep irel
03:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b1] (rev bb)
 Subsystem: Intel Corporation Dual Band Wireless-AC 7260 [8086:4070]
lsusb -d 8087:07dc
Bus 001 Device 003: ID 8087:07dc Intel Corp.

--problem :
The bluetooth part of the intel 7260 wifi/bluetooth card needs a firmware file to operate.
The version of my card is reported in dmesg as :

Bluetooth: hci0: read Intel version: 3707100180012d0d00

this will load firmware file

Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.7.10-fw-1.80.1.2d.d.bseq

When using a bluetooth headset the ad2p profile is supported but the hsp/hfp profile doesn't work, I believe the version in the current linux-firmawre package is patch version 39.

--solution :
Using the latest firmware with patch version 42 solves the problem :

https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/commit/intel/ibt-hw-37.7.10-fw-1.80.1.2d.d.bseq?id=629a5e089e300ba153c1358cca2193a7671c2f80

With this firmware the hsp/hfp profile is working, this means the microphone and the sound of the bluetooth headset are working correctly.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: linux-firmware 1.173.12 [modified: lib/firmware/intel/ibt-hw-37.7.10-fw-1.80.1.2d.d.bseq]
ProcVersionSignature: Ubuntu 5.0.0-36.39~18.04.1-generic 5.0.21
Uname: Linux 5.0.0-36-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.9
Architecture: amd64
CurrentDesktop: XFCE
Date: Fri Nov 15 19:45:35 2019
Dependencies:

InstallationDate: Installed on 2016-05-10 (1284 days ago)
InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
PackageArchitecture: all
SourcePackage: linux-firmware
UpgradeStatus: Upgraded to bionic on 2019-09-18 (57 days ago)

You-Sheng Yang (vicamo) wrote :

Yes, the latest revision of that blob in bionic branch has patch version 39: https://git.launchpad.net/~ubuntu-kernel/ubuntu/+source/linux-firmware/commit/intel/ibt-hw-37.7.10-fw-1.80.1.2d.d.bseq?h=bionic&id=fb328183532ffc7a1a54e84fb53467e275a95b79 . This should only affect Bionic because Cosmic and later releases have already patch version 42.

Changed in linux-firmware (Ubuntu):
status: New → Confirmed
assignee: nobody → You-Sheng Yang (vicamo)
You-Sheng Yang (vicamo) on 2019-11-18
Changed in linux-firmware (Ubuntu):
status: Confirmed → In Progress
You-Sheng Yang (vicamo) wrote :
description: updated
Changed in linux-firmware (Ubuntu Bionic):
status: New → In Progress
assignee: nobody → You-Sheng Yang (vicamo)
Seth Forshee (sforshee) on 2019-11-26
Changed in linux-firmware (Ubuntu):
status: In Progress → Invalid
You-Sheng Yang (vicamo) on 2019-11-27
Changed in linux-firmware (Ubuntu Bionic):
status: In Progress → Fix Committed
Timo Aaltonen (tjaalton) wrote :

it's not fix-committed until the package is moved to -proposed

Changed in linux-firmware (Ubuntu Bionic):
status: Fix Committed → In Progress
status: In Progress → Fix Committed

Hello <email address hidden>, or anyone else affected,

Accepted linux-firmware into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/linux-firmware/1.173.13 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

I confirm that the package fix the bug.

I downloaded it from :
https://launchpad.net/ubuntu/+source/linux-firmware/1.173.13/+build/18178805/+files/linux-firmware_1.173.13_all.deb

I believe it may be necessary to halt, wait some seconds then start the computer after install (and not just restart the computer) as the firmware is loaded directly in the bluetooth adapter.

You-Sheng Yang (vicamo) on 2019-12-03
tags: added: verification-done-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.173.13

---------------
linux-firmware (1.173.13) bionic; urgency=medium

  * Update linux-firmware in bionic for 5.3 hwe kernel (LP: #1852512)
    - linux-firmware: mediatek: add firmware for mt7668u Bluetooth
    - firmware/huc/bxt: Add huC Update for BXT
    - bnx2x: Add FW 7.13.11.0.
    - linux-firmware: add firmware for MT7615E
    - drm/i915/firmware: Add BXT GuC v32.0.3
    - drm/i915/firmware: Add SKL GuC v32.0.3
    - drm/i915/firmware: Add KBL GuC v32.0.3
    - drm/i915/firmware: Add GLK GuC v32.0.3
    - drm/i915/firmware: Add GLK HuC v03.01.2893
    - drm/i915/firmware: Add ICL GuC v32.0.3
    - drm/i915/firmware: Add ICL HuC v8.4.3238
    - Mellanox: Add new mlxsw_spectrum firmware 13.2000.1122
    - nvidia: update GP10[2467] SEC2 RTOS with the one already used on GP108
    - UBUNTU: SAUCE: iwlwifi: Add iwlwifi firmware files for 5.3 hwe kernel
    - UBUNTU: [Packaging] Update nic-firmware.lst for 5.3 hwe kernel

  * Intel 7260 bluetooth firmware doesn't have working hsp/hfp profile
    (LP: #1852785)
    - linux-firmware: Update firmware patch for Intel Bluetooth 7260 (B5/B6)

 -- Seth Forshee <email address hidden> Tue, 26 Nov 2019 14:50:55 -0600

Changed in linux-firmware (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for linux-firmware has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers