Comment 76 for bug 1520343

Queeq (i-queeq) wrote :

For me it started working on 4.4 kernel only with firmware 1.158. You may want to try that (there's 1.159 currently available): http://packages.ubuntu.com/yakkety/all/linux-firmware/download
Don't worry that it's in 'yakkety' repo, should work on xenial too.
If that doesn't help, you can try kernel 4.5 or later.