Comment 10 for bug 1394368

Wallcom (wallcom) wrote :

Now, with the support for this ID added, a new Problem exists; the same as with many other ath3k users:
It only works sporadically: Works -> Reboot - > Doesn't work -> After a few reboots it works again

When it doesnt work:
[ 3.657288] usbcore: registered new interface driver ath3k
[ 4.025700] usb 2-5: new full-speed USB device number 6 using xhci_hcd
[ 4.154563] usb 2-5: New USB device found, idVendor=04ca, idProduct=300d
[ 4.154565] usb 2-5: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 4.710941] usbcore: registered new interface driver rtsx_usb
[ 7.155744] Bluetooth: Error in firmware loading err = -110,len = 448, size = 4096
[ 7.155756] Bluetooth: Loading patch file failed
[ 7.155765] ath3k: probe of 2-5:1.0 failed with error -110
[ 13.128354] Bluetooth: RFCOMM TTY layer initialized
[ 13.128364] Bluetooth: RFCOMM socket layer initialized
[ 13.128369] Bluetooth: RFCOMM ver 1.11
[ 15.039498] usb 2-5: reset full-speed USB device number 5 using xhci_hcd
[ 15.039537] xhci_hcd 0000:00:14.0: Setup ERROR: setup context command for slot 4.
[ 15.039542] usb 2-5: hub failed to enable device, error -22
[ 15.151621] usb 2-5: reset full-speed USB device number 5 using xhci_hcd
[ 15.151645] xhci_hcd 0000:00:14.0: Setup ERROR: setup context command for slot 4.
[ 15.151651] usb 2-5: hub failed to enable device, error -22
[ 15.263518] usb 2-5: reset full-speed USB device number 5 using xhci_hcd
[ 15.280189] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8802496fdc00
[ 15.280193] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8802496fdc90
[ 15.280195] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8802496fdc48
[ 15.280197] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff88009b164348
[ 15.280198] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff88009b164300

Just like in these (still open) Bug Reports:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1260825
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1336179