Comment 17 for bug 1291459

psalter (phil-salter) wrote :

Thanks to the details above I was able to get my Dvico Fusion Dual Digital 4 working on Mythbuntu Trusty 14.04.3 . The problem was solved at kernel 3.19. Problem is related to cxusb.c where the #define MAX_XFER_SIZE 80 was changed from 64 to 80. Details of change are at LinuxTV.org:
https://git.linuxtv.org/media_tree.git/commit/?id=eb9da073bd002f2968c84129a5c49625911a3199

diff --git a/drivers/media/usb/dvb-usb/cxusb.c b/drivers/media/usb/dvb-usb/cxusb.c
index b7461ac..f379f7e 100644
--- a/drivers/media/usb/dvb-usb/cxusb.c
+++ b/drivers/media/usb/dvb-usb/cxusb.c
@@ -46,7 +46,7 @@
 #include "si2157.h"

 /* Max transfer size done by I2C transfer functions */
-#define MAX_XFER_SIZE 64
+#define MAX_XFER_SIZE 80

 /* debug */
 static int dvb_usb_cxusb_debug;

I looked through the ubuntu kernels for the updated cxusb.c and found it looked ok after 3.19.0 .
To fix my Mythbuntu Trusty I loaded linux-headers-3.19.0-47 and it all worked.

I wanted to update comments here so that anyone else doing searches for the problem might find a quick answer as there are not very many search results relating to Dvico card and later kernel.