Support for Ericsson F5521gw Mobile Broadband Module missing in Ubuntu maverick/LTS kernel packages

Bug #756842 reported by Marius B. Kotsbak on 2011-04-10
4
Affects Status Importance Assigned to Milestone
linux-backports-modules-2.6.38 (Ubuntu)
Undecided
Unassigned

Bug Description

Config option "USB_NET_CDC_NCM" giving module "cdc_ncm" is missing in Ubuntu kernels, even though it is marked as default in stock kernels. This requires manual compilation of that module for supporting Ericsson F5521gw.

As this is an USB standard (CDC NCM), potentially other current or future modems could be supported by this module:

static const struct usb_device_id cdc_devs[] = {
        { USB_INTERFACE_INFO(USB_CLASS_COMM,
                USB_CDC_SUBCLASS_NCM, USB_CDC_PROTO_NONE),
                .driver_info = (unsigned long)&cdc_ncm_info,
        },
        {
        },
};

Thus I propose the module should be included in the default Ubuntu kernels.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-image-generic 2.6.35.28.36
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.35-28.50-generic 2.6.35.11
Uname: Linux 2.6.35-28-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: marius 10612 F.... pulseaudio
CRDA: Error: [Errno 2] Ingen slik fil eller filkatalog
Card0.Amixer.info:
 Card hw:0 'Audigy'/'SB Audigy 1 [SB0092] (rev.3, serial:0x531102) at 0x1000, irq 21'
   Mixer name : 'TriTech TR28602'
   Components : 'AC97a:54524123'
   Controls : 194
   Simple ctrls : 30
Date: Sun Apr 10 22:22:02 2011
HibernationDevice: RESUME=UUID=fa34f6fd-830d-47c4-bf6d-9f20e9e60876
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100427.1)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.

 vboxnet0 no wireless extensions.
MachineType: Hewlett-Packard HP xw4300 Workstation
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.35-28-generic root=/dev/mapper/1_TB_Raid1-Root_lucid_64 ro crashkernel=384M-2G:64M,2G-:128M quiet splash
ProcEnviron:
 LANGUAGE=nb_NO:nb:no_NO:no:nn_NO:nn:en
 PATH=(custom, user)
 LANG=nb_NO.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.38.5
SourcePackage: linux
WifiSyslog: Apr 10 20:16:21 mariuspc kernel: [ 2246.876184] process `skype' is using obsolete setsockopt SO_BSDCOMPAT
dmi.bios.date: 08/02/2006
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 786D3 v01.10
dmi.board.name: 0A00h
dmi.board.vendor: Hewlett-Packard
dmi.chassis.asset.tag: CZC5320X63
dmi.chassis.type: 6
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr786D3v01.10:bd08/02/2006:svnHewlett-Packard:pnHPxw4300Workstation:pvr:rvnHewlett-Packard:rn0A00h:rvr:cvnHewlett-Packard:ct6:cvr:
dmi.product.name: HP xw4300 Workstation
dmi.sys.vendor: Hewlett-Packard

Marius B. Kotsbak (mariusko) wrote :
summary: Support for Ericsson F5521gw Mobile Broadband Module missing in Ubuntu
- kernel packages
+ maverick kernel packages
Marius B. Kotsbak (mariusko) wrote :

This module was introduced in kernel 2.6.38 and as maverick uses 2.6.35, this driver is not included. We probably need a backport of the module.

affects: linux (Ubuntu) → linux-meta (Ubuntu)
Marius B. Kotsbak (mariusko) wrote :

The module is even missing in package linux-backports-modules-compat-wireless-2.6.38-2.6.35-28-generic.

affects: linux-meta (Ubuntu) → linux-backports-modules-2.6.35 (Ubuntu)
affects: linux-backports-modules-2.6.35 (Ubuntu) → linux-backports-modules-2.6.38 (Ubuntu)
Marius B. Kotsbak (mariusko) wrote :

Hmm, now that I got the modem, it seems that it works properly out of the box with Network Manager using cdc_wdm and cdc_acm drivers, so I'm not sure if it is beneficial to use the cdc_ncm instead.

Marius B. Kotsbak (mariusko) wrote :

Now that Natty is released, we can close this bug.

Brad Figg (brad-figg) on 2011-05-04
Changed in linux-backports-modules-2.6.38 (Ubuntu):
status: New → Confirmed
Marius B. Kotsbak (mariusko) wrote :
summary: Support for Ericsson F5521gw Mobile Broadband Module missing in Ubuntu
- maverick kernel packages
+ maverick/LTS kernel packages
Marius B. Kotsbak (mariusko) wrote :

This seems to be fixed in Lucid now.

Changed in linux-backports-modules-2.6.38 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers