dm-crypt missing from initramfs

Bug #1862215 reported by Adam Collard on 2020-02-06
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-5.4 (Ubuntu)
Undecided
Unassigned

Bug Description

Attempting to boot linux-image-5.4.0-12-generic and it failed to find my LVM VG. -9 worked without issue.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: linux-image-generic 5.4.0.12.15
ProcVersionSignature: Ubuntu 5.4.0-9.12-generic 5.4.3
Uname: Linux 5.4.0-9-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu16
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Thu Feb 6 17:20:45 2020
InstallationDate: Installed on 2016-11-01 (1192 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
SourcePackage: linux-meta-5.4
UpgradeStatus: Upgraded to focal on 2020-01-20 (17 days ago)

Adam Collard (adam-collard) wrote :
Andy Whitcroft (apw) on 2020-02-06
affects: linux-meta-5.4 (Ubuntu) → linux-5.4 (Ubuntu)
tags: added: champagne
Seth Forshee (sforshee) wrote :

What is printed on the screen when this happens? Are you able to collect dmesg, or at least look at it for errors?

We have a newer version in -proposed with numerous updates from upstream stable, could you give that a try? We have a ppa (ppa:canonical-kernel-team/proposed) that you can use to get the -proposed kernel without enabling all of -proposed.

Changed in linux-5.4 (Ubuntu):
status: New → Incomplete
Adam Collard (adam-collard) wrote :

Partial transcription from the attached photo:

"Gave up waiting for root file system device"...

"ALERT! /dev/mapper/ubuntu--vg-root does not exist"

Adam Collard (adam-collard) wrote :

Same behaviour of 5.4.0-14.17

Changed in linux-5.4 (Ubuntu):
status: Incomplete → New
Seth Forshee (sforshee) wrote :

I tried doing a fresh focal install with lvm/encrypted root and that is working fine. I'll try starting from eoan and upgrading to focal to see if that behaves differently.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-5.4 (Ubuntu):
status: New → Confirmed
Neil McPhail (njmcphail) wrote :

Oddly, I've just had this on 5.4.0-14, whereas 5.4.0-12 works perfectly. Maybe something is messed up in initramfs generation?

Seth Forshee (sforshee) wrote :

That's certainly a possibility. Can you check from the busybox shell what modules are loaded when you see the boot failure (cat /proc/modules)? Or unpack the initramfs and see what modules are included? Seems like dm-crypt would be the critical one here.

There are likely userspace components that could also be causing the issue, though I don't know what those would be.

Neil McPhail (njmcphail) wrote :

Running cat /proc/modules gives:
i915
i2c_algo_bit
crc32_pclmul
drm_kms_helper
syscopyarea
sysfillrect
sysimgblt
fb_sys_fops
psmouse
sdhci_pci
cqhci
sdhci
lpc_ich
i2c_i801
ahci
drm
libahci
e1000e
wmi
video

(There may be a transcription error or 2 in there, so photo is at http://ovh.themcphails.uk/index.php/s/t94YwXRktqrYHsb )

Certainly no evidence of dm-crypt or similar.

Seth Forshee (sforshee) wrote :

Interesting. If you list the contents of the initramfs in /boot (lsinitramfs /boot/initrd.img-5.4.0-14-generic) do you see dm-crypt.ko in the list of files?

Adam Collard (adam-collard) wrote :

$ lsinitramfs /boot/initrd.img-5.4.0-14-generic | grep dm-crypt
1 $

https://paste.ubuntu.com/p/bDq66dMjYM/ for the full list

Adam Collard (adam-collard) wrote :

$ lsinitramfs /boot/initrd.img-5.4.0-9-generic | grep dm-crypt
usr/lib/modules/5.4.0-9-generic/kernel/drivers/md/dm-crypt.ko

Confirmed it is there for -9

summary: - Failure to boot with LVM + encrypted root disk
+ dm-crypt missing from initiramfs

Ah, suspect this is actually an incident of bug 1864360, confirmed I do not have cryptsetup-initramfs installed, and purged all transitional packages

summary: - dm-crypt missing from initiramfs
+ dm-crypt missing from initramfs
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers