Comment 2 for bug 109559

There is no apache at all.But I tracked problem down and fixed it.Here it comes.

I did run lighttpd under custom non-default user I'd created myself.All worked fine, startup script launches lighttpd as root but I pointed out to server to change to restricted user upon startup (in it's config file I used server.username and server.groupname to switch to restricted user).

During upgrade, owner and group of (existing and not empty!) lighttpd logs folder (/var/log/lighttpd) were changed for unknown reason to another user (intended to run www server but hey, I already had another user for this purpose!).Once server worked as restricted user and logs folder has been assigned to another owner\group, server was unable to write log file due to lack of permissions and exited due to this fact.

So, I have to ask: why updater has to alter owner and group of already existing and non-empty folder during system upgrade?Imho it should be left as is (or at least, you have to change owner after confirmation since this potentially may affect server's operations).

Anyway, not a serious issue - those who run servers have to be smart a bit or better do not run servers othervice.