[FFe] [needs-packaging] Lightning 1.0 Beta for Thunderbird 3

Bug #531867 reported by Derek Kaye
380
This bug affects 99 people
Affects Status Importance Assigned to Milestone
iceowl (Debian)
Fix Released
Unknown
lightning-extension (Ubuntu)
High
Chris Coulson
Nominated for Lucid by otmarstahl

Bug Description

Binary package hint: lightning

I guess this is a similar issue to Bug #527138

Lightning is reporting as being installed in "Ubuntu software centre" and here:

dezza@beatrice:~$ apt-cache policy lightning-extension
lightning-extension:
  Installed: 0.9+nobinonly-0ubuntu3
  Candidate: 0.9+nobinonly-0ubuntu3
  Version table:
 *** 0.9+nobinonly-0ubuntu3 0
        500 http://gb.archive.ubuntu.com lucid/universe Packages
        100 /var/lib/dpkg/status

However it doesn't show up in Thunderbird 3. My guess is that this is because this build of lightning depends on Thunderbird 2?

Workaround: Install Lightning from Thunderbird's Tools > Add-ons menu.

Other possible useful information:

dezza@beatrice:~$ lsb_release -rd
Description: Ubuntu lucid (development branch)
Release: 10.04
dezza@beatrice:~$ uname -a
Linux beatrice 2.6.32-15-generic #22-Ubuntu SMP Tue Mar 2 02:24:17 UTC 2010 i686 GNU/Linux
dezza@beatrice:~$ apt-cache policy thunderbird
thunderbird:
  Installed: 3.0.1+nobinonly-0ubuntu1
  Candidate: 3.0.1+nobinonly-0ubuntu1
  Version table:
 *** 3.0.1+nobinonly-0ubuntu1 0
        500 http://gb.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status
dezza@beatrice:~$

Revision history for this message
xylo (stefan-endrullis) wrote :

I have the same problem with lightning, but I cannot even install the extension manually since it seems to be not supported for 64 bit systems like mine:
# uname -a
Linux lausen 2.6.32-15-generic #22-Ubuntu SMP Tue Mar 2 02:23:29 UTC 2010 x86_64 GNU/Linux

I get an error that the build type Linux_x86_64-gcc3 is not compatible, but that's not an direct Ubuntu issue.

Here is my OS info and package info:

# lsb_release -rd
Description: Ubuntu lucid (development branch)
Release: 10.04
# apt-cache policy thunderbird
thunderbird:
  Installiert: 3.0.1+nobinonly-0ubuntu1
  Kandidat: 3.0.1+nobinonly-0ubuntu1
  Versions-Tabelle:
 *** 3.0.1+nobinonly-0ubuntu1 0
        500 http://de.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status
# apt-cache policy lightning-extension
lightning-extension:
  Installiert: (keine)
  Kandidat: 0.9+nobinonly-0ubuntu3
  Versions-Tabelle:
     0.9+nobinonly-0ubuntu3 0
        500 http://de.archive.ubuntu.com lucid/universe Packages

Revision history for this message
Guillaume Pascal (guigui14100-deactivatedaccount) wrote :

In the sofware center is old version (version 0.9), Thunderbird 3 work with version 1 beta 1

https://addons.mozilla.org/fr/thunderbird/addon/2313

summary: - [Lucid] Lightning doesn't work with Thunderbird 3
+ [needs-packaging] Lightning 1.0 Beta for Thunderbird 3
Revision history for this message
Ancoron Luziferis (ancoron) wrote : Re: [needs-packaging] Lightning 1.0 Beta for Thunderbird 3

No, even version 1.0 beta X doesn't on any 64-bit system I have because of the strange version string:

"Lightning" could not be installed because it is not compatible with your Thunderbird build type (Linux_x86_64-gcc3). Please contact the author of this item about the problem.

...and the config hack mentioned somewhere doesn't help too.

Revision history for this message
Ancoron Luziferis (ancoron) wrote :

...it even works on 64-bit MacOS X so it really does look like Ubuntu's fault here on Thunderbird itself, rather than upstream authors.

Revision history for this message
Cary Litchford (cary-litchford) wrote :

I resolved this error by installing the latest beta build of lightning from here:

http://www.secudb.de/~seuffert/mozilla/2010-03-03 - lightning 1.0b2pre x86_64 linux english/

Revision history for this message
Shane Rice (shane2peru) wrote :

Hmm, that link is either cut off, or doesn't work. :( I would like to give the latest lightning a try.

Shane

Michael Stucki (mstucki)
Changed in lightning (Ubuntu):
status: New → Confirmed
Revision history for this message
tigerente (f-wenzel) wrote :

@Shane: Try http://www.secudb.de/~seuffert/mozilla and pick the latest directory. Indeed, it works on my lucid amd64-system :-). However, it would of course be good if lightning could be readded to the ubuntu feeds...

Revision history for this message
Michał Gołębiowski-Owczarek (mgol) wrote :

@Cary Litchford, tigerente
Would You mind _not_ providing links to pre- versions, which are of alpha stability and can crash, lose data and other terrible things? If one wants to install Lightning in a 64-bit environment, here is a page with link to beta versions, not beta pre:
https://help.ubuntu.com/community/ThunderbirdLightning

Revision history for this message
Michał Gołębiowski-Owczarek (mgol) wrote :

@Cary Litchford
Me once more: 1.0b2pre is _not_ a beta version, but a beta pre, like written explicitly in a version number. That means, this is a version which in some time, after updates and so on, will become beta 2. Now it is just a very unstable version (the instability level can depend on how close we are to the beta 2 release).

Revision history for this message
FreeMinded (pascal-planetmages) wrote :

This one works for me on Kubuntu 10.04 64bit system
http://releases.mozilla.org/pub/mozilla.org/calendar/lightning/releases/1.0b1/contrib/linux-x86_64/lightning.xpi

Would be nice to see it in the Package Manager thought.

Cheers!

Revision history for this message
John Vivirito (gnomefreak) wrote :

bug #527138 Is not really the same. We have to strip the lightning-sunbird source than we can update lightning. Please see bug #531867 for more info on lighnting 1.0

Revision history for this message
Simon Déziel (sdeziel) wrote :

I can also confirm that this one works for me on Ubuntu Lucid 10.04 64bit.

http://releases.mozilla.org/pub/mozilla.org/calendar/lightning/releases/1.0b1/contrib/linux-x86_64/lightning.xpi

Revision history for this message
nZain (patrick-stalph) wrote :

I'm running lucid 64bit. Unfortunately, I'm unable to get thunderbird+lightning+gdata-provider running, since at least the gdata-provider (enables google calendars) is not available for 64bit. Too sad.

Revision history for this message
Rex Mundi (service-redterra) wrote :

I've compiled both lightning and gdata from the comm-1.9.1 source which works with the current version of Thunderbird in the Lucid x86_64 repositories. You can get them here: http://rex-bits.redterra.net/rex-s-bits/thunderbirdlightningonubuntu1004amd64

affects: lightning (Ubuntu) → lightning-sunbird (Ubuntu)
Changed in lightning-sunbird (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → High
status: Confirmed → In Progress
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Requesting a FFe for this. I know it's pretty late in the day to be doing this, but lightning is something that we only dropped from the archive as a last resort last cycle because there wasn't anybody with enough time to get it up-to-date. There are several reasons why I consider it important to ship this again:

1) Corporate users of Thunderbird generally expect to have access to this
2) Official builds are only distributed for i386, leaving our amd64 users to have to get it from unofficial sources
3) It's popular :)

I'm pretty much ready to go with this if I can get an ACK

summary: - [needs-packaging] Lightning 1.0 Beta for Thunderbird 3
+ [FFe] [needs-packaging] Lightning 1.0 Beta for Thunderbird 3
Revision history for this message
hs (hs4711) wrote :

This should go along with an update to thunderbird 3.1, as this release officially targets the thunderbird 2 user base. and this would help all who didn't update because of the missing lightning-extension.

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

hs - we already have thunderbird 3.1 in maverick

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

I've put the current packaging (along with an amd64 build) in http://people.canonical.com/~chrisccoulson/lightning-sunbird/

Revision history for this message
hs (hs4711) wrote :

Chris Coulson, I´d requested Thunderbird 3.1 for Lucid, together with lightning-extension. Mozilla says, this is the version to please upgraders from 2.x.

Additionally, your packages of lightning-extension version 1.0~b2 require Thunderbird 3.1. Thunderbird 3.0 is only compatibly with version 1.0~b1.

Best for users would be to release Thunderbird 3.1 together with lightning-extension as an update to lucid.

Revision history for this message
Frans Gifford (fgiff) wrote :

Can we remove the 'affects iceowl'? Ubuntu don't distribute iceowl (they distribute sunbird/lightning) and iceowl has built correctly on Ubuntu since at least the Lucid betas. I know this because I've been rebuilding icedove/iceowl in my ppa since Ubuntu broke thunderbird/lightning. The problem is not upstream, it's solely a problem with Ubuntu's thunderbird/lightning combination.

Revision history for this message
Colin Watson (cjwatson) wrote :

FFE approved, on the understanding that this will be in universe (as lightning-sunbird previously was, in karmic and earlier).

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

This has been accepted in to Maverick now

affects: lightning-sunbird (Ubuntu) → lightning-extension (Ubuntu)
Changed in lightning-extension (Ubuntu):
status: In Progress → Fix Released
Changed in iceowl (Debian):
status: Unknown → Fix Released
Revision history for this message
JD Evora (jdevora) wrote :

Looks like the packages provided by Chris Coulson are not compatible with Thunderbird 3.0.9

Shouldn't there be a 10.04 version available in the repositories? it is a LTE version after all

Revision history for this message
Pander (pander) wrote :

On Ubuntu Maverick 10.10 from its Ubuntu's repos, the following works:
thunderbird 3.1.5+build1+nobinonly-0ubuntu0.10.10.1
with
xul-ext-lightning 1.0~b2+build2+nobinonly-0ubuntu2

Revision history for this message
Micah Gersten (micahg) wrote : Re: [Bug 531867] Re: [FFe] [needs-packaging] Lightning 1.0 Beta for Thunderbird 3

We'll be pushing Thunderbird 3.1 to Lucid next month along with Lightning.

On 10/27/2010 12:11 PM, JD Evora wrote:
> Looks like the packages provided by Chris Coulson are not compatible
> with Thunderbird 3.0.9
>
>
> Shouldn't there be a 10.04 version available in the repositories? it is a LTE version after all
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.