Unity greeter indicators don't show on second launch

Bug #1605117 reported by Roman Shipovskij on 2016-07-21
58
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Light Display Manager
High
Unassigned
lightdm (Ubuntu)
High
Robert Ancell
Xenial
High
Unassigned

Bug Description

[Impact]
Unity Greeter indicators don't show second time greeter started.

[Test Case]
1. Log in with greeter
2. Log out

Expected result:
Unity greeter is shown with all UI elements as in step 1.

Observed result:
Unity greeter is shown but only one indicator shows (accessibility)

[Regression potential]
Low. The fix was already present in the Bzr branch (removed some unneeded code that would accidentally close stdin). The fix was not released since it hadn't been shown to be a problem before this report.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Changed in lightdm (Ubuntu):
importance: Undecided → Medium
Changed in lightdm:
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Robert, could you have a look to that issue?

 It's easy to reproduce:
- log in an uptodate xenial system
- start a guest session
- close it

-> the greeter only has the custom a11y indicator

Looking a bit more it seems the greeter session bus fails to start which makes indicators to bail out (there is an error in the greeter log "Failed to launch bus: Failed to connect to session bus"), it also makes unity-settings-daemon not work properly it seems (resolution is wrong when screen configs change)

Changed in lightdm (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
importance: Medium → High
Robert Ancell (robert-ancell) wrote :

This occurs on the second launch of the greeter.

Robert Ancell (robert-ancell) wrote :

The problem does not occur using the latest lp:lightdm/1.18

Robert Ancell (robert-ancell) wrote :

Looks like this commit fixes it:

revno: 2327
committer: Robert Ancell <email address hidden>
branch nick: 1.18
timestamp: Wed 2016-06-29 15:16:05 +1200
message:
  Remove unused unititialized file descriptors - could cause stdin to be closed

Sebastien Bacher (seb128) wrote :

thanks Robert, I can confirm that this patch applied on the current xenial package fixes the issue

Changed in lightdm (Ubuntu):
status: Confirmed → In Progress
Robert Ancell (robert-ancell) wrote :

I've made a release with just this change (1.18.2-0ubuntu2).

Changed in lightdm:
status: Confirmed → Fix Committed
milestone: none → 1.18.3
Changed in lightdm (Ubuntu):
status: In Progress → Fix Committed
Changed in lightdm:
importance: Undecided → High
description: updated
description: updated
description: updated
summary: - LightDM tray items disappear after logout
+ Unity greeter indicators don't show on second launch

Hello Roman, or anyone else affected,

Accepted lightdm into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lightdm/1.18.2-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in lightdm (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed

Updating from xenial-proposed fixes the problem:

~# apt-cache policy lightdm
lightdm:
  Installed: 1.18.2-0ubuntu2
  Candidate: 1.18.2-0ubuntu2
  Version table:
 *** 1.18.2-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu xenial-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     1.18.2-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages
     1.18.1-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu xenial/main i386 Packages

tags: added: verification-done
removed: verification-needed
Changed in lightdm (Ubuntu Xenial):
importance: Undecided → High
seanlano (seanlano) wrote :

I can confirm that the 1.18.2-0ubuntu2 version fixes the problem for me too

Mostly for the records, I've had a very similar, but more severe problem. Since upgrading from 14.04 to 16.04, not only were the indicators (other than a11y) missing, but I couldn't log in anymore. The correct password was reproducibly rejected as incorrect. After the next restart of lightdm, things worked smoothly, until the next logout. I'd reckon that the same cause that kept the indicators from loading kept lightdm from connecting to its source of authentication (PAM?), but that's highly guesswork.

The new 1.18.2-0ubuntu2 so far seems to have fixed that variant of the problem, too.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.18.2-0ubuntu2

---------------
lightdm (1.18.2-0ubuntu2) xenial; urgency=medium

  * debian/patches/lp1605117.patch:
    - Fix stdin being accidentally closed, causing indicators not to show in
      unity-greeter (LP: #1605117)

 -- Robert Ancell <email address hidden> Fri, 29 Jul 2016 15:18:41 +1200

Changed in lightdm (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for lightdm has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in lightdm:
status: Fix Committed → Fix Released
Changed in lightdm (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers