Screen Freeze on Bootup - Lubuntu 12.10 PPC Alternate Aug 30 Build

Bug #1044180 reported by Ron Mitchell
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
lightdm (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Installing from Alternate CD for Lubuntu 12.10 PPC August 30 2012 build.

Boot appeared to be normal until it came time to display the desktop.

2 photos attached of what appeared. Computer appeared then to freeze

Computere is an eMAC 1.2 Ghz G4 processor. 1 Gig RAM 80 Gig hard drive. Internal hard drive has no other operating system on it.

did <ctl-alt-F1> to boot to command line interface.
did <ubuntu-bug>

Photo of reporting screen attached. Since I was not connected to the internet, I was unable to report the bug from there.

Tags: iso-testing
Revision history for this message
Ron Mitchell (rm2892) wrote :
Revision history for this message
Ron Mitchell (rm2892) wrote :

Additional photo of but reporting form

Revision history for this message
Ron Mitchell (rm2892) wrote :

2nd photo of frozen cursor

Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1044180

tags: added: iso-testing
Revision history for this message
Ron Mitchell (rm2892) wrote :

Probleem continues with build of Sept 2 2012

still the same symptoms as reported above.

Revision history for this message
Ron Mitchell (rm2892) wrote :

problem continues with build of Sept 7 2012

Revision history for this message
Ron Mitchell (rm2892) wrote :

*****PROBLEM SOLVED*******

downloaded the file emac4.txt from:

http://mac.linux.be/content/xorgconf-emac-g4125-radeon-9200-debian-lenny

copied it to /etc/X11/xorg.conf

rebooted and all was normal.

Revision history for this message
ojordan (ojordan12345) wrote :

The xorg.conf files on that site are garbage. The one you have downloaded is a prime example. I would advise you not to use them.

The above xorg.conf uses the fbdev driver - a generic unaccelerated driver. You should only use it as a last resort.

Have you tried turning off KMS? - http://ubuntuforums.org/showthread.php?t=2053596

Revision history for this message
Ron Mitchell (rm2892) wrote : Re: [Bug 1044180] Re: Screen Freeze on Bootup - Lubuntu 12.10 PPC Alternate Aug 30 Build

Sent from my iPod

On 2012-09-09, at 12:27 AM, ojordan <email address hidden> wrote:

> The xorg.conf files on that site are garbage. The one you have
> downloaded is a prime example. I would advise you not to use them.
>
> The above xorg.conf uses the fbdev driver - a generic unaccelerated
> driver. You should only use it as a last resort.
>
> Have you tried turning off KMS? -
> http://ubuntuforums.org/showthread.php?t=2053596
>
> --
> You received this bug notification because you are subscribed to the
> bug
> report.
> https://bugs.launchpad.net/bugs/1044180
>
> Title:
> Screen Freeze on Bootup - Lubuntu 12.10 PPC Alternate Aug 30 Build
>
> Status in “debian-installer” package in Ubuntu:
> New
>
> Bug description:
> Installing from Alternate CD for Lubuntu 12.10 PPC August 30 2012
> build.
>
> Boot appeared to be normal until it came time to display the desktop.
>
> 2 photos attached of what appeared. Computer appeared then to freeze
>
> Computere is an eMAC 1.2 Ghz G4 processor. 1 Gig RAM 80 Gig hard
> drive. Internal hard drive has no other operating system on it.
>
> did <ctl-alt-F1> to boot to command line interface.
> did <ubuntu-bug>
>
> Photo of reporting screen attached. Since I was not connected to the
> internet, I was unable to report the bug from there.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1044180/+subscriptions

Revision history for this message
Ron Mitchell (rm2892) wrote :

Thank you for the suggestions, I'll try that. I simply went with what
worked and in so doing ended several days of frustration.

Ron Mitchell

Sent from my iPod

On 2012-09-09, at 12:27 AM, ojordan <email address hidden> wrote:

> The xorg.conf files on that site are garbage. The one you have
> downloaded is a prime example. I would advise you not to use them.
>
> The above xorg.conf uses the fbdev driver - a generic unaccelerated
> driver. You should only use it as a last resort.
>
> Have you tried turning off KMS? -
> http://ubuntuforums.org/showthread.php?t=2053596
>
> --
> You received this bug notification because you are subscribed to the
> bug
> report.
> https://bugs.launchpad.net/bugs/1044180
>
> Title:
> Screen Freeze on Bootup - Lubuntu 12.10 PPC Alternate Aug 30 Build
>
> Status in “debian-installer” package in Ubuntu:
> New
>
> Bug description:
> Installing from Alternate CD for Lubuntu 12.10 PPC August 30 2012
> build.
>
> Boot appeared to be normal until it came time to display the desktop.
>
> 2 photos attached of what appeared. Computer appeared then to freeze
>
> Computere is an eMAC 1.2 Ghz G4 processor. 1 Gig RAM 80 Gig hard
> drive. Internal hard drive has no other operating system on it.
>
> did <ctl-alt-F1> to boot to command line interface.
> did <ubuntu-bug>
>
> Photo of reporting screen attached. Since I was not connected to the
> internet, I was unable to report the bug from there.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1044180/+subscriptions

Revision history for this message
Ron Mitchell (rm2892) wrote :

tried solutions suggested here:

http://ubuntuforums.org/showthread.php?t=2053596&highlight=ppc

They did not work for me. Same result as reported above.

Revision history for this message
ojordan (ojordan12345) wrote :

Please read the new comments on the ubuntu forum thread. If you still have problems with video=ofonly radeon.agpmode=-1 then please attach an Xorg.0.log plus dmesg log (to be found in the /var/log directory).

Revision history for this message
Ron Mitchell (rm2892) wrote :

Files attached.

The code at the forum thread did nothing to help me.

Ron M

Revision history for this message
Ron Mitchell (rm2892) wrote :

dmesg file

R

Revision history for this message
Ron Mitchell (rm2892) wrote :

This file, when placed in /usr/share/X11/xorg.conf.d/ does work, in that the graphical user interface appears looking quite normal. /etc/X11/xorg.conf (the generic driver) was removed for this run.

R

Revision history for this message
ojordan (ojordan12345) wrote :

You are only using radeon.agpmode=-1 in those logs. You need to also use video=ofonly.

Revision history for this message
Ron Mitchell (rm2892) wrote :

I did try that, but got only a blank screen. Couldn't even get into CLI <ctn-alt-F1>.

Does it matter which arguement comes first?

Revision history for this message
Ron Mitchell (rm2892) wrote :

here's my /var/log/Xorg.0.log for a case where I used the 2 commands:

video=ofonly radeon.agpmode=-1

It produces a blank screen and from there I'm unable to do <cntl-alt-F1> or anything else.

Sorry for the delay in reply. I've been on the sick list for the past few days, and yesterday it really got bad. Flu or something. When I don't feel like going near the fridge or the computer, I know it's not good.

Ron Mitchell

Revision history for this message
Ron Mitchell (rm2892) wrote :

Forgot to post the file

Ron M

Revision history for this message
ojordan (ojordan12345) wrote :

Ron, there is nothing obviously wrong in that Xorg.0.log. To be honest I'm a bit confused with what is working and what isn't. According to your comments here https://bugs.launchpad.net/openchrome/+bug/1041625/comments/40 you have a working live ISO. Similarly, Lars Nooden reports a working desktop with a recent ISO in bug #1046951 . Presumably you are testing a recentish alternate install too? Is your problem only to do with an installed system? If you install from a working live/desktop ISO do you then get a problem on the installed system? Can we isolate the problem to installing from the alternate CD? Or has the problem now gone away in recent versions?....

Revision history for this message
Ron Mitchell (rm2892) wrote :

Ok, let me see if I can get this straight:

Using builds from September 13th

1) The live ISO - burned to a DVD-RW boots the desktop with distorted (8 bit) colours on some of the buttons and title bars.

2) If I attempt to install from the live CD, I get the blank dialog box headed "Install". Unable to proceed from there

3) The Alternate install disk also burned to a DVD-RW completed the installation successfully, but when I booted from that, it resulted in a blank screen with a cursor in the centre which appeared to have the same graphics distortions; ie coloured horizontal bars at one small square in the centre of the screen. I could move the cursor and sometimes the colour distortions would disappear, but then come back as I moved the cursor about. Was unable to get anything else except the distorted cursor. I could however jump to a CLI by doing <ctl-alt-f1).

4) Booted as in (3) but with command <video=ofonly> I got a blank screen and was unable to proceed anywhere from there.

Clear as mud?

Ron Mitchell

On Sun, 16 Sep 2012 18:46:08 -0000
ojordan <email address hidden> wrote:

> *** This bug is a duplicate of bug 1046951 ***
> https://bugs.launchpad.net/bugs/1046951
>
> Ron, there is nothing obviously wrong in that Xorg.0.log. To be honest
> I'm a bit confused with what is working and what isn't. According to
> your comments here
> https://bugs.launchpad.net/openchrome/+bug/1041625/comments/40 you have
> a working live ISO. Similarly, Lars Nooden reports a working desktop
> with a recent ISO in bug #1046951 . Presumably you are testing a
> recentish alternate install too? Is your problem only to do with an
> installed system? If you install from a working live/desktop ISO do you
> then get a problem on the installed system? Can we isolate the problem
> to installing from the alternate CD? Or has the problem now gone away
> in recent versions?....
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1044180
>
> Title:
> Screen Freeze on Bootup - Lubuntu 12.10 PPC Alternate Aug 30 Build
>
> Status in “debian-installer” package in Ubuntu:
> New
>
> Bug description:
> Installing from Alternate CD for Lubuntu 12.10 PPC August 30 2012
> build.
>
> Boot appeared to be normal until it came time to display the desktop.
>
> 2 photos attached of what appeared. Computer appeared then to freeze
>
> Computere is an eMAC 1.2 Ghz G4 processor. 1 Gig RAM 80 Gig hard
> drive. Internal hard drive has no other operating system on it.
>
> did <ctl-alt-F1> to boot to command line interface.
> did <ubuntu-bug>
>
> Photo of reporting screen attached. Since I was not connected to the
> internet, I was unable to report the bug from there.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1044180/+subscriptions

--
Ron Mitchell <email address hidden>

Revision history for this message
ojordan (ojordan12345) wrote :

I can't reproduce your problem with an installed system from a live CD (13/9/2012 with video=ofonly radeon.agpmode=-1 boot parameters) .... are you able to confirm this is an 'alternate' only problem?

Revision history for this message
Ron Mitchell (rm2892) wrote :

It was the live cd installed system.

I'm going to download both again tonight and try it all again. Hopefully I should then be able to report based on current builds.

Seems like mine is the only eMac on the planet that won't accept the normal yaboot commands.

Ron

On Mon, 17 Sep 2012 18:06:34 -0000
ojordan <email address hidden> wrote:

> I can't reproduce your problem with an installed system from a live CD
> (13/9/2012 with video=ofonly radeon.agpmode=-1 boot parameters) .... are
> you able to confirm this is an 'alternate' only problem?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1044180
>
> Title:
> Screen Freeze on Bootup - Lubuntu 12.10 PPC Alternate Aug 30 Build
>
> Status in “debian-installer” package in Ubuntu:
> New
>
> Bug description:
> Installing from Alternate CD for Lubuntu 12.10 PPC August 30 2012
> build.
>
> Boot appeared to be normal until it came time to display the desktop.
>
> 2 photos attached of what appeared. Computer appeared then to freeze
>
> Computere is an eMAC 1.2 Ghz G4 processor. 1 Gig RAM 80 Gig hard
> drive. Internal hard drive has no other operating system on it.
>
> did <ctl-alt-F1> to boot to command line interface.
> did <ubuntu-bug>
>
> Photo of reporting screen attached. Since I was not connected to the
> internet, I was unable to report the bug from there.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1044180/+subscriptions

--
Ron Mitchell <email address hidden>

Revision history for this message
Ron Mitchell (rm2892) wrote : Re: [Bug 1044180] Re: Screen Freeze on Bootup - Lubuntu 12.10 PPC Alternate Aug 30 Build

There are problems with both iso's, both the live CD and the alternate.

The live CD produces the blank dialogue boxes which make an install impossible. The alternate will install ok, but produces an installation with a blank screen and except for the cursor.

When I first started testing in early August, these problems were not happening.

Ron M
------Original Message------
From: ojordan
Sender: <email address hidden>
To: <email address hidden>
ReplyTo: Bug 1044180
Subject: [Bug 1044180] Re: Screen Freeze on Bootup - Lubuntu 12.10 PPC Alternate Aug 30 Build
Sent: Sep 17, 2012 11:06

I can't reproduce your problem with an installed system from a live CD
(13/9/2012 with video=ofonly radeon.agpmode=-1 boot parameters) .... are
you able to confirm this is an 'alternate' only problem?

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1044180

Title:
  Screen Freeze on Bootup - Lubuntu 12.10 PPC Alternate Aug 30 Build

Status in “debian-installer” package in Ubuntu:
  New

Bug description:
  Installing from Alternate CD for Lubuntu 12.10 PPC August 30 2012
  build.

  Boot appeared to be normal until it came time to display the desktop.

  2 photos attached of what appeared. Computer appeared then to freeze

  Computere is an eMAC 1.2 Ghz G4 processor. 1 Gig RAM 80 Gig hard
  drive. Internal hard drive has no other operating system on it.

  did <ctl-alt-F1> to boot to command line interface.
  did <ubuntu-bug>

  Photo of reporting screen attached. Since I was not connected to the
  internet, I was unable to report the bug from there.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1044180/+subscriptions

Sent on the TELUS Mobility network with BlackBerry

Revision history for this message
ojordan (ojordan12345) wrote :

I have a G4 iBook. I've installed fine with the alternate tonight. I used 'install video=ofonly'.

I think possibly KMS is picking a poor modeline for you and your signal is going out of range for your monitor. Hence black screen. Otherwise it is your card (see the kernel release notes about the radeon 9200). It doesn't really explain why the live/desktop CD brings you to a working 8 bit desktop and the alternate doesn't though......

Revision history for this message
Ron Mitchell (rm2892) wrote : Re: [Bug 1044180] Re: Screen Freeze on Bootup - Lubuntu 12.10 PPC Alternate Aug 30 Build

Makes sense. Could be just my eMac. If nobody else is having the problem, then it need not concern you further.

I'm trying another experiment here. Setting up QEMU one of my other boxes that has Ubuntu Studio on it. Will see what happens there.

Very much appreciate your help, and I will have a look at the kernel release notes.

Ron M

On Tue, 18 Sep 2012 21:45:02 -0000
ojordan <email address hidden> wrote:

> I have a G4 iBook. I've installed fine with the alternate tonight. I
> used 'install video=ofonly'.
>
> I think possibly KMS is picking a poor modeline for you and your signal
> is going out of range for your monitor. Hence black screen. Otherwise
> it is your card (see the kernel release notes about the radeon 9200).
> It doesn't really explain why the live/desktop CD brings you to a
> working 8 bit desktop and the alternate doesn't though......
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1044180
>
> Title:
> Screen Freeze on Bootup - Lubuntu 12.10 PPC Alternate Aug 30 Build
>
> Status in “debian-installer” package in Ubuntu:
> New
>
> Bug description:
> Installing from Alternate CD for Lubuntu 12.10 PPC August 30 2012
> build.
>
> Boot appeared to be normal until it came time to display the desktop.
>
> 2 photos attached of what appeared. Computer appeared then to freeze
>
> Computere is an eMAC 1.2 Ghz G4 processor. 1 Gig RAM 80 Gig hard
> drive. Internal hard drive has no other operating system on it.
>
> did <ctl-alt-F1> to boot to command line interface.
> did <ubuntu-bug>
>
> Photo of reporting screen attached. Since I was not connected to the
> internet, I was unable to report the bug from there.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1044180/+subscriptions

--
Ron Mitchell <email address hidden>

Revision history for this message
ojordan (ojordan12345) wrote :

I can confirm your problem with the alternate install! When I turn off KMS I get the blank screen except the screwed up mouse pointer. I'll look into it. This didn't happen with the live/desktop ISO install.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Revision history for this message
ojordan (ojordan12345) wrote :

Right, this is essentially bug 1040526 . Lightdm (the login manager) can't cope with the 8 bit pseudo colour and completely screws up its display. Once you log in (by just typing your password) the display is okay (all be it in 8 bit).

For the live/desktop ISO install I had selected to login automatically and this is why I wasn't seeing the problem on that install.

Workaround is to increase the colour depth via an xorg.conf (as you say):

Section "Screen"
  Identifier "Screen0"
  DefaultDepth 24
EndSection

Or turn on KMS. If KMS is not selecting an appropriate modeline then you should be able to define your own like you've done before, but called the mode "800x600" instead of "800x600_60.00". It'll probably want to put you into "1024x768" so make sure you define a modeline for that.

Revision history for this message
ojordan (ojordan12345) wrote :

lightdm has a blank display due to 8 bit pseudo colour (fbdev driver)

affects: debian-installer (Ubuntu) → lightdm (Ubuntu)
Revision history for this message
ojordan (ojordan12345) wrote :

@Ron please ignore the comments I made about modelines in post 29. The 10-monitor.conf you have in post 16 should work under KMS too.

Revision history for this message
Ron Mitchell (rm2892) wrote :

Right. It certainly seems to.

Ron

Revision history for this message
Robert Ancell (robert-ancell) wrote :

Closing assumed fixed.

Changed in lightdm (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers